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DATABASES 

Welcome to Amlib 

 

 

 

 

 

 

 

Databases 

On initial activation of Amlib you will be required to select the database to: use for this session. 

 Live Database: Shared database for LIVE operation of the Library 

 Test Database: Test database for testing and training – this can be updated from time to 

time using a restore of the LIVE database 

 

Getting Started… 

Introductory training is designed to “get you started”. Once you have used your system for a while, 

you may wish to consider further training on specific tasks or modules. 

  

 

OPAC &/or NetOpacs 
(Public Use) 

 

 

SERVER: Operating 

System: Database:  

SQL Server 2005 or  

SQL Server 2008 or 

Oracle 

 

WORKSTATIONS 

(Staff Use) 
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NAVIGATION OVERVIEW 

Logging On 

1. Double-select on the Amlib icon on the Desktop: 

 

2. The Login screen will then display – for training purposes, use the following login (unless set up 

differently for you at installation) and select the OK button: 

 User Name: STAFF 

 Password: AMLIB 

 

3. The Confirm your Working Location screen will then display:  
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4. The screen defaults to the location set up against the Username – although it is entirely 

possible to select a different location if required – select the OK button to confirm the login 

location 

5. The Amlib toolbar will then display: 

 

Login is now complete. 

Please Note: After login, individual usernames and permissions (determining which menus and buttons 

are enabled for the user) can bet set up in: Main > Supervisor > User Names: 

 See: Appendix 1: Setting Up Usernames and Permissions for further information 

 

Logging Off 

 Individual modules can be logged off by using the shortcut Ctrl + L 

 The [X] at the top-right of the screen can be used to closed sub-screens within a 

module/application but will only minimize the main screen (it cannot be used to close an entire 

module) 

 

 The entire system can be exited by using the shortcut Ctrl + E (or Ctrl + X*) which closes all 

modules currently in use and logs out of the Amlib client 

*Please Note: This shortcut is controlled by the Use Windows keyboard shortcuts instead of Amlib 

shortcuts (Y/N) setting in Main > Supervisor > Installation – Other tab. Ctrl + E (Windows) and Ctrl + 

X (Amlib).  



Introductory Training 

 

 

Last Updated: 27 August 2016  
 Page 11 

Icon Toolbar 

It is possible for the icon toolbar to display in 1, 2, 3, 4, 5, 6, or 12 columns: 

1. Change the settings by right-selecting on any of the icons: 

 

 

 

 
 

Please Note: Module names will display as the mouse is moved along the toolbar – for 

example: Catalog. 

 

2. The number of columns that the toolbar displays in and button colours (to match the module 

colours) can then be changed – to select/enable: scroll down to the desired selection and 

left-select with the mouse 

3. The selected settings and screen position can be saved by ensuring that the Save on Exit is 

ticked 
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Core System Orientation 

 
[Top Bar] 

 

 

                                                                                           
  [Borrower]             [Stockitem]         [Catalogue]   [Authorities] 

                                                

 

                                                                                             
         [Circulation]       [Periodicals]       [Finance & Orders] 
             - Issues 

               - Returns/Chute Returns 

               - Reservations 

               - Transfers 
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Standard Screens 

 Modules colour-coded so you always know where you are! 

 Consistent screen display 

 Multiple display of applications – with multiple screens open simultaneously 
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General Use of the Tool Bar and Function Keys 

KEY COMMAND DESCRIPTION 

[F1] CLEAR Clears all data in the window 

[F2] INSERT Inserts a new field or record  

[F3] SAVE/UPDATE Saves any new fields or modifications 

[F4] DELETE Deletes the field or record 

[F5] QUERY Either starts a search or refreshes the screen 

[F6] TABLE Displays the table from the search query 

[F7]  Scrolls through the table, to the beginning 

[F8]  Scrolls through the table, to the last item 

[F9]  Scrolls through the table, to the next item 

[F10]  Scrolls through the table, to the end 

 

Fast Keys 

Fast keys are available to access applications – for example: Ctrl + B to go to the Borrower Screen. 

These can be set to use Amlib shortcuts or Windows shortcuts. 

SHORTCUT WINDOWS 

Crtl + A Authority 

Ctrl + B Borrower 

Ctrl + C Copy 

Ctrl + G Catalogue 

Ctrl + E Exit from Amlib 

Ctrl + F Finance 

Ctrl + H Help 

Ctrl + I Issues 

Ctrl + K Keyword Search Facility (Stockitem) 

Ctrl + L Log Off Application 

Ctrl + M Marc Take-Up 

Ctrl + O Orders 

Ctrl + P Periodicals 

Ctrl + Q Reservations 
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Ctrl + R Returns 

Ctrl + S Stockitems 

Ctrl + T Transfers 

Ctrl + U Chute Returns 

Ctrl + V Paste 

Ctrl + W Where Search (Borrower/Stockitem only) 

Ctrl + X Cut 

Menus 

Menus are always available for exploring in all modules. 

The Main menu is available from most screens, and can be used for moving around the system – for 

example: Main > Reports > select individual Reports screen – for example: RepCirculation 

(Circulation Reports) 
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Moving Between Fields 

 Use the Tab button to move between fields, use Shift-Tab buttons to move in reverse 

 Use the Alt-Tab buttons to move between open modules 

Cut, Copy and Paste Commands 

After highlighting, select these keys to: 

 Amlib shortcuts Windows shortcuts 

Copy: Ctrl + Insert Ctrl + C 

Paste: Shift + Insert Ctrl + V 

Cut:  Shift + Delete Ctrl  + X 

Alternatively, you can right-select and choose the appropriate option: Cut, Copy or Paste. 

Saved Files 

The Amlib client allows the use of various Saved Files (a file containing a list of patrons, stockitems, 

catalogue records, etc.).  Also, see Appendix 2. 

 A File menu is available in many modules – for example: Borrower, Stockitem and Catalogue. 

These Saved Files can be useful for global changes – for example: Altering Class and Types at the 

beginning of the year, changing Juniors to be Young Adults, etc. They can also be used to change items en 

masse to be Closed Reserve or to have a certain Process. Catalogue Files can be given a particular 

Authority – for example: Subject Heading. They can also be used to check or report on newly imported 

records for Borrowers or Stockitems. 

Saved Files can also be used for reporting purposes. For example: return a file of books, (General > 

ReturnFromFile) or to print Spine Labels using a list of items contained in the Saved File, etc. 

It is even possible to loan out a Saved File – for example: The Environment File which may contain 25 

books, 3 DVDs and 5 flash drives all on the Environment theme.  

They can also be used for Periodical Circulation Lists. 
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Getting Help 

Help is available from the online manual. 

Word Version 

 This can be accessed from any module screen by selecting Ctrl + H, if you have MS Word on 

your PC 

HTML Version 

 You can also access a HTML-version of the Help file using your web browser (for example: 

Internet Explorer or Mozilla Firefox)  

 Add the chapters as Favourites or Bookmarks by choosing the relevant frame.htm file – for 

example:  Borframe.htm 

 An index to the left of the Help screen contains headings which are hyperlinked to the 

relevant information (you are also able to use the Find facility of your web browser) 
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SEARCHING WITHIN MODULES 

There are comprehensive search facilities within the Authority, Borrower, Stockitem and Catalogue 

modules. You are also able to search for patrons and items within the Circulation module. 

There are separate modules for OPAC and NetOpac (if purchased). 

Borrower 

 Any field of the Borrower Details screen is searchable 

 It is also possible to search using the grey box of the Address screen for a Street name, etc. 

 Previous Queries: The last 5 searches are kept in case they need to be re-performed. Use the 

-1 to -5 buttons to select a previous search 

 
 

1. Typing in a few letters (for example: smi) in the Surname field and selecting the F5 Query 

button will display all borrowers starting with those letters – for example: Smith, Smithers, 

Smith-Lawrence, etc. – the results will display in a Borrower List table 

HINT: To access a list of codes in a field type: .<Tab> . For example: in the Borrower Type 

field, typing .<Tab>  will display a list of your Borrower Type Codes and Descriptions. Double-

select to make a selection.  
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2. Double-selecting on a line will show the details of that borrower: 

 

3. You are then able to move through the table using the arrow keys F7 <<, F8 <, F9 >, F10 >> or 
F6 Table to get back to the Borrower List table display 

4. It is possible to save the records to file using the File menu, or go to other applications for 
the items – for example: Issues, Stockitem – by selecting XReferences from the menu 

Colour 

Colour is used to indicate certain borrower statuses: 

 Red  Borrower owes money 

 Grey  Borrower has been inactive for 12 months or more 

 Black   Normal borrower 

Printing from a List (Table) 

1. In the Borrower List (or Stockitem List) highlight the items to be included in the report, 

select: Table > F6 Print 

 

HINT: Highlight items by selecting with the mouse. To highlight a range, select the first item and find 

the last item in the range and hold down the Shift key and select with the mouse. To highlight 

several individual items from the list, hold down the Ctrl key and select with the mouse.  
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Stockitem 

 Most fields of the Stockitem screen are searchable 

 

 Use the Query Via options to determine the type of search to be performed 

Query Via 

 

  

OPTION DESCRIPTION 

Item Browse (phrase) search for data displayed within the Stockitem module 

Cat Browse (phrase) search for data displayed within the Catalogue module 

Keyword Keyword search one of the six bibliographic lines within the Stockitem screen (Title, 

Author, Subject, Publisher, Series or Call No) – for example: typing a keyword into 

the Subject line will perform a keyword search on just the Subject fields 

Any Keyword search any of the six bibliographic lines  within the Stockitem screen (Title, 

Author, Subject, Publisher, Series or Call No) – for example: even if the keyword is 

typed into the Title line, all six fields (Title, Author, Subject, etc.) will be searched 

Previous 

Queries 

The last 5 searches are kept in case they need to be re-performed. Use the -1 to -5 

buttons to select a previous search 

Bibliographic Information (from Catalogue record) 
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Keyword Search 

1. Ensure the Query Via option selected is Keyword 

2. Type in a word (for example: sport) in the Subject field and select the F5 Query button – a 
Stockitem List table will display with all the items that include sport as part of the subject – 
for example: Sport, Sports medicine, Sport - Australia, etc. 

HINT: To access a list of codes in a field type: .<Tab> . For example: in the Stockitem Sts Code 
field, typing .<Tab>  will display a list of your Stockitem Stats Codes and Descriptions. 
Double-select to make a selection. 

 

3. Double-select on a line to show the full details of that item: 

 

4. You are then able to move through the table using the arrow keys F7 <<, F8 <, F9 >, F10 >> or 
F6 Table to get back to the Stockitem List table display 

5. It is possible to save the records to file using the File menu, or go to other applications for 
the items – for example: Catalogues, Authorities, Periodicals – by selecting XReferences 
from the menu 

Colour 

Colour is used in certain modules to assist in browsing the list: 

 Red  Items are overdue 

 Black  Items are on loan 

 Green  Items are available for loan 

 Grey  Items are on order 

 Magenta Items are on reserve 
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Catalogue 

1. It is possible to XReference from a Stockitem record to the Catalog record to see the 

complete Bibliographic details for an item (including all Subject Headings, Notes, Added 

Authors, etc.) : select XReferences > Catalogue 

 

2. It is also possible to XReference from the Catalog record: use the Holdings button or from 

the menu, select XReferences > Stockitems 
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Searching 

1. Type the search phrase into the Search Term box at the bottom of the screen: 

 

2. Select the F5 Query button – the Query Options prompt will display: 
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3. Double-select on the Enquiry Option you would like to use (for example: Subject) – the 

results will display in a Catalogue List table: 

 

4. Double-select (or select and select <enter>) to display the full catalogue record: 

 

Please Note: Typing in more than one word invokes a Boolean “AND” search. 

Query Options 

It is possible to alter the query options (once set) for subsequent searches: 

 From the menu, select Catalogue > Query Options – the Query Options prompt will then 

redisplay 

 Double-select on the Enquiry Option you would like to use 
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Search Sizes 

 The results of the Table from a search will display in a set (for example: 250 items) and the 

next set can be viewed by selecting the F11 button or Table > ContinueQuery 

 The set size can be altered if required – for example: from 250 items to 1000 items 

 The default settings can be changed in the Main > Supervisor > Installation – System tab 

Default search cache size setting 

Set the Search Size 

1. From the Stockitem menu, select Item > Query Settings > SetSearchSize, from the Borrower 

Details menu, select Borrower > SetSearchSize or from the Catalog menu, select Catalogue > 

SetSearchSize 

 

 

2. The Set Results Search Size screen will display: 

 

3. Select a search size from the list 
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Print using a Report 

1. In the Stockitem List (or Borrower List), select: Table > Report F7 – the List Reports screen 

will display: 

 

2. Select a specific style – for example: Author, Title, Call No and Form 

3. Select the F9 Order button to select the sequence in which the items display – for example: 

Title, Call No. etc. 

4. Use the Caption box to add a heading to your report – for example: Weeding List 

5. Select the F8 View button to display the report 

 

6. The print button can then be used to print the report 
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Where Searching 

This function is available in the Stockitem and Borrower modules only. It is possible to search for 

items or borrowers using a range of fields and operators. This is a great way to get simple Counts – 

for example: for State Government Library statistics, which the Public Libraries need to report on a 

yearly basis.  

The Where search query results can be displayed in a List or saved to a File. 

The Where search itself can also be saved. 

1. You can access Where searches in the Stockitem and Borrower modules by selecting 

Application > Where... (in the Stockitem module) or Application > BorrowerWhere (in the 

Borrower module) – the Where Search screen will display: 

 

2. Choose Search column: it can be helpful to have a look at the main Stockitem (or Borrower) 

screen if you’re confused about which fields contain what information 

3. Choose Operator: these are the same as in the Reports module 

OPERATOR DESCRIPTION EXAMPLE 

LIKE Where the required data in this field 

begins with the text entered 

LIKE ELD (for Eldorado) 

LIKE Where the required data in this field does 

not begin with the text entered 

LIKE ELD (for all except Eldorado) 

IN Useful for selecting multiple codes IN A,J,YA (for all of these types) 
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IN Useful for multiple codes not to be 

included 

IN ILL,LS (to exclude these types) 

= Where the text entered is exactly equal to 

the data required 

= A (borrowers with a code of A for 

Adult) 

 Where the text entered is not equal to the 

data required 

Useful for NOT EQUAL TO NULL – choose 

this operator, do not enter any data and 

select the Paste button 

 J (borrowers who do not have a 

code of J) 

< Where the text entered is less than the 

data required 

< 01/10/10 (less than 1 Oct 2010) 

< Where the text entered is equal or less 

than the data required 

< 01/10/10 (less than or equal to 1 

Oct 2010) 

> Greater than >01/10/10 (greater than 1 Oct 2010) 

> Equal or greater than the text entered > 01/10/10 (greater than or equal to 

1 Oct 2010) 

4. Type the Where condition: this can be a date, a code, letters, numbers, etc. 

BUTTON DESCRIPTION 

Paste Adds the Where condition to the Query Description table 

Special This button contains useful fields that can be used for any mathematical operand (i.e. , , 

, , , ) – for example: Current Date 

Delete Deletes the highlighted Where condition from the Query Description table 

AND Includes the AND separator to the Where conditions in the Query Description table (this is 
the default) 

OR Includes the OR separator to the Where conditions in the Query Description table 

( Adds a beginning bracket to the Where condition in the Query Description table 

) Adds a closing bracket to the Where condition in the Query Description table 

5. Once your Where condition is set up you can either: 

a. Count the number of results by selecting the F6 Count button: 

 

b. Get the list of results by selecting the F5 Query button: 
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6. If you wanted to find ALL of something (for example: Borrower, StockItems, items on loan) 

then you could run a query such as: 

c. BarCode IS NOT NULL (all Borrowers) 

d. ItemNo IS NOT NULL (all StockItems) 

e. Issue Due Date Back IS NOT NULL (all items on loan) 

 

The NULL value is achieved by simply leaving a blank space in the field 3 Type the Where Condition 

and Select Paste – as soon as the Paste button is selected a NULL value is entered into the Query 

Description table. 

Special Button 

The Special button can be used for a number of things including the creation of relational dates 

(dates that aren’t fixed but operate from the concept of a Current Date or the Start of Month). 

For example: if you would like to look at dates from a week ago, or further back, you could enter the 

following Where condition:  

 Issue Date Due Back <= Current date – 7 Days 

1. Select Issue Date Due Back from the 1 Choose Search Column box 

2. Select the < operand from the 2 Choose Operator box 

3. Select the Special button – another Where screen will display 

4. Select the Special operand from the table – for example: Current Date 

5. Adjust the relational value of the selected operand by using the + or – buttons and the Days 

or Months boxes – for example: - 7 Days 
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6. An example of the selected condition will be visible in the box at the top of the screen: 

  

7. Select the Paste button when complete – the where condition will then appear in the Query 

Description section at the bottom of the screen: 
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Saving a Where Search 

It is possible to save a Where search: 

1. Select the F2 Insert button – the Saved Queries table will display: 

 

2. Type in a Description and select the F3 Save button – a prompt will display with the following 

message: The Query File has been created. 

 

3. Select the OK button 

4. Once saved, you can access saved Where searches by selecting the F4 Select button in the 

Where screen, selecting the Saved Query from the list and then selecting the F9 Select 

button 
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Query to File 

It is possible to save the Where search results to a file, which can then be used in other operations 

(including reports). 

1. After choosing your Where parameters, select the F7 QtoFile button – the Saved Query 

Results table will display: 

 

2. You can either use a pre-existing list file or create a new list file:  

a. To use a pre-existing file: select a list entry from the table and select F9 Select (select 

F2 Empty first if you would like to clear any pre-existing list items – look at the Qty 

column to ascertain this.).   

b. Alternatively, a new file can be added by: selecting on the F1 New button, typing in 

the Details (for example: Chelsea Fiction) and then selecting on the F3 Save button. 

Then highlight the file and select on the F9 Select button. 

This Saved File can now be used as part of a report or procedure. 

 See: Appendix 2: Saved Files for further information  
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Some Where search examples are: 

Borrowers who have joined in the last 3 months 

 Joined > Current Date – 3 Months 

All Stockitems 

 Item No IS NOT NULL 

All Junior Items 

 Sts Code LIKE J  
or 

 Call Number LIKE J (if you put J at the beginning of your call numbers for Junior items) 

Stockitems with a Specific Form Code 

 Form = BK 

Items with Cost over $500 

 Current Cost > 500 

Items Never Borrowed 

 Times Borrowed = 0 

Dusty items – Items not used within a certain period of time (for example: Items not used in the 
last 12 months) 

 For Loan = Y  AND 

 Last Active < Current Date – 12 Months 

Items available for loan from a Specific Collection (for example: DVDs) 

 For Loan (Y/N) = Y AND 

 On Loan = N  AND 

 Form = DVD (substitute your own code here, or use Sts Code or Floor) 

Items with More than 3 Reserves 

 Res > 3 

Items Received within a Specific Period 

 Received < 1/7/2009 AND 

 Received > 1/06/2009 

Items Received Since the Beginning of the Month 

 Received > Start of Month 

Stocktake – Missing items (minimum statements required) 

 Stock Take Date IS NULL AND 

 On Loan = N 
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BORROWER INFORMATION 

Menu Options 

The menu is broken up into five areas: 

 Main – giving you access to all the other modules and many of the sub-screens 

 Application – most the codes/settings used within the Borrower module are set up here (for 
example: Borrower Types and Borrower Titles) 

 Borrower – which contains additional Borrower-related functionality (for example: Borrower 
Addresses, History and Memos) 

 XReferences – links to other modules and associated functionality 

 File – access to Saved Files and associated functionality 

From the Borrower menu within this screen it is possible to: 

 Add/edit borrower information, including addresses 

 Check reservations 

 Check financial details 

 Check/print loan history 

 Add memos 

 Load photographs in digital formats 

 Re-register borrowers 

Set up/check your pre-set codes and descriptions for the relevant groups in the Borrower Module 

Application menu. These can be classified specifically by the site but generally: 

TYPES The Category to which Loan privileges are set – for example: Staff, Adult, Year 8, ILL 

Libraries, House Bound, etc. (Application > BorrowerTypes) 

GROUPS Usually the house, faction for students or other category (not often used in Public Libraries) 

(Application > BorrowerGroups) 

CLASSES Class or room names for students – usually where overdues are sent for Schools (not often 

used in Public Libraries) (Application > BorrowerClasses) 

TITLE Can be used to automatically generate default Sex (Application > BorrowerTitle) 

REF1 / 

REF2 

Free-text fields: Often is used in schools for a Student’s ID or Shortname (for example: comes 

from Admin system). Public Libraries use them for extra information  

LOCATION Branch, Library, Campus or Department name (Main > Supervisor > Locations) 

STATUS Most statuses would be set to no restrictions (0K) but can be changed – for example: Lost 

card, Restricted borrower, Blacklisted (Application > BorrowerStatus) 
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SUBURB Used to populate the Suburb name and Postcode when entering Addresses (to save time and 

provide Statistics) (Application > BorrowerSuburb/Streets/Wards) 
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Borrower Screen 

 BarCode: Usually Student ID No (Schools). Validation 

checks are made 

PIN: The PIN is an alphanumeric field (not case sensitive). It 

can be used for security reasons when borrowers are 

checking their own information in the OPAC screen 

Balance: Any money owing will display. It is not a data entry 

field. 

Title: Mr, Ms, Mrs, Dr, Professor, etc 

Sex: Gender will be M or F – will be automatically 

generated from Title if Default Sex is entered 

Scope: Library Group(s) a query will search over 

Potential Charges: Links to Issues where the Potential 

Charges display for the current Borrower. This is the amount 

of Overdue Charges due if the item/s were to be returned on 

the current date 

Address: Three addresses may be supplied for each 

borrower with 4 lines available for each Address – includes 

telephone number 

Picture: Display of Borrower picture if loaded 

Enquiry Security Level: Not used in current Release 

Search Size (for example: 200) and Table Information –for 

example: Sequence No 6 in Set of 41 

Loan Count and Memo count: Number of items on loan 

and number of Borrower memos 

BirthDate: Enter dates in dd/mm/yyyy format. You do not 

need to type the / symbol. 

Location: Registration points for Borrowers 

Email: To Store email address. Can also be used as address for Circulation 

notices sent by e-mail. On entering a Valid email address, Use for Notice 

changes to Y. Validation rules apply. 

Use for Notices: Use Email for Circulation notices (Y/N) 

Mobile/Cell: To store mobile phone number. Can also be used as number 

for circulation notices sent by SMS   

Use Mobile/Cell for Notices: Use Mobile/Cell for Circulation notices (Y/N) 

Ref1 and Ref2: Free text fields. Can be used for matching 

purposes during Borrower and Borrower Picture Import. It 

is possible to customise the labels for these fields. 

Status: Special process associated with the Borrower – for example: BANNED, 

LOST CARD. Allows a borrower to be banned. A nominal status is set in Main > 

Supervisor > Installation – Borrower tab 

 

Lib Group: Displays the Library Group for the location for this borrower record 

Type: The main category of borrower at a particular library. 

Loan rules are applied against Borrower Types. 

Group: Optional category for borrower. 

Class: Optional category for borrower. 

 

Surname: Family name 

Give Name: First name 

Middle Name: Usually only first initial (if from import) 

Exclude from Debt Collection: Excludes borrower from Debt Collection 

processes (where applicable) 

Reg Expiry: The date at which this borrower will expire 

Last Active: The date the borrower was last active in Circulation for an Issue, Renewal or Reservation 
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Entering New Borrowers 

1. Launch the Amlib client 

2. Go Main > Borrower > Borrower – the Borrower Details screen will display: 

 

3. From the menu, select Borrower > EnterNewBorrower – the Borrower Details screen will 

enter creation mode (the F2 Insert button will become bolded) 
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4. To access a list of codes in a field select . (full stop) and <Tab>on your keyboard – for 

example: in the borrower Type field, type . and then select the <Tab> key – a list of Borrower 

Type Codes and Descriptions will display: 

 

5. Double-select on an entry to make a selection 

6. After entering all necessary details select the F2 Insert button – the Borrower Address screen 

will automatically display 
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Addresses 

1. From the menu, select Borrower > Address – the Borrower Address screen will automatically 

display: 

 

2. Enter the Postal address details as required 

3. If Suburb Codes (Application > BorrowerSuburbs from the Borrower Details screen) are 

being used, enter just the Street Address details and go to the Suburb field and identify the 

Suburb: this will then populate the rest of the Address details and the P/Z Code (Postcode) 

field 

4. Enter the Residential and Guardian address details (if applicable) 

5. Select the F3 Update button when complete 

It is possible to link to other addresses (Schools do not usually use this facility as they download the 

Addresses from the Admin system). It is also possible to Wand in another Students card, enter the 

details of the borrower to which the link is to be made and select the F5 Query button. 

 See: Appendix 3: Linking Addresses for more details 

 See: Appendix 4: Import of Borrowers into Amlib for more details of the borrower import 

function 
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XReferences Menu 

 Show Linked Borrowers for Addresses1, 2 and 3 

 Show Items or Reservations 

 Go directly to Issues (it is possible to then loan items etc.) or go directly to reservations (it is 

possible then to reserve/delete reservations, etc.) 

 Go directly to subject interests (it is possible to view items received by the library a certain 

amount of time – for example: the last month for prescribed areas of interest. It is possible 

to send letters or email detailing of new items that include Subject Interests registered) 
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STOCKITEM INFORMATION 

Menu Options 

The menu is broken up into five areas: 

 Main – giving you access to all the other modules and many of the sub-screens 

 Application – most the codes/settings used within the Stockitem module are set up here (for 
example: Stockitem Form Codes and Stockitem Process Codes) 

 Item – which contains additional Stockitem-related functionality (for example: Reserve Item, 
History and Memos) 

 XReferences – links to other modules and associated functionality 

 File – access to Saved Files and associated functionality 

From the Item menu within this screen it is possible to: 

 Create reservations and shuffle reservation queues 

 Check/print loan history 

 Add memos 

 Create inter-library loans 

 Create standalone item records or catalogue records 

Set up/check your codes, descriptions and labelling for the relevant groups in the Stockitem module 

Application menu. These can be classified specifically by the site but generally: 

FORM Usually a physical description or General Material Designation (GMD) of the Stockitem – 

for example: Book, Periodical, Video, Map, Online, etc. Can be used to set Loan 

parameters (Application > StockitemForms) 

STS CODE Used to identify particular collections (or parts of the collections) for Statistical reasons. 

Usually more specific than Form. Can be used to set Loan parameters 

(Application > StockitemStats) 

CALL SET Allow you to search or print reports by the Call number set rather than a call number 

range (Application > StockCallSets) 

DESCRIPTION + Convert Val: Free-text fields: Often used to indicate copy number and conversion values 

LOCATION Branch, Library, Campus or Department name (Main > Supervisor > Locations) 

FLOOR An extra location field. Can show in NetOpacs – for example: Closed Reserve, New Items, etc. 

PROCESS Useful for Process such as Missing, Withdrawn, etc. A date that the Process was created 

displays in the adjacent to the Process Date box. Links can also be made to show in Opac? 

and Alert fields (Application > StockProcess) 
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LOAN TYPE Allows a loan restriction to be placed on the item – for example: Overnight Borrowing 

only, which overrides the normal Loan Borrowing permissions. Mainly used for 

temporary collections. (Application > StockLoanTypes) 

Stockitem Form/Field Labels 

This is bibliographic data originating from the Catalogue record. 

Usually set as: 

Line 1: Title Line 4: Series or ISBN 

Line 2: Author Line 5: Publisher 

Line 3: Subject Line 6: Call Number 

 

The labelling of Lines and Tags used to populate the fields can be adjusted to suit Form type 

(Application > StockitemForms – F9 Display button). 

 See Appendix 5: Stockitem Field Labels for more information 
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Stockitem Screen 

 

 

 

  

 

 

 

 

  

Item No: Usually the Barcode. Able to enter a system 

generated barcode. Validation checks are made. 

Volume: Free text. Allows up to 8 characters. Can be set up 

so that Marc tag is inserted – for example: 300a 

Stats Code: The code may be alphabetic (up to 6 

characters) with description (up to 50 characters). Used 

mainly in the statistics gathering process but may also be 

used as enquiry points 

Catalogue information: Originates from the Catalogue 

data. Line displays set in Stockitem Form – F9 Display.  

Usually set as: 

Line 1: TITLE Line 4: SERIES 

Line 2: AUTHOR Line 5: PUBLISHER 

Line 3: SUBJECT Line 6: CALL NO 

 

Form: Physical description of the Stockitem. Typical Forms 

codes could be CD, BK, VID. The actual code (up to 3 

characters) with description (up to 25 characters). Plays a 

vital role within Circulation and may also be used in Statistics 

Convert Value: Usually ref for conversion data. Label can 

be changed 

Edition: Free text. Allows up to 8 characters. Can be set up 

so that Marc tag is inserted – for example: 260c 

Floor Location: Names of floor locations in your Library – 

for example: CASSETTES, VIDEOS etc. Optional but can 

appear in the Opac under the Permanent Location 

description. 

Search Size (for example: 200) and Table Information –for 

example: Sequence No 6 in Set of 41 

Current Cost: Do not enter $ symbol 

Description: Free text. Label can be changed 

Location: Permanent/Temporary Locations for Stockitems 

For Loan: (Y/N) Default is Y. 

Loan Type: Parameters set according to type e.g. Overnight only 

Opac?: Show this item in Opac (Y/N) 

Alert: Message generated in circulation regarding the item (Y/N) 

Dates: Format is DD/MM/YYYY – for example: 

07/10/1998. No need to type the / symbol. In Received 

date < =  > symbols can be used for queries – for example: 

item before a certain date 

Circulation details: If on loan, current borrower, No. of reserves, order 

Process: Special process associated with the item – for example: MISSING, 

DAMAGED. Linked to Opac? And Alert fields –for example: Alert = Y but Opac = 

N. A Date displayed once a process has been included. This is useful for 

Reporting purposes – for example: Report Missing items entered as Missing 2 

years ago 

 

Library Group: Associated with Login Location – determines privileges within Group 

security if used by your Site e.g. if Multi Campus School. Able to apply security to View, 

Update, Insert, Delete, Batch, Attach, Hold, Loan, Check-in and/or Transfer 

Call Set: If used enable Call numbers to be categorised into 

groups e.g. Chemistry, Physics, Biology etc. 
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LOAN RULES 

Your system is set to control loan periods by Borrower Type and Item Form Code. Alternatively loan 

settings can be controlled by Borrower Type and Item Stats Code. This is an installation parameter 

setting: Main > Supervisor > Installation – Circulation tab: Loan by STATS (Y) or FORM (N). 

 See also: Appendix 6: Setting Default Dates and Holidays for more information 

Borrower Types 

1. Launch the Amlib client 

2. Go to Main > Borrowers > BorrowerTypes – the Borrower Types screen will display: 

 

3. Alter the settings as per the following table: 

COLUMN NAME EXPLANATION OPTIONS 

Type The Type of Borrower (usually a 1-3 digit code  – for 

example: A) 

 

Description A description of the Borrower Type – for example: Adult  

Keep House Bound Borr 

History (Y/N) 

History of past reading records is kept for borrowers until 

deleted, if a Y is entered in this column. They system will 

notify the operator if an item has been borrowed previously 

and how many days ago. If the Borrower history is not kept, 

the system still keeps Stockitem history so the items that a 

person has borrowed can still be checked 

Y/N 

Include In Stats (Y/N) Statistics can be recorded to the hour, day, month or year 

depending upon the settings in Main > Supervisor> 

Y/N 
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StatsParams for the Borrower Types that have a Y set in this 

column 

Max Items On Loan Sets the total number of items that a patron with this 

Borrower Type can loan at any one time. Specific 

limitations/privileges based on Form (or Stats) codes of the 

items can be set by selecting the F7 Loan button 

nn 

Max No. of Reserves Sets the total number of reservations that a patron with this 

Borrower Type is allowed at any one time. Specific 

limitations/privileges based on Form (or Stats) codes of the 

items can be set by selecting the F7 Loan button 

nn 

Return By Date A return date (earlier than those set in the Main > 

Supervisor > Installation – Borrower tab) can be imposed on 

particular Borrower Types – for example: Year 12 students 

dd/mm/yyyy 

Age 

>= 

Age 

<= 

When a new borrower is created the system can assign the 

appropriate Borrower Type parameter depending on age if 

an entry is added within these fields. This is useful for 

creating Junior members in Public Libraries. 

  = Greater or equal to a certain age 

  = Less or equal a certain age 

 

 

Exp Days The number of days before the Borrower Type expires. Once 

a borrower has expired they would need to re-register 

before allowing activity on the system. The Main > 

Supervisor > Installation – Borrower tab A Borrower is re-

registered by (D)ates, (M)onths, (N)o re-register parameter 

would need to be set to M or D for the above to be effective 

nn 

Exp Date The actual expiry date for a patron with this Borrower Type. 

Once a borrower has expired they would need to re-register 

before allowing activity on the system. The Main > 

Supervisor > Installation – Borrower tab A Borrower is re-

registered by (D)ates, (M)onths, (N)o re-register parameter 

would need to be set to M or D for the above to be effective 

dd/mm/yyyy 

Bor Group A Borrower Type parameter may be assigned a default 

Borrower Group (which will then be automatically entered in 

the Group field when the Borrower Type is entered). The 

relevant Group code needs to exist in the Borrower Group 

(Main > Borrowers > BorrowerGroups) table. 

For example: all Teachers could be assigned a group of Staff, 

all Students be assigned a group of Students, all differing 

categories of staff (for example: Library Staff, Council Staff 

could be assigned a group of S for Staff). It can assist in 

defining groups of borrowers for searching or reporting 

purposes. 

Enter a Group 

code – for 

example: STA, 

STU, etc. 
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4. Select the F3 Save button when complete – a prompt with the following message will 

display: You should now check Validation and Loan Parameters for any new or changed 

Borrower Types. 

 

5. Select the OK button 

6. Highlight the Borrower Type you would like to alter (for example: Adult) and select the F7 Loan 

button – the Loan Parameters and Borrower Types screen will display: 

 

7. Alter the settings as per the following table: 

COLUMN NAME EXPLANATION OPTIONS 

Code Displays the Form or Stats code for each corresponding Stockitem 

Form or Stats code 

 

Description Displays the Form or Stats Description for each corresponding 

Stockitem Form or Stats code 

 

Type of Loan Displays whether the Loan is a Daily, Hourly, Overnight, Semester, 

Term or Yearly type Loan* 

D/H/O / 

S/T/Y 

Can Loan (Y/N) Is this form available for the particular Borrower Type – for 

example: Borrower Type of Junior may not be available to loan 

items with a Form code of CD 

Y/N 
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Loan Qty The number of Items with this Form code that may be on loan to a 

patron with this Borrower Type at any one time – for example: a 

Borrower Type may be allowed a maximum of 8 items but only 1 

item with a Form code of Video 

Please Note: Maximum number allowed is set on Borrower Types 

screen – Max Items On Loan column 

nn 

Loan Days The usual loan period in days (can be overridden during issuing). nn 

Grace Period Days Number of days overdue before fines are applied to an item of this 

type. Whether the charge itself is calculated from the actual due 

date or the due date plus the grace period is determined in the 

Main > Supervisor > Installation – Circulation tab Calculate all 

overdue fines from the grace (Y0 or overdue (N) date setting  

nn 

Can Renew (Y/N) Determines whether borrowers can renew items of this type Y/N 

Qty Renew Controls the number of times borrower can renew an item of this 

type 

nn 

Can Rsve (Y/N) Determines whether borrowers can make or request reservations 

for items of this type 

Y/N 

Rsve Qty Controls the number of reservations allowed by a borrower for 

items of this type 

Please Note: Maximum number allowed is set on Borrower Types 

screen – Max No. of Reserves column 

nn 

*End of (T) Term, (S) Semester and (Y) Year can be set in Main > Supervisor > Installation –Borrower 

tab.  The dates will need to be changed manually for a new period once the dates have expired. If the 

date has expired the loan will revert to a same day loan period. 

CODE DESCRIPTION 

H Hourly Loans 

O Overnight Loans 

D Daily 

T Term 

S Semester 

Y Year 

8. Select the F3 Save button when complete – the Loan Parameters and Borrower Types screen 

will close 
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9. To determine which fields are compulsory when entering borrower information, select the F8 

Validtn button – the Validation Rules for Borrower Types screen will display: 

 

10. Simply enter a Y or N into the corresponding column for each Borrower Type/Borrower Field 

combination 

11. Select the F3 Save button when complete 

Please Note: It is also possible to access the Loan rules table from the Stockitem module: 

1. In the Stockitem screen, select Application > StockitemForms (or StockitemStats) – the Form 

Codes (or Stats Codes) screen will display 

2. Select a Form (for example: BK – Books) or Stats Code (For example: AF – Adult Fiction) and 

select the F7 Loan button – the Loan Parameters and Borrower Types screen will display 

3. This screen displays in a Code/Bor Type matrix (rather than the Bor Type / Code shown in the 

Borrower module) 

Enter a New Borrower Type 

1. Launch the Amlib client 

2. Go to Main > Borrowers > BorrowerTypes – the Borrower Types screen will display: 

3. Select the F1 New or F2 Insert button 

4. Enter the parameters in the table 

5. Select the F3 Save button when complete – a prompt with the following message will 

display: You should now check Validation and Loan Parameters for any new or changed 

Borrower Types. 

 

6. Select the OK button 
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CIRCULATION 

The Circulation module controls the movement of stockitems within the system. 

Issues 

Please Note: Ensure that your default return date settings (see Appendix 6: Setting Default Dates and 

Holidays) and your Loan Rules have been properly set prior to commencing circulation operations. 

1. Launch the Amlib client 

2. Go to Main > Circulation > Issues – the Issues screen will display: 

 

3. Wand in the patron barcode (alternatively, you can type in the barcode and hit <Enter>) – 

the borrower details will then display (along with any previously issued items): 

 

4. If the borrower barcode is not known,: 
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a. Select the F4 Bor ? button to display the Borrower Enquiry screen:  

 

b. you can then perform a patron search: type in the Borrower details and select the F5 

Query button 

c. If there are multiple matches, select the borrower and select the F3 Choose button 

5. Once a borrower record is displaying, the Item box becomes active: wand in the first item to 

be issued – the item details will display with an arrow (     ) preceding it: 

 

6. Selecting in the Title/Author/Call No field shows the full Title, Author and Call No: 

 

7. Dragging on the column headings will also widen the view of the Title/Author/Call No field: 

 

8. To checkout additional items, simply wand the barcodes of the items to be issued 

9. If the item barcode is not known: 

a. Select the F5 Item ? button to display the Stock Item Enquiry screen:  
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b. You can then perform an item search: type in the item details and select the F5 

Query button 

c. If there are multiple matches, select the item and select the F3 Choose button 

10. If the Borrower has an item overdue when attempting to issue a new item: 

a.  A prompt with the following message will display: Warning – This Borrower has at 

least one Item that is XX days Overdue. Continue with Issue? 

 

b. Select the Yes button to proceed with the issue (otherwise select the No button) 

11. The number of items on Loan is shown as a count in the top right corner (the actual loans 

display if Show Items box is checked): 

 

12. Items on loan display in date Due Back order with overdue items appearing at the top (in red) 

13. If the borrower displayed in the Issues screen is inactive for a period of time and you attempt 

to issue an item: 
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a. A prompt with the following message will display: Are you sure the Borrower on the 

screen is still the proper Borrower – The Barcode has not been changed for a 

while? 

 

b. Select the Yes button to proceed with the issue (otherwise select the No button) 

14. Once the transaction is complete, select the F8 NewIssues button to print a receipt of the 

new items issued (alternatively, select the F9 Issues button to print a list of all items the 

borrower currently has out on loan) 

15. To issue items to another borrower, simply wand in the borrower barcode – this will 

automatically clear the current borrower details (there is no need to clear the screen first) 

Colour 

Colour is used to indicate certain loan statuses: 

 Red  Overdues 

 Magenta Reserved items 

 Black   Normal issues (not overdue) 

 

Messages 

Messages appear if an operator attempts to: 

 Renew or issue a reserved item 

 Issue a book to a patron with a status of Banned borrower 

 Issue too many items of a particular form type 

 Issue to a borrower who has exceeded their privileges 

 Item is not available for loan 

 Issue to a borrower who has overdues or owes money 
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Loan Options 

OPTION ACTION 

Renew  Renew an 

item 

Double-select on the Date Due for the item: If the Item is reserved a 

message will display (alternatively select the Items > Renew Item 

option from the menu). 

Renew All Select the F3 Renew All button; alternatively select the Items > 

Renew All option from the menu. 

Adjust 

Loan Date 

Dues 

Specific Date 

(for example: 

the Borrower 

is going on 

holidays) 

1. Highlight the item and select Items > Alter Selected Due 

Date from the menu – the Issue Due Date prompt will 

display: 

 

2. Type in the New Due date in dd/mm/yyyy format and select 

the OK button 

3.  To alter all the due dates for items on loan to the borrower, 

select Items > Alter All Due Dates In Table from the menu 

Alter Due 

Date (for 

example: to 

set a 1 day or 

1 week loan) 

1. Highlight the item and select the 1 Day, 3 Day, 1 Wk or 

4Wks button 

 

2. To add days onto the existing due date, highlight the item 

and select the = button (it will become a +) and then select 

the 1 Day, 3 Day, 1 Wk or 4Wks button 

 

Return From Issues 

screen 

1. Highlight the item and select Items > Return Item from the 

menu – this will take you to the Returns screen 

2. The item is now returned (it will appear with an X in front of it 

3. Select the <Esc> key to close the Returns screen 
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Item 

Details 

XRef to the 

Item 

Highlight the item and select Items > Item Details from the menu – 

this will take you to the Stockitem module with full details of item 

Borrower 

Details 

XRef to the 

Borrower 

Select Borrower > Borrower Details from the menu – this will take 

you to the Borrower module and show full details of the borrower 

Check 

Privileges 

To see 

Borrower 

allowances 

Select Borrower > Privileges from the menu: this shows how many 

items may be borrowed, how often they can be renewed (if at all) 

and the due date if a particular form type is issued to the borrower 

Print Options 

From the Print menu option, it is possible to report in various formats – for example: to list items on 

loan and reserved (using the F10 Statement button) or Print Overdues Only as required 

Off Line Circulation 

Off-line Circulation allows you to import your issues, returns or reservations from a dos file, created 

with the Offline Module. This is useful when the Server can’t be accessed (for example: there is a 

power failure where the server is, the IT dept. are “doing things” to the server). The Offline module is 

only available on PCs that have had the relevant programs installed (see separate guide) 
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Returns 

Issues 

Returns are available from the issue screen. 

1. Highlight the item and select Items > Return Item from the menu – this will take you to the 

Returns screen: 

 

2. The item is now returned (it will appear with an X in front of it) 

3. Select the <Esc> key to close the Returns screen 

Returns 

This screen should be used to return items when the borrower is present, as it is also possible to 

renew and reissue items. 

1. Launch the Amlib client 

2. Go to Main > Circulation > Returns – the Returns screen will display: 
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3. Wand in the item barcode into the Item field (alternatively, you can type in the barcode and 

hit <Enter>) – the borrower details will then display (along with any previously issued items): 

 

4. The item is now returned (it will appear with an X in front of it) 

5. If the item barcode is not known: 

a. Select the F5 Item ? button to display the Stock Item Enquiry screen:  

 

b. You can then perform an item search: type in the item details and select the F5 

Query button 

c. If there are multiple matches, select the item and select the F3 Choose button 

6. If you would like to reissue the returned item: 
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a. Simply double-select the returned item – the Issue screen will display 

b. The item will be reissued and then a prompt with the following message will display: 

The item has been successfully issued. 

 

c. Select the OK button, the Returns screen will display 

d. The item is now reissued (it will appear with an ✓ in front of it) 

7. If you would like to renew an item: 

a. Simply double-select the returned item – the Issue screen will display 

b. The item will be reissued and then a prompt with the following message will display: 

The item has been successfully renewed. 

 

c. Select the OK button, the Returns screen will display 

d. The item is now reissued (it will appear with an ✓ in front of it) 

8. To return items for another borrower, simply wand in the item barcode – this will 

automatically clear the current borrower details (there is no need to clear the screen first) 
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Chute Returns 

This screen should be used to return items when the borrower is not present. This screen does not 

display borrower information as you return the items and is therefore faster. 

1. Launch the Amlib client 

2. Go to Main > Circulation > Chute Returns – the Chute Returns screen will display: 

 

3. Wand in the item barcode into the Item field (alternatively, you can type in the barcode and 

hit <Enter>): 

 

4. The item is now returned 
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5. If the item barcode is not known: 

a. Select the F5 key on your keyboard to display the Stock Item Enquiry screen: 

 

b. You can then perform an item search: type in the item details and select the F5 

Query button 

c. If there are multiple matches, select the item and select the F3 Choose button 

 

Main Menu Returns Button 

It is possible to define whether the Returns button on the top menu bar, opens the Returns or Chute 

Returns screen: 

1. Main > Supervisor > Installation – Circulation tab: Display Chute Returns on the Main Menu 

is stead of Returns setting (Y/N) 
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Reservations 

The reservation process enables a patron who requires a particular item/s which is currently 

unavailable (or located at another branch), to request the item on its return. 

 The number of items that may be reserved by any given borrower are defined in the Loan 

Rules screens 

The Loan parameter record for that borrower and any Item form sets the number of items that can 

be reserved. 

Reserving from Stockitem 

It is possible to place a reservation on an item that has been searched for (and displayed) in the 

Stockitem screen: 

1. Launch the Amlib client 

2. Go to Main > StockItems > Stockitem – the Stockitem screen will display 

3. Locate an item by entering your search terms and selecting the F5 Query button: 

 
 

 

4. Once the full item details are displayed, Select Item > Reserve Item  
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5. On the Borrower Enquiry window enter borrower surname, given name or barcode and F5 

Query 

 

 
 

 

6. Double select on the exact borrower if you have performed a general search  

 

 

 

7. You may see a Borrower memo screen appear if memos exist for this borrower, which you 

close 
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8. Collect at location option displays - Select the preferred Collect At location and OK 

 

 
 

9. A popup will allow you to select if you reserve the first available copy or a specific copy.   To 

select the first available (recommended) select Yes to the popup (see note below to reserve 

a single copy) 

 
 

10. A confirmation message will be seen, select OK  

 

 

11. Select the OK button – reserved items will appear with an ✓ in front of them 
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From the Reservations Module 

1. Launch the Amlib client 

2. Go to Main > Circulation > Reservations – the Reservations screen will display: 

 

3. Wand in the borrower barcode or select the F4 key on your keyboard (or select Borrower > 

Borrower Search from the menu) to perform a Borrower Enquiry search – the borrower 

details will display: 

 

4. To search for items, select the F5 key on your keyboard (or select Items > Item Search from 

the menu) to perform an item search – the Stock Item Enquiry screen will display: 
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5. You can then perform an item search: type in the item details and select the F5 Query button 

6. A list of potential reservation items will then display: 

 

Reservations can be satisfied on an ANY or EVERY item basis for multi reserves. 

ANY Any item highlighted will satisfy the reserve and all others will be cancelled – for example: 

for multiple copies  

EVERY Every item highlighted will stay as reserved. None will be cancelled unless done so by the 

operator – for example: if reserving several items by the same Author or by Subject 

7. Satisfy On – select either the Any Item or Every Item option (most people select the Any 

Item option) 

8. To reserve the item/s highlight and select the F3 key on your keyboard (or select Borrower > 

Reserve Items from the menu) 

9. Select the OK button – reserved items will appear with an ✓ in front of them 

 

From Circulation 

1. Launch the Amlib client 
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2. Go to Main > Circulation > Issues – the Issues screen will display 

3. Wand in the borrower barcode or select the F4 key on your keyboard (or select Borrower > 

Borrower Search from the menu) to perform a Borrower Enquiry search – the borrower 

details will display: 

 

4. From them menu, select Borrower > Go To Reserve For Borrower – the Reservations screen 

will display: 

 

5. To search for items, select the F5 key on your keyboard (or select Items > Item Search from 

the menu) to perform an item search – the Stock Item Enquiry screen will display: 

 

6. You can then perform an item search: type in the item details and select the F5 Query button 

7. A list of potential reservation items will then display: 
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Reservations can be satisfied on an ANY or EVERY item basis for multi reserves. 

ANY Any item highlighted will satisfy the reserve and all others will be cancelled – for example: 

for multiple copies  

EVERY Every item highlighted will stay as reserved. None will be cancelled unless done so by the 

operator – for example: if reserving several items by the same Author or by Subject 

8. Satisfy On – select either the Any Item or Every Item option (most people select the Any 

Item option) 

9. To reserve the item/s highlight and select the F3 key on your keyboard (or select Borrower > 

Reserve Items from the menu) 

10. Select the OK button – reserved items will appear with an ✓ in front of them 

 

Checking or Cancelling Reservations 

Reserves can be checked from Borrower or Stockitem modules.  

1. On the Stockitem screen (with the item details displaying), select Item > CurrentReserves 

from the menu – the Stockitem Reservations screen will display: 
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2. On the Borrower Details screen (with the borrower details displaying), select Borrower > 

CurrentReserves from the menu – the Existing Reservations for Selected Borrower screen 

will display: 

 
 

3. The Stockitem Reservations list can be amended by changing the Queue (Q Pos) position – to 

jump someone in front of someone else, simply type in a number in the Q Pos field that 

places them before that person: 

 

4. Cancel a reservation: 

a. Highlight the reservation and select the F4 Cancel button – a prompt with the 

following message will display: Delete selected record. Are you sure? 
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b. Select the Yes button (to delete the reservation) or select the No button (to retain it) 

5. Change the Location pickup point: 

a. Highlight the reservation and select the F7 CollLoc button – a Collection Location 

prompt will display:  

 

b. Select the new pickup location and select the OK button 

6. Select the F3 Save button when complete 

Checking in an Item on Return 

1. Launch the Amlib client 

2. Go to Main > Circulation > Returns or Chute Returns – the (Chute) Returns screen will 

display 

3. Wand in the item 
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4. If the item has a reservation on it, a Reservations prompt will display: 

 

5. The following options are available: 

a. Select the Yes button to return the item (and Retain the reservation) 

b. Select the No button to return the item (and Cancel the reservation) 

c. Select the Cancel button to not return the item (and Retain the reservation) 

6. If you select the Yes button, a memo will automatically be generated for that Borrower, and 

a message alerting that the reserved item is available will display when the allocated 

borrower next loans an item 

7. A reservation slip (to place in the item) can be generated by selecting the F11 ResSlip button 

See the Reservations guide for full details of running reservation reports. 
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MANUAL CATALOGUING 

It is a good idea to search for a Catalogue to see if the item has been entered already, and just needs 

an Item attached. Searching for an Item can be done in Catalogue using the ISBN or in Stockitem (for 

example: Author or Title Search). The ISBN can even be wanded if the Barcode reader has been ISBN 

enabled. 

 

It is preferable to create a catalogue first and then create the holding record (Stockitem). If the 

Stockitem is processed first, not all the Tags are made when the Catalogue is created from the Item 

menu. For example: Subject Headings are not transferred across.  

Keywords are created through association with MARC tags – for example: a Subject keyword would 

apply to all tags defined from 600 through to 699: e.g. Topical term (650), Personal name (600), 

Geographic (651) etc. Therefore, when creating your entry, it is important to have a Catalogue 

record as well as a Stockitem because keyword searching will be important. 

There are three manual entry methods available: 

1. Work Sheet Method 

After choosing a template related to the form of the data (for example: fiction/non-fiction 

etc.) the required fields can be filled in. Authority listings can be accessed when appropriate 

(for example: for standard entry of Authors, Subjects, Publishers etc.). 
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2. Editing existing records 

It is possible to duplicate an existing record and alter the relevant data. 

3. New record from scratch 

No Lead Through method. Tags can be inserted and built up to create a full record. 

Please Note: Before beginning to use the Worksheet manual entry, you need to check the tags that 

will be automatically displayed. This is done in Main > Catalogue > CatLeadThruSets. 

Work Sheet Method 

1. Launch the Amlib client  

2. Go to Main > Catalogue > Catalogue (or the  icon) – the Catalog screen will display: 

 

3. From the menu, select Catalogue > Catalog Create – the Select Template prompt will display: 

 

4. Select on the button for an appropriate Lead Thru set – for example: Fiction – the Work 

Sheet will open with a number of pre-set MARC tags already displayed: 
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5. An item’s bibliographic details can now be entered – as you move through the Work Sheet, 

the headings (descriptors) change, so it is possible to observe the type of data required in the 

subfield of the tag 

o See: Appendix 7: USMARC: Some Common Tags for more information 

6. Where the data is, Authority based (for example: Author, Subject Heading, Series, etc.) a listing 

of Authorities can be viewed and selected – for example: to search for a particular Author, 

type the first few letters of the surname, highlight the row and double-select the row or select 

the F1 Check button 

 

7. The Existing Authority Options screen will open displaying all matching Authorities and the 

number of Catalogue records which use each Authority: 

Field Heading 
Subfield 
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8. To select an Authority in the table, simply double-select on it: the contents of the tag being 

checked will then change to match the selected Authority (the text will also change colour 

from black to green) 

 

↓ 

 

9. Once selected (or if there is no matching Authority), select on the red [ X ] to close the 

selection table (if there were no Authorities found the contents of the tag being checked will 

turn red, if there were Authorities found but none were selected the contents will turn pink) 
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10. To enter additional tags, select the F2 Insert button – the Select For Creation table will open 

(the pre-set tags allow for up to 40 entries): 

 

11. Find the required tag and double-select it to select it – a new entry with the selected Tag No 

will appear in the Work Sheet 

12. When the record is complete, select the F3 Save button 

13. If new Authorities are to be created, a prompt with the following message will display: Some 

new Authorities will be created. Continue with Save? (the new Authorities will be 

highlighted in red, so you can check them) 
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14. Select the Yes button – the Created Catalogue – Select Next Action prompt will display: 

 

15. If you intend to create your holdings immediately, then highlight the Create a Stockitem and 

select the OK button (alternatively you can select the Display the created Catalogue if you 

wish to review the actual Catalogue record) 

Adding Stockitems 

This section continues from the section above. If you don’t immediately choose to create a stockitem 

record, you can select XReferences > StockItems from the Catalog menu to initiate the process. 

1. A prompt with the following message will display: No Stockitems exist for the Catalogue. Do 

you wish to create a new Item? 

 

2. Select on the Yes button – a New Stockitem prompt will display with the following message: 

Please choose a Form Type for the new Stockitem  
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3. Choose the appropriate Form type and select on the OK button – the Stockitem main screen 

will enter creation mode (the F2 Insert button will appear bolded) and several fields will be 

pre-populated: 

 

4. Complete the other fields as required – for example: Stats Code, Current Cost, Floor 

location, etc. – to access a list of codes in a field select .<Tab>  

 

For example: in the Stats Code field, selecting .<Tab> will display a list of your Stats Codes 

and Descriptions – double-select on an entry to select it: 
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5. Scan in barcode in the Item No field (if you wish to create a system-generated barcode, leave 

this field blank) 

6. Select on the F2 Insert button when complete – a prompt with the following message will 

display: The Item has been Inserted. 

 

7. Select the OK button 

 

Multiple Copies 

To enter multiple copies of the same catalogue item: 

1. Scan in a new barcode into the Item No field – the F2 Insert button will once again become 

active (bolded) 

2. Change any other details as required – for example: Stats Code, Copy No and Floor location 

3. Select the F2 Insert button when complete 
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IMPORTING NEW ITEMS 

Most sites download their Catalogue data (from places like SLOWA and SCIS). Amlib stores the data 

in USMARC format, which is now the international standard. This is made up of hundreds of MARC 

Tags, which identify data. In the same way that Dewey numbers become familiar, common tags 

become known. 

SOME COMMON 

TAGS 

DESCRIPTION 

020 ISBN 

082 Dewey classification number 

100 Personal name main entry (usually author) 

245 Main title 

260 Publication information 

300 Physical description 

440 Series 

500 General notes 

520 Summary 

650 Subject headings (Topical) 

700 Personal name (Added entry) 

856 Electronic location and access (URL) 

Import MARC Catalogue Data  

There are generally four main stages in the download process. 

 

 

 

 

  

DATA 
Download
ed from 
SCIS or 
sent from 
SLOWA 
etc. 

NEW RECORDS 

Check the new data  

 Stockitems: adding 
barcodes, supplier, 
checking location 
etc. to items in file 

 Catalogues 

 Authorities 

HOLDING FILE 

Loads the data 

to the Screen 

for checking 

UPDATE 

[F3] begins the 

updating 

process after 

setting the 

defaults 
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Accessing the Data for the Download 

1. Launch the Amlib client 

2. Go to Main > Authorities > MarcTakeUp (alternatively use Ctrl + M) – the Marc Import 

screen will display: 

 

3. Select the F1 Open button to display the Open dialogue box 

4. Locate the file to be processed by using the Look in: drop-down box – for example: if the file 

is on the C: drive, the Look in: box may say Local Disk (C:) 

5. Once the file name has been located, use your mouse to select it and select on the Open 

button 

There are two processing options: Bibliographic Data or Authority Data – this guide covers the 

import of Bibliographic Data. 

Bibliographic Data 

This option is to load records which are Bibliographic Data in machine readable format which can be 

imported into Catalogue, Authority and Stockitem (where appropriate) applications of Amlib. 

1. The Marc Import – Open screen will display: 

 

Please Note: If the Import file (Bibliographic or Authority) contains more than 9999 records, it is 

recommended that Open and Update is selected (ticked) so that all records can be loaded into the 
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database. This eliminates the need to load in sections. The maximum records that can be viewed in 

the Holding file is 9999 records.  

HEADING FIELD EXPLANATION/OPTIONS EXAMPLE 

Marc Options Bibliographic 

Data 

Bibliographic data to be created 

for the Catalogue. 

Data from external 

source (for example: 

SCIS, SLOWA, Kinetica 

etc. with USMARC Tags) 

Authority Data Authority data for creation or 

updating of Authority Headings 

and/or cross references. 

See and See Also Update 

from SCIS or other source 

Update the database 

without viewing the 

Marc records 

Open and 

Update 

If checked (ticked), the imported 

items will not display in the 

Holding file.  

The Catalogue will be 

Updated immediately 

If unchecked (unticked), the 

imported items will display in 

the Holding file.  

Review records 

The Catalogue will not be 

updated until the F3 

Update button is 

selected 

Load Range All All records from the file are 

downloaded into a holding file. 

All 

Range Selected records from the file 

are downloaded into a holding 

file. If Range is selected, the next 

2 fields must be updated. 

For example, 1 to 50 

2. Complete the options using the above table: 

a. Marc Options = Bibliographic Data 

b. Open and Update = ticked, unless you want to review each individual MARC record 

c. Load Range = All (unless the file sizes are quite large) 

3. Select on the OK button 
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Bibliographic Options 

1. The Bibliographic Options screen will display: 

 
 

HEADING FIELD EXPLANATION/OPTIONS EXAMPLE 

Marc Details We think the file 

contains 

The data type is displayed  

Standard format 

SCIS 

ABN  

 Total Bibliographic 

records 

The number of Bibliographic 

records will display 

32 

Total Authority 

records (this will only 

display if the import 

is for Authority 

headings) 

The number of Authority headings 

with See/See Also references will 

display 

0 
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2. Select the appropriate Each bibliographic record contains setting: 

Each Bibliographic 

record contains: 

Catalogue data only The system will determine the 

contents of the import file. If only 

Catalogue data exists in the file, 

this will be the Default option.  

SCIS Data 

 

Full Catalogue & 

Stockitem data 

The system will determine the 

contents of the import file. If both 

Catalogue and Stockitem data 

exists in the file, this will be the 

Default option.  

Please Note: This item can be 

selected to create “Dummy” 

Stockitems even though only 

Catalogue Data exists in the Import 

file. 

SL OF WA Data 

Brief Catalogue and 

Order data 

The system will determine the 

contents of the import file. If only 

brief Catalogue data and Order 

data exists in the file, this will be 

the default option. 

AOL Data 

When displaying, 

the records 

show: 

All tags in the file All tags from the Import file will 

display in the Holding file for 

viewing. However, tags not defined 

in Amlib will not load into the 

Amlib Catalogue unless the Marc 

tag is defined. 

If Tag 650v is not used 

in Amlib it WILL still 

display in the Holding 

file. 

 

Only tags defined in 

Amlib 

Only tags used in Amlib will display 

in the Holding file.  

If Tag 650v is not used 

in Amlib it will NOT 

display in the Holding 

file. 
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3. If the Marc Details are set to import Full Catalogue & Stockitem data, the Item Default and 

Item Prices sections will also display: 

HEADING FIELD EXPLANATION/OPTIONS EXAMPLE 

Item Defaults 

Please specify 

default values 

for each item in 

the fields below 

Form The default values set in the Main 

> Supervisor > Installation > 

Stockitem tab will display if 

defined.  

If these fields are not yet defined, 

codes which will apply to the items 

can be entered. Rules for 

automatic entries of Form and 

Stats codes depending on the Tags 

that are imported, and be set in 

Cat Defs in the Stockitem Form and 

Stats codes. 

If during the Import, 

Cat definitions cannot 

be created, each 

Stockitem will have a 

default Form of BK 

(for example) 

 

Location CHELSEA 

Lib Group LIBRARY 

Stats Code ANF 

Floor Loc (optional) DISPLAY 

Process (optional) IN PROCESS 

Item Prices Minimum price of an 

item 

If the item price in the Import file is 

less than the price set here, enter 

the Minimum price 

The Import price is 

$8.00 but the 

Minimum price set 

here is $10.00, the 

price in the Stockitem 

will be $10.00 

 

Appreciate items by 

% 

Items can be appreciated by a 

percentage – for example: GST of 

10% 

10% 

Depreciate old 

stockitems 

Items to be depreciated will be 

dependent on the table set in 

Stockitem > Application > Stats 

Group 

 

Use average prices if 

no price 

Items will be given an average 

price, set in Stockitem > 

Application > Stats Group. If no 

price is entered in the Import File 

 

4. Select the OK button once you have completed modifying your settings 

Please Note: Form and Stats Code defaults from the Main > Supervisor > Installation > Stockitem 

tab display automatically in the fields. If there are no defaults entered, the field will be blank. 

Location displays as the Login Location. Entry of these fields is optional.  As the import of data is 

processed, the Stockitems will be given the default values if there are no catalogue definitions for the 

Form or Stats codes of the items. Form and Stats Code Cat definitions are found in Main > 

StockItems > StockitemForms or StockitemStatsCodes table for the particular code. 

Reviewing Records to be Imported (Optional) 
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It is possible for the importer to review (and edit) the MARC data being imported. 

1. If the importer has decided to review the records being imported (see Bibliographic Data 
step above), the Marc Import screen will display: 

 

2. If you do wish to edit the data (prior to import), use the editing buttons on the right to 
change or delete the individual tags 

Please Note: Editing of the data prior to import is not essential. Changes can be made after 
the data has been imported into the Catalogue. Remember that not all the tags will 
necessarily be Imported, so if editing is considered necessary, change only the tags you know 
will be imported! 

3. Use the F7, F8, F9 and F10 buttons to move between records 

4. Once the data has been reviewed, select the F3 Update button 

Find 

It is possible to use the find function to locate any matching text, tag number or specific Subfield in 

the Holding File data being displayed. For example: use this facility to check all Author entries or 

Subject headings. 

1. From the main menu, select Window > Find – the MarcImport - Find screen will display: 

 

2. Type in the Tag, Subfield or String to find and select the Find Next button 

3. It will then find any matching data in the record currently being displayed: 
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Catalogue Update Options 

1. The Update Options screen will then display, allowing you to select the Cat(alogue) and 

(Stock)Item Options: 

 Cat Options: When an incoming Catalogue is match with an existing Catalogue 

 Item Options: When an existing Catalogue is replaced all existing items 
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PARAMETER FIELD EXPLANATION 

Cat Options 

When an 

incoming 

Catalogue is 

matched with 

an existing 

Catalogue: 

Display an IGNORE/REPLACE 

message 

A message will display at each match occurs. At each 

match, the operator will get a choice to create a new 

catalog, replace the existing or to keep the existing details.  

Keep the existing Record ie NO 

UPDATE 

No Update occurs for the Catalogue 

Add Authorities but Replace Non-

Authorities 

Does not replace existing Authorities but adds new 

Authorities to the record. However, it replaces any Non-

Authority data from the Import 

Replace the existing Catalogue 

ENTIRELY 

All tags from the Import are used, overwriting any existing 

data 

FIELD OPTION EXPLANATION 

Replace all 

tags EXCEPT: 

 

Don’t delete the 

following tags 

from the 

existing 

catalogue e.g. 

650,700 

This will vary according to the setting in Main > Supervisor 

> Installation > Catalogue tab:  

 MARCImport Replace: don’t delete these tags 

from the existing cat 

 MARCImport Replace: don’t import these tags 

from the existing cat 

Adds non-identical tags when importing all but specified 

Tags. Existing data in the specified Tags remains 

unchanged 

 

Don’t import 

the following 

tags from the 

incoming 

catalogue e.g. 

650,700 

Adds non-identical tags when importing. Does NOT import 

the new data in the specified Tags. Existing data in the 

specified Tags remains unchanged 
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PARAMETER FIELD EXPLANATION 

Item Options  

When an 

existing 

Catalogue is 

replaced, all 

existing 

Stockitems: 

Keep their current display No existing Stockitems are refreshed – they remain the 

same 

Are refreshed from the Catalogue All existing Stockitems are replaced by the new Catalogue 

details 

Are refreshed except lines: 

e.g. 1,5,6 

Enter the line numbers to be retained – for example: 6 

(Line 6, which is usually Call Number). Line numbers 

correspond to the 6 lines of Stockitem display (for 

example: Line 1 is usually Title, Line 2 Author etc.) 

FIELD OPTION EXPLANATION 

Please choose 

the location to 

use when 

matching an 

order 

Exact Only order items where location is the same as the 

current Amlib location will be candidates for replacement 

Any Stockitems on the file may replace any order item on the 

database 

Only create 

stockitems 

Checked The import of data will result in no Catalogue records 

being created. Only Stockitems will be created. 

Unchecked 

(Default) 

Create Catalogue records as well as Stockitems 

2. Enter the options you would like, then select the OK button – the Saved Files screen will 

display: 

 

3. Type the names of the files into which all the newly created Catalogues, Authorities and/or 

Stockitems will be saved (if you do not want to check new items – for example: Authorities, 

do not enter a filename) 

4. Select the OK button 

HINT: These files assist in finding the newly created Catalogues, Authorities and/or Stockitems after 

the import. The Filenames are created so that you can identify the file later. A suggested Filename 

could be the type of data – for example: SCIS or EXCHANGE, the date and the initials of the staff 

member processing the data. 
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5. If confirmation of duplicate items has been requested in the parameters, a Catalogue Match 

screen will display every time a duplicate item is found: 

 

6. Are the above two records the same? Select the Yes, No or Replace button 

OPTION EXPLANATION 

Yes The catalogue entry that exists on the database will remain as displayed in the top box. 

A new Stockitem would need to be added if appropriate. The imported record will not 

be included in the New File created for Catalogue or Authorities 

No A new catalogue will be created with the data from the Imported data being used for 

the new catalogue record. The imported record will be included in the New File created 

for Catalogues or Authorities 

Replace The existing catalogue entry will remain but the data will be replaced with the data 

from the imported recorded. The imported record will not be included in the New File 

created for Catalogue but there may be some additions to the Authorities file 

7. An Update prompt will display, indicating the progress of the import: 

 

8. When the update is finished an Update, prompt will display, showing the number of records 

Updated: 
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9. Select the OK button 

10. You will be able to view the log by selecting the F6 Log button 

F6 Marc Log 

This log lists any errors that were experienced in the process of importing the file and also what 

action was taken with certain items. Most of the errors that display in the log are caused by the tag 

numbers not being defined on the Amlib database. This may be because we did not wish to use them 

in the Catalogue data but were present in the data file. 

Checking New Stockitems 

1. Launch the Amlib client 

2. Go to Main > StockItems > Stockitem – the Stockitem screen will display 

3. From the menu, select File > DisplayFile – the Stockitem Saved Query Results screen will 

display: 
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4. Highlight the file you wish to access and select the F9 Select button – a Stockitem List of the 

imported items will display: 

 

5. You can now check to ensure that the item details are correct 

6. Double-select the first entry – the selected item will display in the Stockitem screen 

7. Add the correct Item No (barcode), Current Cost, Sts Code, Form code, Origin/Source (if 

required) and generally check other details 

 

8. To access a list of codes in a field select .<Tab>  

For example: in the Stats Code field, selecting .<TAB> will display a list of your Stats Codes and 

Descriptions – double-select on an entry to select it  

9. Select on the F3 Update button when complete – a prompt with the following message will 

display: The Item has been Updated. 

 

10. Select on the OK button 

1. Add 

Barcode 

2. Check 

Form and 

Stats codes 

3. Check 

Location 

5. Add correct 

price (do not 

add $ sign) 

4. Add 

Origin/Source 

(supplier) if 

required 

6. Add/remove any 

other relevant 

information 
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MODIFYING CATALOGUE DETAILS 

1. Launch the Amlib client  

2. Go to Main > Catalogue > Catalogue (or the  icon) – the Catalog screen will display: 

3. Initiate a F5 Query to locate the Catalogue record that requires editing (alternatively, if the 

item record is open in the Stockitem module, select XReferences > Catalogue) 

 

Modify Using the Work Sheet 

It is now possible to edit an existing catalogue record using the Catalogue Work Sheet. 

1. From the menu, select Catalogue > Catalog Modify using Worksheet – the Work Sheet 

screen will display: 

 

2. The catalogue record can then be edited/modified in the same manner as a new Catalogue 

record 

Field Heading Subfield 
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3. Existing Authorities cannot be altered in the Work Sheet – if a new Authority is to be created 

(for example: one with a different subdivision), then the F2 Insert button should be used to 

enter it on a new line to that of the existing heading (the existing heading can be retained or 

removed using the F4 Delete button) 

Insert 

Inserts a new Tag for the Bibliographic record.  

This process will be different depending on whether the Tag chosen from the list is an Authority or 

Non-Authority Tag.  

 

1. Select the Insert button on the right-hand side of the screen – the Select For Creation table 

with a list of Tag Nos will display: 

 

2. Double-select on the desired Tag 
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Insert Non Authority Tag 

1. If the selected Tag is a Non-Authority – the SubFields window will display: 

 

2. Please ensure you enter the correct data into the correct subfield – selecting the F6 Table 

button gives the Valid SubFields/Parts table available for that Tag: 

 

3. Once the data has been correctly entered select the F3 Update button 

Insert an Authority Tag 

1. If the selected Tag is an Authority – the Authority Replace screen will display: 

 

 Notice the Green colour of the list (in this example: a 650 - Subject Heading)? This is because 

the headings shown come from the Authority module 
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2. Type in a Search Term (for example: Fantasy) and select the F5 Query button – a list of 

matching terms will display: 

 

3. If the correct term is in the list:  

a. Highlight the term and select the F3 Replace button 

b. The Authority Replace window will close and the selected Authority will appear in 

the catalogue record 

4. If the correct term is NOT in the list or your search gives no results: 

a.  Select the F2 NewAut button – the SubFields table will display: 

 



Amlib Introductory Training 

 

 

Last Updated: 25 February 2013 
 Page 95 

b. Please ensure you enter the correct data into the correct subfield – selecting the F6 

Table button gives the Valid SubFields/Parts table available for that Tag: 

 

c. Once the data has been correctly entered select the F3 Update button 

d. Select on the red X in top-tight corner to close the Authority Replace screen – the 

new Authority will have been added to the catalogue record: 

 

Once the Authority has been entered, it is available for use in subsequent catalogue records. 
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Replace 

Replaces the Tag data with an alternative heading. 

1. Highlight an Authority to be replaced 

2. Select the Replace button on the right-hand side of the screen – the Authority Replace table 
will display with highlighted Authority: 

 

3. Type in a Search Term (for example: Wizards) and select the F5 Query button – a list of 
matching terms will display: 

 

4. If the correct term is in the list:  
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a. Highlight the term and select the F3 Replace button 

b. The Authority Replace window will close and the selected Authority will appear in 

the catalogue record 

5. If the correct term is NOT in the list or your search gives no results: 

(Please Note: this option NOT available if User settings have been set to DISABLE 

modification of Authorities in the catalogue screen – the Insert button should be used to 

create a new Authority and the existing Authority removed from the record using the Delete 

button) 

a. Select the F2 NewAut button – a prompt with the following message may display: 

Creating an Authority replaces the existing Authority. Continue? 

 

b. Select on the Yes button – the SubFields table will display: 

 

c. Please ensure you enter the correct data into the correct subfield – selecting the F6 

Table button gives the Valid SubFields/Parts table available for that Tag: 

 

d. Once the data has been correctly entered select the F3 Update button 
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e. Select on the red X in top-tight corner to close the Authority Replace screen – the 

new Authority will have been added to the catalogue record: 

 

If the heading to be replaced is not found, a new Authority can be created. This only replaces the 

existing Authority in this particular item. 

Modify 

Please Note: It is possible to update User Name security so as to DISALLOW the editing of Shared 

Authorities using the Modify button. This helps ensure the integrity of the Shared Authorities (which 

may be in use in other Catalogue records). Authorities can then be modified by XReferencing to the 

Authorities module. 

1. Highlight the Tag to be modified and select the Modify button on the right-hand side of the 

screen – the Tag will open in the SubFields screen 

WARNING: If the tag is an Authority, changes will be made to ALL Catalogue records using this 

Authority. BEWARE! 

 

2. Make the changes 

3. Select the F3 Update button when complete 
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Delete 

Deletes a highlight tag (for this record only – does not affect other Catalogue records or any 

Authorities previously created). 

1. Highlight the Tag to be deleted and select the Delete button on the right-hand side of the 

screen – a prompt will appear with the following message: Delete Current tag. Are you sure? 

 

2. Select the Yes button 

3. The Tag will be deleted 

Hide/Show 

Alternates between hiding/showing tags for this record.  

1. Select on the Hide button on the right-hand side of the screen to hide the Tags in the 

displayed record (Hide will then be replaced by Show) 

2. Select on the Show button on the right-hand side of the screen to show the Tags in the 

displayed record (Show will then be replaced by Hide) 

Please Note: Show must be selected to enable the Duplicate Button. 

Movement of Tags 

1. Highlight the Tag to move and use the arrow keys to move the Tags up or down 

 

Please Note: This sequencing possible within the record depends on what is set in the Main > 

Supervisor > Installation - Catalogue tab: Allow tags to be sequenced anywhere within a catalogue 

(Y/N) parameter. 
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 If it is left at the default Y, staff will be able to use the up and down arrows on the Catalogue 

record to reposition any MARC Tag within that record 

 If it is changed to N, this will then restrict the ability for adjusting the sequence of a MARC 

tag in a specific record to its specific range only. This means that if there is only one MARC 

tag to that record it cannot be moved, but if there is more than one MARC tag, for example 

subject headings, then these can be moved within this group only 

Catalogue Record Created / Last Edited Information 

For newly created (and imported) Catalogue records it is now possible to tell which user created a 

record, and who it was last edited by.  The top line shows when the record was last edited, and the 

bottom line remains the same, showing when the record was created.  This information is not 

retrospective so that for all existing records, only the user, date and time for the last update will be 

shown. 
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MASS DELETION OF STOCKITEMS/SAVING TO FILE 

Items can be deleted easily from a Saved File. These items can be wanded into the File. This is useful 

for Public Libraries who must return items to SLWA, and who want to delete them from their 

catalogue. It is also useful for schools when a weed of resources is performed (for example: after a 

Stocktake). 

This can be done individually within the Stockitem module by calling up the item and selecting the F4 

Delete button. If it is the last copy for the Catalogue, you will be prompted to delete the Catalogue 

entry as well. 

Items can be deleted en masse from a Stockitem List (each item that is to be deleted needs to be 

highlighted) or alternatively from a Saved File. 

 See: Appendix 2: Saved Files for more information 

Stockitem List 

1. Launch the Amlib client 

2. Go to Main > Stockitem > Stockitem – the Stockitem screen will display 

3. Initiate a F5 Query or Stockitem Where search to bring up a list of items to be deleted 

(alternatively, you may decide to use a Saved File as the basis of your deletions – select File > 

Display File > select a saved File > F9 Select) 

 

4. Highlight the items to be deleted 

5. From the Stockitem List main menu, select Table > Mass Item Deletion – the Mass Delete 

Items screen will display: 
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6. Add a tick in the Catalogue: Delete Catalogue if Last? box 

7. Select the OK button – the following prompt will appear: 

 

8. Select the Yes button 

9. The items (and any associated Issue Catalogue records) will be deleted 
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Z39.50 SEARCHING 

Z39.50 is an international information retrieval standard that enables communication between 

computer systems, including those that operate on different hardware and use different library 

software (for example: Amlib, Spydus, Symphony, etc.). Searching of other libraries and databases is 

performed simultaneously in a single search (parallel searching). 

Schools can use the Z39.50 facility link to SCIS. You will need to contact SCIS directly to get your IP 

address authorised and they will supply the SCIS z39.50 details so that you can set them up as a 

Z39.50 Server.  

 See the Catalogue manual for details on how to set up new Servers and new Groups 

Please Note: Use of the bibliographic records via Z39.50 is subject to the terms and conditions of the 

source library. 

Amlib Z39.50 Client 

1. Launch the Amlib client  

2. Go to Main > Catalogue > CatZSearch – the Z39.50 Search screen will display: 

 

3. Select the F5 Query button – Query screen will display: 
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4. Select the Server or Server Group from the Available Servers drop-down box – for example: 

Public Libraries 

5. Type in the Search Attributes – for example:  ISBN, Title, Author, Subject or combination of 

these 

6. Select the OK button – the results will display in the main Z39.50 screen: 

 

7. The columns can be sorted by selecting any of the column headings 

8. Save selected records to a MARC file for import: 

a. Highlight the records (hold the Ctrl key and select on records to highlight more than 

one record) 

b. Select the F4 Import button – the Import method screen will display: 

 

c. Select your import option: 

 Select the Yes button: Save the Marc file and then import it 

 Select the No button: import directly (not all import options will be available) 

 Select the Cancel button: Cancel the import 

d. The highlighted records will be saved to a MARC File shown in the dialogue box, to 

be imported into Amlib via MARC Takeup 
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e. The MARC Takeup process will begin automatically – ensure the folder is the correct 

folder – for example: My Documents 

Please Note: Please refer to Import MARC Catalogue Data: Bibliographic Data for details of the 

remainder of this process. 
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REPORTS 

Reporting and printing can be performed from: 

 Report module is accessed from the icon  or main menu 

 Report/Print buttons on most screens 

 Selecting the [F12] function key at any time can access screen prints. 

 Capture the current window/dialogue box by using Alt + PrtScn. This can later be pasted into 

another application – for example: MS Word 

 Print an entire screen by using PrtScn. This can later be pasted into another application – for 

example: MS Word 

 Selecting a Table report for a file accessed in for example, Stockitem or Borrower. This is 

useful for getting reports for New Accession Lists, A print out of holdings for a particular 

Form code or Stats code (for example: All videos, All Big Books etc.) or Class Lists, etc. 

Reports Module 

Reports are used for every conceivable purpose within Amlib, from printing up tables and updating 
borrower records to printing out overdue notices. 

It is possible to create and run a huge variety of reports covering every single module. In addition, it 
is possible for you to customise these reports in both their design and functionality. 

The creation of a report is covered in broad terms by the following flowchart: 

 

 

 

  

Template 
Design and Function 

Create Report 
Report selection and description 

Data 

Search conditions and parameters 

Files with .QRP 

extension 

Created/edited 

 in Report Writer 

(REPWIN30.EXE) 

Determined by Where 

parameters or by 

selecting a Saved File 

Report Type 
Matching template to module and function 

Order 

Sequencing the results  

Results 

View/printing results  
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Templates 

Whenever Amlib prints, emails or saves a file, it uses a template to determine what should and how 
it should be printed. What is “printed” by the template is determined by a number of factors: 

 Fields in Template – for example: Name, Address, Item No, Title 

 Report Module Category – for example:  Circulation Reports 

 Template Type – for example: Email 

 Where Statement – for example: Borrower Type = A (for Adult) 

Standard System Report Templates 

These are the templates with an ampersand (&) at the beginning of the file name – for example: 

&ODEMAIL.QRP (Overdue Email Notice). They are loaded into the Amlib Reports module and may 

be renamed – without the ampersand (&) – if you alter the content/format of the report template.  

 Please Note: It’s a good idea to note any templates that you have customised (but not 

renamed) and keep them backed up as they will be overwritten during an upgrade.  

Table Report Templates 

These are the templates with a dollar sign ($) at the beginning of the file name – for example: 

$BOTYPES.QRP (List of Borrower Types) They are generally hard-coded into individual Amlib modules 

and cannot be renamed. You may, however, alter the content/format of the report template. 

 Please Note: It’s a good idea to note any templates that you have customised and keep them 

backed up as they will be overwritten during an upgrade. 

Report Types 

REPORT ENTITY TYPES 

Account 

Authority 

Bibliographic 

Borrower 

Catalogue 

Circulation 

Financial 

Inter-Library Loan 

Periodical 

Reservation 

Statistics 

Stockitem 

Where Statements 
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These are the set conditions that the report uses to determine the data to be sent from the database 

to the report template. In general, they are just search terms – for example: All borrowers, all 

borrowers except library staff, members at particular locations, etc 

A good way of getting familiar with Where statements is to perform Where searches in the Borrower 

and Stockitem modules (see below). 

1. Highlight the report in the Reports table and select on the F7 Where button – the Reports - 
Where window will open 

 

2. You can then enter one or more search conditions: 

a. Choose Search column: The options differ between Report Categories and Report 

Types. If you’re not sure which of these is the correct one, it can help to have a look 

at the corresponding module screen you want to get information from – for 

example: The Borrower screen 

b. Choose operator – select from the following list: 

OPERATOR DESCRIPTION EXAMPLE 

LIKE Where the required data in this field 

begins with the text entered 

LIKE ELD (for Eldorado) 

LIKE Where the required data in this field does 

not begin with the text entered 

LIKE ELD (for all except Eldorado) 

IN Useful for selecting multiple codes IN A,J,YA (for all of these types) 

IN Useful for multiple codes not to be 

included 

IN ILL,LS (to exclude these types) 

= Where the text entered is exactly equal to 

the data required 

= A (borrowers with a code of A for 

Adult) 

 Where the text entered is not equal to the 

data required 

 J (borrowers who do not have a 

code of J) 
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Useful for NOT EQUAL TO NULL – choose 

this operator, do not enter any data and 

select the Paste button 

< Where the text entered is less than the 

data required 

< 01/10/10 (less than 1 Oct 2010) 

< Where the text entered is equal or less 

than the data required 

< 01/10/10 (less than or equal to 1 

Oct 2010) 

> Greater than >01/10/10 (greater than 1 Oct 2010) 

> Equal or greater than the text entered > 01/10/10 (greater than or equal to 

1 Oct 2010) 

c. Type the WHERE condition - this could be letters, numbers, dates, codes, etc. (see 

also the Special button below) 

 

d. Once you have entered the Where (or Search) condition, select the Paste button – 
the condition will be added to the table at the bottom of the window 

 

3. You can then add in further conditions: 

 Join conditions together using the AND and OR Boolean operands buttons 
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 Delete unwanted items by highlighting the line and selecting the Delete button 

4. Select the F3 Save button when complete 

Sample Circulation (Overdue) Report 

1. Go to Main > Reports > RepCirculation – the Circulation Reports screen will display 

2. Select the F1 New button – the Select Report Format screen will display 

3. Highlight an overdue template (for example: Overdue List by Class (with page break) – 

&ODLSTOC.QRP) and select the Select button 

 

4. Type in a Report Description – for example: Class Overdue List 

5. If you would like the borrower record to retain a record of any notice sent, then ensure that 

Create Hist (Y/N) = Y 

6. If there are replacement costs involved, ensure that the Create Acct (Y/N) = Y 

7. Select the F3 Save button 

 

Where Statement 

5. Highlight the report in the list and select on the F7 Where button – the Circulation Reports – 

Where screen will display 

6. The statement must include the following settings: 

a. Issue Date Back < Current Date (via Special button) – this can be altered to suit your 

particular needs 

b. Additionally, you may wish to limit by Borrower Location, Type, Group and Class 

c. Select on the F3 Save button when complete 
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Order 

1. Select the report from the list and select on the F9 Order button – the Circulation Reports – 

Order By screen will display 

2. Use the arrow keys to select fields to Order By – for example: Bor Class 

3. Select on the F3 Save button 
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View Report 

When your report is set up with the template, Where statement, and order, you can then preview 

the report as follows: 

1. Highlight the report and select the F8 View button 

2. The Select File for View prompt will display with following message: This type of report may 

use a Saved File as the Source. Do you want to select the file now? (rather than the entire 

database) 

 

3. If you would like this report to use just a Saved File, select the Yes button, otherwise select 

the No button (generally users select the No button) 

4. The report will open in the Report – View screen: 

 

5.  If you wish to print a hardcopy, select on the print icon 
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NETOPACS 

Amlib NetOpacs allows access to your database via the internet or intranet (networked computers). 

This is a dynamic access method where data is accessed in real time. It is possible to allow 

reservations and/or renewals via the NetOpacs.  

Available options can be viewed on our NetOpac sample window at:  

 http://amlibsupport.oclc.com.au/netopacs/index.htm [ no longer available]  

The path of your NetOpacs pages is displayed in the Main > Supervisor> WebParams screen. It is 

necessary to recompile the NetOpacs after any changes to the Opac or WebParams settings in Amlib. 

Please Note: NetOpacs can usually be displayed from your internet browser by typing the address: 

http://servername/amlibweb/webquery.dll?   

The servername will vary from site to site. For example: if the servername was libserver the path 

would be http://libserver/amlibweb/webquery.dll? 

 NetOpacs make extensive use of hyperlinks: a hyperlink is a "hot spot" that allows you to 

jump to another location 

 The Main Menu will vary depending on the Search options – for example: Periodicals, Hot 

Topics, etc. 

 

  

http://amlibsupport.oclc.com.au/netopacs/index.htm
http://servername/amlibweb/webquery.dll
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 Author and Subject generally display an interim (Authorities) Search Result list where the 

matching Authorities will display first, and then the Stockitems displayed after selecting on a 

link: 

 

An Item List will display the Loan Status of each item: 
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 Select on the Title link text to see the full details of each Bibliographic record: 

 

 

 The Main Menu can provide a facility to view Borrower’s own loan information, including 

current loans, reservations and past loans. 

 To view these details the Borrower must enter their personal Barcode number and select 

enter. If required a PIN can be entered as extra security. If a PIN is entered in the Borrower 

Details screen in the Amlib Borrower module for a particular borrower, then this must be 

entered to view these details: 
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MAINTAINING THE SYSTEM 

Most of the maintenance of the system is incorporated into the Backup (e.g. Indexing, clearing logs).  

Backing Up Your Database 

 SQL Server and Oracle installations should have a Database Maintenance Plan and logs of the 

backups should be checked regularly 

 The backup process indexes the database and deletes unnecessary logs 

 We have documents on recommended Database and Backup Maintenance Plans (ensure 

your IT has a copy of this) 

Backup to External Device 

We rely on you to implement a backup maintenance plan in order to reconstruct lost or altered 

Customer files, data or programs. We also need you to implement a database maintenance plan to 

ensure that the Relational Data Base Management System (RDBMS) is operating at optimal levels.  

If there are problems with either the date or error messages in Backups or any questions about 

creating backups please contact Support for further advice as soon as possible. 

 Ensure the Databases are backed up to an external device – for example: Tape 

 Ensure the Logs of the Tape Backup are checked to ensure it was successful 

 Consider the restore capabilities from that Backup device – can the Tape be read by other 

Tape Drives to enable a restore of the data? 

 Consider backup onto an alternative Backup device – for example: a CD-R regularly as double 

insurance  

 If you have any queries about backup do not hesitate to contact Amlib Support 
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APPENDICES 

Appendix 1: Setting Up Usernames and Permissions 

It is possible to create to create user-specific logins for the Amlib client which can then be configured 

to allow access to only certain modules, screens, menu items and buttons. 

View Existing Usernames 

1. Launch the Amlib client 

2. Go to Main > Supervisor > UserNames – the User Names table will display: 

 

3. A list of existing Usernames will be visible with the following settings: 

FIELD EXPLANATION 

User Name This is the User Name used when logging onto the Amlib client 

Location The default location that displays when the User logs into the Amlib client (the 

user may select a different location 

Circ at this Location Only 

(Y/N)  

Y Can operate Circulation only at the location specified in the Location 

field 

N Can operate Circulation at all Locations within the system 

Level An indication of the user’s permissions levels setup. Some of the tasks on the 

system can also be limited using User Level (for example: Attachment security 

level, default Authority security level, etc.), although it is rarely used. 

Enter a New User 

1. Select the F1 New or F2 Insert button – a new entry will appear in the table 
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2. Type in the following: 

a. User Name – use one word only (for example: CHRIS or CHRISW) 

b. Location – the default login location of the user 

c. Circ at this Location Only – Y or N 

d. Level – the level against a User is used only as a guide 

 

3. Select the F3 Save button – the Operator Password screen will display: 

 

4. Type in a Password and Confirm Password 

5. Select the OK button when complete 

6. Close and restart the Amlib client to allow the new User Name to come into effect 

Resetting User Passwords 

1. Launch the Amlib client 

2. Go to Main > Supervisor > UserNames – the User Names table will display 

3. Highlight the User Name in the table 

4. Select the F9 Passwd* button – the Operator Password screen will display: 
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5. Type in the new Password and Confirm Password 

6. Select the OK button when complete 

7. Select the F3 Save button 

8. Close and restart the Amlib client to allow the new Password to come into effect 

*Please Note: If the F9 Passwd button is not visible – the button will have to be activated for the 
User who is resetting the password (see below). 

View Existing User Permissions 

Amlib client Usernames can be configured to restrict access to certain modules, screens, menu items 
and buttons. Only Users with full Supervisor permissions can edit the permissions for other Users. 

1. Launch the Amlib client 

2. Go to Main > Supervisor > UserNames – the User Names table will display 

3. Highlight a User Name in the table 

4. Select the F8 Choose button – the User Security screen will display: 
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Menu Options: 

 ViewingMenu: is used to show/hide the buttons that appear on any given screen for the 

selected User 

 ActualMainMenu: lists the modules/screens/options available which could possibly be 

assigned to the selected User 

 CurrentUserMenu: lists the modules/screens/options actually assigned to the selected User 

(bold for active, grey for inactive) 

 
When a screen/option is selected from the ActualMainMenu, the Give button is used to 

ENABLE the selection – for example: MassBorrowerChange 

 
When a screen/option is selected from the ActualMainMenu, the Take button is used to 

DISABLE the selection – for example: MassBorrowerChange 

 
When a screen/option is selected from the ActualMainMenu, the green Title button is 

used to ENABLE access to the module as a whole – for example: Borrower module 

 
When a screen/option is selected from the ActualMainMenu, the red Title button is used 

to DISABLE access to the module as a whole – for example: Borrower module 

 If access to certain Titles (modules) is DISABLED, the selected User will see fewer icons on the 

Top Bar once they log in (the module names will also be greyed out): 

 

Enabling a Single Username Permission 

1. Go to Main > Supervisor > UserNames – the User Names table will display: 

 

2. Highlight the User Name you would like to grant a permission to and select the F8 Choose 

button – the User Security screen will display 
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3. Navigate to the CurrentUserMenu to see the permissions that the user currently has 

ENABLED (any options that appear in grey in the menu are permissions that the user does 

not currently have): 

 

4. To enable a permission, navigate to the ActualMainMenu and then to the menu option you 

wish to grant- this example uses Stockitem > Mass Change 

 



Amlib Introductory Training 

 

 

Last Updated: 25 February 2013 
 Page 122 

5. The chosen menu item will then display in the Menu Chosen box – for example: 
Stockitems.MassChange 

 

6. Select the green  Give  button 

7. You can then recheck the setting in the CurrentUserMenu to see if it has been ENABLED (it 
will be bolded) 

8. Then close out of the window and restart the Amlib client for the change to have effect 

Disabling a Single Username Permission  

1. Go to Main > Supervisor > UserNames – the User Names table will display: 

 

2. Highlight the User Name you would like to grant a permission to and select the F8 Choose 
button – the User Security screen will display 

3. Navigate to the CurrentUserMenu to see the permissions that the user currently has 
ENABLED (any options that appear in bold in the menu are permissions that are enabled): 
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4. To disable a permission, navigate to the ActualMainMenu and then to the menu option you 

wish to grant- this example uses Stockitem > Mass Change 

 

5. The chosen menu item will then display in the Menu Chosen box – for example: 

Stockitems.MassChange 

 

6. Select the red  Take  button 

7. You can then recheck the setting in the CurrentUserMenu to see if it has been DISABLED (it 

will be greyed out) 

8. Then close out of the window and restart the Amlib client for the change to have effect 
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Enabling Access to an Entire Module 

It is possible to control a user’s access to entire module. 

1. Go to Main > Supervisor > UserNames – the User Names table will display: 

 

2. Highlight the User Name you would like to grant a permission to and select the F8 Choose 
button – the User Security screen will display 

3. Navigate to the CurrentUserMenu to see the permissions that the user currently has – any 
module names that appear in grey in the menu are permissions that the user does not 
currently have – for example: Authorities, Borrowers and Periodical amongst others are not 
permitted for the CIRC Username login example below: 

 

4. To enable a module, navigate to the ActualMainMenu and then to the menu option you wish 
to grant – for example: Borrowers > Borrower 
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5. The chosen menu item will then display in the Menu Chosen box – for example: 

Borrowers.Borrower 

 

6. Select the green  Give  button and then the green  Title  button 

7. Selecting the Current User Menu at this stage will show that you have granted access to the 

Borrower screen only – you still need to add individual menu screen permissions – for 

example: History and Memos using the steps outlined above 

 

8. Then close out of the window and restart the Amlib client for the change to have effect 

Disabling Access to an Entire Module 

1. Go to Main > Supervisor > UserNames – the User Names table will display: 

 

2. Highlight the User Name you would like to grant a permission to and select the F8 Choose 

button – the User Security screen will display 
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3. Navigate to the CurrentUserMenu to see the permissions that the user currently has – any 
module names that appear in grey in the menu are permissions that the user does not 
currently have – for example: Authorities, Catalogues and Finance amongst others are not 
permitted for the CIRC Username login example below: 

 

4. To disable a module, navigate to the ActualMainMenu and then to the menu option you wish 
to remove – for example: Borrowers > Borrower 

 

5. The chosen menu item will then display in the Menu Chosen box – for example: 
Borrowers.Borrower 

 

6. Select the red  Take  button and then the red  Title  button 

7. Selecting the Current User Menu at this stage will show that you have disabled access to the 
Borrower module 

 

8. Then close out of the window and restart the Amlib client for the change to have effect 

Enabling/Disabling Buttons 

It is possible to show/hide the buttons the user sees on any given screen – this can be used to restrict 
the user’s ability to perform certain tasks – for example: perform updates or delete records. 

1. Go to Main > Supervisor > UserNames – the User Names table will display: 
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2. Highlight the User Name you would like to grant a permission to and select the F8 Choose 
button – the User Security screen will display: 

 

3. Navigate to the ViewingMenu and then to the menu option you wish to enable/disable 
buttons for – for example: Borrowers > Borrower – the Borrower buttons menu will display: 

 

The enabled (and therefore visible) buttons will be displayed in green, the disabled (and therefore 
hidden) buttons are in red. 

4. To enable (show) a button, simply select a red button with your mouse – the button will 
then turn green – in the following example, the DELETE button has been enabled: 

 

5. Similarly, to disable (hide) a button, simply select a green button with your mouse – the 
button will then turn red 

6. Then close out of the button menu, the User Security window and restart the Amlib client 
for the changes to take effect 

Enabling the F9 Passwd Button on the User Names Screen 

1. Go to Main > Supervisor > UserNames – the User Names table will display: 
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2. Highlight the User Name you would like to grant a permission to (this will be the operator 
who is ALLOWED to reset User passwords) and select the F8 Choose button – the User 
Security screen will display: 

 

3. From the menu, select ViewingMenu > Supervisor > UserNames – the Sup_UserNames 
button menu will display: 

 

The enabled (and therefore visible) buttons will be displayed in green, the disabled (and therefore 
hidden) buttons are in red. 

4. Select the red  PASSWD  button with your mouse – the button will then turn green:  

 

5. Then close out of the button menu, User Security window and restart the Amlib client for 
the changes to take effect 

6. The button will now be visible on the User Names screen when the selected User is logged in 

Copying Permissions from One User to Another 

It is possible to copy the permissions from another User – for example: copy JOHN’s permissions to CHRIS. 

1. Go to Main > Supervisor > UserNames – the User Names table will display: 
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2. Highlight the User Name you would like to copy the permissions to (for example: CHRIS) and 
select the F8 Choose button – the User Security screen will display: 

 

3. Select the Copy From…  button – a Copy From list will display with all the other Users listed: 

 

4. Highlight the Operator whose permissions you would like to copy – for example: JOHN 

5. Then select the Copy button – a prompt with the following message will display: XXXXX now 
has the same Menu and Button Security as XXXXX. 

 

6. You can review the permissions now enabled for this User by selecting the CurrentUserMenu 
– bolded selections are enabled, disabled selections are greyed out 

7. Then close out of the window and restart the Amlib client for the changes to have effect 

Appendix 2: Saved Files 

There are many functions within the Amlib client that use (or can use) a Saved File as part of the 

process. 

This includes the following: 
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 Reports 

 Mass updates 

 Catalogue Maintenance tasks 

 Subscription Circulation Lists 

 Marc record importing 

Saved Files can be created in the following modules: 

 Authorities 

 Borrower 

 Catalogue 

 Stockitem 

Create a Saved File 

Please Note: Many saved files are created as part of another process. The following shows you how 

to create a Saved File independently of a process. 

1. Launch the Amlib client 

2. Navigate to the appropriate module – for example: Stockitem (Main > StockItems > 

Stockitem) 

3. From the menu, select File > DisplayFile 

 

4. The Stockitem Saved Query Results screen will display: 
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5. Select the F1 New button 

6. Type a description in the Details column – for example: Harry Potter Books 

7. Allow other operators to access this file (Y/N): enter a Y (for Yes) or N (for No) – the default is 

Y 

 

8. Select the F3 Save button when complete 

 

The Saved File has been created and is now ready for use. 
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Create (or Save to) a Saved File from a List 

Please Note: Many saved files are created as part of another process. The following shows you how 

to create a Saved File as part of a search. 

1. Launch the Amlib client 

2. Navigate to the appropriate module – for example: Stockitem (Main > StockItems > 

Stockitem) 

3. Enter your search parameters and select the F5 Query button 

 

4. The results will display in a List: 
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5. Select the items you would like to Save to File – use your mouse to highlight a single item, or 

hold down the Ctrl key and use your mouse to highlight multiple items (if saving ALL items, 

then there is no need to select anything) 

 

6. From the menu, select File > SavedMarked (if you would like to save ALL items, then select 

File > SaveAll) 

 

7. The Stockitem Saved Query Results screen will display: 
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8. It is possible to add the selected items to an existing Saved File or to create a new Saved File 

as follows: 

a. Select the F1 New button 

b. Type a description in the Details column – for example: Harry Potter Books 

c. Allow other operators to access this file (Y/N): enter a Y (for Yes) or N (for No) – the 

default is Y 

 

d. Select the F3 Save button when complete 

9. Highlight the Saved File you would like to use and select the F9 Select button 

Please Note:  If selecting an existing Saved File, it is possible to delete the pre-existing saved 

items from the file by selecting the F2 Empty button 

10. A prompt will display with the following message: The 'XXX' file contains XX stockitems. 

 

The selected items have now been saved to file. 
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Save a Single Item/Borrower to File 

Please Note: It is possible to save the item (or borrower) currently being displayed to a Saved File. 

1. Launch the Amlib client 

2. Navigate to the appropriate module – for example: Stockitem (Main > StockItems > 

Stockitem) 

3. Locate and display the item to be saved 

4. From the menu, select File > AddToNewFile 

 

5. The Stockitem Saved Query Results screen will display: 

 

6. It is possible to add the selected items to an existing Saved File or to create a new Saved File 

as follows: 

a. Select the F1 New button 

b. Type a description in the Details column – for example: Harry Potter Books 
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c. Allow other operators to access this file (Y/N): enter a Y (for Yes) or N (for No) – the 

default is Y 

 

d. Select the F3 Save button when complete 

7. Highlight the Saved File you would like to use and select the F9 Select button 

Please Note:  If selecting an existing Saved File, it is possible to delete the pre-existing saved 

items from the file by selecting the F2 Empty button 

The selected item has now been saved to file. 

View an Existing Saved File 

1. Launch the Amlib client 

2. Navigate to the appropriate module – for example: Stockitem (Main > StockItems > 
Stockitem) 

3. From the menu, select File > DisplayFile – the Stockitem Saved Query Results screen will 
display: 

 

4. Highlight a Saved File and select the F9 Select button – the results will display in a List: 
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Appendix 3: Linking Addresses 

It is possible to link to other addresses – for example, you may wish to link addresses for all members 

of the same family. This makes it easier when a change of address is needed. 

1. Launch the Amlib client 

2. Go to Main > Borrowers > Borrower – the Borrower Details screen will display 

1st Member of the Family 

3. Locate the borrower using F5 Query or wand in their barcode (for example: Sarah J Smith) 

4. From menu, select Borrower > Address from the menu – the Address screen will display 

5. Add the Addresses as required – for example: Postal, Residential, and Guardian 

6. Select the F3 Update button when complete – a prompt with the following message will 

display: Borrower Addresses Updated. 

 

7. Select the OK button 

2nd Member of the Family (if not a child) 

1. Locate the borrower using F5 Query or wand in their barcode (for example: John D Smith) 

2. From menu, select Borrower > Address from the menu – the Address screen will re-display: 
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3. Select the Addresses you would like to link by selecting in the tick boxes adjacent to the 

headings 

4. Select the F6 LinkTo button – the Borrower Family screen will display listing borrowers with 

the same surname: 

 

5. If the borrower to whom the link is to be made is not displaying – for example: the member 

has a different surname – enter the member’s name and select the F5 Query button 

6. Highlight the desired borrower (for example: Sarah J Smith) in the table and select the F3 

Link button 

7. The addresses will then be linked – if the link has not taken place, it may be that the relevant 

address boxes were not ticked (if so you will be returned to the Address screen to tick the 

appropriate boxes) 

8. The address details of the selected borrower (for example: Sarah J Smith) will overwrite the 

address details of second borrower (for example: John D Smith): 
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9. Select the F3 Update button – a prompt with the following message will display: This will 
Update all Borrowers sharing the XXX and XXX Addresses. Continue with Update? 

 

8. Select the Yes button to proceed – a prompt with the following message will display: 
Borrower Addresses Updated. 

 

9. Select the OK button 

Check Links/Update Address Details/Delink Borrowers 

In the Borrower Address screen: 

 To check which other Borrowers the current Borrower is linked to, select the F7 Links button 

 Any changes made to any of the linked borrowers Address details will default to updating All 
borrowers 

 However, there are times when a member shifts to different address and the borrower will 
need to be delinked:  

a. Enter the new address details (the Postal tick box will automatically ticked) 

b. Select the New radio button to indicate that this is a new address and that All the 
linked borrowers are not to be updated 

c. Select the F3 Update button 

 To delink the borrower (without changing the address): 

a. Tick the Postal tick box, select the New radio button and select the F3 Update button 
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1st Child: Wand From Option 

It is sometimes useful to wand from another family member’s card to enter the Address details. This 

allows the first (or Residential) address details of the parent/guardian to be copied to the third (or 

Guardian) address details of the child. 

1. Locate the borrower using F5 Query or wand in their barcode (for example: Luke P Smith) 

2. From menu, select Borrower > Address from the menu – the Address screen will re-display: 

  

3. In this example, we are copying the Address 1 details of Sarah J Smith into the Address 3 

details of Luke P Smith (however, we can copy any Sarah J Smith’s addresses into any of Luke 

P Smith’s addresses) 

4. Select the following: 

a. Wand From:  1 

b. plus = Y (this means plus name: the name of the scanned borrower will be copied 

into Line 1 of the address) 

c. Wand the barcode of Sarah J Smith into the field adjacent to the Wand From field 
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5. The name and Address 1 details of the scanned borrower will be added into the selected 

Address 3 fields 

6. Select the F3 Update button – a prompt with the following message will display:  

Borrower Addresses Updated. 

 

 Select the OK button 

 For subsequent children of the family, the address can be linked to this child by selecting on 

the Guardian box as well as the other addresses and selecting the F6 LinkTo button 
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Appendix 4: Import of Borrowers into Amlib 

The Borrower Import function enables sites to import borrower data from an Administration system 
(for example: Cases, EDSAS, Maze, Synergetic, etc.) into the Amlib system.  

This allows for: 

 New borrowers, including address information, to be included in Amlib without having to 
manually enter them 

 Updates of existing borrower records with new Type, Class codes, addresses etc. 

This function is predominantly used by school libraries at the start of each year/semester to update 
their student records (or add new ones). 

The program allows for the restoration of the old data if necessary. 

It has a facility to “map” administrative codes to those used on your Amlib database. They do not 
have to be the same codes, but need to be matched to the corresponding codes so they will import 
correctly for each borrower record. 

The data file to be imported can be copied from the administrative database onto a USB drive, CD or 
to a file accessible on the network. You will need to know the exact path so that you can access it 
during the Borrower download process (from your administrative database). Once the data file has 
been downloaded from the administrative database, it can be uploaded into Amlib.  

The file sent to you should be in one of the following file formats: 

 CSV (comma delimited) 

 TAB delimited 

 Pipe separated (|) 

You can have empty fields in your import, but they must be left empty and not have the data moved 
across. For example: if you didn’t have a Second Name or Preferred Name, you would leave two 
blank fields where they should be in your file: 

 

Example format (CSV): 

 ANDERL,ANDERTON,LAURENCE,WILLIAM,LAURIE,1,RED,B1SJ,1/01/83,M,BB,MR & MRS W B 
ANDERSON, 5/165 KING EDWARD STREET,BAYSWATER,WA,6053,9462 1111 

If the above example left out the RED Group code, the data would be: 

 ANDERL,ANDERTON,LAURENCE,WILLIAM,LAURIE,1, ,B1SJ,1/01/83,M,BB,MR & MRS W B 
ANDERSON,5/165 KING EDWARD STREET,BAYSWATER,WA,6053,9462 1111 

Pipe (|) separated: 

 ANDERL|ANDERTON|LAURENCE|WILLIAM|LAURIE|1| |B1SJ |1/01/83|M|BB|MR & MRS W B 
ANDERSON|5/165 KING EDWARD STREET|BAYSWATER|WA|605|9462 1111 

Dates must be formatted in one of the following three ways: 
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 11/12/09 

 11/12/2009 

 11 Dec 09 

If there are trailing spaces in the data, the program strips these out and causes no problems with the 

download. 

Format 1: MAZE, Synergetic, CASES, COSYCORNER 

This format contains only 17-18 fields, which should be downloaded into a data file from the 

administrative software (for example: MAZE, Synergetic, CASES, COSYCORNER, etc.) in the sequence 

as shown below.  

Mandatory Fields: The data must include Borrower Shortname (Unique ID/BarCode), Surname and 

Type. These cannot be left as null fields. Any unused fields should be left blank but included as null 

fields.  

 

FIELD CSV COLUMN EXAMPLE 

1. (Unique ID/BarCode) 
Borrower Short Name/MAZE Key 

A ANDERL 

2. Surname B ANDERSON 

3. Given  C LAURENCE 

4. Second Name (only imports initial) D WILLIAM 

5. Preferred (overrides Borrower Given) E LAURIE 

6. Type F 1 

7. Group G RED 

8. Class H B1SJ 

9. Date of Birth (or date of entry depending on 
what is used by the admin. database) 

I 1/01/83 

10. Sex J M 

11. Location K BB 

12. Contact name L MR & MRS W.B. ANDERSON 

13. Contact Address Line 1 M 5/165 King Edward St 

14. Contact Address Line 2 N Bayswater 

15. Contact Address Line 3 O WA 

16. Postcode P 6053 

17. Contact Phone Number Q 9462 1111 

18. Email (Optional) R john.smith@oclc.org 

mailto:judy@infovision.com.au
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Format 2: SIS (WA Education Dept) 

This format contains only 22 fields, which should be downloaded into a data file from the 

Administrative software (SIS) in the sequence as shown in below.  

Please Note: All files must be in a standard .CSV format. Any unused fields should be left blank but 

included as null fields. 

 

FIELD # FIELD NAME TYPE & SIZE EXAMPLE 

1 (Unique ID) 

ID/REF/BarCode 

Alpha Numeric 15 1234 

2 Type Alpha Numeric 1 1 student 

2 teaching staff 

3 Non Teacher 

3 Date of Birth Date 12 JAN 1993 

4 Sex Alpha Numeric 1 M / F 

5 Surname Alpha Numeric 40 Smith 

6 First name Alpha Numeric 40 Jonathon 

7 2nd name Alpha Numeric 20 Peter 

8 3rd name Alpha Numeric 40 Paul 

9 Preferred name Alpha Numeric 40 John 

10 Addr line 1 Alpha Numeric 40 151 Royal St 

11 Addr line 2 Alpha Numeric 40  

12 Addr line 3 Alpha Numeric 40  

13 Suburb Alpha Numeric 50 East Perth 

14 State Alpha Numeric 40 WA 

15 Postcode Alpha Numeric 10 6004 

16 Phone 1 Alpha Numeric 30 9264 1111 

17 Phone 2 Alpha Numeric 30 9264 1113 

18 E-mail Alpha Numeric 100 john.smith@oclc.org 

19 Parent Salute Alpha Numeric 60 Mr & Mrs Smith 

20 Class Alpha Numeric 15 Room 5 

21 Group (Type) Alpha Numeric 2 4 (K, P 12, up etc.) 

22 Entry Date Date 22 SEP 1998 
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Format 3: All Fields/EDSAS (SA Education Dept.) 

You must have at least 19 columns, and up to 25 (with the exception of 22 columns – see Format 2).  

Mandatory Fields: Borrower Shortname (Unique ID/BarCode) and Borrower Type.  Additionally, you 

need to have data in the Location column even if this does not come from your Admin system.  If you 

do not store patron location against the student in your admin system, you can just put a 1 in every 

line of the file and match this 1 to your library location later. 

Please Note: If the data file only contains 19 fields the Guardian details are copied from fields 12 – 

16. Any unused fields should be left blank but included as null fields. 

FIELD CSV COLUMN EXAMPLE 

1. (Unique ID /BarCode) 
Borrower Short Name  

A ANDERL or B9988 

2. Surname B ANDERSON 

3. Given Name C LAURENCE 

4. Middle Name (only imports initial)  D WILLIAM 

5. Preferred Name (overrides Given) E LAURIE 

6. Type F 1 

7. Group G RED 

8. Class H 10A 

9. BirthDate I 01/01/91 

10.  Sex J M 

11.  Location K BB 

12.  Address 3 Line 1 (Guardian Name)  L MR & MRS ANDERSON 

13.  Address 1 Line 1  M 5/165 King Edward St 

14.  Address 1 Line 2  N Bayswater 

15.  Address 1 Line 3  O WA 

16.  P/Z Code P 6053 

17.  Address 1 Tel. Q 08 9462 1111 

18.  Email R laurie@oclc.org 

19.  (Other ID) Ref2  S 18846 

20.  Address 3 Line 2 T 8 Osborne Rd. 

21.  Address 3 Line 3 U Innaloo 

22.  Address 3 Line 3 (merges with 
above) 

V WA 

23.  Address 3 Postcode/Zip Code W 6017 

24.  Address 3 Tel. X 08 9754 0000 

25.  Mobile/Cell Y 0425 113 655 

mailto:judy@infovision.com.au
mailto:laurie@oclc.org
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How Records Are Matched 

The records will be matched in the following way: 

1. Unique ID/Other ID – If the Unique ID/Other ID (BarCode/Ref2) from the file is found in 

Borrower, then the information for that patron will be overwritten with the data there, 

regardless of whether or not the name is the same. So, if a student changes their surname, 

the new surname would come across in the import as long as the Borrower ID/Barcode is 

identical. 

2. Surname/Given Name – If no matching Borrower ID/BarCode is found, the system will then 

do a search for any matching surnames and first names. If there is one match found, the 

system will overwrite that record with the data in your file. 

3. Date of Birth – If more than one match is found for the surname and first name, the system 

will then try to locate the correct one using the date-of-birth. If a matching date-of-birth for 

that surname and first name is found, that record is updated. If the birthdates for these 

Borrowers are null, then the Borrowers are considered duplicates (and the system creates a 

new record with an auto-generated AMLIB BarCode). 

In the example below John Goldsmith changed his Surname to Smith. The BarCode in the Amlib 

borrower record was identical to the Unique Import Key (Unique ID), therefore the details were 

updated, showing the Borrower details with the new Surname. 

 

 The Borrower Import will remove single quotes from any incoming names – for example: 

O'Brien becomes OBrien.  

Suggested ‘Pre-import’ Tasks 

You may wish to move all year 12 students (or year 6 students – for primary schools) into another 

class such as Year 13 or Year 7 using Mass Borrower Change. From there you can upgrade all other 

years and import new students. Any returning year 12 (or 6) students would be updated and moved 

back to class year 12 (6). All Remainder students can be dealt with as necessary. 

Alternatively, all students may be mass changed to a generic class via Mass Borrower Change, thus 

giving all students a single class. When doing then next import, all classes will be changed to the 

correct class.  Any left with the generic class can be dealt with as necessary. 

Before starting the import process, check the Type, Group, Class and Location tables in Amlib to 

ensure all required codes have been created. Check the Location table to ensure that the locations 

required have a Valid for Borrower setting of Y. 
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Importing Into Amlib 

1. Launch the Amlib client 

2. Go to Main > Borrowers > BorrowerImport – the Borrower Import screen will display: 

 

3. Select the F1 Open button – the Import File… screen will display: 

 

4. Browse to file to be uploaded, select (highlight) it and select on the Open button 

5. Your data will appear in the Borrower Import screen and a prompt will display with the 

following message: All the Type, Group, Class and Location Codes have been loaded from 

the Import File.  Use the ‘Setup’ menu to assign each Imported Code an equivalent Amlib 

Code before using the ‘Import’ option to update all the Borrowers. 
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The data read from the Borrower Import File can be sorted or have the actions calculated prior to 

importing the data into Amlib. 

6. To sort: From the menu, select Sort By > and select the sort field – the data can be sorted by 

Surname, Given name, Borrower Type, Group or Class. 

 

7. The calculate action option (Table > Calculate Action) will read the import data and state 

whether each student import will be UPDated, NEW or a DUPlicated student record 

 

8. If the F4 Import button is greyed out, it indicates the mapping between the imported codes 

needs to be setup (or adjusted) to match the codes used within Amlib. If it’s is bolded, the 

skip ahead to step 13 

9. From the menu, select Setup and then select one of the following Borrower fields: Types, 

Groups, Classes or Locations – in the example below, we have selected Types: 

 

Please Note: If a selection is greyed out, this indicates there are no codes requiring mapping 

for that field.  Once a field has been successfully mapped a bolded tick will appear at the 

front of the selection. 
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10. A Setup screen will display with two columns: The Imported Type and the Amlib Type. The 

Imported Type will be the data located in your Borrower Type column (Field 6/CSV column F) 

of your import file. The Amlib Type will be the codes located in the Main > Borrowers > 

BorrowerTypes screen. 

 

11. For each Imported Type, use the Amlib Type drop-down to select a Borrower Type you 

would like to match (map) it against 

   

Please Note: It is possible to map more than one Imported Type to the same Amlib Type. 

12. You will need to do this for all the bolded selections in the Setup menu – when you have 

finished all the fields, they will all have a bolded tick next to them and the F4 Import button 

will then be active (bolded): 

 

13. Select the F4 Import button – the Borrower Import Files screen will display – this screen 

allows you to create files to save New, Updated and Duplicate borrowers to.  It also allows 

you to Overwrite Given name(s) and initial(s) and to Use (their) Date of Birth for unique 

checking. 
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14. Type in the filenames, and tick the settings you would like to use, then select the OK button 

– a prompt will display asking if you wish to save any changed borrowers to a file for 

recovery purposes: It is recommended that all changed Borrowers be written to a text file 

for recovery purposes. Do you want to save changed Borrowers to a file? 

 

WARNING! This is your insurance for your borrower data and is thoroughly recommended!! 

15. If you select the Yes button, a dialog box will display so that you can choose the file name for 

your original data and where to save it 

 

Please Note: In subsequent downloads, the restore.txt or restore.csv file will already exist 

and a message will display asking if you wish to overwrite this file. You would normally 

respond Yes to overwrite the file. 
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16. Once complete, a prompt will display notifying you that: The Borrower Import is complete. 

 

Please Note: The import process can take several minutes (for example: 1-3 seconds per 

borrower). The status of the import displays at the bottom of the screen. 

17. If borrowers with duplicate Borrower IDs are imported, then you will receive notification of 

this as part of the completion notice: The Borrower Import is complete. Some Duplicate 

Borrower ID’s were detected – these Borrowers have been saved to the ‘Duplicate ID’ 

saved file. 

 

File Checking 

1. An Amlib Unique ID (BarCode) was created for the borrower who had the same ID as 

someone else (AMLIB0000…): 

 

2. If you go into the main Borrower screen (Main > Borrowers > Borrower) and go to File > 

DisplayFile you will see your three files for new, updated and duplicate borrowers, and a file 

for any duplicate IDs if your import had any 
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 Common Errors 

 The chosen file does not contain Borrower Import records. 

 

This could be caused by either having the information in the correct columns or having headings 

across the top of your document. Remove any headings and double check your file against the 

Import formats in this document. 

 The chosen file does not contain valid records. 

 

This could be caused by having headings across the top of your import file or it being saved in an 

incorrect format (for example: .xlsx and not .csv). Please remove any headings, ensuring that it only 

contains Borrower information and make sure it is in one of the three formats mentioned at the 

beginning of this document. 

Please Note: It is always a good idea to run a Borrower Import on your test databases first, to ensure 

no errors happen. If you do not have a test databases, please contact Support via one of the above 

methods to find out how to set one up. 

Borrower Import Matching 

The following explains the exact method in which Amlib matches on borrower imported records: 

1. Uses the Unique ID to match on Borrower BarCode 

2. If no matches, then uses the Unique ID to match on Borrower Ref2 
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3. If a Preferred Name has been Supplied: 

 Matches on Surname and Preferred EXACTLY 

4. If 2, matches on Surname and Preferred EXACTLY 

5. If Date-of-Birth Supplied: 

 Searches on Surname, Preferred and Date-of-Birth 

6. If no matches and an Initial has been supplied: 

 Matches on Surname, Preferred and Initial 

7. If no matches and an Initial has NOT been supplied: 

 Matches on Surname, Preferred and NULL Initial 

8. If no Date-of-Birth Supplied: 

9. If no matches and an Initial has been supplied 

 Matches on Surname, Preferred and Initial 

10. If no matches and an Initial has NOT been supplied 

 Matches on Surname, Preferred and NULL Initial 

11. If no matches on Surname and Preferred EXACTLY 

 Searches on Surname EXACTLY and LIKE Preferred (for example: Preferred%) 

12. If no matches, then matches on Surname and Given EXACTLY 

13. If 2, matches on Surname and Given EXACTLY 

14. If Date-of-Birth Supplied: 

 Searches on Surname, Given and Date-of-Birth 

15. If no matches and an Initial has been supplied: 

 Matches on Surname, Given and Initial 

16. If no matches and an Initial has NOT been supplied 

 Matches on Surname, Given and NULL Initial 

17. If no Date-of Birth Supplied: 

18. If no matches and an Initial has been supplied: 

 Matches on Surname, Given and Initial 

19. If no matches and an Initial has NOT been supplied: 

 Matches on Surname, Given and NULL Initial 

20. If no matches on Surname and Given EXACTLY 

 Searches on Surname EXACTLY and LIKE Given (for example: Given Name) 

Appendix 5: Stockitem Field Labels 

Some Stockitems (particularly equipment) do not conform to the standardised labels in use by the 

system.  However, it is possible to modify the labels displayed for a particular Form type.  
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Please Note: The default Stockitem Form type used throughout the system (including the blank 

Stockitem screen) is set in Main > Supervisor > Installation – Stockitem tab: Default Item Form = for 

example: BK. 

1. Launch the Amlib client 

2. Go to Main > StockItems > StockitemForms – the Form Codes table will display: 

 

3. Highlight a Form – for example: EQ and select the F9 Display button – the Stock Display Tags 

screen will display: 
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4. Adjust as per the following example: 

o Line 1: Label = Equipment | Tags to Display = 245 

o Line 2: Label = Model No | Tags to Display = 300 

o Line 3: Label = Manufacturer | Tags to Display = 260 710 

o Line 4: Label = Description | Tags to Display = 500 

o Line 5: Label = Subject | Tags to Display = 650 651 600 

o Line 6: Label = Call Number | Tags to Display = 984 082 

Please Note: Tags to display should type in order of preference (the first tag containing a value will 

then display). 

 

5. Select on the F3 Save button when complete 

6. To refresh the data displayed for a particular stockitem, select Item > RefreshFromCat 

7. Select the F3 Update button to save changes 

 

Appendix 6: Setting Default Dates and Holidays 
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There are two sets of dates that require adjusting at the start of the year/semester/term: The 

Supervisor Installation settings and the Borrower Type settings. 

Supervisor Settings 

Default 

1. Launch the Amlib client 

2. Go to Main > Supervisor > Installation – the Installation (DEFAULT) screen will display 

3. Select the Circulation tab 

 

4. Adjust the following settings: 

a. All items must be returned by the following date: 

b. All Semester loans are due back on the following date: 

c. All Term loans are due back on the following date: 

d. All Year loans are due back on the following date: 

5. Dates must be entered in DD/MM/YYYY format – for example: 15/12/2011 

6. Select the F3 Save button 

7. Exit and restart the Amlib client for the new settings to take effect 
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Location  

It is also possible to adjust these settings by individual Location, allowing for a different set of dates 

to be entered.  It is very important to check your other locations to make sure that old dates are not 

saved in there. 

1. From the Supervisor Module Installation screen: from the menu, select Installation > Choose 

Location – the Installation location screen will display 

2. Select a location (for example: Chelsea Library) and select the OK button 

3. The Installation screen for that location will then display – for example: Chelsea Library 

4. Select the Circulation tab 

 

5. If you would like to use the DEFAULT settings, then you can leave the date settings in this 

table blank, otherwise adjust the following settings (these settings will apply only to that 

location): 

a. All items must be returned by the following date: 

b. All Semester loans are due back on the following date: 

c. All Term loans are due back on the following date: 

d. All Year loans are due back on the following date: 

6. Dates must be entered in DD/MM/YYYY format – for example: 15/12/2011 

7. Select the F3 Save button when complete 

8. Repeat for all other circulating locations (including WEB – the location used by the NetOpacs) 

9. Exit and restart the Amlib client for the new settings to take effect 
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Borrower Settings 

1. Launch the Amlib client 

2. Go to Main > Borrowers > BrorrowerTypes – the Borrower Types screen will display: 

 

For each borrower type it is possible to enter a Return By Date that overrides the Supervisor Date 

settings and allows for return dates to be set earlier (if the Return By Date is set after the Supervisor 

Date settings, then these Supervisor Dates will be the cut off point for returns). 

3. Enter a date in DD/MM/YYYY format in the Return By Date field of a selected borrower Type 

– for example: 15/11/2011 

4. Repeat for any borrower Type where the Return By Date is required to be different  

5. Select the F3 Save button when complete 

6. Exit the Borrower module (Ctrl-L) for these settings to take effect 
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Days Closed 

If the Libraries at all campuses are closed on common days (for example: weekends) it is possible to 

set these days closed in the Supervisor module: 

1. Launch the Amlib client 

2. Go to Main > Supervisor > Installation – the Installation (DEFAULT) screen will display 

3. Select the Circulation tab 

 

4. Adjust the following settings: 

 Days of the week when ALL Locations are closed (Sun=0, ...., Sat=6) – type in 06 if 

closed Saturday and Sunday 

5. Select the F3 Save button when complete 

6. Exit and restart the Amlib client for the new settings to take effect 
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Holidays 

It is possible to mark days (holidays) to be ‘closed’ in the calendar (for example: Easter).  

When an item is issued, the program will ensure that it the item is not due for return on closed 

dates. Reservations will not be due for collection on closed dates. Dates may be entered as far in 

advance as desired. 

To mark a date as a closed: 

1. Launch the Amlib client 

2. Go to Main > Supervisor > Calendar – the Calendar screen will display 

3. Use the F7, F8, F9 and F10 buttons to navigate to a month where you want to set a closed 

date: 

 

4. Select a date with your mouse – for example: 1 November 2011 

5. Select the F2 Set button – the Holiday prompt will display: 

 

 Type in a suitable description in the dialogue box – for example Melbourne Cup or 

Term Break 

 Select the OK button 

6. The date will be marked in red (indicating it is closed) – the Date and Description will appear 

in the table to the right of the calendar: 
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7. Once the dates have been set, select the F3 Update button 

8. Exit and restart the Amlib client for the new settings to take effect 

Please Note: Where a Return By date falls on a closed date, the system allocates the next non-closed 

date past that date. 

 Arrow Keys [F7], [F8], [F9], [F10] 

To scroll through the calendar you may use the F7 through F10 keys: 

F7 << Scrolls to the beginning of the year. Selecting 

again, scrolls back to one year past 

F8 < Scrolls to the previous month for the year as 

displayed 

F9 > Scrolls to the next month for the year as displayed 

F10 >> Scrolls to the end of the year. Selecting again 

scrolls one year in advance 

Remove a Closed Date 

1. To remove a closed date, highlight the date 

2. Select the F4 Delete button – this will mark [x]the Closed date for deletion 

3. Select the F3 Update button when complete 

4. Exit and restart the Amlib client for the new settings to take effect 

Copy a Closed Date to Other Locations 

Closed dates in Calendar can be copied to other Locations. 
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1. From the menu, select Calendar > Copy To All – a prompt will display asking: This will make 

every location have exactly the same holiday settings as ‘XXX’. Continue? 

 

2. Select the Yes button – this will copy the closed settings to ALL locations 

3. Once complete, a prompt will display with the following message: Calendar successfully 

reproduced. 

 

4. Select the OK button 

5. Exit and restart the Amlib client for the new settings to take effect 

Different Closed Dates for Each Location 

If different closed dates are required for different Locations. 

1. From the menu, select Calendar > Choose Location – a Location prompt will display 

2. Select the Location and select the OK button 

3. The set the closed dates for this Location 

4. Select the F3 Update button when complete 

5. Exit and restart the Amlib client for the new settings to take effect 
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Appendix 7: USMARC: Some Common Tags 

MARC is an acronym for MAchine Readable Catalogue (record). USMARC was developed by the 

Library of Congress and was formerly named LC MARC. It is now the international standard for 

cataloguing). Each record is written in a format that can easily be read, retrieved and manipulated by 

a computer). 

Each Marc record can consist of: 

Tags 

Each data field (for example: Place Published) is identified by a 3-digit number (replacing descriptors 

for reasons of accuracy, efficiency in computer transfer and storage of bibliographic data.) As MARC 

is written in a format for computers rather than people, Amlib has descriptions of each tag showing 

when tags are inserted. The Worksheet cataloguing screen also has labels at the top of the columns 

to indicate what type of data input is required. 

Subfields 

A lower-case letter or occasionally a number identifies each Subfield. In general, if you are using a 

tag, it MUST contain a Subfield a. Publication data is an exception to this rule. 

Indicators (usually the computer system sorts these out for us – we do not usually have to enter 

data in these columns!) 

Each indicator is identified by a number between 0 to 9 (letters can be used but are not common). 

The numbers often are an indication as to how to “treat” text or categorise a tag. For example, the 

2nd indicator for title indicates the number of non-filing characters to ignore, including spaces. In the 

245 tag below, the 2nd indicator shows 4, to ignore The_ so that filing begins with the letter Q in 

Quasar. The first indicator in the 600 Personal Name Subject Heading entry indicates the type of 

entry (for example: 1 Surname, 3 Family name). Therefore, most would have a 1 as the first indicator. 

Tag “Families” 

000s Control fields, number & codes 

100s Main entries – usually author 

200s Title and Title related fields 

300s Physical description 

400s Series related fields 

500s Notes 

600s Subject related fields 

700s Other added entries – tracings. Included added authors etc. 

800s Series added entries 

900s Locally defined entries. For example, holdings information so used in conversions 
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More Common Marc Tags 

 010: LCCN  Library of Congress Control Number 

 020: ISBN 

 022: ISSN 

 050: LC classification number 

 082: DC classification number  

 100: Author main entry 

 110: Corporate main entry 

 111: Conference main entry 

 130: Uniform title as a main entry, e.g., Bible 

 240: Uniform title after 1XX main entry, e.g. Symphony ... 

 245: Title proper  

 246: Title added entry e.g., a distinctive subtitle  

 250: Edition 

 260: Place, Publisher, Year. 

 300: Physical Description (may include specific material designation, e.g. [videorecording] 

 440: Series  

 490: Series Statement 

 500: General notes 

 502: Thesis note 

 504: Bibliography note 

 505: Contents note. 

 508: Production/credits  

 511: Participants note, e.g., performers, speakers at a conference 

 518: Date and place, e.g., of a performance or conference 

 520: Summary (Most often used with AV material) 

 525: Supplements 

 546: Language of text 

 600: Person as a subject 

 610: Corporate body as a subject 

 611: Corporate body as subject 

 630: Title as a subject 

 655: Genre, e.g., Feature film 

 700: Person as an added entry 

 710: Corporate body as an added entry 

 711: Conference as an added entry 

 730: Uniform title as an added entry 

 856: URL 



  

COMMON TAGS INDIC

ATORS 

1      2 

SUBFIELDS 

Many of these Subfields will never be used. In most cases a tag MUST have a Subfield a. 

020 

ISBN 

0 0 a 

ISBN 

 

z 

Erroneous 

Number (or 

cancelled) 

b 

Qualification 

 

0732248493 0397318487 (pbk) 

022 

ISSN 

(Periodicals often have an ISSN) 

  a 

ISSN 

1077-7199 

082 

Dewey No. 

Used by SCIS 

0 0 a 

Base Number 

b 

Item Note 

523.8 SMI 

099 

Call No.  

Used by SLofWA 

0 0 f 

Prefix 

a 

Base No. 

b 

Author Prefix 

Q 591.994 SMI 

100 

Personal name added entry 

(usually main author) 

0 0 a 

Entry 

q 

Qualifier (Full 

name) 

b 

Roman 

numeral 

d 

Dates 

c 

Qualifier 

Asimov, Isaac L (Isaac Leo) XV 1920- Dr 
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245 

Main Title 

0 4 a 

Title proper 

 

b 

Other title 

information 

(remainder) 

h 

General 

material 

l 

Parallel Title 

 

c  

First 

Statement 

 

n 

Volume 

Number 

p 

Volume Title 

 

 

f 

Second 

Statement 

The Quasars, pulsars, 

and black holes of 

space 

a study [sound 

recording] 

Canto por las 

palams 

Isaac 

Asimov 

Book 4 Taxonomy Pictures by El 

Stymes 

260 

Publication information 

0 0 a 

Place of Publication or 

Distribution 

b  

Name of 

publisher/ 

distributor 

c 

Date of 

Publication 

Sydney : Collins, 1988. 

300 

Physical description 

0 0 a 

Pagination and/or 

volumes 

b 

Illustration 

Statement 

c 

Size 

e 

Other 

material 

38p. Ill. (col.), maps 13cm. 1 study guide 

490 

Series Statement 

0 0 a 

Series Title 

v 

Volume 

Isaac Asimov’s library 

of the Universe 

No.34 

500 

General Notes 

0 0 a 

General Note 

Includes glossary 
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520 

Summary 

0 0 a 

Summary Notes 

Contains information 

on several of marine 

life. Keywords: fish, 

anemones, octopus, 

crayfish 

600 

Subject Heading (Personal 

name) 

1 0 a 

Entry element 

q 

Qualifier (full 

name) 

t 

Title of a 

work 

c 

Qualifier – 

Titles ass. 

d 

Dates 

x 

Subjects 

y 

Period 

z 

Place 

Leakey, L.S.B. (Louis Seymour 

Bazett) 

Sea songs King of France 1903-

1972 

Drama To 1970 United States 

650 

Subject Heading (Topical) 

  a 

Entry Element 

 

x 

Subject or 

form 

subdivision 

y 

Period 

Subdivision 

z 

Place 

Subdivision 

  Astronomy Fiction 19th Century Western 

Australia 

651 

Subject Heading 

(Geographical) 

  a 

Entry Element 

x 

Subject or 

Form 

subdivision 

y 

Period 

Subdivision 

z 

Place 

Subdivision 

  Australia History 1800-1899 Kimberley 

700 

Personal Name (added 

entry) Usually other authors 

  a 

Entry 

c 

Additions to 

name 

q 

Fuller form 

d 

Dates 

t 

Title 

element 
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  Kick, M. A. Dr (Marion 

Anne) 

1901-1975- Works 

856 

Electronic location and 

access 

  u 

Uniform Resource 

Locator (URL) 

z 

Descriptor  

(Link Text) 

http://amlib.net.au Select here to link to 

web site 

There are literally hundreds of MARC tags that can be used. However only about 10% of these are used commonly.  

A useful MARC resource: 

 Library of Congress Home Page: http://www.loc.gov/marc/umb/ and http://www.loc.gov/marc 

http://www.loc.gov/marc/umb/
http://www.loc.gov/marc
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Appendix 8: Support  

We recognise that Customer Support Services are just as important as the product itself. That's why 
we offer the Amlib Software Support Agreement.  
 
Services provided to Customers with current Support and Maintenance Agreements include:          

 Online Support (via Email and OCLC Online Help Desk) 

 Telephone Support 

 Regular Software Updates (including Enhancements and New Features)  

 Remote Access / Diagnostics (via the internet) 

Online Help Desk (TOPdesk) 

New requests for Amlib Support may be logged through the OCLC Online Help Desk.  You may also 
use the helpdesk to review and track existing Amlib Support incidents for your library.  

The OCLC Online Help Desk is available at:  

 https://servicedesk.oclc.org/tas/public/index.jsp   

We ask that queries be logged via the Online Help Desk refer to Appendix 9: Submit a TOPdesk 
Request  for further information on how raise or check calls on TOPdesk. Any URGENT or CRITICAL 
requests requiring immediate assistance can be logged by phone to ensure priority service -  

You will be provided with a login and password for accessing the Online Help Desk. Additional logins 
can be provided as required for other staff at your library. 

OCLC Website 

OCLC’s Support and Training website contains help documentation, training manuals, updates and 

patches, training information, and user group meeting information for our products.  

Each person will have their own login to the OCLC Support and Training website.   If you do not know 

your login to the website, please log a TOPdesk call requesting this information.  

1. Navigate to https://www.oclc.org/support/services/amlib.en.html   Select on the SIGN IN 

link 
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2. Enter your username and password and select Sign in.   

Updates 

New releases and updates to Amlib software are available to download free of charge to licensed 

users. Notification of any new releases and updates is posted on the OCLC website and email 

notification is also sent out via the Amlib mailing lists. 

Software and documentation are available for download from the OCLC Website. 

Mailing List 

Notifications of updates and enhancements to Amlib are also sent out to all Amlib mailing lists.   

 Contact us at support-amlib@oclc.org to confirm that you and other interested staff at your 
library are subscribed to these mailing lists 

User Groups 

There are Amlib User Groups Australia wide. For example, there are two User Groups in Western 

Australia – a School User Group and a Public User Group. These meet approximately three to four 

times a year.  

Please Note: Many notices about Upgrades and User Groups are sent via the mailing list. Please 

notify us of your current Email address. 

Getting Help/Manuals 

Help is available from the online manual. This can be accessed from any application screen by 

selecting Ctrl + H on your keyboard. The online manual uses an internet browser to display. It is also 

possible to add the manual chapters to your Favourites or Bookmarks in your browser. 

Email (Amlib Support) 

 support-amlib@oclc.org 

Amlib Website 

 https://www.oclc.org/support/services/amlib.en.html 

Telephone Support (Amlib Support) 

 1300 260 795 (Local call cost within Australia) 
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Appendix 9: Submit a TOPdesk Request 

 
Login to TopDesk                                      

1. From your Internet browser go to:  

https://oclc.topdesk.net/tas/public/login/form  

2. Enter your Username & Password, and select the 

Login button (remember these are case sensitive) 

    

 

 

Create a New Incident 

 

1. Once logged into TOPdesk, select the ‘New Incident’ button  

 

2. Specify the Incident Type from the drop down box for example: Support question  

 
 

3. Enter details of your Issue/Request into the Request area 

 

4. Once all the details have been filled, select Register button 

  

5. Documents/Screenshots can be attached AFTER registering a new incident, once a new 

Incident is created. On the Home screen of TOPdesk, select the Incident number to which the 

document/screenshot is to be attached 

 
6. To upload supporting documents/screenshot (optional) in the Attachment area:  

 

 
* Click on the Browse button and the Open window will appear navigate to the Document/Screenshot  

   and click the Open button 
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7. Select the Edit button to place a message into the Feedback area to inform Support Staff that 

files have been attached for example: See attached files as requested  

 

1. Once you have added your message, select the Save button 

 

Replying/Adding to Incidents 

If you need to reply to an email Support Staff have sent to you or add further information to an 

incident– please log into TOPdesk and place your reply into the Feedback area 

1. Log into TOPdesk 

2. On the Home screen of TOPdesk select the 

Incident number you wish to reply to or add 

information to 

3. Select the Edit button to place a reply or add to 

an incident  

 

4. Add your reply or additional information into the Feedback area  

 

5. Once you have added your reply or additional information, select the Save button 

 

Finding an Existing Incident Using Quick Finder 

If you want to quickly find existing Incident to reply to, or see the status or actions taken,  this can be 

done through TOPdesk Quick Finder. Use the incident number that that is usually in the Subject of 

emails Support Staff sent to you for example: RE: Regarding incident I12071252; Example School.  

1. Log into TOPdesk 

2. On the Home screen of TOPdesk, on the right side 

of the screen type in the Incident number in the 

Search box 

3. Select the Search icon button, the incident will display 

 


