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This course is designed for those sites that have been using Amlib for some time but would like to 

know more about managing and maintaining the system. 

This course includes: 

System Maintenance which includes backup and deletes unnecessary logs etc. 

System Management which includes tasks that are included in the day to day operations as the site 

deems necessary. 

Data Management which includes database deletions and changes again as the site deems 

necessary. 

Written policies and procedure manuals are useful tools when implementing system management. 

Policy 

Relatively brief and available to outline the “bigger picture”. Useful when issues arise as certain 

decisions have been made and documented, rather than making quick decisions at the time. 

Procedures Manual 

Step by step detail for tasks performed internally. It becomes very important if staff rotate jobs or 

new staff need to be trained. Enhances consistency and accuracy. Maintenance plans and Disaster 

Recovery plans and trials should be considered. 

Note: Screen dumps are useful for including in such documents. Use [F12] to dump a screen or use 

ALT PRINT SCREEN keys from the keyboard to send an image to the clipboard. This image can then be 

pasted into a Word Processing package e.g. Ctrl V into a Word document. 

 

  



 System Management - TASKS 

 

Last Updated: 26 February 2013 
 Page 6 

 

SUMMARY OF SYSTEM ADMINISTRATION TASKS 

 

SUMMARY OF SYSTEM MAINTENANCE TASKS 

DAILY Checking Backup Logs – Amlib Backup Log and Tape verification 

Backing up the system 

Delete unwanted Files 

Delete unwanted Print jobs in Report Scheduler 

If Issues Audit on, delete logs 

Copy Image Files to CD 

WEBSITE updates Check the OCLC Website for updates www.amlib.net.au 

Incidents Assistance, faults and enhancements  – needs User Name and Password to 

log in 

e.g. every 6 weeks Check Server Disk Space 

Delete Netopac Logs  

Delete Amdberror.log in Amlib folder 

After Release Check the Amlib/Previous folder for Previous folder and check for old 

programs that can be deleted 

Ensure Release notes are accessible to view changes e.g. copy to My 

Documents or print them out 

 

SUMMARY OF SYSTEM MANAGEMENT FUNCTIONS 

Offline Application Emergency offline for when server is down 

User Names User Permissions 

Depreciation & Average Pricing Optional 

Creating Periods within Stockitem 

History 

Autolink facility. Optional 

Cat Definitions for STATE LIBRARY OF 

WESTERN AUSTRALIA exchange 

Stockitem Application/Form & Stats codes 

Setting Calendar For setting dates closed 

Circulation Overdue Notices Finance Update (Y/N) 
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SUMMARY OF DATA MANAGEMENT TASKS 

Many of these tasks will depend on the individual library as if these tasks are performed, how 

often and when appropriate 

Deletions Catalogue purge 

Stockitems without Catalogue 

Unreferenced Authorities 

Mass Delete of items/borrower 

Borrower History 

Stockitem History 

Changes Mass change of files 

Stockwand change – can save the process 

Borrower change – from Junior to Young Adult or Junior 

Catalogue and Authority Maintenance Global Updates to Authority or Catalogues 

Stockitem Autolink Global Updates to Stockitem 

History deletions Available in Borrower Reports, Stockitem Autolink 

Reservation Expiry Run through reports or cancel manually 

 

MANAGEMENT REPORTS 

System Activity Supervisor/Library Menu 

Statistics Reports/Repstatistics 

Audit Reports Reports/RepStockitem, RepAuthority, RepBorrower 

Value of Collection Reports/RepStockitem/CountbyForm,Stats 

Counts Reports from RepBorrower or RepStockitem 

Where Searches Stockitem/Borrower for a huge variety of useful reports e.g. items never 

borrowed, ILLs late coming from Supplying library, Reserves of more than 5, 

items with cost over $500, borrowers inactive for 2 years, Juniors who should 

be YA, Young Adults who should now be Adult members, AOL orders not 

received after 6 months etc. etc. 
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SYSTEM MAINTENANCE 

Database Set-Up 

The RDBMS (Database) can be: 

 Microsoft SQL Server 

 Oracle 

The Data is spread over 4 separate Databases: 

 AMCAT: Authority, Catalogue  

 AMLIB: Borrowers, Circulation, Stockitem, History, Reports 

 AMSTATS: Statistics 

 AMLOCAL: Every Parameter, Defaults 

 AMWEB: Some sites have this for Netopacs  

Maintenance  

Most of the maintenance of the system is incorporated into the Backup (e.g. Indexing, clearing logs).  

Backing Up Your Database 

All SQL Server installations should have a Database Maintenance Plan: 

The plan should: 

 Optimise the indexes  

 Back-up the databases (CAT, LIB, LOCAL and STATS) at least once every day. 

 Backup the logs - You can specify how long the backup files are kept - make sure that it is 

long enough for the backup to tape to pick them up. For example if a Daily backup is done it 

may be decided to keep the Backup files for 3 days. 

It is important to check the logs created by backup to ensure that the Backup was successful. It 

should be possible to have this log accessed away from the Server For example - by Library Staff 

If the site is running SQL Server Express Version there is a special Backup that can be run. See 

Appendix for instructions. 

Backup to External Device 

We rely on you to implement a backup maintenance plan in order to reconstruct lost or altered 

Customer files, data or programs. We also need you to implement a database maintenance plan to 

ensure that the Relational Data Base Management System (RDBMS) is operating at optimal levels.  

If there are problems with either the date or error messages in Backups or any questions about 

creating backups please contact Support for further advice as soon as possible. 

 Ensure the Databases are backed up to an external device – for example: Tape 

 Ensure the Logs of the Tape Backup are checked to ensure it was successful 
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 Consider the restore capabilities from that Backup device – can the Tape be read by other 

Tape Drives to enable a restore of the data? 

 Consider backup onto an alternative Backup device – for example: a CD-R regularly as double 

insurance  

 If you have any queries about backup do not hesitate to contact Amlib Support 

 

 

Ensure the Images folder is backup to an external device (e.g. CD, Flashram) if there are images on 

either borrower or catalogue records 

Tasks To Be Performed Daily 

 Checking Backup Logs 

 Backing up the system 

Ensuring that you have sound backups of your system is your insurance that your data can be 

recovered if the need ever arises.  

Backing up should be done regularly. We recommend a daily backup. 
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SCHEDULED REPORTS  

1. Launch the Amlib client 

2. Go to Main > Reports > RepPrintProgress – the Print Progress screen will display 

This window will display any Reports which are listed when the F6 Print button is chosen in Reports. 

Examples of Reports sent through the Report Scheduler are scheduled to update accounts, send 

emails, update history etc. There are 3 windows to check: 

 Waiting 

 Running 

 Printed 

Ensure that the queue does not have unwanted print jobs blocking the queue. It is also worthwhile 

to delete the Printed jobs occasionally.  

To delete the Print Jobs 

1. Click the Printed Radio button 

2. Highlight the jobs to be deleted and press F4 Delete  

3. A message will display 

 

4. Answer Yes to confirm deletion 

5.  This will mark them for deletion with a X in Column 1 

6.  Press  F3 Save to save the deletions 

Files – Delete Unwanted Files 

It is recommended to delete all unwanted Files e.g. Import files regularly. Files can be checked in 

Borrower, Authority, Catalogue and Stockitem. Below is the procedure to delete unwanted 

Stockitem Files 

1. Launch the Amlib client 

2. Go to Main > Stockitem > Stockitem – the Stockitem screen will display 

3. Go to File > Display File 

4. Highlight the Files to be deleted and press F4 Delete  

5. This will mark them for deletion with a X in Column 1 



 System Management - TASKS 

 

Last Updated: 26 February 2013 
 Page 11 

 

 

Note: It is possible to cancel the deletion at this stage by highlighting the Files NOT TO BE DELETED 

and pressing the F4 Delete button (again). This will remove the X from the highlighted Files and then 

will not be included in the deletion 

6. Press  F3 Save to save the deletions 

7. A confirmation message will display 

 

8. Answer Yes to delete or No to cancel. 

Note: The same procedure can be used for the Files in the Authority, Catalogue and Borrower 

Modules 

Issues Audit 

This Audit is set in Supervisor > Installation > Other > “Create an audit for all Issues prompted with 

messages (Y/N) 

Warning: If activated, delete logs regularly, as each transaction in Issues that invokes a message is 

recorded. Therefore this log builds up very quickly.  

To check or delete the logs  

1. Launch the Amlib client 

2. Go to Supervisor > Library Menu > Issues Audit 
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3. The Issues Audit window will display 

4. To Order the Issues Audit go to Issues Audit Menu > Order  

5. The Choose Order Columns Window will display 

 

6. Highlight the required Order and arrow across to the right hand Column. Select Asc 

(Ascending) or Desc (Descending) as required 

7. Click OK when the Order has been selected 

To Filter the Display by Date 

1. To filter the display by date  go to Issues Audit Menu > Filter by Date 

2. The Choose Select Date Range will display 

3. Enter the required Date range for the beginning (From) and for the end (To:) in the format 

dd/mm/yyyy and click OK.  
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To Delete logs from the Issues Audit Table 

1. Launch the Amlib client 

2. Go to Main > Supervisor > Supervisor – the Locations screen will display 

3. Go to Library Menu > Issues Audit 

4. Highlight the Issue Audit logs to be deleted and press F4 Delete  

5. This will mark them for deletion with a X in Column 1 

 

Note: It is possible to cancel the deletion at this stage by highlighting the Logs NOT TO BE DELETED 

and pressing the F4 Delete button (again). This will remove the X from the highlighted Logs and then 

will not be included in the deletion 

6. Press  F3 Save to save the deletions 

7. No confirmation message will display. The Logs will be deleted 

Delete Issue Audit Logs by Date Range 

1. To Delete by date  go to Issues Audit Menu > Delete by Date 

2. The Choose Select Date Range will display 

3. Enter the required Date range for the beginning (From) and for the end (To:) in the format 

dd/mm/yyyy and click OK.  
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4. A Confirm Delete message will display 

 

5. Answer Yes to delete or No to Cancel 

6. If Yes is selected a message will display. Select OK to continue 
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Netopac Logs 

A log record is automatically created whenever an error occurs on the database when using 

Netopacs. The Netopac.log will be located on the Web Server in the NetOpacs Folder. The 

Netopac.log can be deleted occasionally. 

 

 

 

Amdberror.Log 

Any SQL errors are written to a log. In case of SQL errors encountered, this log can be emailed to 

OCLC support for verification. This error log can be accessed from the Amlib Folder. 

The report is in ascending date order and therefore the latest errors are at the end of the document. 

The Text file can be cleared by highlighting and deleting the text e.g. every 6 months. 

Old entries 

can be 

deleted e.g. 

older than 2 

months 
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Check Server Disk Space 

Ensure that the free space on the server running SQLBase or Oracle. Generally there should be at 

least 500 Mb free space. If the free space falls below 100 MB immediate action will be required to 

prevent a system crash. 

 

Icon Setup On New Pcs 

When installing a new Amlib Client machine, a decision needs to be made as to where to access the 

Amlib programs according to the following options: 

 Access to Amlib Programs from the Server  or 

 Install the programs locally and access from the new PC 

If you are not sure where you currently access the Amlib program from you can find out by: 

1. Right-click on the Amlib Icon of a different Amlib Client and select Properties 

2. On the shortcut tab, locate the Target field and note the file path 

 If the Target point to a different drive – for example a library drive or I:/ drive etc 
then you are most likely accessing Amlib from a server:  follow Option 1 

 If the file path points to C:/Amlib/Amlibtop.exe  then you are most likely accessing 
the program from a locally install on the PC- follow Option 2 
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Option 1- Access the Programs from the Server 

In the Amlib folder on the server,  navigate to Amlib > Utilities > Icons > Iconsetup.exe  

Copy the Iconsetup.exe file to the new PC and run the file on the PC as below, browsing to  the Amlib 

folder on the server – see notes below 

Option 2- Install the Amlib programs 

Copy the Amlib folder from an existing PC that is running Amlib (or from the Server). This will ensure 

that the Programs are the Version suitable for the Database. 

Run the Amlib > Utilities > Icons > Iconsetup.exe file on the PC and browse to the Amlib folder on the 

local PC where you have just saved it 

Running the IconSetup Facility 

This is used to set up PC Icons, set the Database Login, and for installing Active X. 

1. Access the Icon Setup facility from Amlib > Utility >Icons > IconSetup.exe. Double clicking on 
it will bring up a Wizard 
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2. Browse for the path of the Amlib program files. Find the folder where this PC will access 
Amlib from (as per Option 1: the Server, or Option 2: Local PC ). Once selected click Next  
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3. In the “Select Components” dialog, “Choose Modules To Install” and also generally select the 
boxes for “Admin Tasks” (to ensure the Database connection is correct in the Amlib 
configuration file). Click Next  

 

4. Enter the Database login and Password. Enter the correct Username and Password (usually 
SYSADM for both). For security reasons, this will be encrypted when stored in the 
configuration file. Click Next 
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5. Choose the Destination for the Shortcut. Usually the default is fine. Click Next 

 
Select Additional Task. Generally Install desktop icons for selected Components. Click Next. 

 

6. Ready to Install. Review and Confirm and select Install 
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7. Select Finish to exit the IconSetup Utility 

 

 
Note: If the Amlib path is already pointing to the correct file and you wish only to set the Database 
Login, take off the ticks in Select Components Window - Choose Module Icons and Functions to 
Install at Step 3. Click Next. 
 

 
 

 

 

SYSTEM MANAGEMENT FUNCTIONS 
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Emergency Planning 

In the event of emergencies, the most important precaution is to have sound backups. If the Server 

hard disk fails or for some reason becomes unusable, it may be necessary to restore your data from 

tape. Check the backup information supplied with this manual. 

Offline Circulation 

Setting Up Offine On A Pc  

Amlib Offline is a facility which enables barcodes to be read while the Amlib Programs are 

unavailable from the Server. It can also be used on a computer disconnected from the network e.g. A 

laptop used for a Mobile library. When the Server is available again and the Issues screen is in 

operation, the files from Offline can be downloaded using the Borrower/Offline Issues menu from 

the Issues Window. 

Check the Supervisor/Check Digits screen to ensure that there is a table of Barcode validations set 

up. If this is blank, it will be necessary to enter the validations of the Barcodes that are used (see 

below). Every time this table is updated, a message will display. The new offline.ini that is created 

will need to be copied to the offline folder on each PC. 

 

A Folder needs to be created on the local disk (e.g. C:\ drive) of Circulation PCs in a separate 

directory, especially where Amlib is loaded from a network drive. This will enable the Offline module 

to be used even if the network or server is down. This folder needs to contain: 

Offline Ini (offline parameter file). This is created each time the Supervisor, Check Digits table is 

saved. If the Check Digits table is altered, the updated offline.ini should be recopied to the PCs 

running Offline from their C Drives. 

Offline.exe (offline application) 

Deploy (contains many of the dll files needed to run the program). Copy all files from the Deploy 

folder to the Offline folder. As well as the Deploy contents, one extra dll (Amshell.dll is needed - This 

found in the Amlib/Programs directory. 

Offline Operation  

A Windows Shortcut can be set up on the Desktop. When loaded, select the relevant application 

from the Options menu. 
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When an option is chosen, a File is created automatically with the date and time as a File Name. 

Ensure the path is correct. 

 

 

If an existing File is chosen, it is possible to overwrite the existing file or append to it. This is useful for 

Mobile libraries where there are several stops. 
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As Borrower and Item barcodes are entered, the system will write records to the file. To change to a 

new borrower select [F1]. The table is cleared whenever a new Borrower barcode is wanded. If a 

Barcode does not comply to the Offline.ini file a message will display: 

 

 

If many offline transactions are being entered, e.g. for half a day or more, it would be a good idea to 

start a new file. To change to a new file just click the file ? icon.  

The offline facility may also be used to capture Returns and Stocktake information. The Returns and 

Stocktake output file format is one item number per record. 

Note: In order for the program to correctly validate check digits there must be a file of the name 

‘offline.ini’ in the working directory of the PC. This file is recreated whenever you change the Check 

Digits window in the Supervisor module. 

Once captured to file as above, the barcodes are able to downloaded when the Server is available 

once more. Download: 

 Offline Issues (from Issues/Borrower menu) 

 Offline Returns (from Returns/Borrower menu 

CREATING NEW USERNAMES 
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It is possible to create to create user-specific logins for the Amlib client which can then be configured 

to allow access to only certain modules, screens, menu items and buttons. 

View Existing Usernames 

1. Launch the Amlib client 

2. Go to Main > Supervisor > UserNames – the User Names table will display: 

 

3. A list of existing User Names will be visible with the following settings: 

FIELD EXPLANATION 

User Name This is the User Name used when logging onto the Amlib client 

Location The default location that displays when the User logs into the Amlib client (the 

user may select a different location 

Circ at this Location Only 

(Y/N)  

Y Can operate Circulation only at the location specified in the Location 

field 

N Can operate Circulation at all Locations within the system 

Level An indication of the user’s permissions levels setup. Some of the tasks on the 

system can also be limited using User Level (for example: Attachment security 

level, default Authority security level , etc), although it is rarely used. 

 

  



 System Management - TASKS 

 

Last Updated: 26 February 2013 
 Page 26 

 

Enter a New User 

1. Click the F1 New or F2 Insert button – a new entry will appear in the table 

2. Type in the following: 

a. User Name – use one word only (for example: CHRIS or CHRISW) 

b. Location – the default login location of the user 

c. Circ at this Location Only – Y or N 

d. Level – the level against a User is used only as a guide 

 

3. Click the F3 Save button – the Operator Password screen will display: 

 

4. Type in a Password and Confirm Password 

5. Click the OK button when complete 

6. Close and restart the Amlib client to allow the new User Name to come into effect 
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Resetting User Passwords 

1. Launch the Amlib client 

2. Go to Main > Supervisor > UserNames – the User Names table will display 

3. Highlight the User Name in the table 

4. Click the F9 Passwd* button – the Operator Password screen will display: 

 

5. Type in the new Password and Confirm Password 

6. Click the OK button when complete 

7. Click the F3 Save button 

8. Close and restart the Amlib client to allow the new Password to come into effect 

*Please Note: If the F9 Passwd button is not visible – the button will have to be activated for the 

User who is resetting the password (see below). 
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USER PERMISSIONS 

Amlib client User Names can be configured to allow access to only certain modules, screens, menu 

items and buttons. Only Users with full Supervisor permissions can edit the permissions for other 

Users. 

View Existing User Permissions 

1. Launch the Amlib client 

2. Go to Main > Supervisor > UserNames – the User Names table will display 

3. Highlight a User Name in the table – for example: JOHN 

4. Click the F8 Choose button – the User Security screen will display: 

 

Menu Options 

 ViewingMenu: is used to show/hide the buttons that appear on any given screen for the 

selected User 

 ActualMainMenu: lists the modules/screens/options available which could possibly be 

assigned to the selected User 

 CurrentUserMenu: lists the modules/screens/options actually assigned to the selected User 

(bold for active, grey for inactive) 
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When a screen/option is selected from the ActualMainMenu, the Give button is used to 

ENABLE the selection – for example: MassBorrowerChange 

 
When a screen/option is selected from the ActualMainMenu, the Take button is used to 

DISABLE the selection – for example: MassBorrowerChange 

 
When a screen/option is selected from the ActualMainMenu, the green Title button is 

used to ENABLE access to the module as a whole – for example: Borrower module 

 
When a screen/option is selected from the ActualMainMenu, the red Title button is used 

to DISABLE access to the module as a whole – for example: Borrower module 

 If access to certain Titles (modules) is DISABLED, the selected User will see fewer icons on the 

Top Bar once they log in (the module names will also be greyed out): 

 

Enabling a Single Username Permission 

1. Go to Main > Supervisor > UserNames – the User Names table will display: 

 

2. Highlight the User Name you would like to grant a permission to and click the F8 Choose 

button – the User Security screen will display 
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3. Navigate to the CurrentUserMenu to see the permissions that the user currently has 

ENABLED (any options that appear in grey in the menu are permissions that the user does 

not currently have): 

 

4. To enable a permission, navigate to the ActualMainMenu and then to the menu option you 

wish to grant- this example uses Stockitem > Mass Change 

 

4. The chosen menu item will then display in the Menu Chosen box – for example: 

Stockitems.MassChange 
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5. Click the green  Give  button 

6. You can then recheck the setting in the CurrentUserMenu to see if it has been ENABLED (it 

will be bolded) 

7. Then close out of the window and restart the Amlib client for the change to have effect 

Disabling a Single Username Permission  

1. Go to Main > Supervisor > UserNames – the User Names table will display: 

 

2. Highlight the User Name you would like to grant a permission to and click the F8 Choose 

button – the User Security screen will display 

3. Navigate to the CurrentUserMenu to see the permissions that the user currently has 

ENABLED (any options that appear in bold in the menu are permissions that are enabled): 

 

4. To disable a permission, navigate to the ActualMainMenu and then to the menu option you 

wish to grant- this example uses Stockitem > Mass Change 
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5. The chosen menu item will then display in the Menu Chosen box – for example: 

Stockitems.MassChange 

 

6. Click the red  Take  button 

7. You can then recheck the setting in the CurrentUserMenu to see if it has been DISABLED (it 

will be greyed out) 

8. Then close out of the window and restart the Amlib client for the change to have effect 

Enabling Access to an Entire Module 

It is possible to control a user’s access to entire module. 
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1. Go to Main > Supervisor > UserNames – the User Names table will display: 

 

2. Highlight the User Name you would like to grant a permission to and click the F8 Choose 

button – the User Security screen will display 

3. Navigate to the CurrentUserMenu to see the permissions that the user currently has – any 

module names that appear in grey in the menu are permissions that the user does not 

currently have – for example: Authorities, Borrowers and Periodicals amongst others are 

not permitted for the CIRC Username login example below: 

 

4. To enable a module, navigate to the ActualMainMenu and then to the menu option you 

wish to grant – for example: Borrowers > Borrower 
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5. The chosen menu item will then display in the Menu Chosen box – for example: 

Borrowers.Borrower 

 

6. Select the green  Give  button and then the green  Title  button 

7. Selecting the Current User Menu at this stage will show that you have granted access to the 

Borrower screen only – you still need to add individual menu screen permissions – for 

example: History and Memos using the steps outlined above 

 

8. Then close out of the window and restart the Amlib client  for the change to have effect 

Disabling Access to an Entire Module 

1. Go to Main > Supervisor > UserNames – the User Names table will display: 
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2. Highlight the User Name you would like to grant a permission to and click the F8 Choose 

button – the User Security screen will display 

3. Navigate to the CurrentUserMenu to see the permissions that the user currently has – any 

module names that appear in grey in the menu are permissions that the user does not 

currently have – for example: Authorities, Borrowers and Finance amongst others are not 

permitted for the CIRC Username login example below: 

 

4. To disable a module, navigate to the ActualMainMenu and then to the menu option you 

wish to remove – for example: Borrowers > Borrower 

 

5. The chosen menu item will then display in the Menu Chosen box – for example: 

Borrowers.Borrower 
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6. Select the red  Take  button and then the red  Title  button 

7. Selecting the Current User Menu at this stage will show that you have disabled access to the 

Borrower module 

 

8. Then close out of the window and restart the Amlib client  for the change to have effect 

Enabling/Disabling Buttons 

It is possible to show/hide the buttons the user sees on any given screen – this can be used to restrict 

the user’s ability to perform certain tasks – for example: perform updates or delete records 

1. Go to Main > Supervisor > UserNames – the User Names table will display: 
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2. Highlight the User Name you would like to grant a permission to and click the F8 Choose 
button – the User Security screen will display: 

 

3. Navigate to the ViewingMenu and then to the menu option you wish to enable/disable 
buttons for – for example: Borrowers > Borrower – the Borrower buttons menu will display: 

 

The enabled (and therefore visible) buttons will be displayed in green, the disabled (and therefore 
hidden) buttons are in red. 

4. To enable (show) a button, simply click a red button with your mouse – the button will then 
turn green – in the following example, the DELETE button has been enabled: 

 

5. Similarly, to disable (hide) a button, simply click a green button with your mouse – the 
button will then turn red 

6. Then close out of the button menu, the User Security window and restart the Amlib client  
for the changes to take effect 

Enabling the F9 Passwd Button on the User Names Screen 

1. Go to Main > Supervisor > UserNames – the User Names table will display: 

 



 System Management - TASKS 

 

Last Updated: 26 February 2013 
 Page 38 

 

2. Highlight the User Name you would like to grant a permission to (this will be the operator 

who is ALLOWED to reset User passwords) and click the F8 Choose button – the User 

Security screen will display: 

 

3. From the menu, select ViewingMenu > Supervisor > UserNames – the Sup_UserNames 

button menu will display: 

 

The enabled (and therefore visible) buttons will be displayed in green, the disabled (and therefore 

hidden) buttons are in red. 

4. Click the red  PASSWD  button with your mouse – the button will then turn green:  

 

5. Then close out of the button menu, User Security window and restart the Amlib client  for 

the changes to take effect 

6. The button will now be visible on the User Names screen when the selected User is logged in 

Copying Permissions from One User to Another 

It is possible to copy the permissions from another User – for example: copy JOHN’s permissions to CHRIS. 

1. Go to Main > Supervisor > UserNames – the User Names table will display: 
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2. Highlight the User Name you would like to copy the permissions to (for example: CHRIS) and 

click the F8 Choose button – the User Security screen will display: 

 

3. Click the  Copy From…  button – a Copy From list will display with all the other Users listed: 

 

4. Highlight the Operator whose permissions you would like to copy – for example: JOHN 

5. Then click the Copy button – a prompt with the following message will display: XXXXX now 

has the same Menu and Button Security as XXXXX. 
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6. You can review the permissions now enabled for this User by selecting the 

CurrentUserMenu – bolded selections are enabled, disabled selections are greyed out 

7. Then close out of the window and restart the Amlib client  for the changes to have effect 
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STOCKITEM CAT DEFINITIONS 

By setting the Cat Definitions for Forms and Stockitem codes, the correct Stats and Form codes are 

given to items as they are created. The Default codes do not need Cat Definitions as they will 

automatically be inserted unless an alternative rule applies. 

Form Codes: Cat Definitions 

Form Cat Definitions are found in the Window Menu of the Stockitem Form code screen. 

1.  Launch the Amlib client 

2. Go to Main > StockItems > StockitemForms – the Form Codes table will display: 

 

3. Highlight a Form code in the table – for example: AC – Audio Cassettes 

4. From the menu, select Window > Cat Defs – the Form Codes for Catalogues window will 

display: 

 

5. To set a Cat definition: 

a. Select a Tag number – for example: 300 
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b. Enter the data that MUST be present for valid items to be given this Form Code in 

the Must Contain field– for example: Sound Cassette 

c. Enter the data that MUST NOT be present for valid items to be given this Form Code 

in the Must Not field – for example: CD 

d. Click the Paste button 

6. Click the F3 Save button when complete 

Stats Codes: Cat Definitions 

1. Launch the Amlib client 

2. Go to Main > StockItems > StockitemStatsCodes – the Stats Codes table will display 

 

3. Highlight a Stats Code in the table – for example: J – Junior Fiction 

4. Click the F8 Cat Def button – the Stats Codes for Catalogues window will display: 

 

5. To set a Cat definition: 

a. Select a Tag number – for example: 82 
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b. Numbers:  

i. Select either the Must Contain or Must Not Contain radio button (the Ignore 

button is only used when creating non-numerical definitions) 

ii. Enter Must Start With and/or Must Not Start With data (optional) 

iii. Click the Paste button 

c. Tag:  

i. Ensure Numbers is set to Ignore 

ii. Select either the Starts With, Contains anywhere before first space or 

Contains anywhere in tag radio button 

iii. Enter Must Start With and/or Must Not Start With data 

iv.  Click the Paste button 

6. Click the F3 Save button when complete 

A setup for Schools might be:  

CODE EXAMPLE 

NF DEFAULT as set up in Main  > Supervisor > Installation – Stockitem tab or set in 

MARC Take up 

F Tag 82 must not contain numbers 

A setup for Public Libraries might be: 

CODE EXAMPLE 

ANF DEFAULT as set up in Main  > Supervisor > Installation – Stockitem tab or set in 

MARC Take up 

AF Tag 99 must not contain numbers.  

Must contain F but not contain J before the first space. 

JK Tag 99 

Must contain JK before the first space 

JNF Tag 99 must contain numbers 

Must contain J but not contain JK before the first space. 

JF Tag 99 must not contain numbers 

Must contain J but not contain JK before the first space. 

 

CALENDAR 
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Days Closed 

If the Libraries at all campuses are closed on common days (for example: weekends) it is possible to 

set these days closed in the Supervisor module: 

1. Launch the Amlib client 

2. Go to Main > Supervisor > Installation – the Installation (DEFAULT) screen will display 

3. Select the Circulation tab 

 

4. Adjust the following settings: 

 Days of the week when ALL Locations are closed (Sun=0, ...., Sat=6) – type in 06 if 

closed Saturday and Sunday 

5. Click the F3 Save button when complete 

6. Exit and restart the Amlib client for the new settings to take effect 
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Holidays 

It is possible to mark days (holidays) to be ‘closed’ in the calendar (for example: Easter).  

When an item is issued, the program will ensure that it the item is not due for return on closed 

dates. Reservations will not be due for collection on closed dates. Dates may be entered as far in 

advance as desired. 

To mark a date as a closed: 

1. Launch the Amlib client 

2. Go to Main > Supervisor > Calendar – the Calendar screen will display 

3. Use the F7, F8, F9 and F10 buttons to navigate to a month where you want to set a closed 

date: 

 

4. Select a date with your mouse – for example: 1 November 2011 

5. Click the F2 Set button – the Holiday prompt will display: 

 

 Type in a suitable description in the dialogue box – for example Melbourne Cup or 

Term Break 

 Click the OK button 

6. The date will be marked in red (indicating it is closed) – the Date and Description will appear 

in the table to the right of the calendar: 
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7. Once the dates have been set, click the F3 Update button 

8. Exit and restart the Amlib client for the new settings to take effect 

Please Note: Where a Return By date falls on a closed date, the system allocates the next non-closed 

date past that date. 

 Arrow Keys [F7], [F8], [F9], [F10] 

To scroll through the calendar you may use the F7 through F10 keys: 

F7 << Scrolls to the beginning of the year. Clicking again, 

scrolls back to one year past 

F8 < Scrolls to the previous month for the year as 

displayed 

F9 > Scrolls to the next month for the year as displayed 

F10 >> Scrolls to the end of the year. Clicking again scrolls 

one year in advance 

Remove a Closed Date 

1. To remove a closed date, highlight the date 

2. Click the F4 Delete button – this will mark [x] the Closed date for deletion 

3. Click the F3 Update button when complete 

4. Exit and restart the Amlib client for the new settings to take effect 

Copy a Closed Date to Other Locations 

Closed dates in Calendar can be copied to other Locations. 
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1. From the menu, select Calendar > Copy To All – a prompt will display asking: This will make 

every location have exactly the same holiday settings as ‘XXX’. Continue? 

 

2. Click the Yes button – this will copy the closed settings to ALL locations 

3. Once complete, a prompt will display with the following message: Calendar successfully 

reproduced. 

 

4. Click the OK button 

5. Exit and restart the Amlib client for the new settings to take effect 

 

Different Closed Dates for Each Location 

If different closed dates are required for different Locations. 

1. From the menu, select Calendar > Choose Location – a Location prompt will display 

2. Select the Location and click the OK button 

3. The set the closed dates for this Location 

4. Click the F3 Update button when complete 

5. Exit and restart the Amlib client for the new settings to take effect 
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DEPRECIATION 

Each Stockitem Stats code is associated with a Group. These groups are used to assign depreciation 

rates and cost prices to items. The actual prices used are formulated by STATE LIBRARY OF WESTERN 

AUSTRALIA. By Depreciating by Groups varying percentage depreciation figures can be set, and Local 

stock can be exempt from depreciation as required. Depreciation can be set via Location or for All 

Locations using [F8] for specific Location and [F9] for All Locations. 

 

To view Price information for any of the Stats groups, highlight the line and select AccPri [F7]. A table 

will display, which allows the entry of current depreciation rates and minimum prices for each Form. 

 

 

COLUMN EXPLANATION 

Form Type Available Form Types that can be allocated average 
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prices 

Year of First Average Price First average price as defined on the Prices Table for this 

particular form. 

Year of Last Average Price Last average price as defined on the Prices Table for this 

particular form. 

Always use Average Price 

Before Year 

Before the year entered in this column, give the average 

price for the particular year rather than calculate 

according to percentage 

Depreciation Rate (%) The rate at which the prices will be depreciated in the 

new calculation 

Minimum Depreciation Cost 

($) 

A minimum amount, so that if the value of the 

calculation falls below this amount, enter this amount in 

the cost field rather than the calculated figure 

 

To be eligible for depreciation, depreciation rates must be entered for every type of Form. 

In addition, an average price for each year can be entered for Forms of items by selecting Prices [F7]. 

 

Running Depreciation 

Depreciation can be set to be depreciated on a Straight Line basis or on a Reducing Balance basis. 

The method is selected in Supervisor, Library Menu, Installation, Stockitem – Deprec. Items on 

straight line basis. An option as to whether 10% GST is removed prior to depreciation and then 

reapplied can be selected from Supervisor, Library Menu, Installation, System – If price includes GST 
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this removed before depr and recalculated after.  Regardless of the Depreciation method, the same 

Depreciation Tables are used within Amlib. The essential difference is in the calculation and which 

cost price is used for the calculation. 

The Depreciation can be performed on one item or as a Mass Depreciation from Stockitem, 

StatsGroups.  

The date Depreciation uses is the Accession Date of the Stockitem. If there is no Accession Date, it 

uses the Received Date of the Stockitem. 

As the item is depreciated, the system considers: 

Method of Depreciation e.g. Straight Line or Reduced Balance 

The Stats Group code which has the Percentage Rate, Minimum price restrictions 

Last Depreciation date (items Depreciated in the last 12 months will not be included or new items 

accessioned in the current year will not be subject to Depreciation) 

Rounding formulas as set in Stockitem, Application, StockOrigins for the particular Source 

Straight Line Depreciation 

A Straight Line Depreciation uses the Original Cost Price which is stored in Stockitem/Item/History. 
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Note: The Original Cost field is assigned the same value as the cost field when a new item is manually 

inserted Example or Straight Line Depreciation 

An item worth $27.00 was purchased in 1995, and therefore 6 years old at 2001. 

Within the tables, the depreciation rate is set at 10% 

It simply calculates 60% (6 years x 10% = 60%) of the Original Cost e.g. of $27.00 

This will be $16.20 

So the Depreciated pricing will be $27-$16.20= $10.80, rounded off will be $11.00 

Note: Rounding parameters are set in Stockitem, Application, StockitemOrigins 

Reducing Balance 

A Reducing Balance the current cost (i.e. the value visible on the Stockitem Window) is used. 

Example or Reducing Balance Depreciation 

An item worth $27.00 was purchased in 1995, and therefore 6 years old at 2001. 

Within the tables, the depreciation rate is set at 10% 

 1st year it depreciates to $24.30 

 2nd year it depreciates to $21.87 ($24.30 – 2.43) 

 3rd year it depreciates to $19.69 ($21.87 – 2.18) 

 4th year it depreciates to $17.73 ($19.69 – 1.96)) 

 5th year it depreciates to $15.96 ($17.73 - 1.77) 

 6th year it depreciates to $14.37 ($15.96 – 1.59) 

Rounded off that will be $14.00 

Depreciation Process 

The Depreciation process can take a large amount of system resources to implement, and should not 

be done when the library is busy as all other applications will be slow 

Items can be depreciated on a yearly basis. Depreciate all items at the Login Location via the Stats 

Group Table by selecting DepLoc [F8]. To depreciate all items use DepAll [F9]. 

Start Depr From, End At 

The value in this field is the unique Stockitem number and depending upon your installation could be 

in the range 1 to 999999 depending upon how many items are in the database. 

A message will display: 
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For every item on the database at the Current Location this will 

Assign an average price if the price is 0.00 and a parameter entry can be found 

Depreciate the current price by the respective % if the price has not be depreciated within the last 12 

months (a field in the Stockitem History records the last depreciation date). 

At the end of the process, a message will display. 

 

The Accession date of an item is used in these calculations.  

Note: New items accessioned within the last 12 months will not be depreciated 

The Stockitem history will keep a note of the Depreciation change and enters the Last Depreciation 

Date. 

 

Individual items can also be depreciated from Stockitem, Item, Depreciate item.  
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DATA MANAGEMENT 

Catalogue Maintenance 

Insert all Unused Catalogues Records into a Saved File 

1. In Amlib go to Main  > Catalogue > CatMaintenance 

2. Choose the Maintenance Task from Field 1 – Insert all unused Catalogues into a Saved File 

3. Enter an appropriate date in the “Only consider catalogue records before” parameter 

4. Click the  Options button to select or create a file for the Unused Catalogs 

 

5. Press Start [F3] to begin the task. 

 

6. A message will display at the end of the task, giving a summary of the changes made. 

 

The items can then be viewed by displaying the Catalogue File. 
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7. The records can be investigated.  

8. If the catalogue records are to be deleted, the task can be run “Delete all Unused Catalogues 

that are in a Saved File” in the same way as shown above 
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Authority Maintenance 

Mass Delete Unused Authorities 

To mass delete Authorities that are not being reference by catalogue records select this option.   

Schools that import the SCIS Authority File should not perform this task, as they will want to keep the 

unused headings for future use. 

10. In Amlib go to Main  > Authorities > MarcTagMaintenance 

11. Choose the Marc Tag Maintenance Task from Field 1 – Mass Delete All Unused Authorities 

 

12. Under field 2, use the Select Tags... button select the tag the maintenance task is to apply 

the deletion to.  Some tasks allow multi selection of tags, whilst some will allow only one tag.  

Tick the tags you want to delete the unused authorities from and select OK 

 

13. Under field 3 select the Options... button to choose the deletion level  from  Level 1, Level 2 

or Level 3 then select OK  (these are explained further below) 
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OPTION EXPLANATION EXAMPLE 

Mass Delete Unused 

Authorities – See 

options in more detail 

below 

3 options that can be chosen. Level 1 will 

delete the least data, Level 3 the most 

data: 

Level 1: Only Authorities that have never 

been used on your database will be deleted. 

Therefore subject headings that have been 

used as a See, See also, RT, NT etc. will not 

be deleted 

Level 2: Will delete Authorities that are not 

attached to a Catalogue record but will 

retain Authorities where one of the 

references (NT, BT etc.) is attached to a 

Catalogue record 

Level 3: Will delete any Authority that is not 

directly attached to a Catalogue record 

See below in Table 

format “Mass Delete 

Unused Authorities” 

NB: As schools 

import SCIS 

Authority headings, 

they may not wish 

to delete the Unused 

headings 

 

14.  Press  F3 Start to begin the task 

 

15. A confirmation message will be seen, select OK 
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EXAMPLE – WILL THE TERM BE DELETED?? 

Term Usage Level 1 

Only Authorities that have 

never been used on your 

database will be deleted. 

Therefore subject headings 

that have been used as a 

See, See also, RT, NT etc. 

will not be deleted 

Level 2 

Will delete Authorities 

that are not attached to 

a Catalogue record but 

will retain Authorities 

where one of the 

references (NT, BT etc.) 

is attached to a 

Catalogue record 

Level 3 

Will delete any 

Authority that is not 

directly attached to a 

Catalogue record 

Cats 0 Y Y Y 

Cats 

     NT Kittens 

0 N - (the heading is used 

by the system by having 

a cross reference) 

Y Y 

0 

Cats 

     NT Kittens 

0 N  N -Neither term will be 

deleted (the Cats 

heading is being 

referenced by a 

catalogue record 

through the cross 

reference) 

Y - The Term Cats will 

be deleted. The Term 

Kittens will remain (the 

heading is being directly 

referenced by a 

catalogue record) 

1 

Cats 

     NT Kittens 

1 N N - Neither term will be 

deleted (the Kittens 

heading is being 

referenced by a 

catalogue record 

through the cross 

reference) 

Y - The Term Kittens will 

be deleted. Cats will 

remain (the heading is 

being directly 

referenced by a 

catalogue record) 

0 

Cats 

     NT Kittens 

1  N N N - (both headings are 

being directly 

referenced by a 

catalogue record) 

1  

Cats 1 N N N 
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Mass Merge Duplicate Shared Authorities 

This is a Mass merge process and the system automatically merges any duplicate shared Authority - 

for example Subject headings or Authors, without allowing the User to first view any duplicates.  It 

will keep the fuller authority and merge the shorter version to the larger version.  

1. In Amlib go to Main  > Authorities > MarcTagMaintenance 

2. Choose the Mass Merge Duplicate Shared Authorities Task from Field 1 

 

 

OPTION EXPLANATION EXAMPLE 

Mass Merge Duplicate 

Shared Authorities 

This merges authorities that have identical 

Search keys and merges them to one 

Authority without User Intervention 

Please Note: This option should be used 

with caution as some Authors may have the 

same name but in fact are different 

Authors  

John Smith (1866- 

1924) and John 

Smith (1948 -) are 

different authors but 

they have the same 

Search string – these 

would be merged if 

this option is run 

 

3. Under Box 2 highlight the Marc Tag to which to apply the task then select OK.  If merging 

Subject Headings, tick the Tag for the 650. You will need to redo the other tags if they are 

required e.g. 651 
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4. Ignore Fields 3 and 4 as these are not required for this task 

5. Press F3 Start  

6. You will receive a notification, select OK 
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Stockitem Maintenance 

Item Table Menu 

Contains maintenance tasks for Stockitems. 

 

NOTE: 

 

Change Due Dates & Mass Item Change need a File for Processing. If a 

File is not chosen first, the Menu options will remain grey 

 

 

Stockitem Mass Item Deletion 

 

Stockitem Mass Change is useful for maintenance of Stockitem Records. 

 

 

The procedure is to firstly create a Saved file within Stockitem Module 

Secondly we then mass delete the items within the file. 

Creating the Saved File with stockitems for deletion 

 

There are three different ways to conduct the query within Amlib to collate the stockitems necessary 

to save to the Stockitem File. Simply choose from either of the following three suggested methods 

depending on your needs. 

NOTE: 

 

MassItemDeletion will only become available after displaying a Saved File as 
the File references are used to determine which Stockitems on the Database 
will be deleted. 
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To create a File in Stockitem, either: 

 Wand into File  

 Conduct a Query in Stockitem 

 Perform a Where Search or 

File creation alternative 1 -  Wand into File 

1. From the Stockitem >  Application screen, select File. Select the menu option WandIntoFile.  

 

2. F4Select to choose a File. If a suitable File does not exist, select [F1], type a description (eg. 
Mass Deletions) and Select Save using [F3].  
If a suitable File does exist, but items are already in the File which need to be excluded, 

highlight the File and select Empty [F2]. 

 

3. Select the File by highlighting the File and pressing [F9] Select. 
4. Wand the barcodes of the items to be included in the File. As you wand the items you will 

notice the number of items increase for the File on the taskbar of the Stockitem screen.  
Once you have wanded all the items, select File. You will see a tick next to the WandIntoFile 

menu item. To de-activate this click the WandIntoFile option again. The tick will disappear. 

File creation alternative 2 -Conduct a Query in Stockitem 

1. Perform a query to select the Stockitems to change, save the results into a File by selecting 
File > > Save All or Save Marked or SaveNotMarked (as appropriate). 

 

 

2. If a suitable File does not exist, select [F1], type a description and Select SaveF3.  
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If a suitable File does exist, but items are already in the File, which need to be excluded, highlight 

the File and select Empty [F2]. 

3. Once the File has been created or emptied, select the File by highlighting the File and 
pressing [F9] Select. 

4. The items can then be mass changed as shown under the heading Making the Changes. 

File creation alternative 3 - Where Search 

1. Where Searches can be used for creating Files in Stockitem. Set the parameters as required. 
For example, those items not counted in a Stocktake that are DVDs. 

 

2. Choose Query into File [F7].  
If a suitable File does not exist, select [F1], type a description and Select Save using [F3].  

If a suitable File does exist, but items are already in the File, which need to be excluded, highlight 

the File and select Empty [F2]. 

3. Select the File by highlighting the File and pressing [F9] Select. 

Deleting the Items 

Mass Item Deletion 

1. After saving the File, close the Table and go back to the Stockitem Details screen. Select File 
> DisplayFile. Highlight the appropriate File and select [F9].  

2. When the items display, highlight all the items in the table and choose MassItemDeletion 
from the Table menu. 
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The following message will appear asking if you want confirmation of delete messages.  In most 

cases, you would press No, and this automatically deletes the stockitem, and the catalogue record if 

it is the last stockitem for the catalogue record. 

If however, you want to be warned before the catalogue record is deleted when the last stockitem is 

deleted, you should press Yes.  

 

Pressing Yes (and when an item in the table is the last stockitem for the catalogue) will result in the 

message below, allowing you to choose to keep the catalogue record if needed. 

 

If an item has been reserved it cannot be deleted and will remain in the file.  Once the reserve is 

removed the item can then be deleted. 
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Stockitem Autolink  

This facility allows a Global refresh of Stockitems according to the option chosen. The option is 

selected from the table. This can be done on selected items from a saved file or against the database 

by entering a Start and End of Unique numbers (e.g. 1 to 99999) entered.    

Please Note:  Ensure that you have recent Amlib backups prior to running Autolink. Many of these 

facilities, though useful, are powerful and make global changes. They should be run in consultation 

from Amlib Support and as directed.    During the following step all users should NOT be using the 

Stockitem Module for anything BUT searching. 

 

 

OPTION EXPLANATION 

*Rebuild keys using 

Stockitem data (uses 

Stock Stopwords) 

This would only be used if the Stopword listing had been changed in 

Authority, Application, KeywordStopList. Enter a range of Unique 

numbers to Rebuild (e.g. 1 to 100000). You will then be asked to enter 

the Line Number (e.g. Line 1, Title, Line 4 Series) to Rebuild. Once this is 

selected, the Rebuild will commence. A message will display indicating 

the number of items Rebuilt.  

*Non Catalogued items 

Only (Same as Rebuild 

Keys) 

This would only be used for Stockitems with no Catalogue data, if the 

Stopword listing had been changed in Authority, Application, 

KeywordStopList. Enter a range of Unique numbers to Rebuild (e.g. 1 to 

100000). You will then be asked to enter the Line Number (e.g. Line 1, 

Title, Line 4 Series) to Rebuild. Once this is selected, the Rebuild will 
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commence. A message will display indicating the number of items 

Rebuilt.  

*Refresh ALL items from 

catalogue using (excludes 

Periodicals and Orders) 

 

 

Refreshes all Stockitems that are different to the Catalogue data. This 

needs to be used with caution, as there may be a reason behind making 

the Stockitems different (e.g. Primary Campus having different Call Nos. 

to Senior Campus but sharing the same Catalogue Number). Enter a 

range of Unique numbers to Rebuild (e.g. 1 to 100000).  A message will 

display indicating the number of items refreshed.  

Note: Single items can be Refreshed from Catalogue from the 

Stockitem, Item menu 

Remove Excess History Can be set to delete history entries from Stockitem records based on 

Installation parameters.  

For large libraries from time to time it may be necessary to delete 

history records from the Borrower and Stockitem modules.  The history 

records contained within the stockitem history are directly linked to the 

borrower history. Deleting the Stockitem ‘RETURN’ history also deletes 

the corresponding ‘RETURN’ entry in the borrower history. Borrower 

Types that have the ‘Keep History’ parameter set to ‘Y’ do not have 

their READING history deleted in this process. The Stockitem History 

Deletion Autolink function will only delete history records as 

determined in  Supervisor > Installation > Circulation > Keep the last 

### History records 

Change of Stats Period – 

Issues, renewals, reserves 

by item 

Creates a new Statistics Period so that the new statistics can be 

compared to the previous period. This history can be viewed in the 

Stockitem /Item/ History menu. This needs to be used with Caution as 

when run several times, the History can only be viewed for 2 periods - 

Current Period and Previous Period. The possibility of checking what 

has never been borrowed since System inception will be lost.  Use only 

under guidance of Amlib Support. 

Get File Enables the refresh to be restricted to a Saved File. When this is 

selected, a list of Stockitem Files display where the relevant File can be 

selected 

 

Please Note:  Facilities marked with an asterisk (*) will prompt for lines to be refreshed from 

Catalogue 

 

Run the Stockitem Autolink  

1. In Amlib navigate to Main > Stockitems  > Stockitem 

2. Select Application > StockitemAutolink 
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3. In the Options section tick the task to be completed  

 

4. To perform the task against the entire database enter 1 next to Start and 99999 next  to End  
OR to perform the task only on a saved file select the GetFile button  

 

  

5. Select the Start button (note the and the End count will then refresh to the number of 
records to be affected) 

 

 

6. Tick the lines that are to be refreshed.   These are the 6 lines of the Stockitem screen and/or 
Volume, Edition and Call Set fields. Only tick those Stockitem lines that are to be rebuilt from 
Catalogue (note that the Remove Excess History option does not display this screen, all 
others do) 
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7. The process will then run, displaying the updates as it runs.   This is a system intensive 

process so avoid making any other demands on the system until it is complete 

 

8. At the end of the process a message will display, indicating the number of items processed, 

select OK 
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Mass changes to Stockitem 

There are 2 options for Mass Change of items: 

 Stockwand Change  

 File – Mass Change from the File e.g. After wanding into File 

Stockwand Change 

This facility is used to define a set of changes and apply those changes to all items: 

1. Individually from the Barcode (select Start and begin wanding the Item Numbers) [F6] 

2. From a File [F7]  

3. From a Saved Where Search [F8] 

Stockwand Change – setting Values to change 

1. Launch the Amlib Client 

2. Go to Main > StockItems> StockWandChange – the Stockitem Wand Change screen will 

display 

3. Choose the Column to Change box 1: select a parameter – for example: Process 

4. Type the new Value into box 2 

Please Note: A list of codes can be accessed from box 2 by entering a full stop and pressing the Tab 

key on your keyboard. The Special button can be used for assigning Date ranges using the Current 

Date which can be very useful. 
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5. Click the Paste Button 

6. The values to change will display in the Columns at the base of the screen 

Using the Special Button 

Useful for selecting the Current Date and perhaps minus (or Add) a number of days of Months. 

7. Click the red Special button – the Update prompt will display: 

 

8. Select/enter your date parameters 

9. Click the Paste button 
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Executing the Changes 

The Changes can be applied in one of 3 methods: 

1. Individually from the Barcode: 

a) Click the F6 Start button – the Start prompt will display containing a confirmation 

message: 

 

b) To proceed, click the Yes button 

c) Begin wanding the Items into the Item No field for the changes to be applied 

2. From a Saved File: 

a) Click the F7 FrFile button – the Stockitem Saved Query Results screen will display 

b) Highlight the relevant File (saved previously) and click the F9 Select button – the Mass 
Change from file prompt will display with the number of items to change defined as 
well as the File selected: 

 

c) Review the message and if the information is correct click the Yes button to proceed 
d) A  prompt with the following message will  display when complete:  

The XX Stockitems have been Updated. 

 

3. From a Saved Where Search: 

a) Select the F8  FrWhere button – the Saved Queries  screen will display 
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b) Highlight the relevant saved Where Search (Saved previously) and click the F9 Execute 
button – the Mass Change from Saved Where prompt will display with the number of 
items to change defined as well as the Where Search selected: 

 

c) Review the message and if the information is correct click the Yes button to proceed 
d) A  prompt with the following message will display when complete: 

 The XX Stockitems have been Updated. 

 

Saving a StockWandChange  

A Stockwand Change can be saved for future use: 

1. With the Stockwand Change parameters displayed click the F2 Insert button – the Saved 

Stock Wand Changes screen will display: 

 

2. Type a Description in the field at the bottom of the screen 



 System Management - TASKS 

 

Last Updated: 26 February 2013 
 Page 72 

 

3. Click the F3 Save button 

Reusing a StockWandChange set of Parameters 

1. Go to Main > StockItems> StockWandChange – the Stockitem Wand Change screen will 

display 

2. Click the F4 Select button – the Saved Stock Wand Changes screen will display 

3. Highlight the required StockWand Change 

4. Click the F9 Select button 

5. The parameters will display where the items can be selected by wanding, from a File or from 

a Saved Where search 

 

 

6. Type a Description in the field at the bottom of the screen 

7. Click the F3 Save button 
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Borrower Maintenance 

Borrower Table Menu 

Contains maintenance tasks for Borrowers. 

 

NOTE: 

 

Mass Borrower Change, Mass Address2 Delete & Mass Address 3 Delete 

need a File for Processing. If a File is not chosen first, these Menu 

options will remain grey 

 

 

Deletions 

Single deletions of Borrowers can be done from the Borrower Details screen. 

Mass deletions of Borrowers can be done from the Borrower Table menu. The Borrowers in the 

table need to be highlighted to make the deletions. 

Borrowers with loans, reservations or Memos will NOT be deleted. 

Mass Borrower Change  

This process can be used to change Borrower Group, Type, Class, etc. The example used here is 

Borrower Group.  

1. Launch the Amlib client 

2. Go to Main > Borrowers > BorrowerWhere – the Borrower Where screen will display 

3. Create a Where clause – for example: Group = CHI (this will search for all Borrowers who are 

in that particular group) 

a. Highlight the field to search on: Group 

b. Choose Operator: = 
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c. Enter the Where condition, or the exact data you want to find – for example: CHI 

d. Click the Paste button to insert the clause into the table 

 

4. Click on the F7 QtoFile button – the Borrower Saved Query Results screen will now display: 

 

5. Click on the F1 New button to create a new Saved File 

6. Type in a name for the file in the Details column – for example: Groups to Change 

7. Click on F3 Save button 

8. Highlight the new Saved File and click on the F9 Select button to save results to this file 
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9. A prompt will display noting the number of borrowers contained in the file 

 

10. Click the OK button 

11. Go to Main > Borrowers > Borrower – the Borrower screen will display 

12. Select File > DisplayFile – the Borrower Saved Query Results file screen will display 

   

13. Highlight the required Saved File and click on the F9 Select button to display the file 

14. From the Borrowers List screen, select Table > Mass Borrower Change 
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6. The Mass Change of Borrowers within a File screen will display: 

 

7. Enter the following settings: 

a) Select the field you wish to change for all stockitems in the file example -  Group 

b) Type in the new value example, which is what you are changing all stockitems to be – for 
example: DUT 

c) Click on the Paste button to insert the new criteria into the bottom table 

d) Click on the F3 Update button to start the mass change 

15. This will change all the Borrower Groups in this file so that they are now Dutch 
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Mass Memo Borrowers 

It is possible to attach memos to Borrowers “en masse” by applying a Memo to a table of borrowers.   
Firstly, decide whether Memo Types will be included in the Memo, and if so ensure that the Memo 
Type to be selected is defined  

Check Memo Types 

1. In Amlib navigate to Main > Supervisor  > Supervisor screen  
2. Select Library Menu > Memo Types 
3. To add a new Memo Type select F1 New 

 

4. Type in a Memo Type code, and Description  
5.  Enter  whether the memo is Valid for Holdings (to be applied to Stockitems),  Valid for 

Members (to be applied to Patrons), Show as Default (to pop up in Circulation Y/N) 
6. If you wish the memo to expire enter an Expire in n days time number, otherwise leave this 

column blank 
7. Select F3 Save and  log out of Amlib and back in  

Mass Memo the Borrowers 

1. Find the Borrowers to whom the Memo will be applied from a Where search or a Query. If 
they are Borrowers that cannot be queried at the same time, find the assorted Borrowers and 
save them to a File so that they can be displayed together in a borrower table.  This example 
uses searching for borrowers for a particular class using a Where Statement 

2. Go to Main > Borrowers > Borrower Where 
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3. Enter an appropriate Where Statement to find your borrowers- for example Class = 7A and 
Paste 

 

4. Select the  F5 Query button 

5. A Table will display. If only some of the Borrowers from the Table are to be sent Memos, 
highlight those Borrowers – use Ctrl + Click to select multiples, or Shift + Click to select a 
range. 

6. Select Mass Memo All Borrowers or Mass Memo Marked Borrower as appropriate.   
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Step 3: The Mass Memo Data screen will display 

 

Enter the details as required: 

1. Select Memo Type if appropriate – this will automatically insert the Show Default, the Date 

Defaults and the Memo Message. To view the Memo Types available, type . <TAB> (full stop 

and press the TAB key) 
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2. If no Memo Type is to be used, enter the Show, Start and End Dates and Message details. 

Show: Y/N/O 

Y  The operator is alerted every time the Borrower’s identity is entered in 

circulation 

N The memo can be viewed from the Borrower memo option 

O The memo can be viewed from Opac  

 Date: The date (in the format of dd/mm/yyyy) to begin showing the memo. This is defaulted 
to today’s date but may be altered 

 

 End Date: The date (in the format of dd/mm/yyyy) to finish showing the memo. This is 
defaulted to the date as calculated in Supervisor, Installation, Borrower, “Delete memo after 
xx days”. This may be altered 

 

 Type:  Optional. A type of memo can be entered to assist with deletions, reporting, queries 
etc.  

 

 Message Details: Text of up to 250 characters can be entered. 

3. Select Save [F3]. 

Step 4: Memos will be automatically placed against the Borrowers. When the Borrower is displayed 

in Circulation the memo will display if the Show is set to Y.  
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NOTE: 

 

Whether the Memo appears in the Borrower Module depends on 

the Supervisor, Installation parameter for the relevant Location 
(from Installation Menu). Check the Borrower button – 

Parameter is  “Show Memos in Borrower automatically” 

 

 

Borrower Update Reports 

Borrower update reports can now be run to change borrower status, add memos and delete the 

address 3 field (for those borrowers that are changing to adult status). 

In the following example, we are changing the Borrower Type of Young Adult members to an Adult 

Type and deleting the Guardian Address. 

Template 

1. Launch the Amlib client 

2. Go to Main > Reports > RepAddNew – the Report Files screen will display: 

 

3. Locate and highlight the &BORUPD.QRP template 

4. Click the F2 Modify button – the Borrower – Modify Report File screen will display: 
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5. Check the following settings: 

a. Choose Type = Borrower Automatic Update 

b. Update Entity (Y/N) = Y 

6. Click the F3 Update when complete 

Create the Report 

1. Go to Main > Reports > RepBorrower – the Borrower Reports screen will display 

2. Click the F1 New button – the Select Report Format list will display: 

 

3. Highlight the &BORUPD.QRP template and click the Select button 

4. A new report will be added to the list of reports 

5. Type in a Description – for example: Update Borrower Address 3 
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6. The Update Entity (Y/N) column setting must be set to Y 

7. Click the F3 Save button when complete 

 

Set Where Parameters 

Your where parameters can be set according to the changes you need to make to your database, and 

which group(s) of people these changes apply to. 

The Where statement here selects those borrowers with a YA borrower type who are now over 18. 

If you are unsure of how to set your where parameters for the update you wish to carry out, please 

contact Amlib support. 

1. Highlight the Report 

2. Click the F7 Where button – the Borrower Reports – Where screen will display: 

 

3. Enter the following details: 
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a. BorType – for example: BorType = YA 

b. BirthDate – for example: BirthDate <= Current Date – 18 Years (use the Special 

button to insert Current Date – 216 months) 

4. Click the F3 Save button when complete (the Where screen will close) 
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Update Parameters (F10 More) 

The F10 More button is used to set up the new values and whether a Memo is to be sent. 

A report employing F10 More parameters must be run via the Scheduler. 

1. Highlight the report 

2. Click the F10 More button – the More screen will display 

3. Click the F1 New or F2 Insert button  

4. Enter the following Line 1 parameters (see Notes below): 

a. Report Line Number = 1 

b. Column = T 

c. New Value = A (for Adult) 

d. Send Memo = Y (optional) 

5. Click the F3 Save button when complete 

6. Enter the following Line 2 parameters (see Notes below): 

a. Address 3 = Y (this will delete the Borrower’s Guardian Address) 

7. Click the F3 Save button when complete 

 

 COLUMN 1 COLUMN 2 COLUMN 3 COLUMN 4 COLUMN 5 

HEADING Report Line 
Number 

Column New Value Send Memo Address 3 

EXAMPLE 1 T A Y <leave blank> 

 2 <leave blank> <leave blank> <leave blank> Y 

COMMENT Line 1 is used 
for updates 

Line 2 is used to 
delete 
Borrower 
Address 3 

Borrower field – 
can be 
Borrower Types 
(T), Classes (C) 
Groups (G) or 
Status (S) 

The new value – 
must be a valid 
code for the 
selected column 

If Y, create the 
memo in Text 
for Letter, 
found at the top 
of the Borrower 
Reports screen 

If Y, can be used 
to delete 
Address 3 
(Guardian 
Address) from 
Borrower 
record 
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Notes 

Updates: The new value is the new Borrower Type (or Borrower Status, Borrower Class or Borrower 

Group) that you wish to change the Borrowers to. 

In the example given above, the Borrower Type would be changed to Adult, or A. The value entered 

in this column will depend on your Borrower Type settings. If you unsure, check your settings before 

proceeding: Go to Main > Borrower > BorrowerTypes: 

 

Memo: If you wish to add a memo to each borrower record that is changed, type a Y in the Send 

Memo column. Otherwise, type N in the Send Memo column. 

Delete Guardian Address: Type a Y in the Address 3 column if you wish to have the guardian address 

deleted (for example in the case where YA members are changed to A members, for these records 

you may prefer to have the guardian address deleted as this is no longer required). 

Memos 

If you have placed a Y in the Send Memo column, then the Memo text must then be set up. 

1. Highlight the report 

  

2. Click the Text for Letter button – the Letter Text screen will display: 
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3. Type in the text that you would like to see in the Borrower Memo – for example: Borrower 

to sign register and present ID 

4. Click the F3 Save button when complete 

View Report 

Once the report is set up, you can then preview the report as follows: 

1. Highlight the report and click the F8 View button 

2. The Select File for View pop-up will appear: 

 

3. Click the No button to run this report against all borrowers 

4. The report will open in the Report – View window: 

 

5.  If you wish to print a hardcopy, click on the print icon 
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Print Report (via Scheduler) 

Borrower Update reports MUST be run via the Scheduler. 

Start the Scheduler 

1. From the Reports screen, select Application > RepStartSchedule 

 

2. The Report Scheduler screen will then open 

3. Select your printing options: Ensure Save to File is ticked (you can tick all three if you intend 

on printing up multiple reports using multiple formats during a session) 

 

4. Then click the OK button 

5. After clicking OK, if you go back into the Application menu you will see that 

RepStartSchedule is now greyed out with a tick next to it – this indicates that the Scheduler is 

now running 
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Scheduling the Report 

1. With your report highlighted, select the F6 Print button – the Print dialogue box will open 

2. Select from the following options: 

a. From: 

 Database (to search the entire database) 

b. To: 

 File (to save a report as a file) 

c. Frequency: 

 Once Only 

 

3. Once you have selected all of your settings, click the OK button – the Report – Save As screen 

will display: 

 

4. Select a Save in: location and type in a File name: 
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5. Click the Save button when complete 

Check Print Progress 

1. You can check the progress of your reports at any time by going into Main > Reports > 

RepPrintProgress 

 

2. You can also click through the three tab options at the top to see the ones that are Waiting, 

Running, or have already been Printed 

3. Your report will show up in Printed when it is complete 

 

The matching Borrower details should then be updated. 

Updated Borrower Record: 



 System Management - TASKS 

 

Last Updated: 26 February 2013 
 Page 91 

 

 

Memo that appears in Circulation: 
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System Activity Trends 

The system activity window gives a brief overview of the system for the following activities. The 

colours used in the graph are different for each activity. 

 Issues (Green) 

 Returns (Red) 

 Reserves (Blue) 

 Enquiry (Yellow) 

This window may also be used to initiate spreadsheet data transfer. 

1. Launch the Amlib client 

2. Go to Main > Supervisor > System Activity – the Circulation Activity screen will display: 

 

3. This window is actually using the collected statistics and may be used to view any period by 

changing the from and to values for Hrs, Days, Mths and Yrs fields from the top of the 

window (highlight the field with your mouse and overwrite it) and then selecting Window > 

Refresh from the menu – the following ranges apply: 

a. Hrs: 0 – 23 – for example: 8 – 18 (for stats between 8am and 6 pm) 

b. Days: 1 – 31 – for example: 1 – 12 (for the first 12 days of the month) 

c. Mths: 1 – 12 – for example: 1 – 3 (for the first quarter) 

d. Yrs: 2XXX – 2XXXX – for example: 2009 – 2010 (for the 2009 and 210 stats) 

Please Note: By default, the Hrs, Days, Mth and Yrs fields will default to the current date and time. 

Please Note: When viewing statistics on the system activity window you may only view down to the 

level at which stats are being collected – for example: if you are not collecting by hour enter 0 - 23 in 

the hours fields. 
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4. The display can be changed to be Hour, Day, Month or Year using the Summarised by radio 

button selections at the bottom of the screen 

5. The default display is: All Locations – to view a particular location in isolation: 

e. Select Window > ChooseLocation from the menu 

 

f. The following prompt will display: 

 

g. Highlight the desired location and click the OK button – the Location at the top of 

the screen will change to match the selected Location 

These fields can be adjusted and 

then Window > Refresh selected 

to populate the display 
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h. Select Window > Refresh to refresh the statistics displayed 

 

6. The default display is to show IssuesReturns – the system activity can be changed to be 

viewed by Borrower (Green), Stockitem (Red), Catalogue (Blue) and Authority (Yellow) by 

selecting Window > Enquiries and then Window > Refresh 

 

As the population of statistics grows the data collection queries may take some time so this should 

not be activated when the system is busy. 

Please Note:  Use Window > Refresh whenever you have changed any of the selection fields. 

Printing 

If you have a colour printer, you can print the image. There is no Print button in the Amlib client but 

you can capture a screenshot by holding the Alt button while clicking the PrtScn button on your 

keyboard. You can then paste (Ctrl + V) the image into Word or WordPad for printing. 
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APPENDIX 1: BACKUP AMLIB SQL SERVER & CREATE TEST DATABASES:  

SQL SERVER MANAGEMENT STUDIO 

If you have any queries about backup do not hesitate to contact our OCLC Support office. 

The following databases must be backed up: 

 AMCAT 

 AMLIB 

 AMLOCAL 

 AMSTATS 

 AMWEB 

Backup 

1. Launch Microsoft SQL Server Management Studio 

2. Expand the Databases selection tree [+] 

3. Right-click on the AMCAT database and select Tasks > Back Up... 

 

4. The Back Up Database window will open 

5. Select the General page 

6. Choose the following options: 

 Source 

o Database: AMCAT 

o Backup type: Full 
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 Destination (can leave as default) 

o Click on the Add button to open the Select Backup Destination window 

o Click on the ... button to browse to and select a destination 

o Click on the OK button  

 

 

7. Select the Options page 

8. Choose the following options: 

 Overwrite media 

o Overwrite all existing backup sets 
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 Reliability 

o Verify backup when finished 

 

9. Click the OK button 

10. When complete the following message will appear: The backup of database ‘AMCAT’ 
completed successfully. 

 

11. Repeat steps 3 – 10 for  the AMLIB, AMLOCAL, AMSTATS and AMWEB databases 
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Create a Test Database 

The following databases will be created: 

 TECAT 

 TELIB 

 TELOCAL 

 TESTATS 

 TEWEB 

Create Databases 

1. Launch Microsoft SQL Server Management Studio 

2. Right-click on Databases and select New Database... – the New Database window will open 

 

3. Database Name = TECAT 

4. Click the OK button to create the database 

5. Repeat steps 2-4 to create the TELIB, TELOCAL, TESTATS and TEWEB databases 
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Restore Backed Up Databases to New Test Databases 

1. Expand the Databases selection tree [+] 

2. Right-click on the TECAT database and select Tasks > Restore > Database... – the Restore 
Database window will open 

 

3. Select the From device: radio button 

4. Click the ... (Select Devices)button – the Specify Backup screen will open 
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5. Click the Add button – the Locate Backup File window will open 

 

6. Select the corresponding AMCAT.BAK file 

7. Click the OK button to return to the Specify Backup window 

8. Click the OK button to return to the Restore database window 

9. Tick the Restore box for the selected database 

10. Select the Options page 

11. Restore options – select Overwrite the existing database (WITH REPLACE) 

12. Edit the paths of the Data and Log files in the Restore Database files as: table so that they 

reflect the path of the test database file name – for example: TECAT.mdf and TECAT_log.ldf 

13. Click the OK button – the database will be restored 
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14. The following message will appear when complete: The restore of the database XXXX 

completed successfully. 

 

15. Repeat steps 2-14 for all the TE databases 

Map User Schema 

It may be necessary to clear the old user schema first. 

1. Click the New Query button – this will open up the SQL Query screen 

2. Type in the following: 

 use TECAT 

 drop schema sysadm 

 drop user sysadm 

 

3. Click the ! Execute button 

4. Repeat for all TE databases 

Map User Schema 

1. Expand the Security selection tree [+] 

2. Expand the Login selection tree [+] 

3. Right-click on the SYSADM and select Properties – the Login Properties window will open 

4. Select a page = User Mapping 

5. Users mapped to this login: ensure there are ticks against ALL the TE databases 

6. Database role membership for: ensure that db_owner is ticked 

7. Click the OK button when complete 
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Link the Amlib Client to the Test Database 

1. In the Amlib folder on the Amlib server, locate the SQL.ini file 

2. Open the SQL.ini file in Notepad 

3. Scroll down to the server paths section – you should see the existing server paths for the 

default (Live) SQL databases: 

; This is the server paths used for the default SQL server 

REMOTEDBNAME=AMCAT,DRIVER=SQL SERVER;SERVER=MYSERVERNAME\SQLEXPRESS;DATABASE=AMCAT 

REMOTEDBNAME=AMLIB,DRIVER=SQL SERVER;SERVER= MYSERVERNAME \SQLEXPRESS;DATABASE=AMLIB 

REMOTEDBNAME=AMLOCAL,DRIVER=SQL SERVER;SERVER= MYSERVERNAME \SQLEXPRESS;DATABASE=AMLOCAL 

REMOTEDBNAME=AMSTATS,DRIVER=SQL SERVER;SERVER= MYSERVERNAME \SQLEXPRESS;DATABASE=AMSTATS 

REMOTEDBNAME=AMWEB,DRIVER=SQL SERVER;SERVER= MYSERVERNAME \SQLEXPRESS;DATABASE=AMWEB 
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4. Copy the existing set and then paste underneath, then edit the new set to create the link to 

the TE 

; This is the server paths used for the test SQL server 

REMOTEDBNAME=TECAT,DRIVER=SQL SERVER;SERVER=MYSERVERNAME\SQLEXPRESS;DATABASE=TECAT 

REMOTEDBNAME=TELIB,DRIVER=SQL SERVER;SERVER= MYSERVERNAME \SQLEXPRESS;DATABASE=TELIB 

REMOTEDBNAME=TELOCAL,DRIVER=SQL SERVER;SERVER= MYSERVERNAME \SQLEXPRESS;DATABASE=TELOCAL 

REMOTEDBNAME=TESTATS,DRIVER=SQL SERVER;SERVER= MYSERVERNAME \SQLEXPRESS;DATABASE=TESTATS 

REMOTEDBNAME=TEWEB,DRIVER=SQL SERVER;SERVER= MYSERVERNAME \SQLEXPRESS;DATABASE=TEWEB 

5. Save the changes 

The test database is now linked to Amlib. 
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APPENDIX 2: Amlib SQL Server 2008 Maintenance Plans 

This document applies to any purchased version of SQL Server 2008 or 2008R2. This does not apply 

to the Express version. 

Your library has invested considerable time and effort in the creation of the library data, so it is vital 

to protect this investment and ensure that loan transactions and financial records are safe. The most 

important tool in this process is the Maintenance Plan.  

A properly configured Maintenance Plan does more than just backup the databases. It also runs a 

number of important tweaking tasks which help to keep the system healthy and running as fast as 

possible. 

Third party backup utilities are NOT a substitute for running an SQL Server Maintenance Plan, despite 

any claims made by their manufacturers. 

Make sure that you check to see if any other Maintenance plans are being run on the server. They 

may be configured in a way that will affect the Amlib databases, certainly you will have to avoid 

scheduling conflicts. 

Step One: 

In SQL Server Management Studio, expand “Management” and right-click on “Maintenance Plans”, 

then select “New Maintenance Plan...”: 

 

Give the new plan a suitable name: 
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One you have clicked on “OK”, this screen will open: 

 

Step Two: 

From the “Toolbox” on the sidebar, select the “Back Up Database Task”, then drag and drop it into 

the white area: 

 

 

Double click on the task to open the configuration settings. 
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Click on the downward facing arrow on the dropdown box next to “Database(s)” and select the 
databases to be backed up (all Amlib databases, i.e. AMCAT, AMLIB, AMLOCAL, AMSTATS and 
AMWEB – yours may have prefixes other than “AM”). 

 

 

Tick the box next to “Backup set will expire” and set the expiration period based on your IT’s backup 

policies. If your IT has no policy on how long the backups should be kept, you can leave it at the 

default 14 days: 
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Ensure that your Database Backup Task contains the same settings as the screenshot below, then 
select “OK”: 
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Step Three: 

In addition to backing up the entire databases, we will also want to make a backup of the transaction 

logs. Once again, drag and drop the “Back Up Database Task” from the Toolbox on the sidebar into 

the white space to create a second task. 

 

To avoid confusion, you can rename tasks by clicking once on the bolded text at the top and altering 

it: 

 

 

Double click on the second task to open its configuration settings. 

Change the “Backup Type” to “Transaction Log” and again select your Amlib databases from the 

“Database(s)” drop down: 
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Like with the full backups, tick the box next to “Backup set will expire” and set the expiration period. 

Transaction logs can take up quite a lot of room, so OCLC recommend change this to expire every 7 

days, but this is dependent on the size of your hard drive. 

 

 

Ensure that all of your settings as the same as the screenshot below, then click on “OK”: 
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Step Four: 

From the Toolbox on the Sidebar, drag and drop the “Check Database Integrity Task” into the white 

space. 

 

Double click on the task to open the configuration settings and select your Amlib databases. 

 

Ensure that “Include Indexes” is ticked and select “OK”. 
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Step Five: 

From the Toolbox on the Sidebar, drag and drop the “Update Statistics Task” into the white space. 

 

 

Double click on the task to open the configuration settings. Select your Amlib databases from the 

“Databases” drop down and select “OK”. 
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Leave the defaults: “All existing databases” and “Full scan”. 

Step Six: 

Drag and drop the “History Cleanup Task” from the Toolbox on the Sidebar into the white space. 

 

 

Double click on this task to view the configuration settings. Most of them should be left as the 

default, but you may wish to alter the expiration period. 
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Step Seven: 

Now that all of the tasks have been created, they need to be connected. When selected, each task 

will have a green arrow down the bottom: 

 

Click on this green arrow and drag it out to the next task in the list. Do this to all tasks so that they 

are pointing towards the next one that was created.  

The final task will not be connected to a future task. 
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Step Eight: 

The final step in settings up your maintenance plans is to create a schedule. 

At the top of the white space, click on the calendar icon: 

 

It is recommended that these tasks be run daily and set to occur outside of normal opening hours. 

 

Some considerations to be made when scheduling your plan: 

 Make sure any scheduled reports have occurred before your Maintenance Plan 

 Allow sufficient time for scheduled reports to be completed 

 Make sure other system tasks will happen after your Maintenance Plan 

 Allow sufficient time for your Maintenance Plan to be completed 

After your plan has been scheduled, you can save the plan and exit SQL Server Management Studio. 

If you have any queries, please contact Amlib Support either via the Online Helpdesk 

(https://servicedesk.oclc.org) or via email (support-amlib@oclc.org). 
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APPENDIX 3: DISASTER RECOVERY PLANNING 

Losing your library data is a frustrating, expensive and unnecessary experience; don’t let it happen to 

you.  

This document doesn’t pretend to teach you everything that you need to know about disaster 

recovery, but it should get you thinking along the right lines. Many City and Shire Councils and some 

schools will already have disaster recovery plans; this document focuses on the elements of such a 

plan that relate to library management systems. 

O'Toole's Commentary on Murphy's Law – “Murphy was an optimist” 

There are a number of events that can bring your library management system to a complete halt, 

some are temporary, some are not. 

1. Equipment failure 

 Hard Disk crash 

 Network failure 

 Virus attack 

2. Power Outage 

 Anything between a momentary disk-frying surge and a couple of candle-lit days 

3. Operator/Administrator error 

 Accidental deletion of files or data 

 Mistakes while editing configuration files (INI files) 

 Removal of User permissions 

4. Fire 

 The most compelling reason for keeping off-site backups 

 Even if the whole building and collection is lost you will want to recover the data for 
your insurance claim 

5. Theft 

These things happen to school and community libraries regularly, if you don’t have a good disaster 

recovery plan you will lose all your data, thousands of catalogue and holdings records, all your 

circulation information and any value added cataloguing that you have done. You will not be happy. 

 

 

 

Make a Plan 
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There are three phases to a disaster recovery plan: 

Before: 

o Preventative 

Are there any actions you can take that might prevent the disaster from happening?  

 Replace aging hardware before it fails 

 Use power line filters and/or surge protectors, at least on the server 

 Keep your Operating System up-to-date by installing Service Packs 

 Use up-to-date virus protection software 

 Use only commonly available backup media, software and drives 

 Monitor the amount of free disk space on your database server to ensure 
that there is enough space for the backups and database growth 

 Follow the OCLC recommended procedures for backups 

 Document the backup and recovery procedures 

 Make sure that each action is assigned to a person 

o Preparedness 

Are there any actions you can take that will ensure that you are properly prepared to 

respond to and recover from the disaster?  

 Maintain and check backup procedures 

o If the databases are backed up to disk, SQL Base always does, you 
also need a process to copy the backup files to some other location 
and or media for off-site backup 

o Copy the following folders onto the backup media as well as the 
database backups: 

 Folder containing Images linked to Catalogues 

 Folder containing Images linked to Borrowers 

 Folder containing NetOpac html files 

 Folders containing AmlibNet html files 

o Label backup media clearly 

o Rotate backup media so that you are not over-writing the most 
recent backup 

 Keep off-site backups of the backup data and recovery software 

 Check the backup logs – allow access for both Library and IT staff for this 
purpose 
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 Keep your Amlib installation CDs – they always contain everything you need 
to carry out a fresh installation of the client software and also the latest SQL 
Base Database Management System 

 Carry out a test recovery onto a set of test databases at regular intervals 

 Install and test Offline on more than one PC etc. 

During 

o Response 

What action should be taken when a disaster occurs?  

 Use Offline for circulation during power outages and network or server failures. 

 Power down machines running on UPS devices before the battery fails. 

After 

o Recovery 

What action must be taken to restore library services to normal or at least make data available for 

the insurance claim? 

 Borrow, rent or buy a replacement server as soon as possible 

 Install the required Operating System, Database Management Software and backup utilities. 

 Restore the Amlib databases from the most recent backup 

 Install the Amlib Client software from the Amlib Installation CD 

 Make sure that the new system is working 

Allocate Responsibility 

Decide who is responsible for each action that is specified in the plan and make sure that the person 

acknowledges the responsibility. 

Practice 

At regular intervals, practice recovering you library’s databases from the most recent backups. This is 

one good reason for having a set of test databases, you can practice restoring from a backup on 

them with no risk to your live data.  

Put these regular practices into you plan. 

Review 

Over time software systems change, new utilities get installed, web pages are updated, new people 

move into important roles; this means that your plan may become out-of –date. To avoid this review 

you plan at regular intervals.  

Staff changes are a big cause of problems in Backup and Recovery procedures. Review the whole 

process with each new person so that there is a clear understanding of what is being done, why it is 

being done and by whom. 
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