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OVERVIEW 

This manual is designed in showing how to use Report Writer (Repwin30.exe) to edit existing and 

create new report templates for use within Amlib. 

The creation and editing of report templates is covered in broad terms by the following flowchart: 
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USING REPORT WRITER 

Report Writer (Repwin30.exe) is a separate program, produced by Gupta, utilised by the Amlib 

programs for Reports. A number of Report templates have been developed in Amlib which can be 

edited or customised from existing formats. The report templates designed for Amlib contain all the 

Fields needed to format and present the data you provide. Once Report Writer is mastered it can be 

used to create new reports from existing formats. 

The Report Template is the Design of the Report. This report template contains the fields, lines, 

boxes and pictures you want to include in your report. It does not contain the actual report data. The 

Template design is subject to the Report Type defined.  

The Report Type is the mechanism used by the Amlib reports module to pass specified fields through 

to the report template. The report type also dictates the columns/fields that can be used in a ‘Where 

statement’. For example the design of a Circulation Report will use different Fields to that of a 

Borrower History Report. 

Each Report that exists in Amlib has an individual template stored as a *.qrp file. Each template has a 

unique file name which needs to be used when setting up the report in Amlib. Each report template 

may have the following sections: 

Report Header Optional. Appears only once and can contain a title or header for the 

beginning of the report. 

Page Header Optional. Can contain titles or headers that appear on each page.  

Header Option. Appears before the first line of a group of records. (These do not 

display until Break groups are defined). For example a Break may be 

implemented for Class and a Heading showing the Class name at the top of 

each break of Class 

Detail Block  Information from individual rows showing data from the database. Reports 

have only one Detail block per report template. 

Footers Optional and may contain Totals for each group. 

Page Footer Optional and may contain Page Numbers. Shown on each page of the 

Report. 

Report Footer Optional and may contain Grand Totals or other data at the end of the 

Report. 

 

Each of these sections may contain any combination of the following: 
 

Background Text A field in the Report containing static text. 

Fields Contain data input 

Pictures/Graphics Can hold bitmaps, graphic or OLE objects. 
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Amlib Reports 

Amlib reports are made up of: 

 

Naming Reports 

Often Reports in Amlib have a prefix of "&" eg "&borfull.qrp", # e.g. #stkinv.qrp or $ (for Table 

Reports) eg $itelist.qrp. It is strongly recommended that sites DO NOT use these prefixes for their 

own customised reports. It is recommended that new reports (based on a copy of the most relevant 

existing report) be created using a site-specific prefix. 

It is strongly recommended that you save any report files you are working on into a Temporary folder 

on your PC and make changes in this folder before saving them back onto your network drive. It is 

also strongly recommended that you keep a copy of your customised report in a KEEP or MODS 

folder so that there is no chance of reports being overwritten by one of our releases. 

Editing Templates 

This course is aimed at showing how the existing templates can be edited and saved as new reports 

for using within Amlib. It is important to begin with a template as close as possible to the desired 

outcome so that changes can be made and it will be compatible with the Report Application of 

choice. For example, if an email is to be composed for your site for Overdues, it is important to start 

with the Email template that already exists, make changes and save it with a new name. Never start 

with an empty Report Writer screen – it will never work as it does not have any Input items 

programmed into the Report. 

Programming with complex strings etc. is not to be covered and if required, programmer assistance 

is advised. 

Customization 

Report Writer enables the design of Amlib Reports to be customised. The level of customisation will 

depend on the outcome desired. This can be a simple as altering some background Text and saving 

the Report. It could also be complex, altering Fields and Headings, saving the Report with a new 

name and adding the new Template as a Report to be used in Amlib. 
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ACCESSING REPORT TEMPLATES 

Option 1 Report Writer  

The Report Writer program REPWIN30.EXE is located on your Amlib server or local PC in the 

\Amlib\Utility\Repwin folder. It is suggested that if this program is used often, that a shortcut is 

saved on the Desktop as an Icon. 

To open template files using RepWin30: 

1. Launch RepWin30 

 

2. Select File> Open,  the File Open screen will display 

 

3. In the Directories: box select and navigate to the drive on which the Amlib/Report folder 

resides in. All available reports will be displayed in the File: box    

HINT: You can move back a directory by using the [..] option. 

4. Select the file and then click on the OK button 
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Please Note: Files beginning with $ or & symbols indicate that they are system reports. Any updating 

of these reports should be saved as filenames with alternative beginnings eg letters etc. 
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Option 2 Windows Explorer 

To open template files using Windows Explorer: 

1. Open a Windows Explorer Window 

2. Navigate to the \Amlib\Report folder on your Amlib server or local PC 

 

3. Highlight & Double-click template file to open – chosen template will display in RepWin  

Note: If it is the first time a .qrp file type is opened REPWIN30.EXE may need to be selected 

for Windows to open .qrp files automatically in the future.  

 

Selecting REPWIN30.EXE to open template files for the first time in Windows Explorer: 
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1. Open a Windows Explorer Window 

2. Navigate to the \Amlib\Report folder on your Amlib server or local PC 

3. Highlight & Double-click template file – the Open With window will display 

4. Click the Browse button  

5. Navigate to the \Amlib\Utility\Repwin folder on your Amlib server or local PC 

6. Highlight REPWIN30.EXE, and click the Open button 

 

7. Once returned to the Open With window, ensure the ‘Always use the selected program to 

open this kind of file’ tick box is ticked 

 

8. Click the OK button – the chosen template will display in RepWin  
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A GUIDE TO REPORT TEMPLATE NAMES 

When you first look at the templates, the names appear to be in some form of code. Since a 

template name can have a maximum of 8 characters, the names consist of abbreviations to indicate 

the type of report and sometimes the contents. Refer to the guide below for abbreviations and their 

meanings. 

SYMBOL TEMPLATE TYPE EXAMPLE EXAMPLE DESCRIPTION 

& System &ODEMAIL.QRP Overdue Email Notice 

$ Table $BOTYPES.QRP List of Borrower Types 

# Special #ADDLABL.QRP Borrower Address Labels 

[No symbol] Custom AMODEML.QRP Custom Overdue Email 

 

Abbreviation Meaning Example 

Auth Authority templates &authsb2.qrp, &authful.qrp 

B Borrower templates &bct.qrp, &bclt.qrp 

Bor Borrower templates &bordata.qrp, &borsht.qrp 

Bib Bibliographic templates &bib.qrp, &bib2.qrp 

Borh Borrower history templates &borhist.qrp, &borhisc.qrp, 

&borh10.qrp 

CI Circulation issues slips &CI1ISS.qrp, &CI1New.qrp, 

&CI1000.qrp 

Fin Financial templates &finbudg.qrp, &fincurr.qrp, 

&fintran.qrp 

ILL Inter-library loan templates &ILLEREM.qrp, &ILLLET.qrp 

N Standard letter templates &n1add10.qrp, &n1addem.qrp 

NC, NEC, NEI NetOPAC programmed templates &nctbrf.qrp, &nectbrf.qrp, 

&neitbrf.qrp 

Od Circulation templates – Overdues &odemail.qrp, &odlet1c.qrp, 

&odlet1g.qrp 

Email, eml E-mail templates &odemail.qrp, &reseml.qrp 

Let Letter templates &odlet1c.qrp, odlet1g.qrp 

OR, OS Order templates &orsi.qrp, &orsicl.qrp, 

&osd100.qrp 

PE Periodical templates –  

Periodicals and Suppliers 

&PE0010.qrp, &PE0100.qrp, 

&PE1000.qrp 

PI Periodical templates –  

Periodicals and Issues 

&PI0001.qrp, &PI0100.qrp, 

&PI0010.qrp 

PIC Periodical templates –  

Periodicals, Issues, Copies 

&PIC010.qrp, &PICLAIM.qrp 

PICS Periodical templates –  

Periodicals, Issues, Copies, Stockitems 

&PICS010.qrp, PICS001.qrp 

SU Periodical templates –  &SU1000.qrp 
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Suppliers only 

Res Reservation templates &resbrf.qrp, &reseml.qrp, 

&reslist.qrp 

Sad Stockitem audit templates &saddet.qrp, &sadbr.qrp 

Spine, Spn Spine label templates &spn9c.qrp, &spine9.qrp 

Stac Statistics Reports -  

Grouped by borrower class 

&stac511.qrp, &stac520.qrp 

Stag Statistics Reports –  

Grouped by borrower group 

&stag531.qrp, &stag540 

Stat Statistics Reports –general &stat100.qrp, &stat210 

Stk Stockitem Reports &stktact.qrp, &stkcfs.qrp 

Stkh Stockitem History &stkhist.qrp, &stkhisu.qrp, 

&stkhcsc.qrp 

Stktur Stockitem Turnover reports &stktur1.qrp, &stktur2.qrp 

X Reports that output to Microsoft Excel &xstkfs.qrp, &xstat20.qrp, 

&xstkcsv.qrp 

 
Statistics templates 
 

Number/letter Meaning Example 

100 Summary by year &stat110.qrp, &stat111.qrp 

200 Summary by month &stat200.qrp, &stat205.qrp 

300 Summary by day &stat300.qrp, &stat310.qrp 

400 Summary by hour &stat410.qrp, &stat411.qrp 

500 More detailed reports e.g. containing 

borrower type, suburb etc. 

&stat500.qrp, &stat502.qrp 

600 Detailed reports &stat620.qrp, &stat630.qrp 
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EDITING REPORT TEMPLATES - 4 EASY STEPS 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

STEP 1: Amlib/Report Application 

Select the report to edit. 

Take note of the Report Type & Report Filename. 

STEP 2: RepWin30 Report Writer  

Open the Report to edit. 

Edit as required. Save as a different filename. 

STEP 3: Amlib/Report Application/RepAddNew. 

Find the Report “Family” and add the Filename as a new Template. Ensure that the 

Report Type is correct. 

STEP 4: Amlib/Report Application 

Add the Report as a new report using the Template just created. 

 Give the Report a Description. 

 Set the Where parameters to determine which data will be displayed.  

 Set the order of the Report as appropriate. 
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Step 1: Amlib/Report Application 

To identify report to edit in the Amlib client: 

1. Launch the Amlib client 

2. Go to Reports category required – for example: Stockitem Reports (Main > Reports > 

RepStockitem) 

3. The corresponding Reports screen will display: 

 

4. Highlight report to be edited and take note of the Report Type & Report Filename – for 

example: the report to be edited here is a report type of Title Author Call No and Barcode. 

The template is &STKBRF.QRP. 
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Step 2: RepWin Report Writer 

1. Open a Windows Explorer Window 

2. Navigate to the \Amlib\Report folder on your Amlib server or local PC 

3. Locate template identified in STEP1 and highlight it, duplicate the template and rename it 

The general practice when customising a report template is to remove the ampersand (&) 

and add in a few letters indicating your library name: 

 &STKBRF.QRP  CHESTKBRF.QRP 

4. Highlight & Double-click the renamed template – chosen template will display in RepWin 

5. Edit/ format template as desired: 

 Background Text that can be edited simply be double clicking on the Background 

Text you want to edit – the Format Background Text Dialogue box will open 
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 Data Fields can be edited by highlighting the Data Field you want to edit, and clicking 

the Editor button 

 

6. Save edited template from the main menu, select File > Save.  
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Step 3: Amlib/Report Application/RepAddNew 

Loading Template into Amlib client using RepAddNew: 

1. Launch the Amlib client 

2. Go to Main > Reports > RepAddNew – the Report File window will open: 

 

3. From the Report Entity drop-down, select the appropriate module for your report – for 

example: Stockitem 

4. Click F1New button – the New Report File window will open: 
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5. Type in an appropriate Description – for example: Title, Author, Call No and Process 

6. Template – click on the Browse button – the Choose Report window will open  

 

7. Navigate to the Amlib/Reports folder on your Amlib Server (if the template has been loaded 

onto your PC – then navigate to the local folder)  

8. Files of type:  

 Select Custom Report Templates (*.qrp) for customised templates  

 Select System Report Templates (*.qrp) for all standard system templates  

9. Locate the template to be loaded and highlight it  

10. Click the Open button – the template will be selected the Choose Report window will close  

11. Choose Type – it is essential that the appropriate type be chosen that this will inform how 

your template operates and the information that is sent to it – in this example: Stockitems 

(Default) has been selected. Note that the Type will be the same as the original template the 

edited version was based on  
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12. Message – leave blank  

13. Default Stats Code – it is possible to collect statistics on the number of times that this report 

is run by adding an entry into the Statistics Codes table (Main > Supervisor > StatsParams) 

and then adding the Stat Type into the Default Stats Code box – this is optional and may be 

left blank  

14. Default Detail Stats Code – it is possible to collect statistics on the number of individual 

notices that a particular report generates by adding an entry into the Statistics Codes table 

(Main > Supervisor > StatsParams) and then adding the Stat Type into the Default Detail 

Stats Code box (not available for all modules) – this is optional and may be left blank  

15. Update History (Y/N) – it is possible to retain a record of the report having been generated – 

for example: the above Overdue Letter report can add a record of the overdue being printed 

to the Borrower History of affected patrons  

16. Update Entity (Y/N) – this field can be used to update the status or alter a parameter of a 

record – for example: an account may be generated for an overdue circulation report  

 

17. Click the F3 Update button  

18. The Report File window will open – click F3 Save button to save added template. 

  



RepWin Report Writer Manual 

 

 

Last Updated: 4 October 2013 
 Page 21 

Step 4: Amlib/Report Application 

1. Launch the Amlib client 

2. Go to Reports category required – for example: Stockitem Reports (Main > Reports > 

RepStockitem) 

3. The corresponding Report screen will display: 

 

4. Click the F1New button – the Select Report Format table will display: 
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5. Highlight the report you would like to use and click Select button – for example: 

CHESTKBRF.QRP 

 

6. Your selection will appear at the bottom of the Reports table in red:  

 

 

7. Type in an appropriate Report  Description – for example: List of Items that contain a 

PROCESS 

 This is a description often serves as the heading of the report (including many 

Stockitem reports) 

8. Click the F3Save button to save the added report template 

9. Highlight the report in the Reports table and click the F7Where button, unless a Saved File is 

to be used. 

10. Click the F8 View button, when report is ready to be viewed.  
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TEMPLATES BASICS 

Pallet 

It may be convenient to have the Pallet available it is a quick access bar to tools used in formatting 

report templates. 

1. From the main menu, select View > Pallet - the Pallet tool bar screen will display:  

 

 

Note: Alternatively place your cursor anywhere on the template, and right click the mouse and click 

through the Tools available 

  

 

 

Selector Tool 

Field Tool 

Picture Tool 

Auto Selector Off 

Add Background Text 

Box Tool 

Line tool – add extra lines 

AutoSelectOn 
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Selector Tool 

The selector tool allows the selection of items within a template, and it’s a good idea to have this 

tool selected by default prior to editing templates. 

1. From the main menu, select Tools > click on Selector Tool 

 

2. The selector tool is now selected, when hovering over particular parts of the template a four-

way arrow will appear indicating item can be selected: 
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Background Text 

Literal text only e.g. The name of the Site for a heading, Labels on columns etc. 

Insert Background Text 

1. From the main menu, select Tools > Background Text  

 

 

2. Position the cursor where you would like the background text to appear and click to insert 

The cursor will remain in the text box so you can start typing the background text that you 

want to display each time the report is printed.  
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Fields 

Fields can be inputs (Objects that are derived from the database e.g. Borrower Name, Address etc.), 

A literal String (combining of input items and background text, using single quotes) or formulas that 

can be created using the formula editor. 

Format Fields 

1. Double click a field – the Format Fields screen will display 

 

 Character e.g. Font size, Fonts 

 Line Wrapping: e.g. To get the Maximum wrapping of the text. 

 Repeating Values e.g. Suppressing repeating values so that the repeating text is not 

shown. 

 Justification e.g. Centering, left or right alignment 

 Formatting e.g. Field display format 

 

Alternatively you can click a field and edit field formats from the main menu bar:   
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Editor 

Data items and functions for fields can be defined and selected from the editor screen. 

1. Highlight a field, in the main menu bar select the Editor button – the Formula Editor screen 

will display: 
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Blocks 

Blocks form the backbone of reports and can come in the form of: 

Headers: Optional  Report Header Contains a Report Title – only appears at the beginning of 

the Report 

Page Header Contains information to appear at the top of every page 

Group Header Contains information to appear at the beginning of every 

Break Group. Will only appear if Break Groups are defined 

Footers: Optional Report Footer Contains Report totals and summaries 

Page Header Contains information to appear at the bottom of every 

page e.g. Page Numbers 

Group Header Contains information to appear at the end of every Break 

Group. Will only appear if Break Groups are defined 

Detail Blocks Data that is sourced from the database. Reports only have one Detail Block 

per Report Template 
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Headers 

Optional and can be: 

Report Header Appears only once, containing a title. 

Page Header Contains messages, references, page numbers etc. and appears on each page. 

Group Header Appears before the first line of a group of records. (These do not display until 

Break groups are defined. 

 
The Statistics report below has many Group Headers. 
 

 

Header Settings 

 Each Header can have settings e.g. Minimum height, these can be changed by double clicking 

on the Header field e.g. Page Header 
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Line Settings  

 The first line after a header can also have settings defined e.g. Page break before. 

Check this by double clicking on the first line after the Header (in the grey space rather than 

on a field or text box. 

Footers 

Also Optional can be Report Footer, Page Footer or Group Footer. 

 Group Footers may contain Totals for the group. 

 Page Footers can contain Page Numbers or copyright information that would need to be 

shown on each page of the Report. 

It is possible to keep the Group information on a page – for example to prevent a page break forming 

in the middle of an Overdue Slip – see Keep on Page section of this guide. 
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Detail Blocks 

Data that is sourced from the database. Reports only have one Detail Block per Report Template: 
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Break Groups 

Information such as Borrower, Class, Type etc will need to be grouped into units.  

Each group contains an input item that tells the report when to break e.g. On Borrower Type. 

 

When Break Groups are defined, new Headers and Footers will display for each Break Group. 

However, only one detail block displays. 

To add new break  

1. From the main menu, select Format > Break Groups… – the Format Break Group screen will 

displaying with currently defined input items and a list of already defined break groups: 

 

2. Select & highlight an item form the Input Items list, click the Right arrow button to copy 

across to the Break Groups list 

3. Repeat step 2 for each break group item. Break items must be defined in the same order as 

the sort order of the input rows 

4. To delete an item from the Break Groups list box, highlight  an item in the Break Groups list 

and click the Left arrow button 

5. Click the Ok button to apply the defined break groups. Once all Break Groups have been 

defined any reporting activity will add new header and footer block captions for each of the 

break group items defined 
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Input Items 

Individual data elements used in the Fields of the Report and are usually the same as the data fields 

within Amlib e.g. BorType. An Input Item contains data from the database such as Titles, Birthdates, 

Costs etc. as well as Current Date. These are usually entered in the Detail Blocks but can be entered 

in Header or Footers – for example to Form a Heading of a Report. These are only available if 

programmed into Reports. 

Note: When setting up a report template for circulation, a Borrower who has a Guardian (3rd 

Address) becomes a BOR_CHILD, and the Guardian is BOR_NAME. A Borrower with no Guardian 

remains BOR_NAME 

 

 

Spot the Difference! 

Background text consists of individual words or sentences: 

e.g. Field labels  

 

e.g. Headings 
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e.g. Sentences 

 

 
Fields contain abbreviations that are often separated by an underscore and are quite obvious: 

 

Strings are a combination of background text and fields. 
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How to Change Text 

Note: Ensure prior to making any changes to a template save the template with a new name to avoid 

overwriting existing template – see A GUIDE TO REPORT TEMPLATE NAMES section of this manual. 

 

Changing Wording on Report Templates 

1. Open the template you want to changed  

2. Double click on the area of text that you wish to change 

 

3. The Format Background Text screen will display. 

a. Click into the Text area box, highlight and delete text or add text as necessary 

b. You can also change font size or style, in the Character  area 

 

4. Click the Ok button to add or change the text in for this particular text box 

 

  



RepWin Report Writer Manual 

 

 

Last Updated: 4 October 2013 
 Page 36 

How to Add Extra Space (Adding Lines) 

If spaces are required in a report template to separate certain areas of a text extra lines can be 

added. 

1. Open the template to be changed 

2. From the main menu, ensure  View > Pallet is ticked 

3. Select the Line tool button from the palette 

 

4. Hover over the area in the template where a line is to be inserted, until the cursor turns into 

the square line tool symbol. Then click to make the extra line 

Tip: You may have to put your cursor on the top or bottom edge of an existing line.  

 

 
Note: Be careful where lines are placed. If additional lines are added to the detail block, with 
most templates, this will add lines for each item that is listed – as shown here: 
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How to Reduce Space by Deleting Lines, Text Boxes or Fields 

1. Open the template to be changed 

2. Click on a line, text box or fields to be deleted to highlight it: 

 
 

3. Press the ‘Delete’ button on the keyboard 

How to Adjust the Size of Your Fields or Text 

1. Open the template to be changed 

2. Click on a field/text to be changed 

 
 

3. Move your mouse cursor to the edge of the field/text selected, until the cursor changes to a 

double sided   arrow. Then click and drag the edge to the desired size 
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How to Move Fields or Text 

1. Open the template to be changed 

2. Click on a field/text to be changed 

 

3. Move your mouse cursor over the top of the field/text selected, until the cursor changes to a 

four-way   arrow. Then click and drag field/text to the desired position 
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General rules for moving fields, text or objects 

1. Fields, Text or objects can be moved left or right within the same line, only to the extent of 

the page (where the grey lines ends) 

2. Things can be moved to lines above or below, only within the same section. That is, fields 

cannot be move from a line in the detail block to a line in the header. However can copy text, 

create the background text box in the other section and the paste the text into it 

3. Leave a small space between each field so that the words do not overlap 

 

4. Field and text boxes can overlap and make it difficult to see the edges of each and display in 

the report as mashed text or data. When moving items in small spaces, we suggest creating 

an extra line to move things onto, then deleting the line once the move is finished 
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How to Add Text 

1. Open the template to be changed 

2. If a new line is required, create a new line 

3. From the main menu, ensure  View > Pallet is ticked 

4. Select the Background tool button from the palette 

 

5. Click in the line where a text is to be displayed 

 

6. Adjust the background text box accordingly to fit the text – if it’s a large sentence, it will 

need the space across the whole line. 

. 

Tip:  If you can’t select your text box, try clicking on the line space behind it, and then click onto the 

text box. 
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7. Double click the text box to select it and add required text 

 

8. Set the font size, style and add bold or italics as needed, then click the OK button 
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How to Add Fields 

1. Open the template to be changed 

2. If a new line is required, create a new line 

3. From the main menu, ensure  View > Pallet is ticked 

4. Select the Field tool button from the palette 

 

5. Click in the area where a field is to be placed 

 

4. Adjust the field box if required. Move your mouse cursor to the edge of the field selected, 

until the cursor changes to a double sided   arrow. Then click and drag the edge 

to the desired size. 
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5. Highlight the data field to be edited, and click the Editor button on the main menu bar. 

 

6. From the Data items box, select the field to be added. In this case, we want to add the call 

number, which is line 6 in the stockitem screen. 

7. Double click the item to display it in the top section of the screen. 

 

8. Click the OK button 

9. The data item is now carried across to the selected and field 
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REPORT TEMPLATES – VIEWING THE REPORT 

 

Design Mode [Ctrl + D] 

Used for Editing, displaying Fields etc. 

 

 

Preview Mode [Ctrl + V] 
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FORMATTING REPORT TEMPLATES 

Aligning Cells 

1. Highlight a cell which has the correct alignment 

2. Highlight another cell to align to this cell with. Hold the Shift key and clicking with the left 

mouse 

3. From the main menu, select Format > Align Left Sides. For costs, it is necessary to align cells 

the right sides 
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Front Style and Point Size from the Ruler 

1. Select field(s) or background text in a report template to be changed 

 Multiply multiple field(s) or background text can be selected by pressing the Shift 

button on the keyboard and clicking them individually to select the items. 

 All objects residing on a line can be selected simultaneously by pressing the Ctrl 

button on the keyboard and clicking a selected line. 

2. From the main menu bar, click the down arrow next to the Font box to display the font list. 

Select the font to be applied to the field(s) or background text 

3. From the main menu bar, click the down arrow next to the Point box to display to display the 

point sizes list. Select the point size to be applied to the field(s) or background text 

 

 

 

 

4. Report Activity changes the font size and type in selected fields. These changes are reflected 

in the report work area 

  

Font Box Point Size Box 
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Formatting Options 

Formatting can be set from the Background Text Box or the Editor Box. Formatting can include 

Boarders, Tabs or Colours.   

Boarders 

Use this procedure to place a border around background text or the contents of a field. 

1. Select a field or background text box in a report template to at add a boarder 

2. Double click the Field or Background Text Box – the Format Field or Background Text screen 

will open: 
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3. Click the on the Borders… button – the Format Boarders screen will open: 

 

4. Make the changes as required and click the OK button 

Setting Formats e.g. All Capital  

If required, the Case for an entire Field can be set to Upper or Lower Case. 

1. Select & highlight a field to be changed 

2. On the main menu click the Editor button 

 
 

3. In the Editor screen, from the Functions selection box double click StrUpper  
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4. Replace the word  ‘String’ with the field name to be in uppercase (e.g. cut & paste the field 

name) 

    

5. Click the OK button 
 

In the example above both Suburb & State (BA_ADDR3) are now set in capitals. 

 

Colours/ Shading 

Shading or colouring of fields, lines, boarders or text. 

1. Select & highlight a field or background text to be changed 

2. Double click the Field or Background Text Box – the Format Field will open: 
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3. Click the on the Colors… button – the Format Text Colors screen will open: 

 

4. Make the changes as required and click the OK button 
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Field Formats 

Formats can be applied to the following types of fields: 

 Date 

 Cost 

 Numbers 

Date 

The formatting of these fields will ensure the outputs will appear in a certain time and day format 

when the report template is used.    

1. Select & highlight a field to be changed 

2. On the main menu click the FMT drop-down box – the available formatting options will 

display: 

 

3. Click on the required formatting option for the particular field 

 

In the example above dd:MMM:yyyy was selected. The report will now be printed in the 

following format 
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Cost 

Dollar signs and decimal points can be added to these types of fields.  

Note: Costs are generally Right justified so that they can line up correctly.  

1. Select & highlight a field to be changed 

2. On the main menu click the FMT drop-down box – the available formatting options will 

display: 

 

3. Click on the required format for the particular field to alter the cost output format 
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Numbers 

The formatting of numbers maybe necessary to show decimal places, some formatting maybe 

needed to remove the inclusion of decimal places e.g. Month, Year, Page Numbers. By default 

numbers are usually displayed with decimal places. 

1. Select & highlight a field to be changed 

2. On the main menu click the FMT drop-down box – the available formatting options will 

display: 

 

4. Click on the required format for the particular field to alter the cost output format 
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Field Width 

DYNAMIC WIDTH  

 Dynamic field width with Line Wrapping results in a "snaking fields" effect, where all 

subsequent linked fields are shifted to the right to accommodate for the extra text.  

 

 Dynamic size fields (without line wrapping) should be linked to the adjacent fields on the 

same line to avoid overwriting their contents. When this option is selected, the field width 

changes to suit the length of its contents.  This combination is very useful when working with 

form letters and have variable length text linked to fixed length text.  

 
MAXIMUM WIDTH – Fits to maximum 
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Linking Adjacent Fields 

1. Select & highlight two field to be linked 

 Multiply multiple field(s) can be selected by pressing the Shift button on the 

keyboard and clicking them individually to select the items. 

2. From the main menu, select Format > Link Fields  
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Report Description 

 

If a template uses the field, REPORT_DESC, the description will be filled automatically upon running 

the template. The description is taken from the Report Description column in the Reports table 

within Amlib - therefore the Heading of the Report can simply be entered or modified using the 

Report Description. 
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Keep on Page 

To ensure that all lines in a block are kept together on a single page.  

1. Highlight & Double-click Block Title e.g. Footer – Format Block will display: 

 

Note: If there is insufficient space on the current page, Report activity will start a new page for the 

next block of text.   

Line Wrapping 

Line wrapping is used to control how the data is displayed in a field, how much of is displayed, and 

how it affects the subsequent lines of the report.  
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Lines are broken at words whenever possible, otherwise words are broken.  Lines also break at 

carriage returns. 

Note: This feature is disabled for the Page Header and Page Footer blocks. 

There are four options to line wrapping: 

1. None This is the default setting. The text within the field contents is truncated when the end 

of the field is reached, printing to the defined length of the field and not wrapping to the 

next line. 

2. Dynamic Adds as many continuation lines as is needed to display all the field's contents.  All 

subsequent report lines are pushed down the page to accommodate these extra lines (unless 

Overlay Existing Lines is selected.  

3. Maximum This option adds up to the specified number of continuation lines. Field contents 

are truncated when this maximum is reached. All subsequent report lines are pushed down 

the page to accommodate these extra lines (unless Overlay Existing Lines is selected).  

Select the Maximum control box, and enter the maximum number of lines to be printed for 

that field. 
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4. Overlay Existing Lines This option is enabled when either Dynamic or Maximum line 

wrapping is selected. By selecting the Overlay Existing Lines option a current field will overlay 

the subsequent report line. This prevents text of subsequent lines from being pushed down 

the page.  Extra field lines will not overlay the text in the next block group. It only overlays 

lines in the current block. Additional new lines are added below the current block as 

necessary.   

If lines of a file is to be overlaid into the subsequent report lines turn unselect the Overlay 

Existing lines and the next report line starts after the last wrapped line.  

Page Break Before 

Page Break Before option can be used on the first line of a break group header. This enables each 

new break group to start on a new page.  

Note: Page Break Before is disabled for lines in page the Page Header and Page Footer blocks. 

1. Highlight & Double-click the first line of the break group header – the Format Line will 

display: 



RepWin Report Writer Manual 

 

 

Last Updated: 4 October 2013 
 Page 61 

 

 

Picture/ Graphics 

Report Activity accepts a large variety of graphics formats as input to the picture object.  All graphics 

must be displayed within a picture object. 

To import a graphic to your report 

1. Select area where graphic is to be inserted, by highlighting & selecting a line in the report 

template 

 

2. From the main menu, select Edit > Insert Object – the Insert New Object screen will appear: 

3. Double click the Picture object – the Format Picture screen will display: 

 

4. From the Object Type list, select: Microsoft Word 97 – 2003 Document 

5. Click the OK button, a blank Microsoft Word document will open 



RepWin Report Writer Manual 

 

 

Last Updated: 4 October 2013 
 Page 62 

6. From the Word toolbar click the Insert tab  

 

7. Click the Picture button, the Insert Picture browser screen will open. Navigate to the location 

where graphic is stored 

 

8. Select the picture to be imported, and click the Insert button. The picture is now inserted 

into the blank Word document 

9. From the Word toolbar, select File > Save 

10. Click the Exit [x] button to close the Word document: 

 

 

11. The graphic is now inserted into the report template: 
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12. To resize the graphic, move your mouse cursor to the edge of graphic until the cursor 

changes to a double sided arrow. Then click and drag the edge to the desired size 
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Page Margins / Page Size 

To change the page margins & size 

1. From the main menu, select Format > Report – the Format Report window will display.   

2. By default page size, width/ height and orientation are selected. To change these accordingly 

inserted the correct page margin value in the Top, Bottom, Left, and Right boxes if different 

from the defaults.  

 

 

Note: Values are to be entered either in inches or centimeters depending on the report 

preference configuration. To check the configuration on the main menu, select Report > 

Preferences… the Report Preference window will display: 

 

 
 

3. Click the OK button to return to the report and for reports the changes to come into take 

effect 
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Columns 

Some Reports may be better suited to displaying in Columns e.g. Bibliography. Columns can be 

created using the column options in the Format Report Window. 

To add column to a report 

1. From the main menu, select Format > Report – the Format Report window will display 

2. Type in the required column number into the Number of Column box e.g. 2  

3. Type in the required spacing between the column into Spacing Between Column box 

 

 
 

4. Click the OK button to return to the report, a column is now inserted into the report 

 

Please Note: The data in a column can be prevented from breaking by using footer. 
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 See: Footers for more information 
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ADVANCE FEATURES 

Accessing Help  

1. From the main menu, select Help > Index – the Help window will display 
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Formula 

Formula can be created to combine one or more items with operators or functions within the 

Formula Editor window. 

 Field name can be selected from the Data Items table  

 Functions can be selected using the Functions table    

 

Strings 

Combining Input items with background text.   

E.g. 

'During this term ' || StrLeft( BOR_CHILD , StrScan( BOR_CHILD , ' ' ) ) || ' borrowed the following 

book' || StrIFF( StrLength( STK2_LINE1 ) , '' , '' , 's' ) || ' from the school library.  ' || StrIFF( StrLength( 

STK2_LINE1 ) , '' , 'It is' , 'They are' ) || ' now overdue.' 

Please Note: This is usually best left to programmers. Please contact Amlib support for assistance. 
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Totals 

Totals can be formulated to return a numeric value which can be assigned to a field or used in 

formula.  The numeric value will be dependent on the data provided by the report input.  

Create Input Totals  

1. From the main menu, select Format > Input > Totals a list of all input totals previously 

defined for this report is shown: 

 

2. Click on the New button – the Define Total box will display 

3. Type in a Name for this new Input Total  

4. Use the formula combo box to select the total’s category by which the report is to evaluate 

each time an input row is fetched into the report 

5. Use the statistics combo box to select type of statistics you want your total to return. 

Option Explanation 

Average Returns the average value of the item you selected in the Totals Category since the 

last reset occurred. 

Count Returns the number of occurrences of the item specified by the Totals Category since 

the last reset occurred. 

CountNull Returns the number of null occurrences of the item specified by the Totals Category 

since the last reset occurred. 

CountUnique Returns the number of unique occurrences of the item specified by the Totals 

Category since the last reset occurred. 

Maximum Return the maximum value found for the item specified by the Totals Category since 

the last reset occurred. 

Minimum Return the minimum value found for the item specified by the Totals Category since 

the last reset occurred. 

Sum  Returns the sum values for the item specified by the Totals Category since the last 

reset occurred. 

Value Return the actual value of the item or formula that you selected in the Formula 
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combo box.  

 

6. Use the restart event combo box to set when report activity zeroed the accumulated 

statistics 

Option Explanation 

FirstFetch The totals statistics is zeroed once before the first fetch. You can use this to produce 

total for the entire report. 

PageBreak The total statistic is zeroed at the beginning of each page break. You can use this to 

produce totals for each page of the report. If you use this you can display the 

calculated statistic at the end of each page. If you turn Pre-Process on you can also 

display your input total at the beginning of each page. 

BreakGroup 

(Name) 

The total statistic is zeroed at the beginning of the specified break group.  

 

7. Check the process, if you want your total statistics to be calculated before the remainder of 

the report is processed 

Option Explanation 

Ticked Report inputs are fetched and inputs totals are processed during the first pass. The 

input rows are then re-fetched to build the rest of the report during the second 

pass. 

Un-Ticked Report input totals are computed as the input rows are processed. The statistics 

returned by Report activity are the current running value.  

 

 

8. Click the OK button to return to the input total listing The newly defined input total will now 

be available as a Data Items for fields in a report  

9. Click the Close button to return to the report 
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Adding Input Total to a Field 

See How to add field for further information. 
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CROSS TABS  

A cross tabular report item [Crosstab] calculates and returns rows and columns of statistics on your 

data. You need to first specify the Row(s), then the Column(s), and finally the Values for which you 

want to gather statistics. 

COLUMNS 

ROWS HEADING HEADING HEADING HEADING 

HEADING XXX XXX XXX XXX 

HEADING XXX XXX XXX XXX 

HEADING XXX XXX XXX XXX 

Creating a New CROSS TAB  

1. From the main menu, select Format > Input > Crosstabs the Format Crosstabs screen will 

display: 

 

2. Click on the Create new Crosstab button – the Quick Crosstab will open 

3. Highlight the category you wish to be on the left axis (row). And click the 

Arrow button to move category from the Categories box across to the Selected Row 

Categories box: 
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4. When the categories for the rows have been defined, click the Forward button to define 

column categories. 

 

5. Highlight the category you wish to be located on the column. And click the 

Arrow button to move category from the Categories box across to the Selected Row 

Categories box: 

 

Note: Ensure that the Format field displays the format to suit the Category selected. 

6. When the categories for the columns have been defined, click the Forward button to select 

the values of the individual cells 
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7. Click the Forward button to define statistics (Category headings) 

 

 

 

8. Click the Forward button to define summary statistics (Total headings) 

 

9. Click the Forward button to define crosstab (Crosstab Name) 
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10. Click the OK button to return to the Format Crosstab listing The newly defined Cross Tabs will 

now be available as a Data Items for fields in a report  

11. Click the Close button to return to the report 
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Adding CROSS TAB to a Report 

Cross tab can be added to report as a field.  

See How to add field for further information. 
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Altering Reports for Excel Import 

To alter report that are able to be used in MS Excel, delimiter (|| '|' ||) must be inserted between 

data items in a Field.  

Adding Delimiters to Field 

1. Add a field to a report - see How to add field for further information 

2. Highlight the data field to be edited, and click the Editor button on the main menu bar 

3. From the Data items box, highlight item and double click to make the selection 

4. Type in the delimiter into the formula area 

 

 
5. Repeat step 3 & 4 to insert the rest of the required data item 

6. Click the OK button to return to the report, field with data item seperated by delimiters will 

be displayed:

 

Note: 
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 Save the customised template into the Amlib/Reports folder on the Amlib server. This will 

make the template available for use for all users. Alternatively, you may save it into a local 

folder on your PC – but please be aware, that the template (once loaded) will only be 

available for use on that PC. 

 

 Ensure that the template is saved with a name that clearly identifies it as a customized excel 

report template  – for example: XSTKCSV2.QRP 
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REPORT TEMPLATE - MENUS 

Dropdown Menus 

The menu items used to alter reports are listed below. Contents of any other menu items can be 

checked in the Repwin Help files. 

File Menu  

Command Use this command to 

New Start a new report 

Open Open an existing report 

Save Save the current report to a file. The saved report has a default file 

extension of .qrp 

Save As Save the current report with a new name, a new directory, or in a different 

drive.  The saved report has a default extension of .qrp 

Save Pages As Save the report pages to an ASCII or RTF format 

Test Data Generate test data for your report to use during Report Preview. 

Print Print the current report 

Exit Quit the Reports application 

 

Edit Menu 

Command Use this command to 

Undo Undo the previous action 

Cut Cut the data from the Report 

Copy Copy the field 

Paste Paste data previously Cut or Copied 

Paste From Paste images into the Report 

Clear Delete data 

Select All Select all data in the report. 

 

 
Report Menu 

Command Use this command to 

Design 
 

When altering reports, you need to be in Design mode. 

Preview 
 

View the format of the report with dummy data. 

 

Tools Menu 

Command Use this command to 

Selector Tool Enable selection of one of the tools 

Background Text Insert new background text 

Field Insert a new field 

Box Insert a new box 

Picture Insert a new picture 

Line Insert a new line 
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Auto Selector Insert more than one tool into the report 

Insert Line Insert a new line 

 

Format Menu 

Command Use this command to 

Report Set page size and margins 

Input Input variables that have been programmed into the report. 

Break Groups Set breaks between blocks and pages 

Block Format blocks 

Line Format line 

Fields Format field 

Background Text Format background text 
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APPENDIX 1: LIST OF REPORT TYPES AVAILABLE IN AMLIB 

The reports in Amlib can be separated into two categories: 

1. Report templates used in the Reports module. Report template files beginning with & are 

used in the Reports module and should be renamed if the report template is customised by 

the user 

2. Report template files beginning with $ or # are embedded in the Amlib client and cannot be 

renamed, but may be customised to suit individual sites. These reports are automatically 

used when the F6 Print button is clicked or a File > Report is used in any of the modules 

Report templates can be altered through the use of Repwin30.  

Please Note: Any reports beginning with $, & or # may be automatically replaced by new releases or 

upgrades of Amlib. Customised report templates should be kept in a separate folder in the 

Amlib/Reports folder on the Amlib server. 

Please Note: The template descriptions may differ from system to system 

RepAuthority (Authority Reports) 

 Go to Main > Reports > RepAuthority 

TEMPLATE DESCRIPTION REPORT TYPE 

&AUTH856.QRP HTTP 856 Tag Export (for hyperlink 

verification) 

Authority (Default)  

&AUTHAUD.QRP Authority Audit (listing operator, date and 

time) 

Authority Audit 

&AUTHBRF.QRP Brief listing of Authority records Authority (Default) 

&AUTHBR2.QRP Brief listing of Authority records (in 2 

columns) 

Authority (Default) 

&AUTHFS2.QRP List of See and See Also References (in 2 

columns) 

Authority with See and See 

Alsos 

&AUTHFUL.QRP Full listing of Authority records Authority (Default) 

&AUTHSAB.QRP Brief listing of See Also References See / See Also references 

&AUTHSA2.QRP Brief listing of See Also References (in 2 

columns) 

See / See Also references 

&AUTHSBR.QRP Brief listing of See References See References 

&AUTHSB2.QRP Brief listing of See References (in 2 columns) See References 
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RepBibliographic (Bibliographic Reports) 

 Go to Main > Reports > RepBibliographic 

o Use F10 More to map fields for Fixed layout Reports 

o If Report Stats Codes set – then Statistics table updated 

TEMPLATE DESCRIPTION REPORT TYPE 

&BIB.QRP Full Bibliographic without TAG Numbers Bibliographic (Default) 

&BIB2.QRP Full Bibliographic without TAG Numbers (in 2 

columns) 

Bibliographic (Default) 

&BIBCSV.QRP Bibliographic Export Fixed layout Reports 

&BIBFULL.QRP List of catalogue records with full 

bibliographic details 

Bibliographic (Default) 

&BIB2431.QRP Full list of bibliographic details Use &BIBFULL.QRP 

&BIB2432.QRP Summary of bibliographic details Use &BIBFULL.QRP 

&BIBFIXD.QRP Fixed Layout Catalogue Print Fixed layout Reports 

&BIBFIXS.QRP Fixed Layout Catalogue Print with Subject 

Headings 

Fixed layout Reports 

&BIBFL10.QRP Fixed Layout 10 fields Fixed layout Reports 

&BIBFL28.QRP Fixed Layout 2 columns 8 fields Fixed layout Reports 

&CTITEMX.QRP Fixed Layout with Image Bib with Image + stock 

&DVDCOV.QRP DVD Cover Fixed layout Reports 

&VIDCOV.QRP Video Cover Fixed layout Reports 
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RepBorrower (Borrower Reports) 

 Go to Main > Reports > RepBorrower  

o Update Entity = Y: Borrower History or Status or Financial Transaction updated (see 

specific reports below) 

o If F10 More set – used for borrower record updates 

o If Report Stats Codes set – Statistics table updated 

TEMPLATE DESCRIPTION REPORT TYPE 

&B%LTSWA Borrower count by Location and Type with % of 

population 

Borrower (Default) 

&BARCODE.QRP 

(&BBARCODE.QRP) 

Borrower list with Barcodes (requires font setup) Borrower (Default) 

&BARCODG.QRP Borrower list with Barcodes by Group (requires 

font setup) 

Borrower (Default) 

&BCAT.QRP Borrower count by Area and Borrower Type Borrower (Default) 

&BCLT.QRP Borrower Count by Location and Borrower Type Borrower (Default) 

&BCLTSWA.QRP Borrower count by Location, Borrower Type, 

Suburb, Ward and Area 

Borrower (Default) 

&BCST.QRP Borrower count by Sex and Borrower Type Borrower (Default) 

&BCT.QRP  Borrower Counts by Location & Borrower Type / 

Gender & Borrower Type / Suburb & Location – in 

3 separate tables 

Borrower (Default) 

&BCTA.QRP Borrower count by Borrower Type and Area Borrower (Default) 

&BCTG.QRP  Borrower Count by Location, Borrower Type, 

Borrower Gender 

Borrower (Default) 

&BCTS.QRP Borrower count by Borrower Type and Sex Borrower (Default) 

&BCTSCH.QRP  Counts by Location & Borrower Type / Gender & 

Borrower Type / Suburb & Location – in 3 

separate tables 

Borrower (Default) 

&BCTSWA.QRP Borrower count by Borrower Type, Suburb, Ward 

and Area 

Borrower (Default) 

&BCTW.QRP Borrower count by Borrower Type and Ward Borrower (Default) 

&BCWT.QRP Borrower count by Ward and Borrower Type Borrower (Default) 

&BFINSU.QRP Borrower Financial Transactions (Summary) 

report – produces a count of the transactions by 

Type 

Borrower (list) Financial 

Borrower Financial Transactions Deletions 

(Summary) 

Can be used to delete paid Borrower Financial 

Transaction records – Update Entity = Y 

Borrower (purge) Financial 

&BORCARD.QRP  Borrower Cards Borrower (Default) 

&BORCRDP.QRP Borrower Cards with Picture Borrower Images 

&BORCSV1.QRP Borrower Export CSV File (Barcode, Surname, 

Given Name, Initial, Ref 2, Borrower Type, Class, 

Group, D.O.B.) 

Borrower (Default) 
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&BORCUPD.QRP 

 

Automatic Borrower Circulation Update – 

changes borrower Statuses, Types, Classes and 

Groups (also allows memos to be sent) 

Borrower must have items on loan. 

Uses Update Entity = Y 

Borrower Circulation 

Automatic Update 

&BORDATA.QRP Borrower Export CSV File (Surname, Given Name, 

Initial, Barcode, D.O.B., Class, Borrower Type, Ref2) 

Borrower (Default) 

&BORFIN.QRP Borrower Financial Transactions report – lists the 

borrower/s and line-by-line details of their 

transactions 

Borrower (list) Financial 

Borrower Financial Transactions (Deletions) 

Can be used to delete paid Borrower Financial 

Transaction records – Update Entity = Y 

Borrower (purge) Financial 

&BORFINO.QRP Borrower Owing (Summary) report – lists the 

borrower/s and a summary of the amounts 

paid/owing/remaining 

Borrower (list) Financial 

Borrower Owing (Deletions) 

Can be used to delete paid Borrower Financial 

Transaction records – Update Entity = Y 

Borrower (purge) Financial 

&BORFINP.QRP Borrower Financial Transactions report – lists 

details of the individual transactions 

Borrower (list) Financial 

Borrower Financial Transactions (Purge) 

Can be used to delete paid Borrower Financial 

Transaction records – Update Entity = Y 

Can be used to mark and delete paid double-

entry Transactions 

Borrower (purge) Financial 

&BORH3.QRP Borrower history count >= 3 transactions Borrower History 

&BORH6.QRP Borrower history count >= 6 transactions Borrower History 

&BORH10.QRP Borrower history count >= 10 transactions Borrower History 

&BORH100.QRP Borrower history count >= 100 transactions Borrower History 

&BORH3N.QRP Borrower history account count. Lists any 

borrower who has had more than 3 accounts in 

the time period set in the Where parameters 

Borrower History 

&BORH6N.QRP Borrower history account count. Lists any 

borrower who has had more than 6 accounts in 

the time period set in the Where parameters 

Borrower History 

&BORHCNT.QRP Borrower transaction count Borrower History 

&BORHCNTC.QRP Borrower transaction count by Class Borrower History 

&BORHICT.QRP Borrower History Reports records (list) 

Can be used to delete records – Update Entity = Y 

Borrower History 

&BHICTSU.QRP Borrower History Reports records (summary) 

Can be used to delete records – Update Entity = Y 

Borrower History 

&BORHISC.QRP Borrower history in class order Borrower History 

&BORHIST.QRP Borrower History Activity records (list) 

Can be used to delete records – Update Entity = Y 

Borrower History 

&BORHISU.QRP Borrower History Activity record (summary) Borrower History 
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Can be used to delete records – Update Entity = Y 

&BORHPOP.QRP Popular Titles by Class Borrower History 

&BORINEM.QRP Borrower interests via Email Borrower Interest Reports 

E-mail 

&BORINT.QRP Borrower Interests Borrower Interest Reports 

&BORMEMO.QRP Borrower Memos Information Borrower Memos 

&BORRAUD.QRP Borrower Audit – includes operator, date and 

time 

Audit Reports 

&BORRFUL.QRP Borrower list with full details Borrower (Default) 

&BORRMED.QRP Borrower list with medium details Borrower (Default) 

&BORSHT.QRP Borrower list with brief details Borrower (Default) 

&BOROWLT.QRP Line by line details including amount owing Borrower (Default) 

&BORREG.QRP Borrower re-registration notice Borrower (Default)  

&BORUPD.QRP 

 

Automatic Borrower Update – changes borrower 

Statuses, Types, Classes and Groups (also allows 

Memos to be sent) 

Uses Update Entity = Y 

Borrower Automatic 

Update 

&N1ADD10.QRP Letter to Borrowers Name and Addresses x 1 

across 

&N1ADDEM.QRP Borrower notice/letter by Email Name and Addresses x 1 

across Email 

&READHIS.QRP Student Reading history count by Class Borrower History 

&XBCT.QRP MS Excel format – counts by Borrower Type Borrower (Default) 

&XBCLT.QRP MS Excel format – counts by Location and 

Borrower Type 

Borrower (Default) 

#ADDLABL.QRP Borrower Address Labels - 3 Wide for Avery 

address labels (7160) 

Name and Addresses x 3 

across 
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RepCatalogue (Catalogue Reports) 

 Go to Main > Reports > RepCatalogue 

o If Report Stats Codes set – Statistics table updated 

TEMPLATE DESCRIPTION REPORT TYPE 

&CATFULL.QRP Catalogue display record 

Does not list MARC Tag numbers (use 

RepBibliographic) 

[One set report type] 

 

RepCirculation (Circulation Reports) 

 Go to Main > Reports > RepCatalogue 

o Create Hist (Y/N) = Y – Borrower Account and Overdue History updated 

o Create Acct (Y/N) = Y – Borrower Financial Transactions updated 

o If F10 More set – used for Borrower Financial Transactions update 

o If Report Stats Codes set – Statistics table updated 

TEMPLATE DESCRIPTION REPORT TYPE 

&AOLPROC.QRP Offline Processing Results/Report Offline process report 

&BTCIRC.QRP Overdue Report displaying Type, Group and 

Class (max 8 lines only) 

Type, Group, Class, AuthForm, 

Item.locn 

&CIRRESA.QRP Recall list for overdue items with attached 

reservations – Author in line 2 

Res, Title, Author, Form, Item 

No, Location 

&CIRRESC.QRP Recall list for overdue items with attached 

reservations – Call Number in line 2 

Res, Title, Call No, Stats Code, 

Item No, Location 

&ODEMAIL.QRP Overdue Notice (Email) Continuous - E-mail 

&ODHLSTC.QRP Overdues Showing Time Due (for Hourly 

Loans) 

Continuous - Full descriptions 

&ODUNIVC.QRP Very overdue report with invoice (max 8 lines 

only) 

Title, Author, Form, Item No, 

Location (Default) 

&ODFEE.QRP Overdue Notice (Letter) with Fees Continuous - Full descriptions 

&ODLET.QRP Overdue Notice (Letter) Continuous - Full descriptions 

&ODLET1C.QRP Overdue Notice (Letter) – arranged by 

Borrower Class 

Continuous - Full descriptions 

&ODLET1G.QRP Overdue Notice (Letter) – arranged by 

Borrower Group 

Continuous - Full descriptions 

&ODLSTC.QRP Overdue List by Class – with no page break 

in-between Classes 

Continuous - Full descriptions 

&ODLSTG.QRP Overdue List by Group – with no page break 

in-between Groups 

Continuous - Full descriptions 

&ODLSTOC.QRP Overdue List by Class – with a page break in-

between the Classes 

Continuous - Full descriptions 

&ODLSTOG.QRP Overdue List by Group – with page break in-

between Groups 

Continuous - Full descriptions 
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&ODLST.QRP Circulation slip with address, phone, cost Continuous - Full descriptions 

&ODSLPC.QRP Overdue slip with cost by Class Continuous - Full descriptions 

&ODSLPG.QRP Overdue slip with cost by Group Continuous - Full descriptions 

&ODSMS.QRP Overdue Notice (SMS) Continuous - Full descriptions 

&ODSTAFF.QRP Overdue slips for staff Continuous - Full descriptions 

&OD200.QRP 

&OD2000.QRP 

&OD2001.QRP 

&OD2005.QRP 

&ODX200.QRP 

&ODX200.QRP 

&ODX2001.QRP 

Overdue Report with Charges – speedimailer 

(3 per page 8 lines only) 

Title, Author, Form, Item No, 

Location (Default) 

&OFFLINE.QRP Offline Files Export Offline files export 

#BODLSBC.QRP Overdue list for shelf check Continuous - Full descriptions 

#COSTLET.QRP Sample Long Overdue Letter with item cost 

(max 8 lines only) 

Title, Author, Form, Item No, 

Location (Default) 

 

RepFinancial (Financial Reports) 

 Go to Main > Reports > RepFinancial 

o Set Update = Y – Financial Transaction updated 

o If Report Stats Codes set – Statistics table updated 

TEMPLATE DESCRIPTION REPORT TYPE 

&CFINSU.QRP Borrower Monthly Transaction Summary Circulation Trans 

&CFINDET.QRP Borrower Monthly Transaction Detail Circulation Trans 

&FINACCT.QRP Account listing Account Listing 

&FINAGE 4.QRP Borrower Aged Financial Transactions  

(4 months) 

Aged Borrower ( 4mths ) 

Transactions 

&FINAGE 6.QRP Borrower Aged Financial Transactions  

(6 months) 

Aged Borrower ( 6mths ) 

Transactions 

&FINAGE12.QRP Borrower Aged Financial Transactions  

(12 months) 

Aged Borrower ( 12mths ) 

Transactions 

&FINALL.QRP Allocation codes List Allocation codes 

&FBFAUD.QRP Borrower Financial Transaction audit Borrower Fin. Trans. Audit 

&FBFSUM.QRP Borrower Financial Transaction audit 

summary 

 If Set Update = Y – YTD is updated 

Borrower Summary Fin. Trans. 

Audit 

&FINBUDG.QRP Account Budget Analysis (Summary) Budget Summary 

&FINCURR.QRP Currency Codes List Currency Codes 

&FINGLC.QRP Account Group codes listing GL Codes Listing 

&FINLEDG.QRP Ledger Details by Account Ledger Format 

&FINSUMM.QRP Summary in Ledger format Ledger Format 

&FINSUPP.QRP Supplier & Account Transactions Summary Ledger Format 

&FINSUP2.QRP Supplier & Accnt Trans Summary (inc Tots) Ledger Format 

&FINTRAN.QRP List of financial transactions Ledger Format 
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&FSUMLT.QRP Financial Summary by Location  Circulation Trans   

#DAILYBF.QRP Daily borrower fines Circulation Trans 

RepILLS (Inter-Library Loans Reports) 

 Go to Main > Reports > RepILLS 

o Update ILLS Status (Y/N) = Y – sets Status to PRINTED 

o If Report Stats Codes set – Statistics table updated 

TEMPLATE DESCRIPTION REPORT TYPE 

&ILLLET.QRP Interlibrary Loan letter Default 

&ILLRNEW.QRP List of ILL items that have been renewed Default 

&ILLEREM.QRP ILL reminder notice (email) to first supplying 

library only 

E-Mail Request 

&ILLEREQ.QRP ILL request (email) to first supplying library 

only 

E-Mail Request 

&ILLERMS.QRP ILL reminder notice (email) to all supplying 

libraries 

E-Mail Request to all suppliers 

&ILLERQS.QRP ILL request via Email to all supplying libraries E-Mail Request to all suppliers 

&ILLREM.QRP ILL Reminder to supplying library Default 

&ILLRNW.QRP ILL renewal request to supplying library Default 

&ILLST.QRP ILL listing of ILL stockitems Default 

&LBFAX.QRP Interlibrary Loan fax Default 

&LBFAXA.QRP Interlibrary Loan fax – varying format Default 

&LSILLS.QRP List of ILL items Default 
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RepOrders (Order Reports) 

 Go to Main > Reports > RepOrders 

o Update Entity (Y/N) = Y – see actual report for entity affected 

o If Report Stats Codes set – Statistics table updated 

TEMPLATE DESCRIPTION REPORT TYPE 

&OOD100.QRP Summary of orders with Order No, Title, 
Quantity and Qty Received (No Supplier) 

Order Header, Order Line & 
Order Items/Non-Items 

&OON100.QRP Summary of orders with stockitem Order Header, Order Line & 

Order Items/Non-Items 

&OSD100.QRP List of orders by Supplier (summary) Supplier, Order Header, Order 

Line & Order Items/Non-Items 

&ORDFRM.QRP Order Form inc TAX 

Update Entity = Y – would update Order 

Header, posting Date Printed to Order 

Header 

Supplier, Order Header & 

Order Line (Default) 

&ORDGST.QRP Order Form with GST separate 

Update Entity = Y – would update Order 

Header, posting Date Printed to Order 

Header 

Supplier, Order Header & 

Order Line (Default) 

&ORDPRT.QRP Purchase Order 

Update Entity = Y – would update Order 

Header, posting Date Printed to Order 

Header 

Supplier, Order Header, Order 

Line & Order Items/Non-Items 

&ORDSUM.QRP Summary of Orders Supplier, Order Header & 

Order Line (Default) 

&OREDI.QRP EDIFACT order 

Update Entity = Y – will automatically send 

EDIFACT order to Supplier and place Date 

Printed to Order Header 

Supplier, Order Header & 

Order Line – EDIFACT 

&ORSI.QRP Order status report – checks current status 

of ordered items 

Supplier, Order Header, Order 

Line & Order Items/Non Items 

&ORSIE.QRP 

 

Order status report via Email – checks 

current status of ordered items 

Supplier, Order Header, Order 

Line & Order Items/Non Items 

E-mail 

&ORSICA.QRP Cancellation of Orders – Order report to 

request cancellation of orders 

Update Entity = Y – will automatically update 

the status to Cancelled to the Order Line 

stock lines 

Supplier, Order Header, Order 

Line & Order Items/Non Items 

to Cancelled 

&ORSICL.QRP Order Claims Notice 

Update Entity = Y – will automatically update 

the status to Claimed to the Order Line stock 

lines 

Supplier, Order Header, Order 

Line & Order Items/Non Items 

to Claimed 

&ORSIECA.QRP Cancellation of Orders via Email – Order Supplier, Order Header, Order 
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report to request cancellation of orders 

Update Entity = Y – will automatically update 

the status to Cancelled to the Order Line 

stock lines 

Line & Order Items/Non Items 

E-mail to Cancelled 

&ORSIECL.QRP Order Claims notice via Email 

Update Entity = Y – will automatically update 

the status to Claimed to the Order Line stock 

lines 

Supplier, Order Header, Order 

Line & Order Items/Non Items 

E-mail to Claimed 

&ORSIR.QRP Returns Notice listing items to be returned 

Update Entity = Y – will automatically update 

the status to Returned to the Order Line 

stock lines 

Supplier, Order Header, Order 

Line & Order Items/Non Items 

to Returned 

&ORSIER.QRP Returns Notice via Email listing items to be 

returned 

Update Entity = Y – will automatically update 

the status to Returned to the Order Line 

stock lines 

Supplier, Order Header, Order 

Line & Order Items/Non Items 

E-mail to Returned 

&ORSIPF Supplier Performance Report Supplier, Order Header, Order 

Line & Order Items/Non Items 

&ORWOSTK.QRP List of Orders without Stockitems attached Supplier, Order Header, Order 

Line & Order Items/Non-Items 
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&OSEGST.QRP Email Order GST separate 

Update Entity = Y – will update Order 

Header, posting Date Printed to Order 

Header 

Supplier, Order Header & 

Order Line - E-mail 

&OSEMAIL.QRP Email Order inc GST 

Update Entity = Y - will update Order Header, 

posting Date Printed to Order Header Screen. 

Supplier, Order Header & 

Order Line - E-mail 

&OSI100.QRP Orders and Stockitems 

Update Entity = Y - will update Order Header, 

posting Date Printed to Order Header 

Order Header, Order Line and 

Received Stockitems 

&OSINV.QRP Invoice details 

Update Entity = Y - will update Order Invoice 

posting a Report Date to Order Invoice screen.  

Supplier, Invoice Header and 

Invoice Line 

&OSU100.QRP Supplier list Supplier 

RepPeriodicals (Periodical Reports) 

 Go to Main > Reports > RepPeriodicals 

o Set Claim = Y – periodical issue (and copy) Claimed set to Y 

o If Report Stats Codes set – Statistics table updated 

TEMPLATE DESCRIPTION REPORT TYPE 

&PE0001.QRP Periodical Title Listing  Periodical 

&PE0010.QRP Periodicals listing (short details) Periodical 

&PE0100.QRP Periodicals listing (medium details) Periodical 

&PE1000.QRP Periodical listing (full details) – details in 

Supplier, Periodical sequence 

Periodical 

&PERCLM.QRP Claim for undelivered issues Periodical & Issue 

&PERLIST.QRP List of titles, Location and Frequency Periodical, Issue, Copy & Item 

(Default) 

&PI0001.QRP Title listing with issues Periodical & Issue 

&PI0010.QRP Title listing with issues (brief details) Periodical & Issue 

&PI0100.QRP Title listing with issues (medium details) Periodical & Issue 

&PICLAIM.QRP Claim Letter Periodical, Issue & Copy 

&PICLE.QRP Periodical, Issue, Copy Email Periodical, Issue, Copy Email 

&PIC010.QRP Periodical, Issues & Copies (Brief details) Periodical, Issue & Copy 

&PICS001.QRP Periodical Stockitem Periodical, Issue, Copy & Item 

(Default) 

&PICS010.QRP Periodical, Issues and Stockitem Periodical, Issue, Copy & Item 

(Default)  

&SU1000.QRP Suppliers Only List Supplier 
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RepReservation (Reservation Reports) 

 Go to Main > Reports > RepReservation 

o Create Hist(Y/N) = Y – Account and Overdue History updated 

o Update Res Status = Y – status updated to PRINTED and financial transactions 

o If F10 More set – used for Financial Transaction update 

o If Report Stats Codes set – Statistics table updated 

TEMPLATE DESCRIPTION REPORT TYPE 

&BKGLISC.QRP Bookings List by Class Unlimited Reservation Format 

&BKGLIST.QRP Bookings List by Borrower Unlimited Reservation Format 

&BKGLSTK.QRP Booking List by Item Unlimited Reservation Format 

&BKGSLP.QRP Bookings Slip Unlimited Reservation Format 

&KINRES1.QRP Sample Reservation Letter Notification Reservations (Default) 

&RAX4000.QRP Phone List for Items reserved awaiting 

collection 

Reservations (Default) 

&RAX4010.QRP Reservation book slips Reservations (Default) 

&RA4000.QRP Postcard format (keeps history) Reservations (Default) 

&RESBRF.QRP Reservation list (brief details) Reservations (Default) 

&RESBRFC.QRP Reservation list (brief details with Class) Reservations (Default) 

&RESBRFG.QRP Reservation list (brief details with Group) Reservations (Default) 

&RESEML.QRP Email reservation notice - E-mail 

&RESEXPB.QRP Reservations cancelled due to non-collection Expired Reservation Clear 

&RESLIST.QRP Reservation list Unlimited Reservation Format 

&RESSMS.QRP Reservation Notice (SMS) Unlimited Reservation Format 
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RepStatistics (Statistics Reports) 

 Go to Main > Reports > RepStatistics 

o If Report Stats Codes set – Statistics table updated 

Most template names begin with &STAT and are all similar but reflect different sequencing of data. 

The report names will give an indication of the order in which parameters should be selected: 

TEMPLATE CODES 

 &STAT1 – summaries by Year, Form 

 &STAT2 – summaries by Year, Month 

 &STAT3 – summaries by Year, Month, Day 

 &STAT4 – summaries by Year, Month, Day, Hour 

 &STAT5 –  details by Borrower Type 

 &STAT6 – count by Location, Type, Borrower 

 &STAC – Location, Borrower Class, Form 

 &STAG – Location, Borrower Group, Form 

 

General Statistical Reports 

TEMPLATE DESCRIPTION REPORT TYPE 

&SAAUDIT.QRP Access Audit - access by Operator showing alterations Access Audit 

&SLAUDIT.QRP Logon Audit - Date and Time Operators logged onto certain 

modules 

Logon Audit 

&SSAUDIT.QRP Search Audit - Search terms used within the Programs and 

the Type of search done 

Search Audit 

&STAT4D.QRP Summary by Location, TransType – Year/Month/Day Matrix Statistics 

&STAT4E.QRP Summary by Location, TransType – Year/Month/Day/Hour  

Matrix 

Statistics 

&STAT4K.QRP Summary by Location, Trans Type – Month/Day Matrix Statistics 

&STAT4J.QRP Summary by Location, Trans Type – Weekday/Week Matrix Statistics 

&STAT4I.QRP Summary by Location, Trans Type – Weekday/Hour Matrix Statistics 

&STAT100.QRP Summary by Location, TransType, Year Statistics 

&STAT101.QRP Summary by Location, TransType, Year Statistics 

&STAT110.QRP Summary by TransType, Location, Year Statistics 

&STAT111.QRP Summary by TransType, Location, Year Statistics 

&STAT200.QRP Summary by Location, TransType, Year, Month Statistics 

&STAT201.QRP Summary by Location, TransType, Year, Month Statistics 

&STAT205.QRP Summary by Location, Year, Month, TransType Statistics 

&STAT210.QRP Summary by TransType, Location, Year, Month Statistics 

&STAT211.QRP Summary by TransType, Location, Year, Month Statistics 

&STAT300.QRP Summary by Location, TransType, Years, Months, Days Statistics 

&STAT301.QRP Summary by Location, TransType, Year, Month, Day Statistics 

&STAT310.QRP Summary by TransType, Location, Years, Months, Days Statistics 

&STAT311.QRP Summary by TransType, Location, Year, Month, Total Day Statistics 

&STAT400.QRP Summary by Location, TransType, Years, Months, Days, Hours Statistics 

&STAT401.QRP Summary by Location, TransType, Year, Month, Day, Hour Statistics 
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&STAT410.QRP Summary by TransType, Location, Years, Months, Days, Hours Statistics 

&STAT411.QRP Summary by TransType, Location, Year, Month, Day, Hour Statistics 

&STA%500.QRP Percentage by Location, TransType, BorType, ItemFormCode Statistics 

&STAT500.QRP Details by Location, TransType, BorType, ItemFormCode Statistics 

&STAT501.QRP Details by Location, TransType, ItemFormCode, BorType Statistics 

&STAT502.QRP Details by Location, Trans Type, BorType, ItemFormCode, 

ItemStatsCode 

Statistics 

&STAT510.QRP Details by TransType, Location, BorType, ItemFormCode Statistics 

&STAT511.QRP Details by TransType, Location, ItemFormCode, BorType Statistics 

&STAT520.QRP Details by Location, TransType, BorType, ItemStatsCode Statistics 

&STAT521.QRP Details by Location, TransType, ItemStatsCode, BorType Statistics 

&STAT526.QRP Details by Location, TransType, ItemFormCode, 

ItemStatsCode 

Statistics 

&STAT530.QRP Details by TransType, Location, BorType, ItemStatsCode Statistics 

&STAT531.QRP Details by TransType, Location, ItemStatsCode Statistics 

&STAT540.QRP Details by Location, TransType, BorType, SuburbCode Statistics 

&STAT541.QRP Details by Location, TransType, SuburbCode Statistics 

&STAT550.QRP Details by TransType, Location, BorType, SuburbCode Statistics 

&STAT551.QRP Details by TransType, Location, SuburbCode, BorType Statistics 

&STAT560.QRP Details by TransType, Location, BorType, WardCode Statistics 

&STAT561.QRP Details by Location, TransType, WardCode, BorType Statistics 

&STAT562.QRP Details by Location, TransType, WardCode Statistics 

&STAT570.QRP Details by TransType, Location, BorType, WardCode Statistics 

&STAT571.QRP Details by TransType, Location, WardCode, BorType Statistics 

&STAT600.QRP Details by Location, TransType, BorType Statistics 

&STAT610.QRP Details by TransType, Location, BorType Statistics 

&STAT620.QRP Details by Location, TransType, ItemStatsCode Statistics 

&STAT630.QRP Details by TransType, Location, ItemStatsCode Statistics 

&STAT640.QRP Details by Location, TransType, ItemFormCode Statistics 

#SUMBOR.QRP Summary of circulation by Borrower details Statistics 

#SUMITEM.QRP Summary of circulation by Item details Statistics 

#SUMMNTH.QRP Summary of Statistics by Month Statistics 

&XSTAT10.QRP Summary by Location, TransType, Year. Fields delimited by 

semi-comma to be saved as Text file & opened in MS Excel. 

Statistics 

&XSTAT20.QRP Summary by Location, TransType, Year, Month.  

Fields delimited by semi-comma to be saved as Text file & 

opened in MS Excel. 

Statistics 

&XSTAT30.QRP Summary by Location, TransType, Year, Month, Day.  

Fields delimited by semi-comma to be saved as Text (.txt) file 

& opened in MS Excel. 

Statistics 

&XSTAT50.QRP Details by Location, TransType, BorType, FormCode.  

Fields delimited by semi-comma to be saved as Text file & 

opened in MS Excel. 

Statistics 

&XSTAT52.QRP Details of Location, TransType and ItemStatsCode Statistics 

&XSTAT53.QRP Details of Location, TransType and ItemFormCode Statistics 

&XSTAT54.QRP Details of Location, TransType, BorType, ItemFormCode & Statistics 
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ItemStatsCode 

 

Statistics Reports based on Borrower Class 

&STAC500.QRP Details by Location, TransType, BorClass, ItemFormCode Statistics 

&STAC501.QRP Details by Location, TransType, ItemFormCode, BorClass Statistics 

&STAC510.QRP Details by TransType, Location, BorType, ItemFormCode, 

BorClass 

Statistics 

&STAC511.QRP Details by  TransType, Location, ItemFormCode, BorClass Statistics 

&STAC520.QRP Details by Location, TransType, BorClass, ItemStatsCode Statistics 

&STAC521.QRP Details by Location, TransType, ItemStatsCode, BorClass Statistics 

&STAC530.QRP Details by TransType, Location, BorClass, ItemStatsCode Statistics 

&STAC531.QRP Details by TransType, Location, ItemStatsCode, BorClass Statistics 

&STAC540.QRP Details by Location, TransType, BorClass, SuburbCode Statistics 

&STAC550.QRP Details by TransType, Location, BorClass, SuburbCode Statistics 

&STAC560.QRP Details by Location, TransType, BorType, WardCode, BorClass Statistics 

&STAC570.QRP Details by TransType, Location, BorClass, WardCode Statistics 

&STAC600.QRP Details by Location, TransType, BorClass Statistics 

&STAC610.QRP Details by TransType, Location, BorClass Statistics 

 

Statistics Reports based on Borrower Group 

&STAG500.QRP Details by Location, TransType, BorGroup, ItemFormCode Statistics 

&STAG501.QRP Details by Location, TransType, ItemFormCode, BorGroup Statistics 

&STAG511.QRP Details by  TransType, Location, ItemFormCode, BorGroup Statistics 

&STAG520.QRP Details by Location, TransType, BorGroup, ItemStatsCode Statistics 

&STAG521.QRP Details by Location, TransType, ItemStatsCode, BorGroup Statistics 

&STAG530.QRP Details by TransType, Location, BorGroup, ItemStatsCode Statistics 

&STAG531.QRP Details by TransType, Location, ItemStatsCode, BorGroup Statistics 

&STAG540.QRP Details by Location, TransType, BorGroup, SuburbCode Statistics 

&STAG550.QRP Details by TransType, Location, BorGroup, SuburbCode Statistics 

&STAG560.QRP Detail by Location, TransType, BorType, Ward, BorGroup Statistics 

&STAG570.QRP Details by TransType, Location, BorGroup, WardCode Statistics 

&STAG600.QRP Details by Location, TransType, BorGroup Statistics 

&STAG610.QRP Details by TransType, Location, BorGroup Statistics 
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RepStockitem (Stockitem Reports) 

 Go to Main > Reports > RepStockitem 

o Create Fin (Y/N) = Y – deletes Stockitem History only 

o If Report Stats Codes set – Statistics table updated 

TEMPLATE DESCRIPTION REPORT TYPE 

&SPINE1.QRP Spine Labels (1 column) Spine Labels 1 label wide 

&SPINE2.QRP Spine Labels (2 columns) Spine Labels 2 label wide 

&SPINE3.QRP Spine Labels (3 columns) Spine Labels 3 label wide 

&SPINE4.QRP Spine Labels (4 columns) Spine Labels 4 label wide 

&SPINE5.QRP Spine Labels (5 columns) Spine Labels 5 label wide 

&SPINE6.QRP Spine Labels (6 columns) Spine Labels 6 label wide 

&SPINE7.QRP Spine Labels (7 columns) Spine Labels 7 label wide 

&SPINE8.QRP Spine Labels (8 columns) Spine Labels 8 label wide 

&SPINE9.QRP Spine Labels (9 columns) Spine Labels 9 label wide 

&SPINE10.QRP Spine Labels (10 columns) Spine Labels 10 label wide 

&SPINE11.QRP Spine Labels (11 columns) Spine Labels 11 label wide 

&SPINE12.QRP Spine Labels (12 columns) Spine Labels 12 label wide 

&SPINE13.QRP Spine Labels (13 columns) Spine Labels 13 label wide 

&SPINEW1.QRP Spine labels with accession plate (2 columns) Spine Labels 1 label wide 

&SADBR.QRP Stockitem audit list (brief details) Item Audit 

&SADDET.QRP Stockitem audit list (medium details) Item Audit 

&STKAUD.QRP Stockitem audit list (full details) Item Audit 

&STKAVG.QRP From a Stats Code shows averages for item - 

cost, issues, renewals, average year 

accessioned – ordered by Stats Code 

Stockitems (Default) 

&STKBCODE.QRP Borrower list with Barcodes (requires font 

setup) 

Stockitems (Default) 

&STKBRF.QRP List of stockitems – Medium details Stockitems (Default) 

&STKCFCS.QRP Stockitem count by form and call number set Stockitems (Default)  

&STKCFS.QRP Count of stockitems by Form and Stats Codes Stockitems (Default) 

&STKCLFS.QRP Count of stockitems by Location, Form and 

Stats Codes 

Stockitems (Default) 

&STKCLSF.QRP Count of stockitems Location, Stats Codes 

and Form 

Stockitems (Default) 

&STKCOP.QRP List of stockitems attached to Cat Ref No – 

with count of items 

Stockitems (Default) 

&STKCRES.QRP Reservations and copies ratio report Stockitems (Default) 

&STKCS.QRP Stockitem count by Stats Code Stockitems (Default) 

&STKCSC.QRP Stockitem count by Stats Code and Call Set Stockitems (Default) 

&STKCSF.QRP Count of stockitems Stats Codes and Form Stockitems (Default) 

&STKFBOR.QRP List of items borrowed by individual 

Borrower name 

Stockitems (Default) 

&STKFS.QRP Count of stockitem by form Stockitems (Default) 

&STKFULL.QRP List of stockitems – full record Stockitems (Default) 
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&STKH5.QRP Shows items where count > 5 Item History 

&STKH10.QRP Shows items where count > 10 Item History 

&STKH20.QRP Shows items where count > 20 Item History 

&STKHCC.QRP Usage count by Form – Call Number order 

giving details of each Stockitem 

Item History 

&STKHCCS.QRP Usage count by Form – Call Number order 

(summary) 

Item  History 

&STKHCSC.QRP Usage count by Form – Stats Code order 

giving details of each Stockitem 

Item History 

&STKHCSS.QRP Usage count by Form – Stats Code order 

(summary) 

Item History 

&STKHIST.QRP Stockitem History list 
Can be used to delete records – Update 
Entity = Y 

Item History 

&STKHISU.QRP Stockitem History deletion – count of 
records deleted 
Can be used to delete records – Update 
Entity = Y 

Item History 

&STKMEMOS.QRP Stockitem memo list Memos 

&STKMRR.QRP Most recent return – damaged item notice 

(letter) 

Most Recent Return 

&STKMRRE.QRP Most recent return – damaged item notice 

(e-mail) 

Most Recent ReturnEmail 

&STKODUE.QRP List of overdue stockitems Stockitems (Default) 

&STKPDC.QRP Count by date published – must be set to 

order  by Edition 

Stockitems (Default) 

&STKSUBJ.QRP List of stockitems by Subject Headings Stockitems (Default) 

&STKTACA.QRP Bibliographic data - Author, Title, Call 

Number 

Stockitems (Default) 

&STKTACT.QRP Bibliographic data – Title, Author, Call No Stockitems (Default) 

&STKTACR.QRP Bibliographic data – Title, Author, Call 

Number, Accession Date, # Reserves 

Stockitems (Default) 

&STKTITL.QRP List of stockitems – Author, Title, Call 

Number, Form, Stats Code details 

Stockitems (Default) 

&STKTUR1.QRP Count of items and turnover by Stats Code 

and Form 

Stockitems (Default) 

&STKTUR2.QRP Count and turnover By Cat Ref Stockitems (Default) 

&STKTUR3.QRP Count and turnover Summary By Stats Stockitems (Default) 

&STKTUR4.QRP Count and turnover By Author Stockitems (Default) 

&STKUCTS.QRP Count of items attached to the same Cat 

record by Form 

Stockitems (Default) 

&STKTCCF.QRP Title, Cost, Call Number and Form Stockitems (Default) 

&STKTACB.QRP Title, Author, Call Number and Barcode Stockitems (Default) 

&STKLTN.QRP Title, #of items, Author, Call Number, Form 

by Location 

Stockitems (Default) 

&STKHIS2.QRP Stock Item History List Summary Item History 

&STKHIS3.QRP Stock Item History List by Location Item History 
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&XSTKCS.QRP MS Excel format – Stockitem Count by Stats 

Code 

Stockitems (Default) 

&XSTKCLS.QRP MS Excel format – Stockitem Count by 

Location and Stats Code 

Stockitems (Default) 

&XSTKFS.QRP MS Excel format – Stockitem Count by Form Stockitems (Default) 

&XSTKCSV.QRP MS Excel format – Stockitem list-Title, 

Author, Call No, Form and Stats Code 

Stockitems (Default) 

&STKTAKE.QRP List of items in Stocktake Stockitems (Default) 

#ITEMINV.QRP Inventory Stockitem list with check-box Stockitems (Default) 



APPENDIX 2: REPORT TEMPLATE WINDOW 

 

 


