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REPORTS – OVERVIEW 

Reports are used for every conceivable purpose within Amlib, from printing up tables and updating 
borrower records to printing out overdue notices. 

It is possible to create and run a huge variety of reports covering every single module. In addition, it 
is possible for you to customise these reports in both their design and functionality. 

The creation of a report is covered in broad terms by the following flowchart: 

 

 

 

  

Template 
Design and Function 

Create Report 
Report selection and description 

Data 

Search conditions and parameters 

Files with .QRP 

extension 

Created/edited 

 in RepWin 

(REPWIN30.EXE) 

Determined by Where 

parameters or by 

selecting a Saved File 

Report Type 
Matching template to module and function 

Order 

Sequencing the results  

Results 

View/printing results  
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Report Module Categories 

The Reports module is split into the following categories: 

REPORT DESCRIPTION EXAMPLES 

RepAccounts Accounts Reports Account Reprints without creating a 

Financial record for the borrower. 

RepAuthority Authority Reports Author, Series, Subject Heading 

Listings, etc 

RepBibliographic Bibliographic (Catalogue Data) 

Reports 

New items displaying Title, Author, 

Subject Headings, Notes etc. 

RepBorrower Borrower Reports Listings of borrowers, loan histories, 

address labels 

RepCatalogue Catalogue Report – for more tag 

displays use RepBibliographic 

4 lines of data to show items by a 

particular author etc. 

RepCirculation Circulation Reports Items on Loan, Overdue lists, slips, 

Letters, Invoices etc. 

RepFinancial Financial Reports Budget categories and expenditure 

etc. 

RepILLS Inter Library Loan Reports ILL notices including request & 

renewal notices etc. 

RepOrders Order Reports Orders, Supplier Listings 

RepPeriodicals Periodical Reports Full journal listing, Suppliers, Renewal 

reminders, Claims etc. 

RepReservation Reservation Reports Pick-up lists, reservation collection 

notices and expired reservations lists 

RepStatistics Statistics Reports Statistics summary and detailed 

reports on library activity. Daily, 

Weekly, Monthly, Yearly etc. Issues by 

Borrower Type or by Form or Stats 

code. 

The Order MUST be correct! 

RepStockitem Stockitem Reports Listing of items, Value of the 

collection 

 

 

UNDERSTANDING REPORT TEMPLATES 
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A Guide to Report Template Names 

PREFIX DESCRIPTION 

#, &, $ System reports – these are supplied with Amlib 

RS, MM, MC Customised reports – any reports beginning with letters are customised 

reports, specific to a library with their own wording 

 

ABBREVIATION DESCRIPTION EXAMPLE 

AUTH Authority templates &AUTHSB2.QRP 

&AUTHFUL.QRP 

B Borrower templates &BCT.QRP 

&BCLT.QRP 

BOR Borrower templates &BORDATA.QRP 

&BORSHT.QRP 

BIB Bibliographic templates &BIB.QRP 

&BIB2.QRP 

BORH Borrower history templates &BORHIST.QRP 

&BORHISC.QRP 

&BORH10.QRP 

CI Circulation issues slips &CI1ISS.QRP 

&CI1NEW.QRP 

&CI1000.QRP 

FIN Financial templates &FINBUDG.QRP 

&FINCURR.QRP 

&FINTRAN.QRP 

ILL Inter-library loan templates &ILLEREM.QRP 

&ILLLET.QRP 

N Standard letter templates &N1ADD10.QRP 

&N1ADDEM.QRP 

NC, NEC, NEI NetOpac programmed templates &NCTBRF.QRP 

&NECTBRF.QRP 

&NEITBRF.QRP 

OD Circulation templates: Overdues &ODEMAIL.QRP 

&ODLET.QRP 

&ODLET1C.QRP 

&ODLET1G.QRP 
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EMAIL, EML E-mail templates &ODEMAIL.QRP 

&RESEML.QRP 

LET Letter templates &ODLET1C.QRP 

ODLET1G.QRP 

OR, OS Order templates &ORSI.QRP 

&ORSICL.QRP 

&OSD100.QRP 

PE Periodical templates: Periodicals and Suppliers &PE0010.QRP 

&PE0100.QRP 

&PE1000.QRP 

PI Periodical templates: Periodicals and Issues &PI0001.QRP 

&PI0100.QRP 

&PI0010.QRP 

PIC Periodical templates: Periodicals, Issues, Copies &PIC010.QRP 

&PICLAIM.QRP 

PICS Periodical templates: Periodicals, Issues, Copies, 

Stockitems 

&PICS010.QRP 

&PICS001.QRP 

SU Periodical templates: Suppliers only &SU1000.QRP 

RES Reservation templates &RESBRF.QRP 

&RESEML.QRP 

&RESLIST.QRP 

SAD Stockitem audit templates &SADDET.QRP 

&SADBR.QRP 

SPINE, SPN Spine label templates &SPN9C.QRP 

&SPINE9.QRP 

STAC Statistics Reports: Grouped by borrower class &STAC511.QRP 

&STAC520.QRP 

STAG Statistics Reports: Grouped by borrower group &STAG531.QRP 

&STAG540.QRP 

STAT Statistics Reports: General &STAT100.QRP 

&STAT210.QRP 

STK Stockitem Reports &STKTACT.QRP 

&STKCFS.QRP 

STKH Stockitem History &STKHIST.QRP 

&STKHISU.QRP 

&STKHCSC.QRP 

STKTUR Stockitem Turnover reports &STKTUR1.QRP 

&STKTUR2.QRP 

X Reports that output to Microsoft Excel &XSTKFS.QRP 

&XSTAT20.QRP 
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&XSTKCSV.QRP 

Statistics Templates 

NUMBER/LETTER DESCRIPTION EXAMPLE 

100 Summary by year &STAT110.QRP, &STAT111.QRP 

200 Summary by month &STAT200.QRP, &STAT205.QRP 

300 Summary by day &STAT300.QRP, &STAT310.QRP 

400 Summary by hour &STAT410.QRP, &STAT411.QRP 

500 More detailed reports  - for example: 

containing borrower type, suburb, etc. 

&STAT500.QRP, &STAT502.QRP 

600 Detailed reports &STAT620.QRP, &STAT630.QRP 

l Subdivides by location See screenshot below 

t Subdivides by type (statistical type) See screenshot below 

b Subdivides by borrower See screenshot below 

f Subdivides by form code See screenshot below 

s Subdivides by stats code See screenshot below 

y Subdivides by year See screenshot below 

m Subdivides by month See screenshot below 

d Subdivides by day See screenshot below 

h Subdivides by hour See screenshot below 

 

UNDERSTANDING REPORT TYPES 
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Report Types and their Associated Templates 

REPORT TYPES AVAILABLE DESCRIPTION EXAMPLE 

ACCOUNT 

No report types Reprint of accounts &ACI100.QRP 

AUTHORITY 

Authority (Default) Lists of Authorities  - for example: Subjects &AUTHBR2.QRP 

See References Lists of Authorities that use See References &AUTHSB2.QRP 

See / See Also References Lists of Authorities that use See Also References &AUTHSAB.QRP 

Authority Audits Authority audits  - for example: Deleted Authorities &AUTHAUD.QRP 

Authority with See and See 

Alsos 

Lists of Authorities that use both See & See Also 

References 

&AUTHFS2.QRP 

BIBIOLOGRAPHIC 

Bibliographic (Default) List of Catalogues with Bibliographic data (for 

example: Subjects, Notes) using Where parameters 

to select the Tags 

&BIB2.QRP 

Fixed layout Reports List of Catalogues with Bibliographic data (for 

example: Subjects, Notes) using F10 More to select 

the Tags 

&BIBFL28.QRP 

Bib with Image + stock List of Catalogues with Bibliographic data & some 

Stockitem set Fields with image included 

&CTITEMX.QRP 

BORROWER 

Borrower (Default) Borrower listings, counts &BORMED.QRP 

Audit Reports Audits - for example: Deleted, New borrowers &BORRAUD.QRP 

Borrower History Items the borrower has lent and returned + items 

generated in reports (overdues, reserves) 

&BORHIST.QRP 

Borrower (purge) Financial Deletion of Borrower financial records &BORFINP.QRP 

Borrower (list) Financial List of Borrower Financial - for example: money 

owing 

&BOFINTO.QRP 

Name and Addresses x 1 across Borrower Letter &N1ADD10.QRP 

Name and Addresses x 1 across 

Email 

Borrower Letter by email  - for example: Welcome 

letter 

&N1ADDEM.QRP 

Name and Addresses x 3 across Address Labels &N3ADD20.QRP 
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Borrower Interest Reports New items alert for Borrowers with Interests &BORINT.QRP 

Borrower Interest Reports - 

Email 

New items email alert for Borrowers with Interests &BORINEM.QRP 

Borrower Profile Reports Borrower Profiles - for example: Age Groups  &BORPROS.QRP 

Borrower Memos Report that allows print of text in Memos &BORMEMO.QPR 

Borrower Images Includes Image of Borrower - for example: Borrower 

card 

&BORCRDP.QRP 

Borrower Automatic Update Enables mass changing of Borrower Types, Classes, 

Groups and Status. Details are changed through the  

F10 More options 

&BORUPD.QRP 

Borrower Circulation Automatic 

Update 

Enables mass changing of Borrower Types, Classes, 

Groups and Status based on due date parameters in 

the ‘where’ statement. Details are changed through 

the F10 More options 

&BORCUPD.QRP 

CATALOGUE 

No report types Catalogue list with the Display lines &CATFULL.QRP 

CIRCULATION 

These templates are often customised for each individual site 

Title, Author, Form, Item No, 

Location (Default) 

Lists & Letters with 8 items/borrower (often used 

with preprinted slips 

&OD2000.QRP 

Title, Call No, Stats Code, Item 

No, Location 

Lists & Letters with 8 items/borrower   

Res, Title, Author, Form, Item 

No, Location 

Recall list for overdue items with attached 

reservations – Author in line 2 

&CIRRESA.QRP 

Res, Title, Call No, Stats Code, 

Item No, Location 

Recall list for overdue items with attached 

reservations – Call No in line 2 

&CIRRESC.QRP 

Type, Group, Class, AuthForm, 

Item.locn 

Lists & Letters with 8 items/borrower displaying 

Type, Group and/or Class 

&BTCIRC.QRP 

Continuous - Full Descriptions Lists & Letters with unlimited items &ODLST.QRP 

Continuous - E-mail Letters with unlimited items via Email &ODEMAIL.QRP 

Offline files export For Advanced Offline only to copy Borrower & Item 

tables  

&OFFLINE.QRP 

Offline process report Report for Advanced Offline Process &AOLPROC.QRP 
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FINANCIAL 

Account Listing Listing of Budget Accounts &FINACCT.QRP 

Allocation Codes Listing of Budget Allocations &FINALL.QRP 

Budget Summary Analysis of Budget &FINBUDG.QRP 

Currency Codes Listing of Budget Currency Codes &FINCURR.QRP 

GL Codes Listing Listing of General Ledger showing levels &FINGLC.QRP 

Ledger Format Account Transaction Totals for Budget &FINLEDG.QRP 

Circulation Trans Circulation Transactions &CFINDET.QRP 

Aged Borrower ( 4 mths ) 

Transactions 

Borrower Monthly Transaction Totals (single line 

Accounting) over 4 months 

&FINAGE4.QRP 

Aged Borrower ( 6 mths ) 

Transactions 

Borrower Monthly Transaction Totals (single line 

Accounting) over 6 months 

&FINAGE6.QRP 

Aged Borrower ( 12 mth s) 

Transactions 

Borrower Monthly Transaction Totals (single line 

Accounting) over 12 months 

&FINAGE12.QRP 

Borrower Fin. Trans. Audit Borrower Financial Transaction Audit (single line 

Accounting) 

&FBFAUD.QRP 

Borrower Summary Fin. Trans. 

Audit 

Borrower Financial Transaction Audit (single line 

Accounting) if set to Update, YTD is updated 

&FBFSUM.QRP 

Borrower Owing Details of borrowers’ fines. For use with print letter 

format templates. 

&FINOWE.QRP 

Borrower Owing Email Details of borrowers’ fines. For use with e-mail 

templates. 

&FINOWEE.QRP 

INTER-LIBRARY LOAN 

Default Letters, Lists &ILLREM.QRP 

E-Mail Request Letters via Email to first supplying library &ILLEREM.QRP 

E-Mail Request to all Suppliers Letters via Email to ALL supplying libraries &ILLEREQ.QRP 
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ORDER 

Supplier, Order Header & Order 

Line (Default) 

Order Forms &ORDGST.QRP 

Order Header, Order Line & 

Received StockItems 

Run in update mode, posts Date Printed to Order 

Header 

&OSI100.QRP 

Order Header, Order Line & 

Order Items/Non-Items 

Summary of Orders with Stockitems etc. &OON100.QRP 

Supplier Supplier Listing &OSU100.QRP 

Supplier, Order Header & Order 

Line - E-Mail 

Email Order &OSEGST.QRP 

Supplier, Order Header & Order 

Line - EDIFACT 

EDIFACT Order &OREDL.QRP 

Supplier, Order Header, Order 

Line & Order Items/Non-Items 

Order Status report  &ORSI.QRP 

Supplier, Order Header, Order 

Line & Order Items/Non-Items 

to Claimed 

Order Claims notices. Update Entity will set status to 

claimed for Order Lines 

&ORSICL.QRP 

Supplier, Order Header, Order 

Line & Order Items/Non-Items 

to Returned 

Returns notice for Orders. Update Entity will set 

status to Returned for Order Lines 

&ORSIR.QRP 

Supplier, Order Header, Order 

Line & Order Items/Non-Items 

to Cancelled 

Cancellation of Orders. Update Entity will set status 

to Cancelled for Order Lines 

&ORSICAL.QRP 

Supplier, Order Header, Order 

Line & Order Items/Non-Items 

E-mail 

Order status report via Email &ORSIE.QRP 

Supplier, Order Header, Order 

Line & Order Items/Non-Items 

E-mail to Claimed 

Order Claims notices via Email. Update entity will set 

status to claimed for Order Lines  

&ORSIECL.QRP 

Supplier, Order Header, Order 

Line & Order Items/Non-Items 

E-mail to Returned 

Returns notice for Orders via Email. Update Entity 

will set status to Returned for Order Lines 

&ORSIER.QRP 

Supplier, Order Header, Order 

Line & Order Items/Non-Items 

E-mail to Cancelled 

Cancellation of Orders via Email. Update Entity will 

set status to Cancelled for Order Lines 

&ORSIECA.QRP 

Supplier, Invoice Header & Invoice details Update entity would post Report Date &OSINV.QRP 
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Invoice Line to Invoice screen 

PERIODICAL 

Periodical, Issue, Copy & Item 

(Default) 

Listings with Stockitems &PICS001.QRP 

Periodical, Issue & Copy Listings with Copies, Claim letter &PICLAIM.QRP 

Periodical & Issue Listing with Issues &PI0100.QRP 

Periodical Listings &PE0001.QRP 

Supplier Suppliers only &SU1000.QRP 

Periodical, Issue, Copy Email Claim letter by Email &PICLE.QRP 

RESERVATION 

Reservations (Default) Reservation notice or list (8 per notice) &RESBRF.QRP 

Expired Reservation Clear Clear reservations en masse &RESEXPB.QRP 

- E-Mail Reservation notice via email &RESEML.QRP 

Unlimited Reservation Format Reservation notice or list (unlimited) &RESLIST.QRP 

STATISTICS 

Statistics Most Statistics Reports &STAT200.QRP 

Access Audit Access to Authorities by Operator  - for example: 

Viewed Attachments, view Authorities giving Date 

and Time 

&SAAUDIT.QRP 

Logon Audit Date and Time Operators logged onto certain 

modules 

&SLAUDIT.QRP 

Search Audit Search terms used within the Programs and the 

Type of search done 

&SSAUDIT.QRP 

STOCKITEM 

Stockitems (Default) Lists of items &STKTACT.QRP 

Item Audit Item Audits  - for example: Items deleted &SADBR.QRP 

Item History Item History &STKHIST.QRP 

Memos Stockitem memo list &STKMEMOS.QRP 

Most Recent Return Last Borrower  - for example: Damaged Item Notice &STKMRR.QRP 

Most Recent ReturnEmail Last Borrower  - for example: Damaged Item Notice &STKMRRE.QRP 
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via Email 

Spine Labels 1 label wide Spine Labels - 1 label across  

Spine Labels 2 label wide Spine Labels - 2 labels across  

Spine Labels 3 label wide Spine Labels - 3 labels across  

Spine Labels 4 label wide Spine Labels - 4 labels across  

Spine Labels 5 label wide Spine Labels - 5 labels across  

Spine Labels 6 label wide Spine Labels - 6 labels across  

Spine Labels 7 label wide Spine Labels - 7 labels across &STKSPN7C.QRP 

Spine Labels 8 label wide Spine Labels - 8 labels across  

Spine Labels 9 label wide Spine Labels - 9 labels across &STKSPN7C.QRP 

Spine Labels 10 label wide Spine Labels - 10 labels across  

Spine Labels 11 label wide Spine Labels - 11 labels across  

Spine Labels 12 label wide Spine Labels - 12 labels across  
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UNDERSTANDING REPORT DESIGN 

Report Templates: Basics 

RepWin is made up of: 

 Background Text 

 Fields 

 Headers 

 Footers 

 Break Groups 

 Input Items 

Palette 

It may be convenient to have the Palette available for selection purposes. 

1. From the menu, select View > Palette – the Palette will then display: 

 

 

 

 

 

 

2. It is possible to right-click on your mouse (in the middle of the screen) to change the tool 

being used 

  

 

Background Text Tool 

Box Tool  

Line Tool – add extra lines 

Auto Selector On 

Selector Tool 

Field Tool 

Picture Tool 

Auto Selector Off 
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Background Text 

 Text with no FIELD information included – for example: Street Address 

To insert Background Text 

1. From the menu, select Tools > Background Text 

 

2. Position the tool where you want the text to be inserted (the text will be left-justified) 

3. Click the left mouse button once – a white text box will be inserted 

 

4. The cursor will remain in the text box so you can start typing the background text that you 

want to display each time the report is printed 

  



Reports Training- Advanced Reports 

 

 

Last Updated: 26 February 2013 
 Page 21 

5. Alternately, click out of the box and then double-click on the text box – the Format 

Background Text screen will display: 

 

6. Insert the text to be displayed in the Text: box 

7. Font-style, font-size, justification, borders, etc, options can also be adjusted (this can also be 

done from the ruler at the top of the screen) 

8. Click the OK button when complete 
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Fields 

Fields can be Inputs (objects that are derived from the Amlib database – for example: Borrower 

Name, Address, etc.), a string value (combining Input items and background text), formulas and 

functions (many of which can be used on Inputs). 

To insert a Field 

1. From the menu, select Tools > Field 

2. Position the tool where you want the field to be inserted (the field will be left-justified) 

3. Click the left mouse button once – a white field box will be inserted 

4. The cursor will remain in the field – at this point it is possible to select an Input option from 

the Content: drop-down box at the top of the screen – for example: BOR_SURNAME 

(Borrower Surname) 

 

5. Alternatively, click out of the box and then double-click on the field box – the Format Fields 

screen will display: 
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6. This screen allows the formatting of the fields in the following ways (some formatting can 

also be done from the ruler at the top of the screen): 

 Character  - for example: Font size 

 Line Wrapping: this sets whether or not the line can wrap to the next line, and the 

number of lines which can be used 

 Repeating Values: this allows repeated values to be suppressed 

 Justification: Left, Center or Right-justified 

 Format:  determine the way in which a field may be displayed – for example: date 

formats 

7. Click the OK button when complete 

Editor 

1. From the ruler menu, select the Editor button (alternatively, you can select the Editor... 

button within the Format Fields screen) – the Formula Editor screen will display: 

 

2. Input Items can be selected from the Data Items window, Formulas from the Formulas 

window (for example: and Functions from the Functions window (for example: CurrentDate) 

3. Click the OK button when complete 
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Blocks 

Blocks form the backbone of the report and can come in the form of: 

TYPES BLOCK COMMENT 

Headers (Optional ) Report Header Contains a Report Title – only appears at the very 

beginning of the Report 

Page Header Contains information to appear at the top of every page 

Group Header Contains information to appear at the beginning of every 

Break Group. Will only appear if Break Groups are defined 

Footers (Optional) Group Footer Contains information to appear at the end of every Break 

Group. Will only appear if Break Groups are defined 

Page Footer Contains information to appear at the bottom of every 

page – for example: Page Numbers 

Report Footer Contains Report totals and summaries – only appears at 

the very end of the Report 

Detail Block Contains data that is sourced from the Amlib database. There is only one 

Detail Block per Report Template 

 

Each block is essentially nested inside another block with the Detail Block sitting at its centre: 

 Report Header 

o Page Header 

 Detail Block 

o Page Footer 

 Report Footer 

Headers 

These are optional and can be defined as follows: 

 Report Header: Appears only once, containing a title 

 Page Header: Contains messages, references, page numbers etc. and appears on each page 

 Group Header: Appears before the first line of a group of records (these do not display until 

Break groups are defined) 
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The Statistics report below has numerous Group Headers: 

 

 Each Header can have settings (for example: minimum height) and can be accessed by 

double-clicking the Header name – for example: Page Header 

 

The first line after a header can also have settings defined – for example: Page Break Before 

 Check this by double-clicking on the first line after the Header (in the grey space rather than 

on a field or background text box 
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Footers 

These are also optional and can be defined as follows: Report Footer, Page Footer and Group Footer. 

 Group Footers may contain Totals for the group. 

 Page Footers can contain Page Numbers or copyright information that would need to be 

shown on each page of the Report. 

Please Note: It is possible to keep Group information from splitting across a page (where there is less 

than 1 page of information) – for example: to prevent a page break forming in the middle of an 

Overdue Slip.  

 See: Formatting – Keep on Page 

 

Detail Block 

 Prints information from individual rows showing data from the Amlib database – there is only 

one Detail Block per report template 

FORMATTING TASKS 

Edit Background Text  

 For example: Changing the wording in an overdue letter. 

1. Open the template you want to change – be sure to save a back-up copy first, in case you 

want/need to go back to it later 
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2. Double-click on the background text that you wish to change – the Format Background Text 

screen will display: 

  

3. Click into the main Text: box, highlight and add/delete text as necessary – you can also 

change the font-size and style: 

 

 4. Click the OK button when complete 
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4. For long sentences, use your cursor to stretch your background text to the edge of the page 

and the text will automatically continue to the next line 

Add Extra Space (by Adding Lines) 

If you want to have spaces in your letter to separate some of the areas of text, you can add some 

extra lines to your template. 

1. Open the template you want to change – be sure to save a back-up copy first, in case you 

want/need to go back to it later 

2. From the menu, select Tools > Line or alternately, select the Line icon on the Palette: 

 

3. Hover your mouse over the area in the template where you wish to put the line, until your 

cursor turns into the square line tool symbol (you may have to put your cursor on the top or 

bottom edge of an existing line) 

4. Left-click to insert the extra line 

 

Please Note: Be careful where you place your lines!  
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 If you add a line to the detail block, with most templates, this will add a line between each 

item that is listed: 

 

 If you want to add space between the existing text around the details, add the extra lines to 

the bottom of the header above the Detail Block or to top of the footer directly following it: 
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Reduce Space by Deleting Lines 

1. Click on the line to highlight it: 

  

2. Click the Delete button on your keyboard 

Adjust the Size of Your Fields or Background Text 

1. Click on the field/background text you want to change: 

 

2. Move your cursor to the edge you want to expand, until the cursor becomes a double-

arrow: ↔ 

3. Then click on the edge of the field, drag it to where you want it to be: 
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Move Fields or Background Text 

1. Click on the field or background text you want to change: 

 

2. Hover your mouse cursor over the highlighted background text or field until the cursor 

becomes a four-way set of white arrows:  

3. Click and drag to the place where you want it to be: 
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Add Text 

1. Create a line, if needed: 

 

2.  From the menu, select Tools > Background Text or alternately, select the Background Text 

icon on the Palette: 

 

3. Click in the line where you want your text to display – a white block will appear: 

 

4. Stretch out the background text box to fit the whole line – if it’s a large sentence, it will need 

the space across the whole line: 
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TIP:  If you can’t select your text box, try clicking on the line space behind it, then clicking onto the 

text box. 

5. Select the background text box by double-clicking it – the Format Background Text screen 

will display: 

 

6. Add in the text you want to the Text: box 

7. Set the font size, style and add bold or italics as needed 

8. Click the OK button when complete 

 

Add Fields 

1. Add a line if necessary 

2. From the menu, select Tools > Field or alternately, select the Field icon on the Palette: 

  

3. Click in the line where you want to place the field – a white block will appear: 
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4. Stretch the edges of the field if necessary – click off the field, then hover your mouse over 

the edge of the field to get the double arrows and then adjust the size: 

 

5. Select the field with your mouse: 
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6. Click the Editor button on the toolbar – the Formula Editor screen will display: 

 

7. From the Data Items box, select the field you want to add – in this example, we want to add 

the call number, which is Line 6 in the Stockitem screen 

8. Double-click the item to display it in the top section of the screen: 

 

8. Click the OK button when complete 

 

  



Reports Training- Advanced Reports 

 

 

Last Updated: 26 February 2013 
 Page 36 

BIBLIOGRAPHIC REPORTS 

Create a Report 

1. Launch the Amlib client 

2. Go to Main > Reports > RepBibliographic – the Bibliographic Reports screen will display 

3. Click the F1 New button – the Select Report Format screen will display 

4. Highlight the report template you would like to use (for example: &BIB.QRP or &BIB2.QRP) 

and click the Select button 

5. Type in a Description – for example: Harry Potter  

6. Click the F3 Save button 

7. Highlight the report and click the F7 Where button – the Bibliographic Reports – Where 

screen will display: 

 

8. There are three unique parameters:  

 Auth Tag: Search for a particular MARC tag 

 Auth Key: Check for particular data contained in the MARC tag 

 Tags to Display: MARC tags to display in report 

9. The statement can include the following settings: 

a. Auth Tag – for example: Auth Tag = 245 (Title) 

b. Auth Key – for example:  Auth Key LIKE Harry Potter (looks for all matching items 

where the Title BEGINS with Harry Potter) 

c. Tags to Display – for example: Tags to Display IN 100, 245 (will display Author and 

Title in report) 
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d. (optional) Enter a start date: Date >= enter a date in DD/MM/YYYY format – for 

example: 01/01/2010 

e. (optional) Enter a finish date: Date <= enter a date in DD/MM/YYYY format – for 

example: 10/10/2010 (a finish date is optional – if not inserted, the report will go up 

to the current date). 

f. You may also want to limit by Catalogue Number(s) 

10. Click the F3 Save button when complete 

11. Click on the F9 Order button – the Bibliographic Reports – Order By screen will display: 

 

Sorting of Bibliographic reports is different to other reports. The Auth Tag that you wish to sort by is 

set in the Where Parameters – for example: 245 (Title) and the Order is set to be sorted by is the 

Auth Key. 

12. Use the arrow keys to select and move the fields to be sorted by – for example: Auth Key 

13. Click the F3 Save button when complete 

14. Click the F8 View button to view/print the report 

Advanced Bibliographic Reports: Fixed Layout Reports using F10 More 

This function is used for mapping data to fields in Fixed Layout reports – for example: the DVD Cover 

template (&DVDCOV.QRP). 

Each row of this table may be used to collect 1 of the 20 fields on the report template. These first 20 

fields contain Tag or Subfield data (Fields 1-20), and the next 20 fields (Fields 1A – 20A) contain the 

associated Tag Descriptions (Go to Main > Authorities > MarcTags to see a complete list of Tag Nos 

and Tag Descriptions). The report outputs all the MARC data to the report. The inclusion of Fields 1A 

– 20A in the report is optional. 
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The table below explains how the user can specify which parts of the MARC tag to send: 

OPERATOR DESCRIPTION EXPLANATION 

blank (Default) The entire MARC tag is printed If the column is left blank, then the entire 

MARC tag is printed 

+ All data in the specified tag is printed 

no matter how many tags are 

included in the record  

All Subject listings are printed, where there 

is only one or several or hundreds! 

and sf in ('p', 'n') Only the subfields specified to be 

printed within this Authority Tag 

If 440 (Series) tag, only the Series name 

and number printed 

and cat_sf in ('c') Only the subfields specified to be 

printed within this Non-Authority 

Tag 

If 260 (Publisher) tag, only the 'c' (Date) 

subfield printed (and not Place or 

Publisher) 

 

  

 COLUMN 1 COLUMN 2 COLUMN 3 COLUMN 4 COLUMN 5 

HEADING Report Line 
Number 

Tag Number eg + or blank 
or and sf in 
('a', 'b') 

blank or and 
cat_sf in ('a', 
'b') 

Not used 

EXAMPLE 1 100    

2 245    

3 082    

4 650    

COMMENT Can be any 
number 
between 1 
and 20 

MARC Tag field 
number – for 
example: 245 
(Title) 

Any Tag can be 
matched to ant 
Line Number 

Specify which 
part of the MARC 
tag to send - see 
table below for 
more details 

Specify which 
part of the MARC 
tag to send - see 
table below for 
more details 

 

FIELDS 1 – 20: 

Display actual 

data for the 

relevant Tags 

within 

Authority 

FIELDS 1A – 

20A: 

Display Tag 

Descriptors 

held in Main > 

Authorities > 

MarcTags 
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Example 1 – Bibliography: 

The template &BIBFL10.QRP is a Bibliography with up to 10 lines that can be defined. The template 

includes MARC Tag descriptors (include the 1A, 2A etc.): 

 

1. Set the More window as follows – the Line numbers correspond to fields inserted on the 

template (in this example: Title and Author) 

a) Select the F1 New or F2 Insert button 

b) Type in field details – the columns are filled in as follows: ' 

i. Report Line Number = 1 and 2 

ii. Tag Number = MARC Tag field number – for example: 245 (Title) and 100 

(Author) 
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Alternatively, the report can be set up to show all 10 lines with all occurrences of Multiple Tags  - for 

example: if more than one 651 Subject occurs, show all headings. You are also able to define which 

subfields are displayed for Authorities and Non-Authorities – for example: only show the Series Title 

and Number (subfields a and v of Tag 440, or only the Date in a Publisher (subfield c).  

 

The following DVD Covers report uses this methodology. 

Example 2 – DVD Cover Report: 

1. Click the F10 More button – the More screen will display 

2. Set the More window as follows – the Line numbers correspond to fields inserted on the 

template 

a) Select the F1 New or F2 Insert button 

b) Type in field details – the columns are filled in as follows: ' 

i. Report Line Number = can be any number between 1 and 20 
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ii. Tag Number = MARC Tag field number – for example: 245 (Title) 

iii. eg + or blank or and sf in ('a', 'b') =  

iv. blank or and cat_sf in ('a', 'b') = 

 

c) Click the F3 Save button when complete 
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Saved Files 

It is possible to use a Saved File for the Report – for example: the DVD Covers or New Items reports. 

Please Note: If the report lacks an Auth Key set in the F7 Where statement, then the selection of a 

Saved File becomes mandatory. 

1. Go to Main > Reports > RepBibliographic – the Bibliographic Reports screen will display 

2. Highlight the report 

 

3. Click the F8 View button 

4. If there is an Auth Key defined in the F7 Where statement, the following prompt will display: 

This type of report may use a Saved Files as the Source. Do you want to select the file now? 

– click the Yes button 
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5. A list of Saved Files will display: 

 

6. Select the Saved File you would like to use and click the OK button – the report will display in 

the Report – View window: 

 

7. Review the report and if it looks okay, send it to print using the Print icon 
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Customising the Fixed Layout Templates 

It is possible to alter the Fixed Layout report using the RepWin – for example: remove the Descriptors 

fields, format Field2 to be italics etc. The customised report should then be given a new name to 

distinguish it from the original – for example: EBIBFL10.QRP for an Eldorado Library specialized 

Report based on the &BIBFL10.QRP template. 

 

↓ 
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Another alteration could be that the Labels are to be applied to Subjects only: 

 

↓ 

 

HINT: A useful formatting tool in RepWin is to highlight Fields that need to be aligned by pressing the 

Shift Key and clicking on the multiple Fields and the selecting Format > Align Left Sides from the 

menu. 
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Please Note: When loading the customised template via RepAddNew ensure that the Choose Type = 

Fixed layout Reports. 

 

This Report will then be available in RepBibliographic: 
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CIRCULATION REPORTS – ADDING CHARGES USING F10 MORE 

The F10 More button provides extra parameters to allow you to apply charges when running the 

reports. These charges will only apply if the F6 Print button is used and RepStartSchedule is started. 

Please Note: User-defined charge types must be added to the Circulation Transaction Types table – 

see Appendix 1: Add the User-Defined Financial Record and Fees Type Names to the Circulation 

Transactions Types (RepCirculation and RepReservations Only) for more information. 

Create a Report 

1. Launch the Amlib client 

 COLUMN 1 COLUMN 2 COLUMN 3 COLUMN 4 COLUMN 5 

HEADING Report Line 
Number 

Line 1 account 
history NAME 

Line 1 overdue 
history NAME 

Line 1 Financial 
record NAME  

Line 1 Fees type 
name 

EXAMPLE 1 OVFINACC OVDFINAL OVDUEACC OVDUEFEE 

COMMENT Line 1 is used 
for History 
and Financial 
reporting 
purposes 

If left blank, the 
system will put a 
Report Type of 
ACCOUNT in the 
Borrower History 
window if Create 
Hist (Y/N) = Y and 
Create Acc (Y/N) = 
Y and the report 
run via the 
Scheduler. 

It is possible to 
specify your own 
name – see 
example (max: 8 
chars). 

Can use to specify 
1st, 2nd, etc 
overdue – for 
example:  
OVDUE1,OVDUE2 

If left blank, the 
system will put a 
Report Type of 
OVERDUE in the 
Borrower History 
window if Create 
Hist (Y/N) = Y and 
Create Acc (Y/N) = 
N and the report 
run via the 
Scheduler. 

It is possible to 
specify your own 
name – see 
example (max: 8 
chars). 

Can use to specify 
1st, 2nd, etc 
overdue – for 
example:  
OVDUE1,OVDUE2 

If left blank, the 
system will put a 
Financial Type of 
OVERDUE in the 
Borrower Financial 
window indicating 
the (replacement) 
Cost for overdue 
items if Create Acc 
(Y/N) = Y and the 
report run via the 
Scheduler. 

It is possible to 
specify your own 
name – see 
example (max: 8 
chars). 

If left blank, the 
system will put a 
Financial Type of 
FEE in the 
Borrower 
Financial window 
for reports that 
have a 
FORM_CHARGES 
field in the report 
if Create Acc 
(Y/N) = Y and the 
report run via the 
Scheduler. 

It is possible to 
specify your own 
name – see 
example (max: 8 
chars). 

HEADING Report Line 
Number 

Line 2 Fee per 
Item $.c 

Line 2 Fee per 
Notice $.c 

Line 2 Fee Print 
Line 

Line 2 not Used 

EXAMPLE 2 2.00 5.00 Includes fees of: <Leave blank> 

COMMENT Line 2 is used 
to add Fees 
to Reports 

Enter amount to 
be charged for 
each overdue item 
[Optional] 

Amount will be 
added to the 
FORM_ 
CHARGES field in 
the Report 

Enter amount to 
be charged per 
notice (in addition 
to any item fee) 
[Optional] 

Amount will be 
added to the 
FORM_ 
CHARGES field in 
the Report 

Text will be added 
to the USER_LINE1 
field in the Report 
[Optional] 
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2. Go to Main > Reports > RepCirculation – the Circulation Reports screen will display: 

 

3. Ensure the Create Acct (Y/N) column = Y 

4. Highlight the report to which you wish to add charges – for example: Overdue Letter (with Fee) 

5. Click on the F10 More button – the More screen will display: 

 

6. Click the F1 New or F2 Insert button 

7. Click the F10 More button – the More screen will open 

8. Click the F1 New or F2 Insert button  

9. Enter the following parameters – for example: 

 Report Line Number = 1 

 Line 1 account history NAME = OVFINACC 

 Line 1 Financial record NAME = OVDUEACC 

 Line 1 Fees type name = OVDUEFEE 
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It is also possible to apply charges at this stage on a per item/notice basis: 

10. Click the F1 New or F2 Insert button  

11. Enter the following parameters – for example: 

 Report Line Number = 2 

 Line 2 Fee per Item = 2.00 

 Line 2 Fee per Notice = 5.00 

 Line 2 Fee Print Line = Includes fees of: 

12.  Click the F3 Save button when complete 

 

The above parameters will charge an overdue fee of $2.00 per item + a $5.00 per notice (admin) fee. 

Customising the Template to Include Charges 

Please Note: The report template must be altered to include the following fields: FORM_CHARGES 

and USER_LINE1. 

 The new &ODFEE.QRP template includes FORM_CHARGES and USER_LINE1. 

 

The FORM_CHARGES field can be added to the total charge [Field = FORM_CHARGES] or included as 

part of a TotalCst. You can also include the field USER_LINE1 which will include the text you entered 

in the F10 More statement. 

 

Borrower Record 
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After running the report with F6 Print and RepStartSchedule, a financial record will be written to the 

Borrower Financial Transactions screen using the parameters set up in F10 More: 

 

If the report also has Create Hist (Y/N) = Y then a history record will also be written t o the Borrower 

History screen using the parameters set up in F10 More:  
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E-MAIL REPORTS 

Several Reports can now be used via Email. See some examples at the end of this document. 

Email Templates 

Borrower Reports (RepBorrower) 

 Send letter via Email: &N1ADDEM.QRP 

 Send interest lists via Email: &BORINT.QRP 

Circulation Reports (RepCirculation) 

 Send reminders via Email: &ODEMAIL.QRP 

ILLs Reports (RepILLS) 

 ILL Email Reminder: &ILLEREM.QRP 

 ILL Email Reminder – All Suppliers: &ILLERMS.QRP 

 ILL Email Request: &ILLEREQ.QRP 

 ILL Email Request – All Suppliers: &ILLERQS.QRP 

Orders Reports (RepOrders) 

 Email Order GST: &OREGST.QRP 

 Email Order including Tax: &OSEMAIL.QRP 

 Order Status Notice via Email: &ORSIE.QRP 

 Order Returns Notice via Email: &ORSIER.QRP 

 Cancellation Notice via Email: &ORSIECL.QRP 

 Claims Notice via Email: &ORSIECL.QRP 

Periodical Reports (RepPeriodicals) 

 Claims Notice via Email: &PICLE.QRP 

Reservation & Bookings Reports (RepReservation) 

 Email notification of Reserve: &RESEML.QRP 

 Email notification of Booking: &BKGEML.QRP 
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Setting Up 

Supervisor Parameters 

To begin, some settings need to be set in the Supervisor module (this need only be done once): 

1. Launch the Amlib client 

2. Go to Main > Supervisor > Installation – the Installation (DEFAULT)screen will display 

3. Select the Other tab 

4. Scroll down set the following: E-mails are sent using the following method:  (M)API or 

(I)nternal or (S)MTP. Set to S, I or M 

 

Generally (S) SMTP is recommended, especially as it is simple and it has advantages over the 

others. It also means that the email client does not need to be open on the PC running the 

notices and allows greater flexibility with regard to setting up “from” and BCC/CC 

parameters. 

 

Then the following parameters should also be set (a full table is included below): 

 SMTP Blind Carbon Copy e-mail address: you can specify the BCC address to send a copy of 

all notices (so that you can verify that they have been sent) 

 SMTP sender e-mail address: the email address to display on the notice sent to the borrower 

(For example: library@oclc.org,  it can be the same as the BCC address) 

 SMTP Server name: the address of the SMTP mail server being used. This might be a server 

address or an IP address 

 

 

5. Click the F3 Save button when complete 

mailto:library@oclc.org
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6. Exit and restart the Amlib client to allow the settings to take effect 

The complete set of parameters to consider: 

Description Explanation Example 

Emails are sent using the 
following methods (M)API, 
(I)nternal or SMTP 

Generally (S) SMTP is recommended, 

especially if the organisation is not using a 

Microsoft Exchange Server. It also means 

that the email client does not need to be 

open on the PC running the notices AND can 

display the “from” name from one of the 

parameters below rather than the email 

address from the email client. 

Set to S, I or M 

SMTP Blind Copy e-mail 
address 

Optional: If using the SMTP for emails. Enter 

only if copies of the email are to sent to a 

chosen email address – for example: Testing 

purposes 

library@amlib.com 

SMTP sender e-mail 
address 

Optional: If using the SMTP for emails, enter 

the Address you wish to indicate as the 

sender 

enquiries@amlib.com.au 

SMTP server login Optional: From your Systems Administrator 

if required 

 

SMTP Server name or IP 
address 

If using the SMTP for emails, enter the 

Server Name or IP Address of the Server 

installed with the e-mail communication 

protocol, responsible for receiving and 

forwarding email messages 

ServerName – for 

example: 

 server.amlib.com.au 

SMTP server password Optional: From your systems administrator if 

required 

 

SMTP server requires a 
login? 

If Y, supply a SMTP server logon and 

password 

If N, leave SMTP server logon and password 

blank 

Y/N 
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The above tasks create Sender and BCC for ALL emails generated by the system.  However, it is 

possible to set up separate SMTP parameters (Sender and CC) for individual locations, modules and 

reports. 

Setup Individual Email Systems by Location 

1. In any Installation screen module, select Installation > Choose Location and choose a 

Location 

2. Repeats steps 2-5 above.  If you would like to use the DEFAULT settings, then the relevant 

fields for each location should be left blank 

3. Once complete, you must exit and restart the Amlib client to allow the settings to take effect 

Setup Individual Email Locations, Modules and Reports 

We recommend leaving the email set-up for particular locations until after initial testing has been 

completed. Once the initial testing has been done, then: 

1. In any Supervisor module, select Library Menu > LocRepSMTP – the SMTP Parameters by 

Location table will display 

2. Select the F1 New or F2 Insert button 

3. Using the drop-down boxes available in each column, select the Location, Report Screen, and 

Report Type 

4. Then type in the individual Sender’s Email and Carbon Copy Email addresses 

5. Click the F3 Save button when complete 

6. Exit and restart the Amlib client to allow the settings to take effect 

 

Please Note: It is not possible to alter a pre-existing entry in the SMTP Parameters by Location table 

– entries must be deleted (using F4 Delete) and then re-entered. 
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Borrower Settings 

For borrowers to receive their overdue notices via email, the borrower record will need to have the 

following: 

 

 Email address – for example:sarah-jane.smith@oclc.org 

 Use for Notices = Y (for Yes) 
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Customising the Report 

Edit the Template 

The email report templates can be customised using Report Writer (RepWin30.exe) – a copy of which 

can be found in the Amlib/Utility folder on your Amlib server (see separate installation instructions). 

It is also possible for Amlib Support staff to modify an existing report if necessary.  

Start off with an existing System Report (for example: &ODEMAIL.QRP) and adjust the wording as 

required – see separate Editing Text in Reports procedure. Be sure to save this customised report 

with a new name (without the & at the front). 

 Please Note: Do not add logos and keep the layout simple for emails. 

 

Save the Template 

 Save the template into the Amlib/Reports folder on the Amlib server.  This will make the 

template available for use to all users. Alternatively, you may save it into a local folder on 

your PC – but please be aware, that the template (once loaded) will only be available for use 

on that PC.  

 Ensure that the template is saved with a name that clearly identifies it as a customised email 

template– for example: BRODEMAIL.QRP 

 

 

 



Reports Training- Advanced Reports 

 

 

Last Updated: 26 February 2013 
 Page 57 

Load the Template 

1. Go to Main > Reports > RepAddNew – the Report Files window will display 

2. From the Report Entity drop-down, select the Report Screen (module) you would like to load 

a template for – for example:  Circulation 

3. Click the F1 New button – the New Report File… screen will display 

4. Type in a Description – for example: Overdue Notice (Email) 

5. Browse to the Amlib/Reports folder on your Amlib Server and locate the template to be 

loaded (if the template has been loaded onto your PC – then navigate to the local folder) 

6. Click on the Open button 

7. Choose Type – ensure you select the relevant email type – for example: Continuous - E-mail 

8. You can leave Default Stats Code blank 

9. Update History (Y/N) = Y 

10. Update Entity (Y/N) = N 

11. Click the F3 Update button 

12. Close out of the Report Files screen 

The template is now loaded and available for use in a Report. 
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Creating the Report 

1. Go to a Reports screen – for example: Main > Reports > RepCirculation 

2. Click the F1 New button – the Select Report Format screen will display: 

 

3. Highlight an email template (for example:  Overdue Notice (Email) using the &ODEMAIL.QRP 

print template) and click the Select button 

4. Type in a Report Description – for example: Overdue Notices by Email 

5. If you would like the borrower record to retain a record of any notice sent, then ensure that 

Create Hist (Y/N) = Y 

6. If there are replacement costs involved, ensure that the Create Acct (Y/N) = Y 

7. Click the F3 Save button 

 

Where Statement 

1. Select the report from the list and click on the F7 Where button 

2. The statement must include the following settings: 

 Bor Email Address IS NOT NULL (Paste without placing a value in 3) 

 Bor Use Email = Y 

 Additional parameters can then be added 

3. Click the F3 Save button 
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Order 

1. Select the report from the list and click on the F9 Order button 

2. Use the arrow keys to select fields to Order By – for example: Borrower Bar No 

3. Click the F3 Save button when complete 
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Printing the Emails 

Using the Scheduler has two benefits over running reports via F8 View: It allows you to schedule 

regularly run reports so that staff do not have to do it manually each time, and it allows for further 

functions as part of the report such as updating Borrower/Stockitem history, creating financial 

accounts, changing records in the database and adding report information to your statistics. Email 

reports MUST be run via the Scheduler. 

This section will take you through setting up a report to use RepStartSchedule. 

Start the Scheduler 

1. From the Report screen (Main > Reports > RepCirculation or RepReservation), select 

Application > RepStartSchedule 

 

2. The Report Scheduler screen will display: 

 

3. Select your printing options: Ensure Email is ticked 

4. Also decide If a report is scheduled by another user do you still want to print it? = Yes/No 

5. Then click the OK button 

6. After selecting “OK”, if you go back into the Application menu you will see that 

RepStartSchedule is now greyed out with a tick next to it – this indicates that the Scheduler is 

now running 
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Please Note: If you need to restart the scheduler at any point, you will need to log out of all Report 

screens (Ctrl + L) and start at the beginning of these instructions. 

Scheduling the Report 

1. With your report highlighted, click the F6 Print button – the Print box will display: 

 

2. Select from the following options: 

a. From: 

 Database (to search the entire database) 

b. To: 

 E-mail (to email it to patrons – this option will only display if the report has 
been created from an appropriately loaded template) 

c. Frequency: 

 Once Only (if this is the only time you’re going to print this report) 

 Daily (if you plan to send it every day) 

 Weekly (if this is a once a week item) 

 Monthly (if this is to be printed every calendar month) 
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 Every ___ days (if you want to set a specific schedule 

d. Schedule: 

 First Print Date (the day you want this report to begin its schedule) 

 First Print Time (specifies the exact minutes the report will run) 

e. Selected Printer: 

 You can specify any active printer on the network to print to – including 
virtual printer drivers such as a third party software that allows you to print 
to PDF (For example: CutePDF Writer) 

3. Once you have selected all of your settings, click the OK button 

Check Print Progress 

1. You can check the progress of your reports at any time by going into Main > Reports > 
RepPrintProgress – the Print Progress screen will display: 

 

2. If your library uses the scheduler for a lot of reports, you can select a frequency type from 
the Filter drop down menu at the top: 

 

3. You can also click through the three tab options at the top to see the ones that are Waiting, 
Running, or have already been Printed: 

 

4. Your report will show up in the Printed tab when it is complete: 
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Email Address Validation Rules 

When email reports are being sent a certain amount of validation is going on. Email addresses are 
rejected if illegal characters are found.  

If the email address is invalid and if the barcode of the patron can be found by the process, the 
Borrower ID is written to a saved Borrower File, which can be checked later. 

If the barcode of the patron cannot be found, no file can be created but an error message is written 
to the amdberror.log in the Amlib folder. 

If the SMTP protocol is being used then any errors encountered will be logged. Neither MAPI nor the 
internal method support error reporting in an accessible way. 

1. Must be at least 5 characters long. Shortest theoretical address is a@b.c 

2. Must contain an “@” 

3. Must have one or more characters before the “@” 

4. Must contain a “.” 

5. No more than 4 characters after the last “.”  

6. No “_” after the “@” 

7. Only one “@” 

8. No invalid chars – the following ranges are invalid: 

 Less than ASCII 48 (except 45 and 46) 

 ASCII 57 to 65 (except 64) 

 ASCII 90 to ASCII 97 (except 95) 

 ASCII > 122 

Please Note: 45 = "-", 46 = ".", 64 = "@" and 95 = "_" 

The formatting of the email is checked against these rules, but the address may it still be invalid. 

Troubleshooting 

Some users may experience some initial problems with SMTP emails not being sent.  This can be the 
result of your anti-virus agent blocking programs that relay (mass) email or your mail server blocking 
relay (mass) emails.   

 There is now a complete Setting-Up Email and Troubleshooting Guide 

Examples 

mailto:a@b.c
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Borrower Subject interests report via email (&BORINEM.QRP) 

Emails the items included for the Interests set in Borrower > XReferences > Subject Interests. The 
Borrower email address and Use for Email details need to be entered in the Borrower window. 
Where parameters can include a Borrower Type (for example: T for Teachers) and Received Date (for 
example: > Current Date – 1 month) 

 

Letters (&1NADDEM.QRP) 

It is possible to change the text of the letter and send it out to selected borrowers. It could be useful 

for advertising promotions, notifying staff, welcoming letter, confirming opening times etc. 

1. To change the text of the letter click on the Text for Letter button 

2. A dialogue box will display where the text of the note or letter can be typed 

3. Select the F3 Save button when complete 

 Note: The F5 Query button can be selected to return the screen to the display at the last 

save. Therefore any changes made after the last save will not be retained. 

The template for this email report has to be set to use the Type of Name & Address x 1 across Email. 
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Inter-Library Loans 

It is possible to email inter-library loan reminders via email. The External Libraries table (select 
Application > StockExternalLibs) in the Stockitems module would need to be updated with the email 
addresses. 

 

Email Order with GST defined (&OSEGST.QRP) 

A number of reports may be produced regarding order status. Email of Orders is now possible. 

 

Email Reservations 

 File Name = &RESEML.QRP 

 Report Entity = Reservations 

 Report Type = - Email 

 Update Entity (Y/N) = Y 

Reservation statuses assist in Reports. When an item with reservations on it is returned, the 

reservation for the first item in the queue changes to a status of RETURN.  

Reservation reports can be run with the Update column set to Y, which when used in relation with 

the F6 Print button updates the status to PRINTED. 

 This ensures that the next batch of Reservation reports are only sent to those people where the item 

is newly RETURNed. For those items that are on the Shelf when reserved, it would be wise to use the 

RESGET memos (set in Supervisor > Locations > Borrower Barcode for Memos) to alert staff to get 
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them the reserved items from the Shelves and wand them through Returns. Alternatively, a pick list 

may also be run in the Reservations report screen. 

 

Damaged Item Notice (&STKMRR.QRP) and E-mail (&STKMRRE.QRP) 

These most recent return reports are for sites who return items from the Borrower's records when 

they are damaged but still want to bill people for the costs of the damaged item. It will display the 

LAST borrower who had the item. If a site does not return the item when it is damaged (and keeps 

the item on loan), then Circulation reports can still be used.  
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RUNNING REPORTS WITH E-MAIL ATTACHMENTS 

Reports with the option to send attachments via e-mail will have the Manage Email Attachments 

button enabled (button text is black). 

 

E-mail attachment parameters must first be set up in Supervisor settings.  Once the correct template 

is selected, attachments such as MS Word documents can be sent with the e-mail messages. 

Supervisor Settings 

1. Launch the Amlib client 

2. Go to Main > Supervisor > Installation – the Installation (DEFAULT) screen will display 

3. Select the Other tab 

4. Scroll down and enter the E-mail Attachment Path = file path to your e-mail attachments. ALL 
e-mail attachment files must be saved to this location. 

5. Enter the E-mail Maximum Attachment Size = maximum size of attachments in Kb (1Mb = 
1024 Kb).  

6. Select the F3 Save button 
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7. Make sure to copy these settings to your other locations – select Installation > Advanced 

Copy – the Advanced Parameter Copy screen will display: 

 

8. Select the following options: 

a. Tick the E-mail Attachment Path and E-mail Maximum Attachment Size (kb) 

parameters 

b. Tick all the locations in the Destination Location(s) box 

9. Select F6 Copy 

10. Exit the Amlib client (Ctrl-E or Ctrl-X) and restart to ensure these settings are propagated to 

the rest of the system 
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Create the Report 

1. Create the report – for example &N1ADDEM.QRP (see separate individual procedures for 

more information about creating email reports) 

 

Adding the Attachment 

1. Highlight the report to which you would like to add an attachment 

2. Select the Manage Email Attachments button – the Manage Email Attachments screen will 

display (the attachment path set in the Supervisor settings will be visible in the Attachment 

Path field): 

 

3. Click the F1 New button – the Select a File to Attach screen will display 

4. Browse to the location of the attachment folder 

5. Select the file and click the Open button 
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6. The document will appear in the File Name box (with an arrow next to it): 

 

7. Select the F3 Save button (the arrow will disappear once saved) 

 

8. To add further attachments, repeat 3 – 7 above 

Please Note: The size restriction set previously in Main > Supervisor > Installation refers to the 
maximum size allowed for an attachment or the total size of ALL the attachments (if there are 
multiple attachments). 

9. To delete attachments: highlight the attachment you wish to delete and click the F4 Delete 
button 

  

10. Once the list of attachments is complete, ensure that you click the F3 Save button to save 
your changes – close out of the screen by clicking the red cross in the corner 
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Email Text 

If you would like some specified text to appear in the body of the e-mail you are sending, you can 

enter this in the Text for Letter area.  

1. Highlight the report you are using, and select the Text for Letter button 

 

2. The Letter Text dialogue box will display: 

 

3. Type (or copy and paste) in your text 

4. Select the F3 Save button when complete – then close out of the screen by clicking on the 

red cross 
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Please Note: When sent, your chosen text will appear in the body of the message: 
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 Start the Scheduler 

1. From the menu, select Application > RepStartSchedule – the Report Scheduler screen will 

display 

2. Ensure that the E-mail box is ticked 

 

3. Click on the OK button 

Schedule the Report 

1. Highlight the report you are using and select the F6 Print button – the Print screen will 

display: 

 

2. Check/Change any Print settings 

3. Click on the OK button 

4. Check progress in Application > RepPrintProgress 

SMS RESERVATIONS & OVERDUES NOTICES 
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Amlib utilizes the Reports module to produce exported text files for Reservation and Overdue 

notifications. 

The SMS mobile phone messaging system works on a ‘campaign’ basis, where a text file is exported 

from Amlib. The file is then sent and imported to the SMS-messaging service supplied by a third party 

(Talking Technologies, Telstra, etc.). The information in the export file from Amlib is used for the 

content of the SMS message.  

The field format requirements of the templates being used will differ between SMS messaging 

providers – generally the file is required to be in .TXT format.  

Amlib employs two SMS messaging templates (which may need to be customised fit the 

specifications of a particular provider): 

 &RESSMS.QRP  Reservations Module 

 &ODSMS.QRP  Circulation Module 

The report templates can be used to print a report in .TXT format using the Amlib Report Scheduler. 

The .TXT file may saved in a local directory (for example: C:\SMS Messaging) or a network directory 

(for example: Q:\Library\SMS Messaging). 

File Transfer Methods 

The most effective way to share files between the two systems is to set up a Windows File Share.  

A user account with appropriate permissions to read, write and delete the transfer files will need to 

set-up; this account will be accessed by both systems.  

See: http://compnetworking.about.com/od/windowsfilesharing/Windows_File_Sharing.htm for 

further details. 

If this is not possible; the .TXT file may be emailed to the SMS messaging provider (see final section). 

http://compnetworking.about.com/od/windowsfilesharing/Windows_File_Sharing.htm
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SMS Templates 

Both overdues and reservation SMS messaging employ the use of a dedicated template.  In some 

circumstances, it may be necessary to edit these templates to adjust the content and sequencing of 

the fields in use to suit the specifications of the SMS messaging provider. 

The templates can be found in the Amlib/Reports folder located on your Amlib server, and can be 

modified using RepWin30.exe (located in the Amlib/Utility/Repwin folder on your Amlib server). 

The simplest method for editing these templates, is to copy them into the Amlib/Utility/Repwin 

folder and then drag-and-drop the template to be edited on the RepWin30.exe program file – this 

will cause the template to automatically open in the editor. 

1. Highlight the fields in the Detail Block and click on the Editor button to reconfigure the 

content and sequencing – being careful not to remove the delimination (usually “,”) 

necessary for creating the required .TXT files. 

Reservations: &RESSMS.QRP 

 

Overdues: &ODSMS.QRP 

 

 

The Editor button may be 

used to modify the content 

configuration. 
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SMS Reservations 

The template may be saved in Amlib/Reports folder on your Amlib server or on a local drive.  

Load the Template 

1. Launch the Amlib client 

2. Go to Main > Reports > RepAddNew – the Report Files window will display 

3. Select Reservation from the Report Entity dropdown 

4. Click the F1 New button – the New Report File… screen will display 

5. Description = Reservation Notices (SMS) 

6. Browse to the Amlib/Reports folder on your Amlib Server and select the &RESSMS.QRP file 

(if the template has been loaded onto your PC – then navigate to the local folder) 

7. Click the Open button 

8. Choose Type = Unlimited Reservation Format 

9. Update History = Y 

10. Update Entity = Y 

11.  Click the F3 Update button 

12. Close out of the Report Files window 

The template is now loaded and available for use in a Report. 
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Create the Report 

1. Go to Main > Reports > RepReservation – the Reservation Reports screen will display 

2. Click the F1 New button – the Select Report Format screen will display 

3. Highlight Reservation Notices (SMS) and click the Select button 

4. Type in a Description – for example: SMS Reservations Notices 

5. Click the F3 Save Button 

 

Create/Modify the Where Statement 

The ‘Where Statement’ for this report should be based on the normal reservation notification report. 

However, with this report an additional line should be added to the ‘Where’ to ensure that it only 

selects the borrowers who have nominated to receive notification via SMS. Generally, borrowers 

without a mobile phone number should be collected in a separate reservations print run that 

produces paper notices. 

1. Highlight the SMS Reservation Notice and click the F7 Where button – the Reservation 

Reports – Where screen will open 

2. Create the following Where conditions: 

o Only Show First in Queue (Y/N) = Y (otherwise ALL reserves on an item will show) 

o Res Item Status = RETURN – this status will change to PRINTED once this report is 

run, to prevent duplicate emails being sent. 

o Bor Mobile/Cell Number IS NOT NULL (Paste without placing a value in 3) 

o Bor use Mobile/Cell (Y/N) = Y 

o (Optional) Res Collect Location = Temp Loc [select using the Special button] – this 

ensures that the item is at the collection location) 

o (Optional) Res Collect Location =  (enter your location code – for example: CHELSEA) 

– this will limit the notices sent to items for collection at the selected location 
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3. Click the F3 Save button when complete 

 

SMS Overdues 

The template may be saved in Amlib/Reports folder on your Amlib server or on a local drive.  

Load the Template 

1. Launch the Amlib client 

2. Go to Main > Reports > RepAddNew – the Report Files window will display 

3. Select Circulation from the Report Entity dropdown 

4. Click the F1 New button – the New Report File… screen will display: 

 

5. Type in a Description – for example: Overdue Notice (SMS) 
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6. Browse to the Amlib/Reports folder on your Amlib Server and select the &ODSMS.QRP file 

(if the template has been loaded onto your PC – then navigate to the local folder) 

7. Click the Open button 

8. Choose Type = Continuous – Full descriptions 

9. Update History = Y 

10. Update Entity = N 

11. Click the F3 Update button 

12. Close out of the Report Files window 

The template is now loaded and available for use in a Report. 

Create the Report 

1. Go to Main > Reports > RepCirculation – the Circulation Reports screen will display 

2. Click the F1 New button – the Select Report Format screen will display: 

 

3. Type in a Description – for example: SMS First Overdue Notice 

4. Click the F3 Save button 
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Create/Modify the Where Statement 

The ‘Where Statement’ for this report should be based on the normal reservation notification report. 

However, with this report an additional line should be added to the ‘Where’ to ensure that it only 

selects the borrowers who have nominated to receive notification via SMS. Generally, borrowers 

without a mobile phone number should be collected in a separate reservations print run that 

produces paper notices. 

1. Highlight the SMS Overdue Notice and click the F7 Where button – the Circulation Reports – 

Where screen will display: 

 

2. Create the following Where conditions: 

o Issue Date Due Back <= Current Date [alter as required] 

o Bor use Mobile/Cell = Y 

o Bor Mobile/Cell Number IS NOT NULL (Paste without placing a value in 3) 

o Bor Location = <specify location code> [optional] 

3. Click F3 Save button 
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Running the SMS Reports File (Reservations/Overdues): File Sharing 

If using the Windows File Sharing method to supply the required .TXT file to your SMS-messaging 

service, then the report will need to be scheduled to run to save the file to the specified directory. 

Reports can be scheduled to run once Daily, several times Daily, or several times Weekly. 

Scheduling the Report   

1. Go to Main > Reports > RepReservation or RepCirculation – the Reservation or Circulation 

Reports screen will display: 

 

2. Select the SMS Reservations Notice or SMS Overdues Notice report 

3. Click the F6 Print button – the Print screen will display: 

 

4. Set the conditions as follows: 
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o From = Database 

o To = File 

o Frequency = Daily or Weekly (if the report is to be run only on certain days a week, 

select Weekly and nominate the day via the First Print Date) 

o First Print Date = <set date for first scheduled occurrence – for example: 30/08/2010> 

o First Print Time = <set time for first scheduled occurrence – for example: 8:30 AM> 

o Overwrite Saved Files = ticked [the same file is then used to generate the notices] 

o Click the OK button when complete 

5. Save the file in .TXT format (Save as type: Text Document) in the drive location to be used 

for file transfers (usually Windows File Sharing) – for example: C:\SMS Message, using the 

following file name: SMS_res_notice or SMS_over-notice 

 

6. If you would like to print a report several times Daily or Weekly, repeat steps 3 – 5 with 

altered First Print Dates and Times) 

7. Check Application > RepPrintProgress to ensure all reports are scheduled correctly (see 

example of screen below) 
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Start the Scheduler 

1. Go to Main > Reports > RepReservation or RepCirculation – the Reservation or Circulation 

Reports screen will display 

2. From the menu, select Application > RepStartSchedule – the Report Scheduler screen will 

display: 

 

3. You must check both the Save to File and E- mail options 

4. Click on the OK button 

5. When the scheduled report run is complete the following text file will be available to be 

transferred to the SMS-Messaging provider for further processing 

Please Note: Please ensure that the Scheduler is started PRIOR to the printing time – otherwise the 

report WILL NOT PRINT! 
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Running the SMS Reports File (Reservations/Overdues): Emailing 

If you are required to supply the SMS-messaging service with your SMS report via email, the email 

can be sent from directly within the system as an attachment. 

The process is similar to that in the previous section, however, the email specifications for the SMS-

messaging service must also be provided. 

Supervisor Parameters 

To begin, some settings need to be set in the Supervisor module (this need only be done once): 

1. Launch the Amlib client 

2. Go to Main > Supervisor > Installation – the Installation (DEFAULT)screen will display 

3. Select the Other tab 

4. Scroll down set the following: E-mails are sent using the following method:  (M)API or 

(I)nternal or (S)MTP. Set to S, I or M 

 

Generally (S) SMTP is recommended, especially as it is simple and it has advantages over the 

others. It also means that the email client does not need to be open on the PC running the 

notices and allows greater flexibility with regard to setting up “from” and BCC/CC 

parameters. 

 

Then the following parameters should also be set (a full table is included below): 

 SMTP Blind Carbon Copy e-mail address: you can specify the BCC address to send a copy of 

all notices (so that you can verify that they have been sent) 

 SMTP sender e-mail address: the email address to display on the notice sent to the borrower 

(For example: library@oclc.org,  it can be the same as the BCC address) 

 SMTP Server name: the address of the SMTP mail server being used. This might be a server 

address or an IP address 

mailto:library@oclc.org
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5. Click the F3 Save button when complete 

6. Exit and restart the Amlib client to allow the settings to take effect 

The complete set of parameters to consider: 

Description Explanation Example 

Emails are sent using the 
following methods (M)API, 
(I)nternal or SMTP 

Generally (S) SMTP is recommended, especially 

if the organisation is not using a Microsoft 

Exchange Server. It also means that the email 

client does not need to be open on the PC 

running the notices AND can display the 

“from” name from one of the parameters 

below rather than the email address from the 

email client. 

Set to S, I or M 

SMTP Blind Copy e-mail 
address 

Optional: If using the SMTP for emails. Enter 

only if copies of the email are to sent to a 

chosen email address – for example: Testing 

purposes 

library@amlib.com 

SMTP sender e-mail 
address 

Optional: If using the SMTP for emails, enter the 

Address you wish to indicate as the sender 

enquiries@amlib.com.au 

SMTP server login Optional: From your Systems Administrator if 

required 

 

SMTP Server name or IP 
address 

If using the SMTP for emails, enter the Server 

Name or IP Address of the Server installed 

with the e-mail communication protocol, 

responsible for receiving and forwarding email 

messages 

ServerName – for 

example: 

 server.amlib.com.au 

SMTP server password Optional: From your systems administrator if 

required 

 

SMTP server requires a 
login? 

If Y, supply a SMTP server logon and password 

If N, leave SMTP server logon and password 

blank 

Y/N 

The above tasks create Sender and BCC for ALL emails generated by the system.  However, it is 

possible to set up separate SMTP parameters (Sender and CC) for individual locations, modules and 

reports. 
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Setup Individual Email Systems by Location 

1. In any Installation screen module, select Installation > Choose Location and choose a 

Location 

2. Repeats steps 2-5 above.  If you would like to use the DEFAULT settings, then the relevant 

fields for each location should be left blank 

3. Once complete, you must exit and restart the Amlib client to allow the settings to take effect 

Setup Individual Email Locations, Modules and Reports 

We recommend leaving the email set-up for particular locations until after initial testing has been 

completed. Once the initial testing has been done, then: 

1. In any Supervisor module, select Library Menu > LocRepSMTP – the SMTP Parameters by 

Location table will display 

2. Select the F1 New or F2 Insert button 

3. Using the drop-down boxes available in each column, select the Location, Report Screen, and 

Report Type 

4. Then type in the individual Sender’s Email and Carbon Copy Email addresses 

5. Click the F3 Save button when complete 

6. Exit and restart the Amlib client to allow the settings to take effect 

 

Please Note: It is not possible to alter a pre-existing entry in the SMTP Parameters by Location table 

– entries must be deleted (using F4 Delete) and then re-entered. 
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Set Up SMS-Messaging Service Parameters 

1. Go to Main > Reports > RepReservation or RepCirculation – the Reservation or Circulation 

Reports screen will display 

2. Select the SMS Reservations Notice or SMS Overdues Notice 

3. Click the F10 More button – the More screen will open 

4. Click the F1 New button  

5. Enter the following parameters: 

COLUMN HEADER COMMENT 

1 Report Line Number Always 3 

2 SMS Always SMS 

3 SMS Message Message body – becomes the message in the email (50 
chars) 

4 Email Address The email address of the SMS-messaging service (50 chars) 

5 Delete File  After Sending - Y or N 

Note: Since Lines 1 and 2 are already used for other reporting purposes, the email function uses Line 3. 

 

6. Click the F3 Save button when complete 

 

7. Highlight the report and click on the F6 Print button – the Print screen will display: 
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8. Set the conditions as follows: 

o From = Database 

o To = File 

o Frequency = Daily or Weekly (if the report is to be run only on certain days a week, 

select Weekly and nominate the day via the First Print Date) 

o First Print Date = <set date for first scheduled occurrence – for example: 30/08/2010> 

o First Print Time = <set time for first scheduled occurrence – for example: 8:30 AM> 

o Overwrite Saved Files = ticked [the same file is then used to generate the notices] 

o Click the OK button 

9. Save as type: Text Document to a specified drive location – for example: C:\SMS Message, 
using the following file name: SMS_res_notice or SMS_rver-notice. (A copy of the file will be 
saved here, unless the Column 5 was set to Delete the File at Step 5 above. 

 

10. If you would like to print a report several times Daily or Weekly, repeat steps 3 – 5 with 
altered First Print Dates and Times) 

11. Check Application > RepPrintProgress to ensure all reports are scheduled correctly (see 
example of screen below) 
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Start the Scheduler 

1. Go to Main > Reports > RepReservation or RepCirculation – the Reservation or Circulation 
Reports screen will display 

2. From the menu, select Application > RepStartSchedule – the Report Scheduler screen will 
display: 

 

3. You must check both the Save to File and E- mail options 

4. Click on the OK button 

5. When the scheduled report run is complete the following text file will be available to be 
transferred to the SMS-Messaging provider for further processing 

Please Note: Please ensure that the Scheduler is started PRIOR to the printing time – otherwise the 
report WILL NOT PRINT! 

 

AUDITS AND AUDIT REPORTS 

The audit reports list stockitems/authorities/borrowers that have been deleted, inserted (added) or 

updated (modified/changed) within a specified time period. 
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In addition to the audits, there are a number of Statistics Reports Audits that look at Operator logons 

and alterations, as well as searches performed in each module. 

Supervisor Settings: Setting Up Audits 

The Audit must be switched on first, before the data can be collected. To check this: 

1. Launch the Amlib client 

2. Go to Main > Supervisor > Installation > Other tab 

3. There are several types of audit: 

 Create an audit for all Authorities (Y/N) 

 Create an audit for all Borrowers (Y/N) 

 Create an audit for all issues prompted with messages (Y/N) 

 Create an audit for all Stockitems (Y/N) 

4. If you would like to keep audit details, ensure that these are set to Y (particularly the last) 

5. Make sure you also check your settings by individual Location: 

a. Select Installation > Choose Location 

b. Select location and click on the OK button 

c. Select the Other tab 

Please Note: Any record/s that were deleted, inserted or updated prior to the audit being switched 

on will not be recorded. 
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Issues Audit 

Issues Audit records all messages that are displayed in issues. If you do not use this particular 

function, make sure the audit is switched off (see Supervisor Settings above): 

 Create an audit for all issues prompted with messages (Y/N) = N 

As the logs fill up quickly and must be regularly maintained (old entries deleted daily or weekly). 

To access the Issues Audit: 

1. Open the Supervisor module 

2. Select LibraryMenu > IssuesAudit – the Issue Audit table will display 

3. Select the F6 Print button to print up the list 

 

To delete entries from the table: 

1. Open the Supervisor module 

2. Select LibraryMenu > IssuesAudit – the Issue Audit table will display 

3. Highlight the entries in the list to be deleted 

4. Click the F4 Delete button – this will mark the entries for deletion 

5. Click the F3 Update button to delete the marked entries 
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Load the Template 

Some audit report templates may need to be loaded before they can then be used in a report.  You 

can also use this method to double-check the Choose Type of an already loaded template. 

1. Go to Main > Reports > RepAddNew – the Report Files window will display 

2. Select the appropriate Report Entity: either Authority, Borrower, Statistics or Stockitem – in 

the example below: Report Entity = Stockitem 

3. Click the F1 New button – the New Report File pane will open 

4. Type in a Description – for example: Audit Full Details 

5. Click on the Browse button to view the Amlib/Reports folder on your Amlib Server and 

locate the template to be loaded – be sure to change the Files of type: drop-down to System 

Report Templates (*.qrp) 

6. Select the template to be loaded and click on the Open button 

7. Change the Choose Type to select an Audit type: 

a. Authority: Authority Audits 

b. Borrower: Audit Report 

c. Stockitem: Item Audit 

d. Statistics: Access Audit, Logon Audit or Search Audit 

8. You can leave Default Stats Code blank 

9. Update Entity (Y/N) = N 

10. Click on the F3 Update button 

11. Close out of the Report Files window 

The template is now loaded and available for use in a Report. 
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Authority Audit Reports 

 Reports can be set up in Main > Reports > RepAuthority 

There is only one type of audit report available: 

1. Audit report: &AUTHAUD.QRP 

1. Go to Main > Reports > RepAuthority – the Authority Reports screen will display 

2. Click the F1 New button – the Select Report Format screen will display 

3. Highlight the &AUTHAUD.QRP template and click the Select button 

 

4. Type a Report Description – for example: Audit New Authorities 

5. Click the F3 Save button 

 

6. Highlight the Audit report and click the F7 Where button – the Authority Reports – Where 

screen will display 

7. Enter your Where parameters – there are three audit types:  
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2. D: Deleted 

3. I: Inserted 

4. U: Updated 

The Where parameters will depend on what you are after.  Typically you would set the Date 

and Audit Type (I/U/D).  You may also include tag numbers or span of numbers (for example: 

> 600 AND < 700). 

 

8. Click the F3 Save button when complete 

9.  (Optional) Click the F9 Order button – you can then set the order for the report to print in. 

You can sort by Date and Tag (or vice versa if you’re looking for a particular tag).  Click the F3 

Save button when complete. 
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10. Click the F8 View button to view the report 

11. Select the print icon to print the report 

 

Borrower Audit Reports 

 Reports can be set up in Main > Reports > RepBorrower 

There is only one type of audit report available: 

5. Audit: &BORRAUD.QRP 

1. Go to Main > Reports > RepBorrower – the Borrower Reports screen will display 

2. Click the F1 New button – the Select Report Format screen will display 

3. Highlight the &BORRAUD.QRP template and click the Select button 

 

4. Type a Report Description – for example: Borrower Audit 
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5. Click the F3 Save button 

 

6. Highlight the Audit report and click the F7 Where button – the Borrower Reports – Where 

screen will display 

7. Enter your Where parameters – there are three audit types:  

6. D: Deleted 

7. I: Inserted 

8. U: Updated 

The Where parameters will depend on what you are after.  Typically you would set the Audit 

Date and Audit Type (I/U/D). You may also want to limit by Location, Borrower Type, etc. 

 

8. Click the F3 Save button when complete 

9. (Optional) Click the F9 Order button – you can then set the order for the report to print in. 

You can sort by Audit Date and Barcode (or vice versa if you’re looking for a particular 

patron).  Click the F3 Save button when complete. 
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10. Click the F8 View button to view the report 

11. Select the print icon to print the report 

 



Reports Training- Advanced Reports 

 

 

Last Updated: 26 February 2013 
 Page 98 

Statistics Audit Reports 

 Reports can be set up in Main > Reports > RepStatistics 

There are three types of audit reports available: 

1. Access Audit: &SAAUDIT.QRP 

This report displays access to the Authority and Catalogue modules by Operator showing alterations 

made. 

 

2. Logon Audit: &SLAUDIT.QRP 

This report displays the date and time Operators logged onto the Authority and Catalogue modules: 

 

3. Search Audit: &SAUDIT.QRP 

This report displays Search terms used with the Authority and Catalogue modules and the type of 

search done: 
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Creating a Statistics Audit Report 

1. Go to Main > Reports > RepStatistics – the Statistics Reports screen will display 

2. Click the F1 New button the Select Report Format screen will display: 

 

3.  Highlight an audit template (Access, Logon or Search) and click the Select button 

4. Type a Report Description – for example: Logons Used 2010 

5. Click the F3 Save button 

 

6. Highlight the Audit report and click F7 Where – the Statistics Reports – Where screen will 

display 

7. Enter your Where parameters – there are two module types:  

 AUTHORITY 

 CATALOGUE 
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The Where parameters will depend on what you are after.  Typically you would set the Date 

and Module parameters, and perhaps Location (Operator Logon Location). 

 

8. Click the F3 Save button when complete 

9. (Optional) Click the F9 Order button – you can then set the order for the report to print in. 

You can sort by Operator and Module (or vice versa if you’re looking for a particular item).  

Click the F3 Save button when complete. 

 

10. Click the F8 View button to view the report 

11. Select the print icon to print the report 
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Stockitem Audit Reports 

 Reports can be set up in Main > Reports > RepStockitem 

There are three types of audit reports available: 

1. Audit Brief Details: &SADBR.QRP 

This report displays a small amount of information for each item: 

 

2. Audit Medium Details: &SADDET.QRP 

This report includes some additional fields: location, publisher, form and stats codes: 

 

3. Audit Full Details: &STKAUD.QRP 

This report displays many additional fields for each item: 

 



Reports Training- Advanced Reports 

 

 

Last Updated: 26 February 2013 
 Page 102 

Creating a Stockitem Audit Report 

1. Go to Main > Reports > RepStockitem – the Stockitem Reports screen will display 

2. Click the F1 New button – the Select Report Format screen will display: 

 

3.  Highlight an audit template (brief, medium or full details) and click the Select button 

4. Type a Report Description – for example: Audit 2010 

5. Click the F3 Save button 

 

6. Highlight the Audit report and click the F7 Where button – the Stockitem Reports – Where 

pane will open 

7. Enter your Where parameters – there are three audit types:  

o D: Deleted 

o I: Inserted 

o U: Updated 

The Where parameters will depend on what you are after.  Typically you would set the Audit 

Date and Audit Type (I/U/D) parameters, and perhaps PermLoc (Permanent Location). 
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8. Select the F3 Save button when complete 

9.  (Optional) Click the F9 Order button – you can then set the order for the report to print in. 

You can sort by Audit Date and Title (or vice versa if you’re looking for a particular item).  

Click the F3 Save button when complete. 

 

10. Click F8 View to view the report 

11. Select the print icon to print the report 
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ACCOUNTS AND UPDATE REPORTS 

Financial accounts can be added to borrower records via Reports. In order for this to work, you need 

to have the Create Acct column set to “Y” and you need to run your reports through F6 Print and 

RepStartSchedule. 

Schools can use this to create a Final Account Due for departing students (where items on loan have 

not been returned and/or lost). 

Create the Report 

1. Launch the Amlib client 

2. Go to Main > Reports > RepCirculation – the Circulation Reports window will display 

3. Click the F1 New button – the Select Report Format screen will display 

4. Highlight an appropriate Report (you may have a standard letter/email template you wish to 

use, or a modified overdue letter/email template added to the reports module) and click the 

Select button 

5. Type in a Report Description – for example: Final Overdue Account 

6. Ensure the Create Hist (Y/N) column = Y (for Yes) 

7. Ensure the Create Acct (Y/N) column = Y (for Yes) 

8. Click the F3 Save button to save the Report 
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Where Statement 

1. Click the F7 Where button – the Circulation Reports – Where screen will display: 

 

2. Enter an appropriate Where Statement – for example: 

a. BorType = SEN (for Seniors) 

b. Issue Date Due Back < Current Date (select via the Special button) 

3. Click the F3 Save button when complete 

Order By 

1. Click the F9 Order button – the Circulation Reports - Order By screen will display: 
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2. Set an appropriate order using the arrow keys to move fields from the Columns table in to 

the Order By table – for example: 

a. Bor Class 

b. Bor Surname 

c. Bor Given 

3. Click the F3 Save button when complete 

F10 More 

Please Note: User-defined charge types must be added to the Circulation Transaction Types table – 

see Appendix 1: Add the User-Defined Financial Record and Fees Type Names to the Circulation 

Transactions Types (RepCirculation and RepReservations Only) for more information. 

  

 COLUMN 1 COLUMN 2 COLUMN 3 COLUMN 4 COLUMN 5 

HEADING Report Line 

Number 

Line 1 account 

history NAME 

Line 1 overdue 

history NAME 

Line 1 Financial 

record NAME  

Line 1 Fees type 

name 

EXAMPLE 1 OVFINACC OVDFINAL OVDUEACC OVDUEFEE 

COMMENT Line 1 is used 

for History 

and Financial 

reporting 

purposes 

If left blank, the 

system will put a 

Report Type of 

ACCOUNT in the 

Borrower History 

window if Create 

Hist (Y/N) = Y and 

Create Acc (Y/N) = 

Y and the report 

run via the 

Scheduler. 

It is possible to 

specify your own 

name – see 

example (max: 8 

chars). 

Can use to specify 

1st, 2nd, etc 

overdue – for 

example:  

OVDUE1,OVDUE2 

If left blank, the 

system will put a 

Report Type of 

OVERDUE in the 

Borrower History 

window if Create 

Hist (Y/N) = Y and 

Create Acc (Y/N) = 

N and the report 

run via the 

Scheduler. 

It is possible to 

specify your own 

name – see 

example (max: 8 

chars). 

Can use to specify 

1st, 2nd, etc 

overdue – for 

example:  

OVDUE1,OVDUE2 

If left blank, the 

system will put a 

Financial Type of 

OVERDUE in the 

Borrower Financial 

window indicating 

the (replacement) 

Cost for overdue 

items if Create Acc 

(Y/N) = Y and the 

report run via the 

Scheduler. 

It is possible to 

specify your own 

name – see 

example (max: 8 

chars). 

If left blank, the 

system will put a 

Financial Type of 

FEE in the 

Borrower 

Financial window 

for reports that 

have a 

FORM_CHARGES 

field in the report 

(see example 2) if 

Create Acc (Y/N) = 

Y and the report 

run via the 

Scheduler. 

It is possible to 

specify your own 

name – see 

example (max: 8 

chars). 
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1. Click the F10 More button – the More screen will display: 

 

2. Click the F1 New or F2 Insert button  

3. Enter the following parameters: 

a. Report Line Number = 1 

b. Line 1 account History NAME = OVFINACC 

c. Line 1 overdue History NAME = OVDFINAL 

d. Line 1 Financial record NAME = OVDUEACC 

e. Line 1 Fees type name = OVDUEFEE (applicable only if Charges apply –see below) 

It is also possible to apply charges at this stage on a per item/notice basis: 

HEADING Report Line 

Number 

Line 2 Fee per 

Item $.c 

Line 2 Fee per 

Notice $.c 

Line 2 Fee Print 

Line 

Line 2 not Used 

EXAMPLE 2 2.00 5.00 Includes fees of: <Leave blank> 

COMMENT Line 2 is used 

to add Fees 

to Reports 

Enter amount to 

be charged for 

each overdue item 

[Optional] 

Amount will be 

added to the 

FORM_ 

CHARGES field in 

the Report 

Enter amount to 

be charged per 

notice (in addition 

to any item fee) 

[Optional] 

Amount will be 

added to the 

FORM_ 

CHARGES field in 

the Report 

Text will be added 

to the USER_LINE1 

field in the Report 

[Optional] 
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4. Click the F1 New or F2 Insert button  

5. Enter the following parameters: 

a. Report Line Number = 2 

b. Line 2 Fee per Item = 2.00 

c. Line 2 Fee per Notice = 5.00 

d. Line 2 Fee Print Line = Includes fees of: 

6.  Click the F3 Save button when complete 

Edit the Template to Include Charges 

Please Note: The report template must be altered to include the following fields: FORM_CHARGES 

and USER_LINE1. 

 The new &ODFEE.QRP template includes FORM_CHARGES and USER_LINE1. 

 

 

The FORM_CHARGES field can be added to the total charge [Field = FORM_CHARGES] or included as 

part of a TotalCst. You can also include the field USER_LINE1 which will include the text you entered 

in the F10 More statement. 

Print Report (via Scheduler) 

If you only want to print a report then the quickest method is to use F8 View and print from the 

Report – View window. 

Using the Scheduler (via the F6 Print button) has several benefits over running reports via the F8 

View button: It allows you to schedule regularly run reports so that staff do not have to do it 

manually each time, and it allows for further functions as part of the report such as updating 

Borrower/Stockitem history, updating the Reservation Status and adding report information to your 

statistics. This report MUST be run via the Scheduler. 
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Borrower 

Once the report is printed each Patron will have an entry in the Borrower Financial Transactions 

window that will show the cost of the item: 

 

Each Patron will also have an entry listed in the Borrower History window that will show that the 

report was run off: 

 

 

A prompt will display with the following message if the item is returned: FINANCIAL DETAILS – XXXX 

was previously charged $XX.XX Auto Charge for Overdue Item for this Item. Cancel the charge? 
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Single Account 

Creating an invoice against a single account can be done via the Where statement in the report. 

 

Email Reports 

If you’re planning to use email notices for those with email at your library, you need to ensure that 

patrons receiving notices by email aren’t also getting hardcopies, and that those who do not have 

email addresses are still receiving hardcopies. 

To do this you need to adjust the Where statement of your hardcopy notice report to include: Bor Use 

Email = N. For the reports you are setting up to be sent by email you need to use: Bor Use Email = Y. 
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Status Updates 

There are other reports that can affect changes in Amlib. For all of these to work, you must have the 

Update column in the report screen set to “Y” and they must all be run through F6 Print and 

RepStartSchedule. 

Reservation Statuses 

When an item is placed on reserve, a Reservation Status is placed against that item.  The status is 

important as the reports use this status as a determinant for what to print and what not to. 

STATUS EXPLANATION 

ISSUE Item was on loan when reserved (reserve placed 

via Amlib client) 

ON LOAN Item was on loan when reserved (reserve placed 

via Opacs) 

SHELF Item was on shelf (available) when reserved 

RETURN Item has been returned AFTER reservation placed 

TRANSFER Item was on transfer when reserved 

ORDER Item was on order when reserved 

READY Reservation on item has been CANCELLED 

through an expiry report and is now ready for the 

next reader 

PRINTED Item was included in a scheduled Reservation 

report with Update Res Status = Y 
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AUTOMATIC BORROWER AND CIRCULATION UPDATES 

Borrower Update Reports 

Borrower update reports can now be run to change borrower status, add memos and delete the 

address 3 field (for those borrowers that are changing to adult status). 

In the following example, we are changing the Borrower Type of Young Adult members to an Adult 

Type and deleting the Guardian Address. 

Template 

1. Launch the Amlib client 

2. Go to Main > Reports > RepAddNew – the Report Files screen will display: 

 

3. Locate and highlight the &BORUPD.QRP template 

4. Click the F2 Modify button – the Borrower - Modify Report File… screen will display: 

 

5. Check the following settings: 
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a. Choose Type = Borrower Automatic Update 

b. Update Entity (Y/N) = Y 

6. Click the F3 Update button when complete 

Create the Report 

1. Go to Main > Reports > RepBorrower – the Borrower Reports screen will display 

2. Click the F1 New button – the Select Report Format list will display: 

 

3. Highlight the &BORUPD.QRP template and click the Select button 

4. A new report will be added to the list of reports 

5. Type in a Description – for example: Update Borrower Address 3 

6. The Update Entity (Y/N) column setting must be set to Y 

7. Click the F3 Save button when complete 

 

Set Where Parameters 
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Your where parameters can be set according to the changes you need to make to your database, and 

which group(s) of people these changes apply to. 

The Where statement here selects those borrowers with a YA borrower type who are now over 18. 

If you are unsure of how to set your where parameters for the update you wish to carry out, please 

contact Amlib support. 

1. Highlight the Report 

2. Click the F7 Where button – the Borrower Reports – Where screen will display: 

 

3. Enter the following details: 

a. BorType – for example: BorType = YA 

b. BirthDate – for example: BirthDate <= Current Date – 18 Years (use the Special 

button to insert Current Date – 216 months) 

4. Click the F3 Save button when complete (the Where screen will close) 
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Update Parameters (F10 More) 

The F10 More button is used to set up the new values and whether a Memo is to be sent. 

A report employing F10 More parameters must be run via the Scheduler. 

1. Highlight the report 

2. Click the F10 More button – the More screen will display 

3. Click the F1 New or F2 Insert button  

4. Enter the following Line 1 parameters (see Notes below): 

a. Report Line Number = 1 

b. Column = T 

c. New Value = A (for Adult) 

d. Send Memo = Y (optional) 

5. Click the F3 Save button when complete 

6. Enter the following Line 2 parameters (see Notes below): 

a. Address 3 = Y (this will delete the Borrower’s Guardian Address) 

7. Click the F3 Save button when complete 

 

 COLUMN 1 COLUMN 2 COLUMN 3 COLUMN 4 COLUMN 5 

HEADING Report Line 
Number 

Column New Value Send Memo Address 3 

EXAMPLE 1 T A Y <leave blank> 

 2 <leave blank> <leave blank> <leave blank> Y 

COMMENT Line 1 is used 
for updates 

Line 2 is used to 
delete 
Borrower 
Address 3 

Borrower field – 
can be 
Borrower Types 
(T), Classes (C) 
Groups (G) or 
Status (S) 

The new value – 
must be a valid 
code for the 
selected column 

If Y, create the 
memo in Text 
for Letter, 
found at the top 
of the Borrower 
Reports screen 

If Y, can be used 
to delete 
Address 3 
(Guardian 
Address) from 
Borrower 
record 
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Notes 

Updates: The new value is the new Borrower Type (or Borrower Status, Borrower Class or Borrower 

Group) that you wish to change the Borrowers to. 

In the example given above, the Borrower Type would be changed to Adult, or A. The value entered 

in this column will depend on your Borrower Type settings. If you unsure, check your settings before 

proceeding: Go to Main > Borrower > BorrowerTypes: 

 

Send Memo: If you wish to add a memo to each borrower record that is changed, type a Y in the 

Send Memo column. Otherwise, type N in the Send Memo column. 

Delete Guardian Address: Type a Y in the Address 3 column if you wish to have the guardian address 

deleted (for example in the case where YA members are changed to A members, for these records 

you may prefer to have the guardian address deleted as this is no longer required). 

Memos 

If you have placed a Y in the Send Memo column, then the Memo text must then be set up. 

1. Highlight the report 

  

2. Click the Text for Letter button – the Letter Text screen will display: 
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3. Type in the text that you would like to see in the Borrower Memo – for example: Borrower 

to sign register and present ID. 

4. Click the F3 Save button when complete 

5. Click on the [X] to close the screen 

View Report 

Once the report is set up, you can then preview the report as follows: 

1. Highlight the report and click the F8 View button – a prompt with the following message will 

display: This type of report may use a Saved File as the Source. Do you want to select the 

file now? 

 

2. Click the No button to run this report against all borrowers 

3. The report will open in the Report – View window: 

 

4.  If you wish to print a hardcopy, click on the print icon 

Print Report (via Scheduler) 

Borrower Update reports MUST be run via the Scheduler. 
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Start the Scheduler 

1. From the Reports screen, select Application > RepStartSchedule 

 

2. The Report Scheduler screen will display 

3. Select your printing options: ensure Save to File is ticked (you can tick all three if you intend 

on printing up multiple reports using multiple formats during a session) 

 

4. Then click the OK button 

5. After clicking OK, if you go back into the Application menu you will see that 

RepStartSchedule is now greyed out with a tick next to it – this indicates that the Scheduler is 

now running 

 

Scheduling the Report 

1. With your report highlighted, select the F6 Print button – the Print dialogue box will display 

2. Select from the following options: 

a. From: 
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 Database (to search the entire database) 

b. To: 

 File (to save a report as a file) 

c. Frequency: 

 Once Only 

 

3. Once you have selected all of your settings, click the OK button – the Report – Save As screen 
will display: 

 

4. Select a Save in: location and type in a File name: 

5. Click the Save button when complete 

The report will then “print”. 

Updated Borrower Record: 
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Memo that appears in Circulation: 
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Running Borrower Circulation Update Reports 

The Borrower Circulation Automatic Update (&BORCUPD.QRP) template was created for the 

purpose of automatically changing the status of borrowers based on the inclusion of due date 

parameters in the Where statement of the report. The application of this would be to change 

borrowers with overdues past a certain due date to a SUSPENDED status. 

To set up the process correctly, the following reports would need to be scheduled in this order: 

1. Borrower Automatic Update (&BORUPD.QRP) to set all borrowers with suspended status to 

a status of OK. 

2. Borrower Circulation Automatic Update (&BORCUPD.QRP) to set all borrowers with the 

given due date parameters to a status of suspended. 

In the event that any borrowers with suspended status return or pay for all their overdues, the 

scheduling of the reports in this way ensures that those borrowers will be re-instated to a status of 

OK. The running of the Borrower Circulation Automatic Update then re-calculates which borrowers 

still fit the criteria for suspension, so that these borrowers still have their SUSPENDED status. 

When the Borrower Circulation Automatic Update report is run, a borrower file is also created which 

contains all the records for borrowers that have had their status changed. 

Setting up the Reports 

Create the Borrower Circulation Automatic Update Report 

1. Launch the Amlib client 

2. Ensure that the borrower circulation update template is correctly set in Main > Reports > 

RepAddNew – Entity = Borrower: 

 Report Type = Borrower Circulation Automatic Update 

 File Name = &BORCUPD.QRP (not to be confused with &BORUPD.QRP) 

 

3. Go to Main > Reports > RepBorrower – the Borrower Reports screen will display 

4. Click the F1 New button – the Select Report Format screen will display 
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5. Highlight the Borrower Circulation Automatic Update (&BORCUPD.QRP) and click the Select 

button 

6. Type in a Description – for example: Borrower Update – Auto Suspension 

7. Ensure the Update Entity (Y/N) column = Y 

8. Click the F3 Save button when complete 

 

9. Highlight the report and click the F7 Where button – the Borrower Reports – Where screen 

will display 

10. Set the due date parameter based on your criteria for suspension of borrowers. You may also 

choose to include parameters if you wish to exclude certain borrowers (for example: 

housebound borrower type or specific location) 

11. Click the F3 Update button when complete 

 

F10 More 

1. Click the F10 More button – the More screen will display  

2. Click the F1 New or F2 Insert button 
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3. Enter the following parameters: 

 Report Line Number = 1 

 Column = S (for Status) 

 New Value = SUSP (for Suspended) 

 Send Memo = Y 

 

The column is set to S in order to change the Status. The new value is the status you are changing 

your borrowers to – this will depend on the settings you have in Main > Borrowers > Borrower – 

Application > Borrower Status: 

 

The Send Memo can be set to either Y or N. If set to Y, the memo will be attached to each borrower’s 

record as a borrower memo. 

4. Click the F3 Save button when complete 

 COLUMN 1 COLUMN 2 COLUMN 3 COLUMN 4 COLUMN 5 

HEADING 

 
Report Line 
Number 

Column New Value Send Memo not used 

EXAMPLE 1 S SUSP Y <leave blank> 

COMMENT Line 1 is used 
for updates 

Borrower field – 
can be 
Borrower Types 
(T), Classes (C) 
Groups (G) or 
Status (S) 

The new value – 
must be a valid 
code for the 
selected column 

If Y, create the 
memo in Text 
for Letter, 
found at the top 
of the Borrower 
Reports screen 
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Memo 

If you set the Send Memo column to be Y in the F10 More screen you will need to fill in the content 

of your memo.  

1. Highlight your report and click the Text for Letter button – the Letter Text screen will display 

 

2. Enter the memo text 

3. Click the F3 Save button when complete and click on the red [X] to close the window 

 

Create the Borrower Automatic Update Report 

1. Click the F1 New button – the Select Report Format screen will display 

2. Highlight the Borrower Automatic Update (&BORUPD.QRP) and click the Select button 

3. Type in a Description – for example: Borrower Update – Clear Suspensions 

4. Ensure the Update Entity (Y/N) column = Y 

5. Click the F3 Save button when complete 
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6. Highlight the report and click the F7 Where button – the Borrower Reports – Where screen 

will display 

7. Enter the Borrower Status to be checked (and cleared) – for example: BorStatus = SUSP 

8. Click the F3 Update button when complete 

 

F10 More 

1. Click the F10 More button – the More screen will display  

2. Click the F1 New or F2 Insert button 

3. Enter the following parameters: 

 Report Line Number = 1 

 Column = S (for Status) 

 New Value = OK (for Unrestricted) 

 Send Memo = D (this will delete the memo if it no longer applies) 

 Address 3 = <leave blank> 
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The Column is set to S in order to change the Status. The new value is the normal OK status you 

would have your borrowers default to – this will depend on the settings you have in Main > 

Borrowers > Borrower – Application > Borrower Status: 

 

4. Click the F3 Save button when complete 

  

 COLUMN 1 COLUMN 2 COLUMN 3 COLUMN 4 COLUMN 5 

HEADING 

 
Report Line 
Number 

Column New Value Send Memo Address 3 

EXAMPLE 1 S OK D <leave blank> 

COMMENT Line 1 is used 
for updates 

Borrower field – 
can be 
Borrower Types 
(T), Classes (C) 
Groups (G) or 
Status (S) 

The new value – 
must be a valid 
code for the 
selected column 

If D, will delete 
if it no longer 
applies –
otherwise set to 
N to leave in 
place 
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Print Report (via Scheduler) 

Borrower Update reports MUST be run via the Scheduler. 

Start the Scheduler 

1. From the Reports screen, select Application > RepStartSchedule 

 

2. The Report Scheduler screen will display 

3. Select your printing options: ensure Save to File is ticked (you can tick all three if you intend 

on printing up multiple reports using multiple formats during a session) 

 

4. Then click the OK button 

5. After clicking OK, if you go back into the Application menu you will see that 

RepStartSchedule is now greyed out with a tick next to it – this indicates that the Scheduler is 

now running 
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Scheduling the Report 

IMPORTANT! In order to ensure that only those borrowers with outstanding items are/remain 

suspended, the reports MUST be run in the following order: 

1. Borrower Automatic Update (&BORUPD.QRP) to set all borrowers with SUSPENDED status to 

back to OK. 

2. Borrower Automatic Circulation Update (&BORCUPD.QRP) to set all borrowers with the 

given due date parameters to a status of SUSPENDED. 

The reports can be run manually run or scheduled to run daily/weekly (as long as they are run in the 

correct order). 

1. With your report highlighted, select the F6 Print button – the Print dialogue box will display 

2. Select from the following options: 

a. From: 

 Database (to search the entire database) 

b. To: 

 File (to save a report as a file) 

c. Frequency: 

 Any frequency can be used: Once Only, Daily, Weekly or Monthly 

d. Schedule: 

 First Print Date (defaults to current date) 

 First Print Time (defaults to current time) 

 

IMPORTANT! In order to ensure that only those borrowers with outstanding items are/remain 

suspended, the reports MUST be run in the correct order! 
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3. Once you have selected all of your settings, click the OK button – the Report – Save As screen 

will display: 

 

4. Select a Save in: location and type in a File name: - for example: Borrower Update- Clear 

Suspensions or Borrower Update – Set Suspensions 

5. Click the Save button when complete 

Check Print Progress 

1. You can check the progress of your reports at any time by going into Main > Reports > 

RepPrintProgress 

 

2. You can also click through the three tab options at the top to see the ones that are Waiting, 

Running, or have already been Printed 

3. Your report will show up in Printed when it is complete 
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Check the Suspended Borrowers 

If required, borrowers that have been suspended with the Borrower Circulation Automatic Update 

report can be checked from a borrower file.  

1. Launch the Amlib Client 

2. Got to Main > Borrowers > Borrower – the Borrower Details screen will display 

3. From the menu, select File > DisplayFile – the Borrower Saved Query Results screen will 

display: 

 

4. Borrower Circulation Automatic Update will be listed under the report name – for example: 

Borrower Update – Auto Suspension 

5. Highlight the saved file and click the F9 Select button to see a Borrower List of the borrowers 

who have been suspended: 
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6. Double-click on a name to bring up the Borrower Details: 
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SAVING A REPORT TO FILE 

You can save your reports to a file, for email or formatting, or just to keep it in an electronic format 

rather than paper. The two ways of doing this are by Table or Report. 

Table 

1. Access a module and perform a search – the results will display in a List 

2. Highlight the items you would like to save to file 

3. Type Ctrl-C to copy them 

4. Open up MS Excel or Word 

5. Type Ctrl-P to paste the selection into a table or page 

After getting a table of results in one of the modules, you can highlight them all to select them and 

do Ctrl + Insert to copy them. Then you can paste the items into Excel or Word. 

 

↓ 

 

This method works best if you don’t have a large number of results. 
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Report 

There are several Excel report templates available which can be used to save to a file. 

In this example, we are going to use the &XSTKCSV.QRP template in the Reports > RepStockitem 

module: 

1. Go to Main > Reports > RepStockitem – the Stockitem Reports screen will display 

2. Click the F1 New button – the Select Report Format screen will display 

3. Highlight the &XSTKCSV.QRP template and click the Select button 

4. Type in an appropriate Description and click the F3 Save button 

5. Enter an appropriate F7 Where search – for example: Title LIKE Harry Potter 

 

6. Order the Report – for example: Title | ASC 

7. Select Application > RepStartSchedule – the Report Scheduler screen will display 

8. Ensure that Save to File is ticked and click the OK button 

 

9. Click the F6 Print button – change the To: option to File and click the OK button 
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10. A Report – Save As dialogue box will display: 

a. To save it for a Word document, leave the Save as type: as Rich Text Format (RTF) 

b. To be able to open it in Excel, change the Save as type: to Text Document 

 

11. You can check the progress of your report in Reports > RepPrintProgress 

12. If you’ve saved the report to open in Excel (Text Document) then you will need to follow 

these steps so it is displayed correctly: 

a. Open Microsoft Excel 

b. Use File > Open to open the text file you’ve saved – ensure that the Files of type: = 

All Files (*.*) 

c. The Text Import Wizard will display: 
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d. Excel will recognise your file as Delimited, so click the Next button 

e. Delimiters: select Semicolon and add a pipe | in the Other box 

f. Click the Next button and then the Finish button 

 

13. Your data will be transferred into the Excel sheet and you can now use the formatting tools 

to customise it: 

 

LOADING TEMPLATES 
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Your new/customised template needs to be saved somewhere that can be accessed by every 

workstation, such as the Amlib/Reports folder on your Amlib server.  

To add them into the Amlib client: 

1. Launch the Amlib client 

2. Go to Main > Reports > RepAddNew – the Report Files window will open 

3. From the Report Entity drop-down, select the appropriate module for your report – for 

example: Circulation 

 

4. Click the F1 New button – the New Report File… window will display 

 

5. Type in an appropriate Description – for example: Overdue Notice (Letter) 
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6. Template – click on the Browse button – the Choose Report window will display: 

 

7. Navigate to the Amlib/Reports folder on your Amlib Server (if the template has been loaded 

onto your PC – then navigate to the local folder) 

8. Files of type:  

 Select Custom Report Templates (*.QRP) for customised templates 

 Select System Report Templates (*.QRP) for all standard system templates 

9. Locate the template to be loaded and highlight it 

10. Click the Open button – the template will be selected the Choose Report window will close 

11. Choose Type – it is essential that the appropriate type be chosen that this will inform how 

your template operates and the information that is sent to it – in this example: Continuous - 

Full descriptions has been selected 

 

12. Message – leave blank 

13. Default Stats Code – it is possible to collect statistics on the number of times that this report 

is run by adding an entry into the Statistics Codes table (Main > Supervisor > StatsParams) 

and then adding the Stat Type into the Default Stats Code box 

14. Default Detail Stats Code – it is possible to collect statistics on the number of individual 

notices that a particular report generates by adding an entry into the Statistics Codes table 
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(Main > Supervisor > StatsParams) and then adding the Stat Type into the Default Detail 

Stats Code box (not available for all modules) 

 

↓ 

 

15. Update History (Y/N) – it is possible to retain a record of the report having been generated – 

for example: the above Overdue Letter report can add a record of the overdue being printed 

to the Borrower History of affected patrons 

16. Update Entity (Y/N) – this field can be used to update the status or alter a parameter of a 

record – for example: an account may be generated for an overdue circulation report 

 

17. Click the F3 Update button 

18. Close out of the Report Files window 

The template is now loaded and available for use in a Report. 
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SCHEDULING REPORTS 

Print Report (via Scheduler) 

If you only want to print a report then the quickest method is to use the F8 View button and print 
from the Report – View window. 

Using the Scheduler (via the F6 Print button) has several benefits over running reports via the F8 
View button: It allows you to schedule regularly run reports so that staff do not have to do it 
manually each time, and it allows for further functions as part of the report such as updating 
Borrower/Stockitem history, updating the Reservation Status and adding report information to your 
statistics. Email and SMS reports MUST be run via the Scheduler. 

This guide will take you through setting up a report to use RepStartSchedule. 

Start the Scheduler 

1. From any Reports screen, select Application > RepStartSchedule – the Report Scheduler 
screen will display: 

 

2. Select your printing options: ensure Printing, E-mail and/or Save to File is ticked (you can tick 
all three if you intend on printing up multiple reports using multiple formats during a session) 

3. Also decide If a report is scheduled by another user do you still want to print it? = Yes/No 

4. Then click the OK button 

5. After clicking OK, if you go back into the Application menu you will see that 
RepStartSchedule is now greyed out with a tick next to it – this indicates that the Scheduler is 
now running: 
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Please Note: If you need to restart the scheduler at any point, you will need to log out of all Report 
screens (Ctrl + L) and start at the beginning of these instructions. 

Scheduling the Report 

1. With your report highlighted, select the F6 Print button – the Print dialogue box will display: 

 

2. Select from the following options: 

a. From: 

 Database (to search the entire database) 

b. To: 

 Printer (to generate print reports) 

 E-mail (to generate email reports – this option will only be available to 
reports that have been created from an appropriately loaded template) 

 File (to save a report as a file) 

c. Frequency: 

 Once Only (if this is the only time you’re going to print this report) 

 Daily (if you plan to send it every day) 

 Weekly (if this is a once a week item) 

 Monthly (if this is to be printed every calendar month) 

 Every ___ days (if you want to set a specific schedule 

d. Schedule: 

 First Print Date (the day you want this report to begin its schedule) 

 First Print Time (specifies the exact minutes the report will run) 

e. Selected Printer: 
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 You can specify any active printer on the network to print to – including 
virtual printer drivers such as a third party software that allows you to print 
to PDF (For example: CutePDF Writer) 

3. Once you have selected all of your settings, click the OK button 

Check Print Progress 

1. You can check the progress of your reports at any time by going into Main > Reports > 
RepPrintProgress – the Print Progress screen will display: 

 

7. If your library uses the scheduler for a lot of reports, you can select a frequency type from 
the Filter drop-down menu at the top: 

 

8. You can also click through the three tab options at the top to see the ones that are Waiting, 
Running, or have already been Printed: 

 

9. Your report will show up in Printed tab when it is complete: 

 

LAUNCH REPORTS UNATTENDED 
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The Report module has been modified so that it can be started from a command line to run all 
currently scheduled reports and then exit. 

Several sites have requested that we build a report Service to run unattended on a server. Currently 
there are no plans to do this. This enhancement will make it possible for sites to schedule the report 
exe to start up, print scheduled reports (including emails) and then shut down. 

Sample Command Line Parameters 

[Exe path] [login] [password] [database] [location] [default window] 

For example: D:\Amlib\Amlib\Programs\Reports.exe staff Amlib LIVE LIB RepPrintProgress 

In the above example: 

 [Exe path] D:\Amlib\Amlib\Programs\Reports.exe 

 [Login] staff 

 [Password] Amlib 

 [Database] LIVE 

 [Location] LIB 

 [Default Window] RepPrintProgress 

The Database Login e.g. LIVE must be in Upper Case in the Command Line path as well as in the 
C:\Windows\Amlib.ini (configuration settings) found on the PC on which the Automatic Reports 
Scheduler is to be launched. 

The Location code will be validated. It must be correct within the Command Line. 

Substitute the above Command Paths and Login details to reflect your own Command Paths and 
Login details. These details can then be entered into a Windows/Scheduled Task pane. We can send 
separate notes on this if required. 

 

Report Functionality 
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If Reports is started using a command line that includes RepPrintProgress as the default window 
argument, the Reports module starts up and opens the Print Progress window. The scheduler is 
started and ALL scheduled reports that are listed to be launched prior to the current date/time will 
be processed.  

Once there are no more reports to process the application shuts down. 

It is important to understand that the Reports application will stay open as long as it takes to process 
all jobs where the date and time is EARLIER than the current time. The Report exe does NOT look 
ahead and stay open for jobs that will become due at some future time. 

Example: 

 Print Job #1 scheduled for 29th March 2007 at 2:00am 

 Print Job #2 scheduled for 29th March 2007 at 3:30 am 

If the Report.exe is loaded at 3:00 am Print Job #1 will be processed but Print Job #2 will NOT be 
processed, unless Print Job #1 takes more than 30 minutes to run.’ 

Please Note: 

Currently only Report.exe does anything with the default window parameter, but the Database and 
Location parameters can be used with any Amlib executable. 

The passed Location code is validated. If it is OK then the application logs on to that Location, 
otherwise the Location selection dialogue is displayed. 

For example launch Amlib automatically without logging in manually by setting the Amlib desktop 
Icon to have the Properties set to the User’s login details. For example: 

 

APPENDICES 
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Appendix 1: Add the User-Defined Financial Record and Fees Type Names to the 

Circulation Transactions Types (RepCirculation and RepReservations Only) 

Please Note: Any user-defined names in column 4 and 5 (Line 1 Financial record NAME and Line 1 

Fees type name) in the F10 More screen must also be added to the Circulation Transaction Types 

table. 

1. Go to Main > Finance > CircFinTypes – Circulation Transaction Types screen will display: 

 

2. To add a new Transaction Type: 

a. Click the New or Insert button 

b. Trans Type – type in the user-defined name – for example: OVDUEACC or OVDUEFEE 

c. Transaction Description – for example: Overdue Account or Overdue Fee 

d. CR or DB = DB 

e. Click the Save button when complete 

  



Appendix 2: Sample Overdue Date Line 

Current Date 

Less than or 

equal to 

Current date 

minus 7 days  

< 

Greater than 

Current date 

minus 14 days 

 

> 

OVERDUE 

SLIP 

Less than or 

equal to 

Current date 

minus 14 days 

< 

Greater than 

Current date 

minus 21 days 

 

> 

OVERDUE 

LETTER 1 

Less than or 

equal to 

Current date 

minus 28 days 

< 

INVOICE LIST – OUTSTANDING 

OVERDUES 

Greater 

than 

Current 

Date minus 

35 days 

> 

Less than or equal 

to Current date 

minus 42 days  

< 

- 
7 14 21 28 

      

35 

 

42 
+ 

0 
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Appendix 3: Operators 

 

 OPERATORS 

For Reports & 

Where Searches 

LIKE LIKE IN IN =  < < > > F12 

Begins 
with 

 

 

 

Does not 

begin with 

Include these 

multiple 

codes  - for 

example: J,A 

Do not 

Include 

these 

multiple  

codes 

Equal 

to… 

Not 

Equal 

to… 

Less 

than 

Less than 

or Equal to 

Greater 

than 

Greater 

than or 

Equal to 

PRINT 

SCREEN 

 


