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REPORTS – OVERVIEW 

Reports are used for every conceivable purpose within Amlib, from printing up tables and updating 

borrower records to printing out overdue notices. 

It is possible to create and run a huge variety of reports covering every single module. In addition, it 

is possible for you to customise these reports in both their design and functionality. 

The creation of a report is covered in broad terms by the following flowchart: 
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TEMPLATES 

Whenever Amlib prints, emails or saves a file, it uses a template to determine what should and how 

it should be printed. 

What is “printed” by the template is determined by a number of factors: 

 Fields in Template – for example: Name, Address, Item No, Title 

 Report Module Category – for example:  Circulation Reports 

 Template Type – for example: Email 

 Where Statement – for example: Borrower Type = A (for Adult) 

Template Location 

Most report templates can be found in the Amlib/Reports folder on your Amlib server. If you do not 

normally have access to this space, then you should contact your IT support staff about arranging 

access to this location to enable you to customise your report templates. 

It is possible load templates from your PC, but these templates will only be available for use by that 

PC. 

Template Types 

Standard System Report Templates 

These are the templates with an ampersand (&) at the beginning of the file name – for example: 

&ODEMAIL.QRP (Overdue Email Notice). They are loaded into the Amlib Reports module and may 

be renamed – without the ampersand (&) – if you alter the content/format of the report template.  

Please Note: It’s a good idea to note any templates that you have customised (but not renamed) and 

keep them backed up as they will be overwritten during an upgrade.  

Table Report Templates 

These are the templates with a dollar sign ($) at the beginning of the file name – for example: 

$BOTYPES.QRP (List of Borrower Types) They are generally hard-coded into individual Amlib 

modules and cannot be renamed. You may, however, alter the content/format of the report 

template. 

Please Note: It’s a good idea to note any templates that you have customised and keep them backed 

up as they will be overwritten during an upgrade. 
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Customised Report Templates 

These are edited/reformatted templates that usually begin with ampersand (&) – and a few with a 

dollar sign ($) – which have been resaved with a new name. The general practice when customising a 

report template is to remove the ampersand (&) and add in a few letters indicating your library 

name:  

 &ODEMAIL.QRP →AMODEML.QRP 

 

SYMBOL TEMPLATE TYPE EXAMPLE EXAMPLE DESCRIPTION 

& System &ODEMAIL.QRP Overdue Email Notice 

$ Table $BOTYPES.QRP List of Borrower Types 

# Special #ADDLABL.QRP Borrower Address Labels 

[No symbol] Custom AMODEML.QRP Custom Overdue Email 

Template Design 

The design of a report template determines what data will ultimately be printed (even taking into 

account the data selection parameters or Where statement) and the format it will be printed in. 

A template is typically subdivided as follows: 

 Report Header and Footer 

 Page Header and Footer 

 Group-defined Headers and Footers – for example: Borrower Barcode 

 Detail Block 

A template is typically comprised of the following: 

 Lines – an object that can be added to any subdivision which can then be formatted and then 

text, fields or images added 

 Background Text – generally text and headings 

 Fields – a placeholder ultimately replaced by information derived from a particular Amlib 

field (for example: Title) or a user-defined variable that performs a function on these fields 

(for example: Total Cost) 

 Images – either pictures or objects that have been imported into the template 

 Box – a user-defined line art shape 
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Editing Templates 

Report Writer (REPWIN30.EXE) is a separate program, produced by Centura, which is utilised by 

Amlib for Reports. We have many templates created for library use, but you can customise them, as 

well as create your own. 

Format 

The text on a report template is known as Background Text. You can see that it is different from 

Fields because Fields show up in white: 

 

It is also possible to incorporate text into a Field: 

 

  

Background Text 
Image 

Fields 
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Insert/Delete Lines 

To delete lines: 

 Click and highlight the line you want to delete and press the Delete button on your keyboard 

To insert lines: 

 Click and highlight the line below where you want to insert a new one and press the Insert 

button on your keyboard 

Edit Text 

1. Double-click on the Background Text object you want to edit – the Format Background Text 

dialogue box will open 

 

2. Edit/format the text as desired 

3. Click on the OK button when complete 
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Edit Fields 

1. To change what is displayed in a Field, you can select the Field and choose a new item from 

the Content drop-down box at the top: 

 

Insert a New Background Text or Field Object 

1. From the main menu, select Tools > Background Text or Field 

2. Position the cursor where you would like the object to appear and click the mouse to insert 

Reposition Background Text and Field Objects 

 You can move text/field objects around by changing the Position and Width in the menu bar: 

 

Change Fonts and Font Sizes 

 You can change and font and size of text/field objects in the menu bar: 
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Saving Templates 

When you have finished customising a template, ensure that the template is saved with a new name 

to avoid it being overwritten in any future upgrades – for example: AMODLET.QRP 

You will notice that the above example does not have an & at the start of the template name.  An & 

indicates that it is a standard System Report Template, and the lack of an & indicates that it is a 

Custom Report Template. 

 

Save the customised template into the Amlib/Reports folder on the Amlib server.  This will make the 

template available for use for all users. Alternatively, you may save it into a local folder on your PC – 

but please be aware, that the template (once loaded) will only be available for use on that PC.  

  



Amlib Basic Reports Manual 

 

 

Last Updated: 19 September 2014 
 Page 13 

Loading Templates 

Your new/customised template needs to be saved somewhere that can be accessed by every 

workstation, such as the Drive:/Amlib/Reports folder on your Amlib server.  

To add them into the Amlib client: 

1. Launch the Amlib client 

2. Go to Main > Reports > RepAddNew – the Report Files screen will display: 

 

1. From the Report Entity drop-down, select the appropriate module for your report – for 

example: Circulation 

2. Click the F1 New button – the New Report File screen will display: 

 

3. Type in an appropriate Description – for example: Overdue Notice (Letter) 
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4. Template – click on the Browse button – the Choose Report screen will display: 

 

5. Navigate to the Drive:/Amlib/Reports folder on your Amlib Server (if the template has been 

loaded onto your PC – then navigate to the local folder) 

6. Files of type:  

 Select Custom Report Templates (*.qrp) for customised templates 

 Select System Report Templates (*.qrp) for all standard system templates 

7. Locate the template to be loaded and highlight it 

8. Click the Open button – the template will be selected the Choose Report window will close 

9. Choose Type – it is essential that the appropriate type be chosen that this will inform how 

your template operates and the information that is sent to it – in this example: Continuous - 

Full descriptions has been selected 

 

10. Message – leave blank 
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11. Default Stats Code – it is possible to collect statistics on the number of times that this report 

is run by adding an entry into the Statistics Codes table (Main > Supervisor > StatsParams) 

and then adding the Stat Type into the Default Stats Code box 

12. Default Detail Stats Code – it is possible to collect statistics on the number of individual 

notices that a particular report generates by adding an entry into the Statistics Codes table 

(Main > Supervisor > StatsParams) and then adding the Stat Type into the Default Detail 

Stats Code box (not available for all modules) 

 
↓ 

 

13. Update History (Y/N) – it is possible to retain a record of the report having been generated – 

for example: the above Overdue Letter report can add a record of the overdue being printed 

to the Borrower History of affected patrons 

14. Update Entity (Y/N) – this field can be used to update the status or alter a parameter of a 

record – for example: an account may be generated for an overdue circulation report 

 

15. Click the F3 Update button 

16. Close out of the Report Files screen 

The template is now loaded and available for use in a Report. 
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Report Types 

REPORT ENTITY TYPES 

Account 

Authority 

Bibliographic 

Borrower 

Catalogue 

Circulation 

Financial 

Inter-Library Loan 

Periodical 

Reservation 

Statistics 

Stockitem 
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SETTING UP REPORTS 

Report Module Categories 

The Reports module is split into the following categories: 

REPORT DESCRIPTION EXAMPLES 

RepAccounts Accounts Reports Account Reprints without creating 

a Financial record for the 

borrower. 

RepAuthority Authority Reports Author, Series, Subject Heading 

Listings, etc 

RepBibliographic Bibliographic (Catalogue Data) 

Reports 

New items displaying Title, Author, 

Subject Headings, Notes, etc. 

RepBorrower Borrower Reports Listings of borrowers, loan 

histories, address labels 

RepCatalogue Catalogue Report – for more 

tag displays use 

RepBibliographic 

4 lines of data to show items by a 

particular author, etc. 

RepCirculation Circulation Reports Items on Loan, Overdue lists, slips, 

Letters, Invoices, etc. 

RepFinancial Financial Reports Budget categories and 

expenditure, etc. 

RepILLS Inter Library Loan Reports ILL notices including request and 

renewal notices, etc. 

RepOrders Order Reports Orders, Supplier Listings 

RepPeriodicals Periodical Reports Full journal listing, Suppliers, 

Renewal reminders, Claims, etc. 

RepReservation Reservation Reports Pick-up lists, reservation collection 

notices and expired reservations 

lists 

RepStatistics Statistics Reports Statistics summary and detailed 

reports on library activity. Daily, 

Weekly, Monthly, Yearly etc. 

Issues by Borrower Type or by 

Form or Stats code. 

The Order MUST be correct! 

RepStockitem Stockitem reports Listing of items, Value of the 

collection 
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Create a Report 

1. Launch the Amlib client 

2. Go to the Reports category required – for example: Circulation Reports (Main > Reports > 

RepCirculation) 

 

3. The corresponding Reports screen will display: 
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4. Click the F1 New button – the Select Format Report table will display: 

 

5. Highlight the report you would like to use and click the Select button 

 Need help with choosing the right report? A complete list is available in the 

Appendices 

6. Your selection will appear at the bottom of the Reports table in red: 

 

7. Type in an appropriate Report Description – for example: First Overdue Notice (Letter) 
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 This is a description often serves as the heading of the report (including many 

Stockitem reports) 

 

8. Report Stats Code – it is possible to collect statistics on the number of times that this report 

is run by adding an entry into the Statistics Codes table (Main > Supervisor > StatsParams) 

and then adding the Stat Type into the Default Stats Code box 

9. Detail Stats Code (where applicable) – it is possible to collect statistics on the number of 

individual notices that a particular report generates by adding an entry into the Statistics 

Codes table (Main > Supervisor > StatsParams) and then adding the Stat Type into the 

Default Detail Stats Code box (not available for all modules) 

 For reports using the same template which already include Stats Codes, you may 

wish to add in unique Stats Code for each report to further differentiate your 

statistics – for example: 1st Overdue and Final Overdue 

 

10. If you would like the affected record to retain a record of any notice generated, then ensure 

that Create Hist (Y/N) = Y 

11. Update (where applicable) – there is often an Update column of some sort present; this 

allows the report to be used to update the status or alter a parameter of a record – for 

example: an account may be generated for an overdue circulation report 

12. Click the F3 Save button 
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Where Statement 

These are the set conditions that the report uses to determine the data to be sent from the database 

to the report template. In general, they are just search terms – for example: All borrowers, all 

borrowers except library staff, members at particular locations, etc 

A good way of getting familiar with Where statements is to perform Where searches in the Borrower 

and Stockitem modules (see below). 

1. Highlight the report in the Reports table and click the F7 Where button – the Reports - 

Where screen will display: 

 

2. You can then enter one or more search conditions: 

a. Choose Search column: The options differ between Report Categories and Report 

Types. If you’re not sure which of these is the correct one, it can help to have a look 

at the corresponding module screen you want to get information from – for 

example: the Borrower screen 

b. Choose operator – select from the following list: 

OPERATOR DESCRIPTION EXAMPLE 

LIKE Where the required data in this field 

begins with the text entered 

LIKE ELD (for Eldorado) 

LIKE Where the required data in this field does 

not begin with the text entered 

LIKE ELD (for all except Eldorado) 

IN Useful for selecting multiple codes IN A,J,YA (for all of these types) 

IN Useful for multiple codes not to be 

included 

IN ILL,LS (to exclude these types) 

= Where the text entered is exactly equal to 

the data required 

= A (borrowers with a code of A for 

Adult) 
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 Where the text entered is not equal to the 

data required 

Useful for NOT EQUAL TO NULL – choose 

this operator, do not enter any data and 

click the Paste button 

 J (borrowers who do not have a 

code of J) 

< Where the text entered is less than the 

data required 

< 01/10/10 (less than 1 Oct 2010) 

< Where the text entered is equal or less 

than the data required 

< 01/10/10 (less than or equal to 1 

Oct 2010) 

> Greater than >01/10/10 (greater than 1 Oct 2010) 

> Equal or greater than the text entered > 01/10/10 (greater than or equal to 

1 Oct 2010) 

c. Type the WHERE condition - this could be letters, numbers, dates, codes, etc (see 

also the Special button below) 

 

d. Once you have entered the Where (or Search) condition, click the Paste button – the 

condition will be added to the table at the bottom of the screen: 

 

3. You can then add in further conditions: 
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 Join conditions together using the AND and OR Boolean operands buttons.  

 Delete unwanted items by highlighting the line and clicking the Delete button 

4. Click the F3 Save button when complete 

 

 

Special Button 

The Special button can be used for a number of things including the creation of relational dates 

(dates that aren’t fixed but operate from the concept of a Current Date or the Start of Month). 

For example: if you would like to look at dates from a week ago or further back, you could enter the 

following Where condition: 

 Issue Date Due Back <= Current date – 7 Days 

1. Select Issue Date Due Back from the 1 Choose Search Column box 

2. Select the < operand from the 2 Choose Operator box 

3. Click the Special button – another Where window will open 

4. Select the Special operand from the table – for example: Current Date 

5. Adjust the relational value of the selected operand by using the + or – buttons and the Days 

or Months boxes – for example: - 7 Days 

6. An example of the expressed condition will be visible in the box at the top of the window: 

 

7. Click the Paste button when complete 
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Brackets 

Brackets can be used to group items together and it is very important that they’re used correctly. 

This screenshot is an example of a Where statement using brackets to find all Adult Fiction items 

whose barcodes begin with a particular alphanumeric range: 

 

If you ran this statement without the brackets, instead of finding items that either had an ItemNo 

starting with 3111 or ASLIB, with the Stats Code of AF, you would find every item where the ItemNo 

started with 3111 (regardless of Stats Code) and every item with the ItemNo starting ASLIB with the 

Stats Code of AF. 

To enter brackets: 

1. Select your first condition in the list that you would like to put brackets around and click the ( 

button at the top of the list 

2. Then select the last condition in the list that you would like to put brackets around and click 

the ) button at the top of the list 
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F9Order 

This feature defines the sequence of the items displayed in the report. For example, an item report 

may be printed in Call Number order if you need to find them on the shelf, or in Title order for 

another list of items. The order can be important for certain reports that require a set sequence – for 

example: Statistics Reports. 

Many of these reports have a fixed order and cannot be changed (the F9 Order button is greyed out). 

To define the sequence, select the F9 Order button. The sort options available differ between 

categories and report types. 

1. Select the report from the list and click on the F9 Order button – the Order By screen will 

display 

2. Use the arrow keys to select fields to Order By – for example: Item Call Number 

3. It is possible to have more than one option – for example: the report may be sorted by Item 

Call Number and if there are several items with the same Call Number, you can then have 

the second option to sort by Item Title 

 

4. The order can be ASCending or DESCending, with ASCending as the default. ASCending goes 

from the lowest value to the highest – for example: A to Z, 1 to 100 (Occasionally the order 

may be better DESCending, such as in a report designed to see the highest costing items) 

 
Choose the sort order. Highlight the sort option and click this button to move the 

option across to the Order By column 

 
Change the sort order. Highlight the sort option to remove in the Order By 

column, and click this button to move the sort option back 

 
Remove all the sort options by clicking this button 

5. The UP and DOWN buttons can be used to move the highlighted field up or down in sort 

priority 

6. Click on the F3 Save button when you have finished defining the order 
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F10 More 

The F10 More button provides additional parameters to allow you to apply charges, set up SMS 
functionality or map the fields to be used. 

Please Note: A report employing F10 More parameters must be run via the Scheduler. 

In this example report, we will be setting up a F10 More statement that includes additional fees: 

Set Up Overdue Fee Parameters 

1. Click the F10 More button – the More screen will display 

2. Click the F1 New or F2 Insert button 

3. Enter the following parameters: 

a. Report Line Number = 2 

b. Line 2 Fee per Item = 2.00 

c. Line 2 Fee per Notice = 5.00 

d. Line 2 Fee Print Line = Includes fees of: 

 

4. Click the F3 Save button when complete 

 COLUMN 1 COLUMN 2 COLUMN 3 COLUMN 4 COLUMN 5 

HEADING Report Line 
Number 

Line 2 Fee per 
Item $.c 

Line 2 Fee per 
Notice $.c 

Line 2 Fee Print 
Line 

Line 2 not 
Used 

EXAMPLE 2 2.00 5.00 Includes fees of: <Leave blank> 

COMMENT Line 2 is 
used to add 
Fees to 
reports 

Enter amount to 
be charged for 
each overdue 
item [Optional] 

Amount will be 
added to the 
FORM_ 
CHARGES Field 
in the Report 

Enter amount to 
be charged per 
notice (in 
addition to any 
item fee) 
[Optional] 

Amount will be 
added to the 
FORM_ 
CHARGES Field 
in the Report 

Text will be added 
to the USER_LINE1 
Field in the Report 
[Optional] 
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Edit the Template to Include Charges 

Please Note: The report template must be altered to include the following fields: FORM_CHARGES 

and USER_LINE1. 

 The new &ODFEE.QRP template includes FORM_CHARGES and USER_LINE1. 

 

The FORM_CHARGES field can be added to the total charge [Field = FORM_CHARGES] or included as 

part of a TotalCst (TotalCst+FORM_CHARGES). You can also include the field USER_LINE1 which will 

include the text you entered in the F10 More statement. 
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VIEW/PRINT REPORT 

View Report 

When your report is set up with the template, Where statement, and order, you can then preview 

the report as follows: 

1. Highlight the report and click the F8 View button 

2. The Select File for View prompt will display: 

 

3. This type of report may use a Saved File as the Source (rather than the entire database).  If 

you would like this report to use just a Saved File, click the Yes button, otherwise click the No 

button (generally users select the No button)  

4. The report will display in the Report – View screen: 

 

5.  If you wish to print a hardcopy, click on the print icon 
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Print Report (via Scheduler) 

If you only want to print a report then the quickest method is to use the F8 View button and print 

from the Report – View window (see above). 

Using the Scheduler (via the F6 Print button) has several benefits over running reports via the F8 

View button: It allows you to schedule regularly run reports so that staff do not have to do it 

manually each time, and it allows for further functions as part of the report such as updating 

Borrower/Stockitem History, updating the Reservation Status and adding report information to your 

statistics. Email and SMS reports MUST be run via the Scheduler. 

This guide will take you through setting up a report to use RepStartSchedule. 

Start the Scheduler 

1. From the Reports screen, select Application > RepStartSchedule: 

 

2. The Report Scheduler screen will display: 

 

3. Select your printing options: Ensure Printing, E-mail and/or Save to File are ticked (you can 

tick all three if you intend on printing up multiple reports using multiple formats during a 

session) 

4. Also decide If a report is scheduled by another user do you still want to print it? = Yes/No 

5. Click the OK button 



Amlib Basic Reports Manual 

 

 

Last Updated: 19 September 2014 
 Page 31 

6. After clicking OK, if you go back into the Application menu you will see that 

RepStartSchedule is now greyed out with a tick next to it – this indicates that the Scheduler is 

now running 

 

Please Note: If you need to restart the scheduler at any point, you will need to log out of all Report 

screens (Ctrl + L) and start at the beginning of these instructions. 

Scheduling the Report 

1. With your report highlighted, click the F6 Print button – the Print dialogue box will display: 

 

2. Select from the following options: 

a. From: 

 Database (to search the entire database) 

b. To: 

 Printer (to generate print reports) 

 E-mail (to generate email reports) 

 File (to save a report as a file) 

c. Frequency: 
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 Once Only (if this is the only time you’re going to print this report) 

 Daily (if you plan to send it every day) 

 Weekly (if this is a once a week item) 

 Monthly (if this is to be printed every calendar month) 

 Every ___ days (if you want to set a specific schedule 

d. Schedule: 

 First Print Date (the day you want this report to begin its schedule) 

 First Print Time (specifies the exact minutes the report will run) 

e. Selected Printer: 

 You can specify any active printer on the network to print to – including 

virtual printer drivers such as a third party software that allows you to print 

to PDF (For example: CutePDF Writer) 

3. Click the OK button when complete 

Check Print Progress 

1. You can check the progress of your reports at any time by going into Main > Reports > 

RepPrintProgress – the Print Progress screen will display: 

 

2. If your library uses the scheduler for a lot of reports, you can select a frequency type from 

the Filter drop-down menu at the top: 
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3. You can also click through the three tab options at the top to see the ones that are Waiting, 

Running, or have already been Printed: 

 

4. Your report will show up in “Printed” when it is complete 
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Additional Items 

When scheduling reports, you must remember: 

 The scheduler must be started prior to the time that reports are scheduled to run – you may 

have a procedure to start the scheduler first thing in the morning. Schedule your reports a bit 

later (for example: if you start at 8:30am, then schedule the first report for 9:30am) so that if 

there are any unforeseen delays, the print schedule will still go as normal. 

 Schedule reports with time to spare: Allow time for Amlib to be started and the scheduler to 

be started. Allow time between scheduled reports (at least 10-15 minutes) in case you need 

time to refill the printer, or something else happens. 

 Check and stock the printer before the reports are due to run: Scheduling reports that print to 

file or send e-mails are somewhat easier to manage, so you may want to try the scheduling 

with these first. If you are scheduling printed reports, ensure that the printer is full of paper, 

not low on toner and if possible have someone near the printer when the reports are due to 

run, so they can fix any paper jams quickly. 

 Check the ‘Waiting’ queue: Old reports that have not run can jam up the print queue and stop 

your scheduled reports from running. It is good practice when starting the scheduler for the 

day to check RepPrintProgress and delete out any old print jobs from the “Waiting” queue. 

 Check and maintain your “Printed” queue: A large amount of print jobs in your printed queue 

can stop your reports from running. While there is ample space in this area to store 

information on past print jobs, the space in not unlimited. If the print jobs are not deleted on a 

regular basis (perhaps quarterly or every few months) this area will eventually become too full 

to allow the reports to run. It is fine to keep some print jobs in the “Printed” area of 

RepPrintProgress. Perhaps keep the last few days or few weeks and delete the rest. How many 

reports and how often you print will determine how far back you can keep this information. 

 If scheduled reports do not run for some reason (there is a paper jam or the scheduler is not 

started, etc.) they will sit in the “Waiting” queue in RepPrintProgress and stop other reports 

from printing. If there is a delay, check the “Waiting” queue. If the reports due to run have a 

date/time next to them that has already passed, these will need to be deleted and then 

manually printed via the ‘print’ button. 

 Check before your re-run reports: If there was a delay or paper jam and you have to run a 

report for a second time, check your settings before running it. If the report creates accounts 

for very overdue items, running it a second time will generate a second charge – it is best to 

run manually via F8 View and then print from the view screen. Do the same if you are adding 

history to records or recording statistics. Reservations will require a different procedure as 

they will already have their status changed to “Printed”. 
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SAVING A REPORT TO FILE 

You can save your reports to a file, for email or formatting, or just to keep it in an electronic format 

rather than paper. The two ways of doing this are by Table or Report. 

Table 

1. Access a module and perform a search – the results will display in a List 

2. Highlight the items you would like to save to file 

3. Type Ctrl + C to copy them 

4. Open up MS Excel or Word 

5. Type Ctrl-P to paste the selection into a table or page 

 

↓ 

 

This method works best if you don’t have a large number of results. 
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Report 

There are several MS Excel report templates available which can be used to save to a file. 

In this example, we are going to use the &XSTKCSV.QRP template in the Reports > RepStockitem 

screen: 

1. Launch the Amlib client 

2. Go to Main > Reports > RepStockitem – the Stockitem Reports screen will display 

3. Click the F1 New button – the Select Report Format screen will display 

4. Highlight the &XSTKCSV.QRP file and click the Select button – a new entry will appear in the 

Stockitem Reports table 

5. Type in an appropriate Description – for example: Harry Potter Items 

6. Click the F3 Save button 

7. Highlight the report and click the F7 Where button – the Stockitem Reports – Where screen 

will display 

8. Enter an appropriate search condition(s) – for example: Title LIKE Harry Potter 

9. Click the F3 Save button 

10. Highlight the report and click the F9 Order button – the Stockitem Reports – Order By screen 

will display 

11. Use the arrow keys to add fields to the Order By column – for example: Title | ASC using the 

arrow keys 

12. Click the F3 Save button 

13. From the menu, select Application > RepStartSchedule – the Report Scheduler prompt will 

display: 

 

14. Ensure that Save to File is ticked and click the OK button 
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15. Highlight the report and click the F6 Print button – the Print screen will display: 

 

16. Change the To: option to File and click the OK button – the Report – Save As dialogue box 

will display: 

 

17. Save As options: 

a. To save it for a Word document, leave the Save as type: as Rich Text Format (RTF) 

b. To be able to open it in Excel, change the Save as type: to Text Document 

18. You can check the progress of your report in by selecting Reports > RepPrintProgress from 

the menu 

19. If you’ve saved the report to open in Excel (Text Document) then you will need to follow 

these steps so it is displayed correctly: 

a. Open MS Excel 

b. Use File > Open to open the text file you’ve saved – ensure that the Files of type: = 

All Files (*.*) 

c. The Text Import Wizard will open 
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d. Excel will recognise your file as Delimited, so click the Next button 

e. Delimiters: select Semicolon and add a pipe | in the Other box 

f. Click the Next button and then the Finish button 

 

20. Your data will be transferred into the Excel sheet and you can now use the formatting tools 

to customise it: 
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REPORTS IN OTHER MODULES 

You can create reports in other Amlib modules such as Stockitem and Borrower by getting a table of 

data. This can be done by either conducting a standard search in the main module screen, or doing a 

Where search. 

Search Size 

The number of items or borrowers that display in a table depend on the Search Size set. In the 

bottom, right hand corner of your screen you will see ?Size which will show you the current Search 

Size setting: 

 

To change the search size: 

1. From the menu, select Item > Query Settings > SetSearchSize – the Set Results Search Size 

screen will display: 
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2. Select a number (for example: 500) – the table will then close and the ?Size will have been 

updated: 

 

3. If there are more items in the results table than the Search Size set, you can go on to the 

next list by selecting Table > ContinueQuery from the menu (or by clicking the F11 button) 

 

Default Search Size 

You can adjust the default search size in Supervisor settings: 

1. Go to Main > Supervisor > Installation – the Installation (DEFAULT) screen will display 

2. (Optional) From the main menu, select  Installation > Choose Location, then select the 

location you log in as 

3. Select the System tab  

4. Scroll down to: Default search cache size = <enter an appropriate size>  – for example: 400 

 

5. Click the F3 Save button when complete 

6. Exit and restart the Amlib client for the new parameters to take effect 
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Creating a Table 

1. In whichever module you’re searching (Borrower or Stockitem) ensure that the screen is clear 

– if not clear: click the F1 Clear button 

2. Enter in your search terms (just about any field in a screen can be used to query the 

database, and you can do full stop (.) and <Tab> to bring up a list of codes, such as in the 

Stats Code field 

There are also different query options available: 

QUERY VIA 

Item Browse search for data displayed within the Stockitem module 

Cat Browse search for data displayed within the Catalogue module 

Keyword Searches any keyword within the Stockitem and Catalogue module using one of the 

six bibliographic lines available: Stockitem: Title, Author, Subject, Series, Publisher or 

Call No. Typing in the Subject line will search only Subject keywords. 

Any Searches for any keyword within the Stockitem and Catalogue module – for example: 

even if the Title line is chosen the keyword will be search in Title, Author, Subject, 

etc. 

 

3. When you have your search terms typed in, select the F5 Query button 

4. If the query finds more than one item, the results will display as a List. From this List the 

items can be viewed individually. It is possible to save the records to a file, or go to other 

applications for the items (for example: Stockitems, Authorities, Periodicals) by choosing the 

XReferences menu at the top of the screen 
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5. In this table view you can change the sequence of items from the Table > Sequence, or you 

can choose Table > Print (F6) or Table > Report (F7): 

Sequence 

1. From the List menu, select Table > Sequence – the Sort Rows prompt will display: 

 

2. You can only choose one sequence option for example: Title 

3. Click the OK button when complete – the then be reordered according to your selection 
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Print (F6) 

1. From the List menu, select Table > Print (or click the F6 key) 

2. Your result list will appear in a print table – click on the print button to print 

 

Report (F7) 

1. Highlight the items you would like to use in the report 

2. Select Table > Report (or click the F7 key) – the List Reports dialogue box will display 

3. All the available templates for that category will be displayed 

4. Select a Report – for example: Author&Title&Call (&STKTITL.QRP) 

5. Click the F9 Order button to choose the sequence of your results: 

 

6. Enter a Caption for the report – for example: Harry Potter List 
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7. Click the F8 View button – the results will appear in a Report – View window 

8. Click on the print button to print 
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WHERE SEARCH 

You can access Where searches in the Stockitem and Borrower modules by selecting Application > 

Where... (in the Stockitem module) or Application > BorrowerWhere (in the Borrower module): 

 

1. Choose Search column: it can be helpful to have a look at the main Stockitem (or 

Borrower Details) screen if you’re confused about which fields contain what information 

2. Choose Operator: these are the same as in the Reports module 

OPERATOR DESCRIPTION EXAMPLE 

LIKE Where the required data in this field 

begins with the text entered 

LIKE ELD (for Eldorado) 

LIKE Where the required data in this field does 

not begin with the text entered 

LIKE ELD (for all except Eldorado) 

IN Useful for selecting multiple codes IN A,J,YA (for all of these types) 

IN Useful for multiple codes not to be 

included 

IN ILL,LS (to exclude these types) 

= Where the text entered is exactly equal to 

the data required 

= A (borrowers with a code of A for 

Adult) 
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 Where the text entered is not equal to the 

data required 

Useful for NOT EQUAL TO NULL – choose 

this operator, do not enter any data and 

click the Paste button 

 J (borrowers who do not have a 

code of J) 

< Where the text entered is less than the 

data required 

< 01/10/10 (less than 1 Oct 2010) 

< Where the text entered is equal or less 

than the data required 

< 01/10/10 (less than or equal to 1 

Oct 2010) 

> Greater than >01/10/10 (greater than 1 Oct 2010) 

> Equal or greater than the text entered > 01/10/10 (greater than or equal to 

1 Oct 2010) 

3. Type the Where condition: this can be a date, a code, letters, numbers, etc 

BUTTON DESCRIPTION 

Paste Adds the Where condition to the Query Description table 

Special This button contains useful fields that can be used for any mathematical operand (i.e. , , 

, , , ) – for example: Current Date 

Delete Deletes the highlighted Where condition from the Query Description table 

AND Includes the AND separator to the Where conditions in the Query Description table (this is 

the default) 

OR Includes the OR separator to the Where conditions in the Query Description table 

( Adds a beginning bracket to the Where condition in the Query Description table 

) Adds a closing bracket to the Where condition in the Query Description table 

4. Once your Where condition is set up you can either: 

a. Count the number of results by clicking the F6 Count button – a prompt with the 

following message will display: XXX Stock Item(s) were found. 
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b. Get the list of results by clicking the F5 Query button – the results will then 

display in the relevant List:  

 

5. If you wanted to find ALL of something (for example: Borrower, StockItems, items on 

loan) then you could run a query such as: 

a. BarCode IS NOT NULL (all Borrowers) 

b. ItemNo IS NOT NULL (all StockItems) 

c. Issue Due Date Back IS NOT NULL (all items on loan) 

 

The NULL value is achieved by simply leaving a blank space in the field 3 Type the Where Condition 

and Press Paste – as soon as the Paste button is clicked a NULL value is entered into the Query 

Description table 

Saving a Where Search 

It is possible to save a Where search: 

1. Click the F2 Insert button – the Saved Queries table will display: 
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2. Type in a Description (for example: Chelsea Junior Fiction) and click the F3 Save button – a 

prompt with the following message will display: The Query File has been created. 

 

3. Once saved, you can access saved Where search by clicking the F4 Select button in the 

Where screen, selecting the Saved Query from the list and then clicking the F9 Select button: 

 

Query to File 

It is possible to save the Where search results to a file, which can then be used in other operations 

(including reports). 

1. After choosing your Where parameters, click the F7 QtoFile button – the Saved Query 

Results table will display: 
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2. You can either use a pre-existing list file or create a new list file:  

a. To use a pre-existing file: select a list entry from the table and click F9 Select (click F2 

Empty first if you would like to clear any pre-existing list items – look at the Qty 

column to ascertain this.).   

b. Alternatively, a new file can be added by: clicking on the F1 New button, typing in 

the Details (for example: Chelsea Fiction) and then clicking on the F3 Save button. 

Then highlight the file and click on the F9 Select button. 

3. This Saved File can now be used as part of a report or procedure 
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APPENDICES 

Appendix 1: Report Writer (RepWin30) 

The REPWIN30.EXE program used to edit reports is located on your Amlib server in the 

Drive:\Amlib\Utility folder (for example: C:\Amlib\Utility) 

You will find both the Repwin folder (containing the REPWIN30.EXE) and the REPWINSETUP.EXE 

(which you can use to install RepWin30 on a local PC). 

If you are unable to access your Amlib server for any reason, then contact Amlib Support and they 

will sent you a copy of the installer. 

To install RepWin30 on your PC: 

1. Copy the REPWINSETUP.EXE to your desktop 

2. Double-click on the REPWINSETUP.EXE – the RepWin30 Report Template Designer for Amlib 

Installer Wizard will display: 

 

3. Just follow the instructions on the Wizard to install 
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Appendix 2: Creating Spine Label Reports 

Most spine label reports require the loading of a customised spine label.  The following guide takes 

you through the entire process for loading the customised template, creating a new report, creating 

a Saved File of items to print and running the report. 

Save the Template 

 Save the template into the Amlib/Reports folder on the Amlib server.  This will make the 

template available for use for all users. Alternatively, you may save it into a local folder on 

your PC – but please be aware, that the template (once loaded) will only be available for use 

on that PC. 

 Ensure that the template is saved with a name that clearly identifies it as a customised spine 

label – for example: PRSPINE5.QRP 

Load the Template 

1. Launch the Amlib client 

2. Go to Main > Reports > RepAddNew – the Report Files screen will display 

3. From the Report Entity drop-down select: Stockitem 

4. Click the F1 New button – the Stockitem – New Report File screen will display: 

 

5. Type in a Description – for example: MyLibraryName Spine labels (5 wide) 

6. Click on the Browse button and navigate to the Amlib/Reports folder on your Amlib Server 

and locate the template to be loaded (if the template has been loaded onto your PC – then 

navigate to the local folder) 

7. Select the file and then click on the Open button 

8. Choose Type – ensure you select Spine Labels (with the matching number of columns to 

those in your template) – for example: Spine Labels 5 label wide 

9. You can leave Default Stats Code blank 
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10. Update Entity (Y/N) = N 

11. Click the F3 Update button to save the new template 

12. Close out of the Report Files window 

The template is now loaded and available for use in a Report. 

Create the Report 

1. Go to Main > Reports > RepStockitem – the Stockitem Reports screen will display 

2. Select the F1 New button – the Select Report Format table will display: 

 

3. Locate the template you just loaded via RepAddNew, highlight it and click on the Select 

button 

4. You will be returned to the Stockitem Reports screen – locate the report you just created and 

highlight it (the entry will be in bolded red and the Report Type = the Report Description of 

the template you loaded) 

 

5. The spine label settings should be typed into the Report Description field – for example: 

5,6,w,a.  DO NOT type in any other descriptive characters as this will stop the report from 

functioning correctly – your Description should be similar to that in the example above. 

The Report Description is composed of four positions using the following criteria: 

a. The first position: how many labels to ignore before printing is commenced. In the 

example there would be 5 labels missed before printing. On a 5 column wide spine 

label printout, printing would then start from the first label on the second line). To 

print on a new sheet of labels, the value would be 0. 
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b. The second position: each line has a maximum of X characters before going to the 

next line (in the example, the line would be 6 characters wide). 

c. The third position – t or w 

i. w: Wrap the remainder of the Call Number to the next line(s) 

ii. t: Truncate the remainder of the Call Number  

(The example will wrap the remainder to the next lines)  

   

591.  591. 

994994 

56890 

 994994 

SMI  SMI 

   

      w    t 

d. The fourth position: a, b or s 

i. a: Puts a full stop at the end of the line 

ii. b: Put a full stop at the beginning to the next line 

iii. s: Sets the space as the break and ignores other Punctuation 

     

591.  591  591.994 

994  .994  SMI 

SMI  SMI   

     

        a       b             s 

6. Select the F3 Save button 

Once saved the line will be bolded red as the report does not have a F7 Where search. Typically this 

report is used only with a Saved File (therefore requiring no Where search).  However, a F7 Where 

search of Received Date = Current Date could be used for those items received on that day only. 
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Wand Into File 

Items can be wanded into a selected file. This is useful if you wish to use the group of items in a 

Report (for example: Spine Labels): 

1. Go to Main > StockItems > Stockitem – the Stockitem screen will display 

2. From the menu, select File > WandIntoFile – the Wand Into File screen will display: 

 

3. Click the F4 Select button – the Stockitem Saved Query Results table will display 

4. You can either use a pre-existing list file or create a new list file:  

a. To use a pre-existing file: select a list entry from the table and click F9 Select (click F2 

Empty first if you would like to clear any pre-existing list items – look at the Qty 

column to ascertain this.).   

b. Alternatively, a new file can be added by: clicking on the F1 New button, typing in 

the Details (for example: Spine Labels) and then clicking on the F3 Save button. Then 

highlight the file and click on the F9 Select button. 
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5. This will return you to the Wand Into File screen – the name of the selected list file will now 

appear in the Saved File: field: 

 

8. You can now start wanding in items: as each item is wanded, the Barcode and Title display in 

the window (they will be automatically saved into the selected Saved File) 

9. After all the items have been wanded close the window by clicking the[ X ] in the top right-

hand corner 

Run the Spine Label Report 

1. Go to Main > Reports > RepStockitem – the Stockitem Reports screen will display 
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2. Locate the report you created as part of the Create a Report procedure above and highlight 

it 

3. Select the F8 View button – the Select Saved File stable will display: 

 

4. Select the File Name (that you wanded your items into) and click the OK button 

5. A Report - View screen will display: 

 

 The above example, shows a report starting at the first label: Report Description = 0,6,w,a 
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 The following example shows a list starting at the tenth spine label: Report Description = 

9,6,w,a 

 

6. Select the print button to print 

Please Note: When the print button is clicked, a prompt with the following message may display: 

Report margins are less than printer offsets…Text may be clipped. Continue? 

 

The message is the result of the report template having particularly narrow borders.  Users should 

click OK button and check printouts to ensure that no clipping has occurred. 

Clearing the File 

After successfully printing the spine labels, the file can be emptied, ready for the next batch. 

1. In the Stockitem module, select File > DisplayFile from menu – the Stockitem Saved Query 

Results screen will display 

2. Highlight the SPINE LABELS file and click the F2 Empty button – a prompt with the following 

message will display: Are you sure you want to remove all entries from the ‘SPINE LABELS’ 

saved file? 

3. Click the Yes button 

4. Click the F3 Save button when complete  
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Appendix 3: Reservation Reports 

Reservation Statuses 

When an item is placed on reserve, a Reservation Status is placed against that item.  The status is 

important as the reports use this status as a determinant for what to print and what not to. 

STATUS EXPLANATION 

ISSUE Item was on loan when reserved 

(reserve placed via Amlib client) 

ON LOAN Item was on loan when reserved 

(reserve placed via NetOpacs) 

SHELF Item was on shelf (available) when 

reserved 

RETURN Item has been returned AFTER 

reservation placed 

TRANSFER Item was on transfer when reserved 

ORDER Item was on order when reserved 

READY Reservation on item has been 

CANCELLED through an expiry report 

and is now ready for the next reader 

PRINTED Item was included in a scheduled 

Reservation report with Update Res 

Status = Y 
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Setting Up the Report: Pick-Up List 

If you allow reservations to be placed on items that are ON SHELF (available) at the time of the 

reservation, then you will need to create and run a report that will create a pick-up list to collect 

these items  

Create Report 

1. Launch the Amlib client 

2. Go to Main > Reports > RepReservation – the Reservation Reports screen will display 

3. Click the F1 New button – the Select Report Format screen will display: 

 

4. Highlight Reservation Pick List (wording may differ – it will be using the &RESLIST.QRP print 

template) and click the Select button 

5. Type in a Report Description – for example: Reservations Pick List  

6. If you would like the borrower record to retain a record of any notice sent, then ensure that 

Create Hist (Y/N) = Y  

7. Update Res Status  = N 

8. Click the F3 Save button  
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Where Statement  

1. Select the report from the list and click the F7 Where button – the Reservation Reports – 

Where screen will display 

2. The statement must include the following settings:  

 Only Show First in Queue (Y/N) = Y (otherwise ALL reserves on an item will show) 

 Res Item Status IN SHELF,READY (this will pick up any available or recently expired 

reservation items) 

 On Loan (Y/N) = N (this will exclude items on loan from the list) 

 (Optional) Item Perm Loc =  (enter your location code) – for example: Item Perm Loc 

= CHELSEA (where multiple locations available) 

 (Optional) Process IS NULL (paste without putting a value in 3 – this will exclude any 

items in Processing, Binding, Missing, etc) 

 (Optional) Is on Order (Y/N) = N (this will exclude any items on order) 

3. Click the F3 Save button when complete 
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Order  

1. Highlight the report from the list and click on the F9 Order button – the Reservation Reports 

– Order By screen will display: 

 

2. Use the arrow keys to select fields to Order By – for example: Item Call Number 

3. Click the F3 Save button when complete 

Print 

1. Highlight the report from the list and click the F8 View button – the Select File for View 

prompt will display with the following message: This type of report may use a Saved File as 

the Source.  Do you want to select the file now? 

 

2. Click the No button 

3. The Report – View screen will display with a list of the items 

4. (Optional) Click the print button to print the list 

Please Note: No notices will be generated to patrons nor will the Reservation Status of the item be 

altered. 
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Update Status on Items 

It is important that the items collected from the shelves should be processed (returned) before being 

set aside for collection. This allows you to do two things: 

1. Generate a collection slip to place in the item (optional) 

2. Updates the Reservation Status of the item to RETURNED 

Setting up the Report: Notices 

This is the report that generates a patron notice.  Notices can be sent in one of three formats: Letter, 

Email or SMS. Unlike the pick list, it is possible to use one report to generate ALL notices for ALL 

locations (if desired). Patron notices MUST be run via the Scheduler to update the Reservation Status 

of the item to PRINTED. 

Create Report 

1. Go to Main > Reports > RepReservation – the Reservation Reports screen will display 

2. Click the F1 New button – the Select Report Format screen will display 

3. Highlight the notice template (&RESMAIL.QRP, &RESEML.QRP or &RESSMS.QRP) you would 

like to use and click the Select button 

4. Type in a Report Description – for example: Reservation Notices 

5. If you would like the borrower record to retain a record of any notice sent, then ensure that 

Create Hist (Y/N) column = Y 

6. Ensure Update Res Status column = Y (this will prevent notices from being printed twice) 

7. Click the F3 Save button when complete 
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Where Statement: Letter 

1. Select the report from the list and click on the F7 Where button – the Reservation Reports – 

Where screen will display: 

 

2. The statement must include the following settings: 

1. Only Show First in Queue (Y/N) = Y (otherwise ALL reserves on an item will show) 

2. Res Item Status = RETURN – this status will change to PRINTED once this report is 

run, to prevent duplicate emails being sent 

3. (Optional) Res Collect Location = Temp Loc [select using the Special button] – this 

ensures that the item is at the collection location) 

4. (Optional) Res Collect Location =  (enter your location code – for example: CHELSEA) 

– this will limit the notices sent to items for collection at the selected location 

3. Click the F3 Save button when complete 
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Where Statement: Email 

Please Note: Please refer to the Email Reports guide for full details for setting up email installation 

parameters. 

1. Select the report from the list and click on the F7 Where button – the Reservation Reports – 

Where screen will display: 

 

2. The statement must include the following settings: 

 Only Show First in Queue (Y/N) = Y (otherwise ALL reserves on an item will show) 

 Res Item Status = RETURN – this status will change to PRINTED once this report is 

run, to prevent duplicate emails being sent. 

 Bor Email Address IS NOT NULL (Paste without placing a value in 3) 

 Bor Use Email (Y/N) = Y 

 (Optional) Res Collect Location = Temp Loc [select using the Special button] – this 

ensures that the item is at the collection location) 

 (Optional) Res Collect Location =  (enter your location code – for example: CHELSEA) 

– this will limit the notices sent to items for collection at the selected location 

3. Click the F3 Save button when complete 
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Where Statement: SMS 

Please Note: Please refer to the SMS Reports guide for full details. 

1. Select the report from the list and click on the F7 Where button – the Reservation Reports – 

Where screen will display: 

 

2. The statement must include the following settings: 

 Only Show First in Queue (Y/N) = Y (otherwise ALL reserves on an item will show) 

 Res Item Status = RETURN – this status will change to PRINTED once this report is 

run, to prevent duplicate emails being sent. 

 Bor Mobile/Cell Number IS NOT NULL (Paste without placing a value in 3) 

 Bor use Mobile/Cell = Y 

 (Optional) Res Collect Location = Temp Loc [select using the Special button] – this 

ensures that the item is at the collection location) 

 (Optional) Res Collect Location =  (enter your location code – for example: CHELSEA) 

– this will limit the notices sent to items for collection at the selected location 

3. Click the F3 Save button when complete 
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Order 

1. Select the report from the list and click on the F9 Order button – the Reservation Reports – 

Order By screen will display: 

 

2. Use the arrow keys to select fields to Order By – for example: Borrower Barcode 

3. Click the F3 Save button when complete 
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Appendix 4: Sample Where Statements 

Overdue Notice (Letter) 

1. Highlight the report and select the F7 Where button – the Circulation Reports – Where 

screen will display 

2. The statement must include the following settings: 

a) Issue Date Back < Current Date (via Special button) – this can be altered to suit your 

particular needs 

3. The following settings are optional: 

a) Borrower Location = CHELSEA 

b) Bor Type IN YR11, YR12 

c) If the patron has a guardian address, then this is the default address for the notice – 

to revert back to the patron address: Always use Address 1(Y/N) = Y 

d) Additionally, you may wish to limit by Bor Group and/or Bor Class 

e) If you are running email reports as well, you should enter the following: Bor Use 

Email != Y 

4. Click on the F3 Save button when complete 

Overdue Notice (Email) 

1. Highlight the report and select the F7 Where button – the Circulation Reports – Where 

screen will display 

2. The statement must include the following settings: 

a. Bor Use Email = Y 

b. Bor Email Address IS NOT NULL (Paste without placing a value in 3)  

c. Issue Date Back < Current Date (via Special button) – this can be altered to suit your 

particular needs 

3. The following settings are optional: 

a. Borrower Location = CHELSEA 

b. Bor Type IN YR11, YR12 

c. If the patron has a guardian address, then this is the default address for the notice – 

to revert back to the patron address: Always use Address 1(Y/N) = Y 

d. Additionally, you may wish to limit by Bor Group and/or Bor Class 

4. Click on the F3 Save button when complete 
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Reservations Pick List 

1. Select the report from the list and click the F7 Where button – the Reservation Reports – 

Where screen will display 

2. The statement must include the following settings:  

a. Only Show First in Queue (Y/N) = Y (otherwise ALL reserves on an item will show) 

b. Res Item Status IN SHELF,READY (this will pick up any available or recently expired 

reservation items) 

c. On Loan (Y/N) = N (this will exclude items on loan from the list) 

d. (Optional) Item Perm Loc =  (enter your location code) – for example: Item Perm Loc 

= CHELSEA (where multiple locations available) 

e. (Optional) Process IS NULL (paste without putting a value in 3 – this will exclude any 

items in Processing, Binding, Missing, etc) 

f. (Optional) Is on Order (Y/N) = N (this will exclude any items on order) 

3. Click the F3 Save button when complete 

Reservations Notice (Letter) 

Please Note: This report must be run via the Scheduler 

1. Select the report from the list and click on the F7 Where button – the Reservation Reports – 

Where screen will display 

2. The statement must include the following settings: 

a. Only Show First in Queue (Y/N) = Y (otherwise ALL reserves on an item will show) 

b. Res Item Status = RETURN – this status will change to PRINTED once this report is 

run, to prevent duplicate emails being sent 

c. (Optional) Res Collect Location = Temp Loc [select using the Special button] – this 

ensures that the item is at the collection location) 

d. (Optional) Res Collect Location =  (enter your location code – for example: CHELSEA) 

– this will limit the notices sent to items for collection at the selected location 

3. If you are running email reports as well, you should enter the following: Bor Use Email != Y 

4. Click the F3 Save button when complete 
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Reservations Notice (Email) 

Please Note: This report must be run via the Scheduler 

1. Select the report from the list and click on the F7 Where button – the Reservation Reports – 

Where screen will display 

2. The statement must include the following settings: 

a. Only Show First in Queue (Y/N) = Y (otherwise ALL reserves on an item will show) 

b. Res Item Status = RETURN – this status will change to PRINTED once this report is 

run, to prevent duplicate emails being sent. 

c. Bor Email Address IS NOT NULL (Paste without placing a value in 3) 

d. Bor Use Email (Y/N) = Y 

e. (Optional) Res Collect Location = Temp Loc [select using the Special button] – this 

ensures that the item is at the collection location) 

f. (Optional) Res Collect Location =  (enter your location code – for example: CHELSEA) 

– this will limit the notices sent to items for collection at the selected location 

3. Click the F3 Save button when complete 

History Report (Borrower or Stockitem) 

1. Select the report from the list and click on the F7 Where button – the Reports – Where 

screen will display 

2. The statement can include the following settings: 

a. History Type = ISSUE 

You can use ISSUE, RENEW OR RETURN 

(Use the Paste button to insert the parameter into the list at the bottom of the 

screen) 

b. If using History Type = Issue, you may want to exclude any alterations made to the 

due date after renewals: History Contents NOT LIKE Due Date Altered 

c. Enter a start date: History Date >= enter a date in DD/MM/YYYY format – for 

example: 01/01/2010 

d. Enter a finish date: History Date <= enter a date in DD/MM/YYYY format – for 

example: 10/10/2010 (a finish date is optional – if not inserted, the report will go up 

to the current date). 

e. You may want to add other restrictors – for example: Borrower No = 

3. Click the F3 Save button when complete 

Audit Report 

1. Select the report from the list and click on the F7 Where button – the Reports – Where 

screen will display 
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2. There are three audit types:  

 D: Deleted 

 I: Inserted 

 U: Updated 

3. The statement can include the following settings: 

a. Enter an Audit Type – for example: Audit Type (I/U/D) = I 

b. Enter a start date: Audit Date >= enter a date in DD/MM/YYYY format – for example: 

01/01/2010 

c. Enter a finish date: Audit Date <= enter a date in DD/MM/YYYY format – for 

example: 10/10/2010 (a finish date is optional – if not inserted, the report will go up 

to the current date). 

d. You may also want to limit by Location, Borrower Type, etc. 

4. Click the F3 Save button when complete 

Statistics Report 

Please Note: For this report, the TransType = the Stats Types in the Statistics Codes table (Main > 

Supervisor > StatsParams): 

 

1. Select the report from the list and click on the F7 Where button – the Statistics Reports – 

Where screen will display 

2. The statement can include the following settings: 

a. Enter an Trans Type – for example: Trans Type (Issue,Ret) IN 5,6,7,10 

 These are the Stats Types for Issues, Renewals, Borrower Visits and Returns 

in the Statistics Codes table (see below) 
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 You can access the complete list of Statistics Codes in the Supervisor module: 

Main > Supervisor > StatsParams 

b. Enter a start date: Trans Date >= enter a date in DD/MM/YYYY format – for example: 

01/01/2010 

c. Enter a finish date: Trans Date <= enter a date in DD/MM/YYYY format – for 

example: 10/10/2010 (a finish date is optional – if not inserted, the report will go up 

to the current date). 

d. You may also want to limit by Location, Borrower Type, etc 

3. Click the F3 Save button when complete 

Authority Report 

1. Select the report from the list and click on the F7 Where button – the Reports – Where 

screen will display 

2. There are four parameters:  

 Key: Check for particular data contained in the MARC tag 

 Tag: Search for a particular MARC tag 

 Oper: User logged in when Authority was created 

 Date 

3. The statement can include the following settings: 

a. Tag – for example: Tag = 245 (Title) 

b. Key – for example:  Key LIKE Harry Potter (looks for all matching items where the 

Title BEGINS with Harry Potter) 

c. Oper – for example: Oper= STAFF (looks for all Authorities entered by users logged in 

as STAFF) 

d. (Optional) Enter a start date: Date >= enter a date in DD/MM/YYYY format – for 

example: 01/01/2010 

e. (Optional) Enter a finish date: Date <= enter a date in DD/MM/YYYY format – for 

example: 10/10/2010 (a finish date is optional – if not inserted, the report will go up 

to the current date). 

4. Click the F3 Save button when complete 

Bibliographic Report 

1. Select the report from the list and click on the F7 Where button – the Reports – Where 

screen will display 

2. There are three unique parameters:  

 Auth Tag: Search for a particular MARC tag 
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 Auth Key: Check for particular data contained in the MARC tag 

 Tags to Display: MARC tags to display in report 

3. The statement can include the following settings: 

a. Auth Tag – for example: Auth Tag = 245 (Title) 

b. Auth Key – for example:  Auth Key LIKE Harry Potter (looks for all matching items 

where the Title BEGINS with Harry Potter) 

c. Tags to Display – for example: Tags to Display IN 100, 245 (will display Author and 

Title in report) 

d. (optional) Enter a start date: Date >= enter a date in DD/MM/YYYY format – for 

example: 01/01/2010 

e. (optional) Enter a finish date: Date <= enter a date in DD/MM/YYYY format – for 

example: 10/10/2010 (a finish date is optional – if not inserted, the report will go up 

to the current date). 

f. You may also want to limit by Catalogue Number(s) 

4. Click the F3 Save button when complete 
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Appendix 5: Sample F10 More Statements 

Bibliographic 

This function is used for mapping data to fields in Fixed Layout reports – for example: the DVD Cover 
template (&DVDCOV.QRP). 

Each row of this table may be used to collect 1 of the 20 fields on the report template. These first 20 
fields contain Tag or Subfield data (Fields 1-20), and the next 20 fields (Fields 1A – 20A) contain the 
associated Tag Descriptions (Go to Main > Authorities > MarcTags to see a complete list of Tag Nos 
and Tag Descriptions). The report outputs all the MARC data to the report. The inclusion of Fields 1A 
– 20A in the report is optional. 

The table below explains how the user can specify which parts of the MARC tag to send: 

OPERATOR DESCRIPTION EXPLANATION 

blank (Default) The entire MARC tag is printed If the column is left blank, then the entire 
MARC tag is printed 

+ All data in the specified tag is 
printed no matter how many tags 
are included in the record  

All Subject listings are printed, where 
there is only one or several or hundreds! 

and sf in ('p', 'n') Only the subfields specified to be 
printed within this Authority Tag 

If 490 | Series statement tag, only the 

Series name and number printed 

and cat_sf in ('c') Only the subfields specified to be 
printed within this Non-Authority 
Tag 

If 260 | Publisher tag, only the 'c' (Date) 

subfield printed (and not Place or 

Publisher) 

 COLUMN 1 COLUMN 2 COLUMN 3 COLUMN 4 COLUMN 5 

HEADING Report Line 
Number 

Tag Number eg + or blank 
or and sf in 
('a', 'b') 

blank or and 
cat_sf in ('a', 
'b') 

Not used 

EXAMPLE 1 100    

2 245    

3 082    

4 650    

COMMENT Can be any 
number 
between 1 
and 20 

MARC Tag field 
number – for 
example: 245 
(Title) 

Any Tag can be 
matched to any 
Line Number 

Specify which 
part of the MARC 
tag to send - see 
table below for 
more details 

Specify which 
part of the MARC 
tag to send - see 
table below for 
more details 
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A fixed layout template displaying the Tag (or Subfield) data (Fields 1-20), and Tag Descriptions 

(Fields 1A – 20A): 

 

  

FIELDS 1A – 20A 

display Tag 

Descriptors held in 

Main > Authorities > 

MarcTags 

FIELDS 1 – 20 display 

the actual data for 

the relevant Marc 

Tags held in the 

Authority Module 
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Borrower 

There are several different F10 More functions depending on the type of template selected. 

 

Circulation 

 COLUMN 1 COLUMN 2 COLUMN 3 COLUMN 4 COLUMN 5 

HEADING 
(Borrower  
Automatic 
Update Report) 

Report Line 
Number 

Column New Value Send Memo Address 3 

EXAMPLE 1 S BA Y <leave blank> 

 2 <leave blank> <leave blank> <leave blank> Y 

COMMENT Line 1 is used 
for updates 

Line 2 is used to 
delete 
Borrower 
address 3 

Borrower field – 
can be 
Borrower Types 
(T), Classes (C) 
Groups (G) or 
Status (S) 

The new value – 
must be a valid 
code for the 
selected column 

If Y, create the 
memo in Text 
for Letter, 
found at the top 
of the Borrower 
Reports screen 

If Y, can be used 
to delete 
Address 3 
(Guardian 
Address) from 
Borrower 
record 

HEADING 

(Borrower 

Financial  

Report) 

Report Line 

Number 

Line 1 – field 1 

deletion 

reference no. 

from report of 

marked for 

delete trans. 

Line 1 Field 2 

– Cutoff date 

< format 

dd/mm/yyyy 

Not used Not used 

EXAMPLE 1 500 01/10/2010 <leave blank> <leave blank> 

COMMENT Line 1 is used 
for deletions 

 

 

If no Date is 
entered the 
Deletion will 
take place 
regardless of 
Date 
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 COLUMN 1 COLUMN 2 COLUMN 3 COLUMN 4 COLUMN 5 

HEADING Report Line 
Number 

Line 1 account 
history NAME 

Line 1 overdue 
history NAME 

Line 1 Financial 
record NAME  

Line 1 Fees type 
name 

EXAMPLE 1 OVFINACC OVDFINAL OVDUEACC OVDUEFEE 

COMMENT Line 1 is used 
for History 
and Financial 
reporting 
purposes 

If left blank, the 
system will put a 
Report Type of 
ACCOUNT in the 
Borrower History 
window if Create 
Hist (Y/N) = Y and 
Create Acc (Y/N) = 
Y and the report 
run via the 
Scheduler. 

It is possible to 
specify your own 
name – see 
example (max: 8 
chars). 

Can use to specify 
1st, 2nd, etc 
overdue – for 
example:  
OVDUE1,OVDUE2 

If left blank, the 
system will put a 
Report Type of 
OVERDUE in the 
Borrower History 
window if Create 
Hist (Y/N) = Y and 
Create Acc (Y/N) = 
N and the report 
run via the 
Scheduler. 

It is possible to 
specify your own 
name – see 
example (max: 8 
chars). 

Can use to specify 
1st, 2nd, etc 
overdue – for 
example:  
OVDUE1,OVDUE2 

If left blank, the 
system will put a 
Financial Type of 
OVERDUE in the 
Borrower Financial 
window indicating 
the (replacement) 
Cost for overdue 
items if Create Acc 
(Y/N) = Y and the 
report run via the 
Scheduler. 

It is possible to 
specify your own 
name – see 
example (max: 8 
chars). 

Please Note: 
Customer-defined 
Financial record 
NAMES must also 
be defined in the 
Circulation 
Financial Types 
screen. 

If left blank, the 
system will put a 
Financial Type of 
FEE in the 
Borrower 
Financial window 
for reports that 
have a 
FORM_CHARGES 
field in the report 
(see example 2) if 
Create Acc (Y/N) = 
Y and the report 
run via the 
Scheduler. 

It is possible to 
specify your own 
name – see 
example (max: 8 
chars). 

Please Note: 
Customer-defined 
Financial record 
NAMES must also 
be defined in the 
Circulation 
Financial Types 
screen. 

HEADING Report Line 
Number 

Line 2 Fee per 
Item $.c 

Line 2 Fee per 
Notice $.c 

Line 2 Fee Print 
Line 

Line 2 not Used 

EXAMPLE 2 2.00 5.00 Includes fees of: <Leave blank> 

COMMENT Line 2 is used 
to add Fees 
to Reports 

Enter amount to 
be charged for 
each overdue item 
[Optional] 

Amount will be 
added to the 
FORM_ 
CHARGES field in 
the Report 

Enter amount to 
be charged per 
notice (in addition 
to any item fee) 
[Optional] 

Amount will be 
added to the 
FORM_ 
CHARGES field in 
the Report 

Text will be added 
to the USER_LINE1 
field in the Report 
[Optional] 
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HEADING Report Line 

Number 

Line 3 SMS Line 3 SMS 

Message 

Line 3 Email 

Address 

Line 3 Y or N to 

Delete file 

EXAMPLE 3 SMS SMS Overdue 

Notice 

sms@smsservic

e.com 

N 

COMMENT Line 3 is used 

for SMS 

reports 

Always SMS Message body – 

becomes the 

message in the 

email (50 chars) 

The email address 

of the SMS-

messaging service 

(50 chars) 

After Sending, 

delete created 

File - Y or N 
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Reservations 

  

 COLUMN 1 COLUMN 2 COLUMN 3 COLUMN 4 COLUMN 5 

HEADING Report Line 
Number 

Line 1 account 
history NAME 

Line 1 reserve 
history NAME 

Line 1 Financial 
record NAME  

Line 1 Res Fees 
type name 

EXAMPLE 1 RESVACC RESVLET RESVACC RESVFEE 

COMMENT Line 1 is used 
for History 
and Financial 
reporting 
purposes 

If left blank, the 
system will put a 
Report Type of 
ACCOUNT in the 
Borrower History 
window if Create 
Hist (Y/N) = Y and 
Set to Y for create 
account = Y (on 
Line 2) and the 
report run via the 
Scheduler. 

It is possible to 
specify your own 
name – see 
example (max: 8 
chars). 

If left blank, the 
system will put a 
Report Type of 
RESADV in the 
Borrower History 
window if Create 
Hist (Y/N) = Y and 
Set to Y for create 
account = N or left 
blank (on Line 2) 
and the report run 
via the Scheduler. 

It is possible to 
specify your own 
name – see 
example (max: 8 
chars). 

If left blank, the 
system will put a 
Financial Type of 
RESADV in the 
Borrower Financial 
window for 
overdue items if 
Set to Y for create 
account = Y and 
the report run via 
the Scheduler. 

It is possible to 
specify your own 
name – see 
example (max: 8 
chars). 

Please Note: 
Customer-defined 
Financial record 
NAMES must also 
be defined in the 
Circulation 
Financial Types 
screen. 

If left blank, the 
system will put a 
Financial Type of 
FEE in the 
Borrower 
Financial window 
for reports that 
have a 
FORM_CHARGES 
field in the report 
if  Set to Y for 
create account = 
Y and the report 
run via the 
Scheduler. 

It is possible to 
specify your own 
name – see 
example (max: 8 
chars). 

Please Note: 
Customer-defined 
Financial record 
NAMES must also 
be defined in the 
Circulation 
Financial Types 
screen. 

HEADING Report Line 
Number 

Line 2 Fee per 
Item $.c 

Line 2 Fee per 
Notice $.c 

Line 2 Fee Print 
Line 

Line 2 Set to Y 
to create 
account 

EXAMPLE 2 2.00 5.00 Includes fees of: Y 

COMMENT Line 2 is used 
to add Fees 
to Reports 

Enter amount to 
be charged for 
each overdue item 
[Optional] 

Amount will be 
added to the 
FORM_ 
CHARGES Field in 
the Report 

Enter amount to 
be charged per 
notice (in addition 
to any item fee) 
[Optional] 

Amount will be 
added to the 
FORM_ 
CHARGES Field in 
the Report 

Text will be added 
to the USER_LINE1 
Field in the Report 
[Optional] 
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HEADING Report Line 

Number 

Line 3 SMS Line 3 SMS 

Message 

Line 3 Email 

Address 

Line 3 Y or N to 

Delete file 

EXAMPLE 3 SMS SMS Overdue 

Notice 

sms@smsservic

e.com 

N 

COMMENT Line 3 is used 

for SMS 

reports 

Always SMS Message body – 

becomes the 

message in the 

email (50 chars) 

The email address 

of the SMS-

messaging service 

(50 chars) 

After Sending, 

delete created File - 

Y or N 
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Add the User-Defined Financial Record and Fees Type Names to the Circulation Transactions Types 

(RepCirculation and RepReservations Only) 

Please Note: Any user-defined names in column 4 and 5 (Line 1 Financial record NAME and Line 1 

Fees type name) in the F10 More screen must also be added to the Circulation Transaction Types 

table. 

1. Go to Main > Finance > CircFinTypes – Circulation Transaction Types screen will display: 

 

2. To add a new Transaction Type: 

a. Click the New or Insert button 

b. Trans Type – type in the user-defined name – for example: OVDUEACC or OVDUEFEE 

c. Transaction Description – for example: Overdue Account or Overdue Fee 

d. CR or DB = DB 

e. Click the Save button when complete  
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Appendix 6: Setup Email 

Supervisor Parameters 

To begin, some settings need to be set in the Supervisor module (this need only be done once): 

1. Launch the Amlib client 

2. Go to Main > Supervisor > Installation – the Installation (DEFAULT) screen will display 

3. Select the Other tab 

4. Scroll down set the following: E-mails are sent using the following method:  (M)API or 

(I)nternal or (S)MTP. Set to S, I or M 

 

Generally (S) SMTP is recommended, especially as it is simple and it has advantages over the 

others. It also means that the email client does not need to be open on the PC running the 

notices and allows greater flexibility with regard to setting up “from” and BCC/CC 

parameters. 

 

Then the following parameters should also be set (a full table is included below): 

 SMTP Blind Carbon Copy e-mail address: you can specify the BCC address to send a copy of 

all notices (so that you can verify that they have been sent) 

 SMTP sender e-mail address: the email address to display on the notice sent to the borrower 

(For example: enquiries@amlib.com.au,  it can be the same as the BCC address) 

 SMTP Server name: the address of the SMTP mail server being used. This might be a server 

address or an IP address 

mailto:enquiries@amlib.com.au
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5. Click the F3 Save button when complete 

6. Exit and restart the Amlib client to allow the settings to take effect 

The complete set of parameters to consider: 

DESCRIPTION EXPLANATION EXAMPLE 

Emails are sent using the 

following methods (M)API, 

(I)nternal or SMTP 

Generally (S) SMTP is recommended, 

especially if the organisation is not using a 

Microsoft Exchange Server. It also means 

that the email client does not need to be 

open on the PC running the notices AND can 

display the “from” name from one of the 

parameters below rather than the email 

address from the email client. 

Set to S, I or M 

SMTP Blind Copy e-mail 

address 

Optional: If using the SMTP for emails. Enter 

only if copies of the email are to sent to a 

chosen email address – for example: Testing 

purposes 

library@amlib.com 

SMTP sender e-mail 

address 

Optional: If using the SMTP for emails, enter 

the Address you wish to indicate as the 

sender 

enquiries@amlib.com.au 
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SMTP server login (Optional) From your Systems Administrator 

if required 

 

SMTP Server name or IP 

address 

If using the SMTP for emails, enter the 

Server Name or IP Address of the Server 

installed with the e-mail communication 

protocol, responsible for receiving and 

forwarding email messages 

ServerName – for 

example: 

 server.amlib.com.au 

SMTP server password (Optional) From your systems administrator 

if required 

 

SMTP server requires a 

login? 

If Y, supply a SMTP server logon and 

password 

If N, leave SMTP server logon and password 

blank 

Y/N 

The above tasks create Sender and BCC for ALL emails generated by the system.  However, it is 

possible to set up separate SMTP parameters (Sender and CC) for individual locations, modules and 

reports. 

Setup Individual Email Systems by Location 

1. In any Installation screen module, select Installation > Choose Location from the menu – the 

Locations prompt will display 

2. Select a Location and click the OK button – the Installation screen for that Location will 

display 

3. Repeats steps 3-5 above:  if you would like to use the DEFAULT settings, then the relevant 

fields for each location should be left blank 

4. Once complete, you must exit and restart the Amlib client to allow the settings to take effect 

Setup Individual Email Locations, Modules and Reports 

We recommend leaving the email set-up for particular locations until after initial testing has been 

completed. Once the initial testing has been done, then: 

1. In any Supervisor module, select Library Menu > LocRepSMTP from the menu – the SMTP 

Parameters by Location screen will display 

2. Select the F1 New or F2 Insert button 

3. Using the drop-down boxes available in each column, select the Location, Report Screen, and 

Report Type 

4. Then type in the individual Sender’s Email and Carbon Copy Email addresses 

5. Click the F3 Save button when complete 

6. Exit and restart the Amlib client to allow the settings to take effect 
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Borrower Settings 

For borrowers to receive their overdue notices via email, the borrower record will need to have the 

following: 

 

 Email address – for example: richard.dawkins@oclc.org 

 Use for Notices = Y (for Yes) 
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Report Settings 

When creating an Overdue or Reservation email report, the following two settings must be included 

in the F7 Where parameters: 

 Borrower Email Address NOT NULL (Paste without a value in 3 to get a NULL value) 

 Bor Use Email = Y 

 

Appendix 7: Manage Email Attachments 

Reports with the option to send attachments via e-mail will have the Manage Email Attachments 

button enabled (button text is bolded). 

 

E-mail attachment parameters must first be set up in Supervisor settings.  Once the correct template 

is selected, attachments such as MS Word documents can be sent with the e-mail messages. 
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Supervisor Settings 

1. Launch the Amlib client 

2. Go to Main > Supervisor > Installation – the Installation (DEFAULT) screen will display 

3. Select the Other tab 

4. Scroll down and enter the E-mail Attachment Path = file path to your e-mail attachments. ALL 

e-mail attachment files must be saved to this location 

5. Enter the E-mail Maximum Attachment Size = maximum size of attachments in Kb (1Mb = 

1024 Kb) 

6. Click the F3 Save button when complete 

 

7. Make sure to copy these settings to your other locations – select Installation > Advanced 

Copy – the Advanced Parameter Copy screen will display: 

a. Parameter Set  = Other 

b. Tick the E-mail Attachment Path and E-mail Maximum Attachment Size (kb) 

parameters 

c. Click the Select All button adjacent to the Destination Location(s) box 

d. Click the F6 Copy button 

e. Click the Done button 
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8. Exit and restart the Amlib client to allow the settings to take effect 

Create the Report 

1. Go to Main > Reports > RepBorrower or RepCirculation – the Reports screen will display 

2. Create the report – for example &N1ADDEM.QRP (see separate individual procedures for 

more information about creating email reports) 
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Adding the Attachment 

1. Highlight the report to which you would like to add an attachment 

2. Select the Manage Email Attachments button – the Manage Email Attachments screen will 

display: 

 

3. The attachment path set in Main > Supervisor > Installation will be visible in the Attachment 

Path field 

4. Click the F1 New button – the Select File to Attach prompt will display: 

 

5. Browse to the location of the attachment folder, select the file and click the Open button 

6. The document name will appear in the File Name box (with an arrow next to it) 

 

7. Click the F3 Save button (the arrow will disappear once saved) 
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8. To add further attachments, repeat 4 – 7 above 

Please Note: The size restriction set previously in Main > Supervisor > Installation refers to the 

maximum size allowed for an attachment or the total size of ALL the attachments (if there are 

multiple attachments). 

9. To delete attachments: highlight the attachment you wish to delete and click the F4 Delete 

button 

 

10. Once the list of attachments is complete, ensure that you click the F3 Save button to save 

your changes – close out of the screen by clicking the [ X ] in the corner 

Email Text (RepBorrower Only) 

 When sending an Email Letter to Borrower (&N1ADDEM.QRP) with attachment(s) in 

RepBorrower it is possible to send some accompanying text (see Appendix 8: Text for Letter) 

Running the Report 

 This report MUST be run via the Scheduler 
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Appendix 8: Text for Letter (RepBorrower) 

The Text for Letters button can be used to add text to the Letter to Borrower (&N1ADD10.QRP) and 

Email Letter to Borrower (&N1ADDEM.QRP) templates. The Text for Letters function can also be 

used to populate borrower update memos. 

1. Go to Main > Reports > RepBorrower – the Borrower Reports screen will display: 

 

2. Highlight the report you are using, and select the Text for Letter button – the Letter Text 

dialogue box will display: 

 

3. Type (or copy and paste) in your text 

4. Select the F3 Save button when complete – then close out of the screen by clicking on the 

red cross 
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Please Note: When sent, your chosen text will appear in the body of the message: 
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Appendix 9: List of Report Templates in Amlib 

For a full list of Report Templates available please refer to the 'List of Amlib Reports Installed with 

New Versions' guide available on the OCLC Website, 

Amlib>Documentation>How to Guides Documentation>Reports, Miscellaneous 

https://www.oclc.org/support/services/amlib/documentation/how-to-guides-

documentation/reports.en.html 

(Contact Amlib Support if you require a login to this website or assistance with the selection of a 

report template)  

https://www.oclc.org/support/services/amlib/documentation/how-to-guides-documentation/reports.en.html
https://www.oclc.org/support/services/amlib/documentation/how-to-guides-documentation/reports.en.html


Appendix 10: Operators 

OPERATORS 

For Reports & 

Where Searches 

LIKE LIKE IN IN =  < < > > F12 

Begins 

with 

 

 

 

Does not 

begin with 

Include these 

multiple 

codes e.g. J,A 

Do not 

Include 

these 

multiple  

codes 

Equal 

to… 

Not 

Equal 

to… 

Less 

than 

Less than 

or Equal to 

Greater 

than 

Greater 

than or 

Equal to 

PRINT 

SCREEN 

 


