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OVERVIEW 

Catalogue records store the bibliographic details of the items within a given collection. As such they 

allow users to search for and identify works within a collection grouped by author, title, subject, etc.  

The Authorities and Stockitem modules are closely linked with the Catalogue module. 

The Authorities module is responsible for the availability, maintenance and format of the Authorities: 

MARC tag listings (comprised of such things as authors, titles and subjects) that are standardized to 

ensure the consistency of the data between catalogue records. These Authorities are searched from 

the Catalogue module for insertion into a Catalogue record. 

The Stockitem represents the holdings (the individual copies of an item) and can display Catalogue 

data according to the certain pre-defined display parameters. Whilst it is possible to create a 

Stockitem record that does not use a Catalogue record as the source of its bibliographic data, the 

Stockitem record without a Catalogue record to reference cannot be keyword searched. For 

example: an Inter-Library Loan usually has no Catalogue record attached, so Keyword searching is not 

possible because there are no underlying MARC tags.  

When creating new Catalogue records, Amlib allows the import of MARC records from external 

agencies (for example: SCIS, State Library of WA, Libraries Australia, etc). Import is also available 

from the CatZServer (subject to copyright). 

Functionality includes the manual creation of records from a Worksheet, as a Lead Thru Set, 

Duplicate or as a record built up from scratch.  

 

  Catalogue 
Record necessary for 

searching comprised of 

multiple MARC tags 

Stockitems 
Individual issue details 

Necessary to 

loan/circulate items 

Authorities 

Ensures consistency of 

MARC tag data in 

Catalogue records 



 

AUTHORITIES CATALOGUE STOCKITEM 

Authority Control: 

 Maintains consistency 

Standards for : 

 Authors 

 Subject headings 

 Series, etc 

 Keyword codes assigned to MARC Tags 

MARC Tags: 

 Creation 

 Maintenance 

 Format (for example: hyphen in Subject 

headings) 

 See and See Also References 

 

 

Bibliographic Data: 

 Contains data fields that identifies the 

Catalogue record 

 Made up of MARC Tags 

Authority Shared: 

Usually searched within the Authorities module to 

maintain consistency 

 Authors (100) 

 Added Authors (700,710) 

 Subject headings (600 – 699) 

 Series, etc (440, 490) 

Authority Non-Shared: 

 ISBN (020) 

 Title (245) (usually) 

 Added Title (740) 

Non-Authority Tags: 

 Notes (500 – 599) 

 Publisher (260) (usually) 

 Extent (300) 

Holdings Data: 

 Contains data fields that identifies the 

Item record 

 Displays 6 lines of bibliographic data from 

the Catalogue record (usually Title, 

Author, Publisher, Series/ISBN, Subject, 

Call No)as determined by the F9 Display 

parameters in the Form Codes screen 

Other data includes: 

 Barcode (Item No) 

 Cost 

 Date Accessioned 

 Date Received 

 Form code 

 Location 

 Floor Location 

 Process (for example: Missing) 

 Stats Code 

 



 

PARAMETERS 

Supervisor 

Installation: Catalogue Defaults 

It is possible for Amlib to use certain MARC tags (for example: 020 | ISBN) for duplicate checking 

purposes. This is especially important when importing records (where a lack of matching can result in 

unwanted duplicate records). 

1. Launch the Amlib client 

2. Go to Main > Supervisor > Installation – the Installation (DEFAULT) screen will display 

3. Select the Catalogue tab: 

 

4. Type the desired settings into the Value column (see the following list for parameters to 

adjust) 

5. Click the F3 Save button when complete 

6. Exit and restart the Amlib client for these settings to take effect 
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FIELD EXPLANATION EXAMPLE 

A Marc record exists if 
one of the following 
tags match 

 

(Found in DEFAULT 
screen only) 

A check is made for existing data matching the Tag 
numbers entered with the importing data. Note: ISBN 
has 2 modes when dealing with Multiple ISBNs. If the 
020 Tag is included, Amlib will look at all the ISBN’s 
within an incoming record and match as required 

001 020 022 

Match any: 
Enter only 
one ISBN 
Tag No in 
the Value 
column 

The ISBN/s of the existing record must 
match one of the multiple ISBN’s 
within the incoming record for it to be 
considered existing – for example: 
when the Import file has 2 ISBNs and 
the existing Catalogue has only 1 (or 
more) a match will occur if at least 
one ISBN matches   

001 020 022 

Match 
exact: 
Enter the 
number of 
020s to 
match the 
incoming 
with the 
existing 

The ISBN/s of the existing record must 
match with the same number of 
(multiple) ISBN’s entered here. If ALL 
the ISBNs match with those in the 
incoming record, it will be considered 
existing  

The record from the input file with 
multiple ISBN's must match ALL the 
existing catalogue ISBN's  (for 
example: 001 020 020), so if the 
incoming record has 2 ISBNs a match 
with an existing record will take place 
only if BOTH ISBNs match 

001 020 020 022 

Allow Catalogues to be 
restricted from 
viewing in NetOpacs 
(Y/N) 

N The Opac View Restriction (Y/N) default within 
the Catalog screen will be set to N and the 
checkbox cannot be edited  

Y 

Y The Opac View Restriction (Y/N) default within 
the Catalog screen will be set to N but the 
checkbox can be edited 

Allow tags to be 
sequenced anywhere 
within a Catalogue 
(Y/N) 

N The Marc Tags in the Display section of Catalog 
screen can only be moved within the Tag No 
and not anywhere else. The Arrows will be 
inactive once the end of the section is reached 

If set to N, the order of the 
Tags in a particular section 
(the example: 650), can be 
altered but not beyond the 
650 section. If set to Y, the 
order of the Tags can be 
set anywhere on the 
display – for example: a 
650 Tag could display 
above the 020 Tag. 

Y The Marc Tags in the Display section of Catalog 
screen can be moved anywhere in the record. 
The Arrows will be active to move to any Tag 
sequence 

Automatically 'Show' 
the Catalogue details 
after a Search (Y/N) 

Y When the Catalog screen displays: always 
display the full Bibliographic data for the 
Catalogue record, rather than the User clicking 
the Show button on the Screen 

Y 

N When the Catalog screen displays: the User will 
need to click the Show button or choose 
Catalogue > ShowAsDefault from the Catalog 
menu, to display the full Bibliographic data for 
the Catalogue record  
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Automatically 'Tick' 
the Worksheet button 
in Catalogue Create 
(Y/N) 

Y Set the Default to have the Worksheet 
displayed for Catalogue creation 

Y 

N The Default is not set to Worksheet and the 
user may click the Worksheet button if it is 
required 

Catalogue deletion 
level (1-4) (1=least 
severe, …, 4=most 
severe) 

When catalogues are deleted, all the Non-
Authorities are automatically deleted. The levels 
below only apply to the Authorities that were 
attached to the Catalogue that is to be deleted.  

Levels 1, 3 and 4 also delete the non-preferred 
Authority if the preferred authority is not attached 
to a catalogue.  Level 1 does this because a unique 
authority should not have anything seeing it. 

1 

Level 1: (Least SEVERE) The Authority will only be deleted if it is: 

 Not attached to any other Catalogue 

 A unique Authority 

Level 2: The Authority won't be deleted if it: 

 Is attached to any other Catalogue record 

 Is Seen By another Authority 

 Has a See Also reference to another Authority 

 Is Seen Also By another Authority 

Level 3: The Authority won't be deleted if it: 

 Is attached to any other Catalogue record 

 Has a See Also reference to another Authority that is attached any other 
Catalogue record 

 Is Seen Also By another Authority that is attached to any other Catalogue 

Level 4: (Most SEVERE) The Authority won’t be deleted if it: 

 Is attached to any other Catalogue 

Default for catalogue 
Opac Restrict (Y/N) 

Enable the Catalogue Restriction for the OPAC (as 
opposed to NetOpacs) to be set. Most sites would 
set this to N 

N 

Display Tag 
Description in 
Catalogue instead of 
Tag No 

Y Displays a Description rather than a Marc Tag 
number – for example: Topical Subject Heading 

The Descriptions are set in Main > Authorities > 
MarcTags 

N 

N Displays the Marc Tag number – for example: 
650 
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Enter % to adjust price 
on item on Marc 
Import (eg 10 = +10%) 

The percentage entered will be the default price 
adjustment in the Bibliographic Option screen during 
the Marc Import. This allows for the Item Price 
during Marc Import to be appreciated automatically. 
For example: to allow for GST. This default can be 
overridden within the Bibliographic Option screen if 
required  

10 (defaults to: +10%) 

MarcImport Replace: 
don’t delete these tags 
from the existing cat 

 

(Found in DEFAULT 
screen only) 

During the Marc Import, sets the default for the 
Bibliographic Option screen – identifying Tags that 
are not to be replaced: 

 Does not delete the existing data from the 
specified Tag(s): the Tag is automatically 
placed in the Don’t delete… field box 

 Does import the new data for all other Tags 
(deleting any existing data) 

 

Y 

MarcImport Replace: 
don’t import these 
tags from the incoming 
cat 

 

(Found in DEFAULT 
screen only) 

During the Marc Import, sets the default for the 
Bibliographic Option screen – identifying Tags that 
are not to be replaced: 

 Does not import the new data for the 
specified Tag(s): the Tag is automatically 
placed in the Don’t import… field box 

 Does import the new data for all other Tags 

 

N 

Only match an AOL 
record if the incoming 
record has the same 
location 

For Advanced Order Records (W.A. State 
Government of Western Australia data only). Will 
only match an AOL record from an exchange if the 
AOL has the same location as the incoming record 

Y 

Replace an Order if 
one of the following 
tags match an Order 
No 

The system compares the Order Numbers on an  
incoming exchange and replaces the existing data 
only if the  Order Numbers are matched to the data 
in the specified Tags 

001 035 



 Catalogue Training – Short Online Course  

 

 

Last Updated: 26 February 2013 
 Page 9 

Round the price of all 
imported Stockitem to: 
(ie 0.05 = 5 cents) 

(Found in DEFAULT 
screen only) 

When importing Stockitem records with prices, the 
Item Current cost and the Original Cost (if new 
items), are to be rounded to the amount set in this 
parameter 

0.05 

Tag to be formatted as 
an ISBN 

(Found in DEFAULT 
screen only) 

ISBNs and ISSNs are usually formatted with – 
separators between the numbers. The actual 
formatting depends on a number of rules and is 
based on the starting numbers in a group.  

020  

Tag to be formatted as 
an ISSN 

(Found in DEFAULT 
screen only) 

022 

Tag to be used as the 
AOL Order No 

(Found in DEFAULT 
screen only) 

(WA State government sites only) When AOL files 
are processed the system will generate an order 
number based on the contents of the Tag Number 
field defined in this parameter.  

001 

Tags using the first 
indicator as the 
number of chars to 
ignore 

(Found in DEFAULT 
screen only) 

For filing, the first indicator displays a number of 
characters to ignore – for example: “the” would 
have a second indicator of 4 

730 740 

Tags using the second 
indicator as the 
number of chars to 
ignore 

(Found in DEFAULT 
screen only) 

For filing, the second indicator displays a number of 
characters to ignore – for example: “the” would 
have a second indicator of 4 

240 245 440 490 745 840 

Use the (L)ogin group 
or (C)atalogue group 
for the group code of 
new non-authority 
tags? 

The Library Group code used when inserting Non-
Authority tags would usually be the same as the 
Catalogue Group code. However, there may be 
instances where libraries may want the option of 
using the Login lLcation’s Group code 

C (Default) 
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Installation: Stockitem Defaults 

The setting for this is contained in the Installation settings: 

1. Launch the Amlib client 

2. Go to Main > Supervisor > Installation – the Installation (DEFAULT) screen will display 

3. Select the Stockitem tab: 

 

4. Type the desired setting into the Value column (see the following list for parameters to 

adjust) 

5. Click the F3 Save button when complete 

6. Exit and restart the Amlib client for these settings to take effect 

User Security: Modify a Shared Authority in the Catalogue Screen 

The Catalogue module Modify button can be used to update any MARC tag in a Catalogue record 
including Shared Authorities.  This has the potential to allow a user to unknowingly alter other 
records also using that Shared Authority.  

For this reason, we recommend setting the Modify button to be greyed out if a Shared Authority is 
selected. This help ensures the integrity of the Shared Authorities by making them only editable in 
the Authorities module. 

1. Launch the Amlib client 

2. Go to Main > Supervisor > UserNames – the User Names screen will display: 
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3. Select a User Name in the table and click the F8 Choose button – the User Security screen 
will display: 

 

4. From the main User Security menu, select ActualMainMenu > Catalogues > Catalogue – 
NoSharedAuthUpdate 

5. Menu Chosen display should now be: Catalogue.NoAuthUpdate 

6. Click the green  Give  button to DISABLE the Users ability to modify a Shared Authority in the 

Catalogue module 

7. Close the User Security screen by clicking on the red [ X ] 

8. Exit and restart the Amlib client for these settings to take effect 

All Modules: Saved Files 

1. Launch the Amlib client 

2. Go to Main > Supervisor > Installation – the Installation (DEFAULT) screen will display 

3. Select the Other tab: 

 

4. Apply security to all Saved Files (Y/N) can be set for all saved files in any module that has this 
function available. If this is set to N (for No) when saved files are viewed, the screen displays 
as shown: 
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If the parameter value is Y (for Yes) this allows the operator to stipulate whether other operators are 
able to access this file when the file is being created. The operator who created this file can also modify 
the column at a later time. When other operators select to view another operator’s files, only the ones 
with a Y (for Yes) in the Allow other operators to access this file (Y/N) column will be displayed: 

 

In the example above, the Apply security to all Saved Files (Y/N) parameter has been set to Y (for 
Yes).  The operator Lucy has seven (7) Saved Files created in the Catalogue module, four (4) of which 
have had the Allow other operators to access this file (Y/N) column set to N (for No).  

When another operator views her files they will only see for (4) displayed: 

 

5. Change the setting as desired and click the F3 Save button 

6. Exit and restart the Amlib client for these settings to take effect 

This setting can also be set by Individual Location.
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MANUAL CATALOGUING 

It is a good idea to search for a Catalogue to see if the item has been entered already, and just needs 

an Item attached. Searching for an Item can be done in Catalogue using the ISBN or in Stockitem (for 

example: Author or Title Search). The ISBN can even be wanded if the Barcode reader has been ISBN 

enabled. 

 

It is preferable to create a catalogue first and then create the holding record (Stockitem). If the 

Stockitem is processed first, not all the Tags are made when the Catalogue is created from the Item 

menu. For example: Subject Headings are not transferred across.  

Keywords are created through association with MARC tags – for example: a Subject keyword would 

apply to all tags defined from 600 through to 699: e.g. Topical term (650), Personal name (600), 

Geographic (651) etc. Therefore when creating your entry, it is important to have a Catalogue record 

as well as a Stockitem because keyword searching will be important. 

There are three manual entry methods available: 

1. Work Sheet Method 

After choosing a template related to the form of the data (for example: fiction/non-fiction 

etc.) the required fields can be filled in. Authority listings can be accessed when appropriate 

(for example: for standard entry of Authors, Subjects, Publishers etc). 

2. Editing existing records 
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It is possible to duplicate an existing record and alter the relevant data. 

3. New record from scratch 

No Lead Through method. Tags can be inserted and built up to create a full record. 

Please Note: Before beginning to use the Worksheet manual entry, you need to check the tags that 

will be automatically displayed. This is done in Main > Catalogue > CatLeadThruSets. 

Work Sheet Method 

1. Launch the Amlib client  

2. Go to Main > Catalogue > Catalogue (or the  icon) – the Catalog screen will display: 

 

3. From the menu, select Catalogue > Catalog Create – the Select Template prompt will display: 

 

4. Click on the button for an appropriate Lead Thru set – for example: Fiction – the Work Sheet 

will open with a number of preset MARC tags already displayed: 
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5. An item’s bibliographic details can now be entered – as you move through the Work Sheet, 

the headings (descriptors) change, so it is possible to observe the type of data required in the 

subfield of the tag 

o See: Appendix 7: USMARC: Some Common Tags for more information 

6. Where the data is Authority based (for example: Author, Subject Heading, Series, etc.) a 

listing of Authorities can be viewed and selected – for example: to search for a particular 

Author, type the first few letters of the surname, highlight the row and double-click the row 

or press the F1 Check button 

 

7. The Existing Authority Options screen will open displaying all matching Authorities and the 

number of Catalogue records which use each Authority: 

Field Heading 
Subfield 
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8. To select an Authority in the table, simply double-click on it: the contents of the tag being 

checked will then change to match the selected Authority (the text will also change colour 

from black to green) 

 

↓ 

 

9. Once selected (or if there is no matching Authority), click on the red [ X ] to close the 

selection table (if there were no Authorities found the contents of the tag being checked will 

turn red, if there were Authorities found but none were selected the contents will turn pink) 
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10. To enter additional tags, click the F2 Insert button – the Select For Creation table will open 

(the preset tags allow for up to 40 entries): 

 

11. Find the required tag and double-click it to select it – a new entry with the selected Tag No 

will appear in the Work Sheet 

12. When the record is complete, click the F3 Save button 

13. If new Authorities are to be created, a prompt with the following message will display: Some 

new Authorities will be created. Continue with Save? (the new Authorities will be 

highlighted in red, so you can check them) 
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14. Click the Yes button – the Created Catalogue – Select Next Action prompt will display: 

 

15. If you intend to create your holdings immediately, then highlight the Create a Stockitem and 

click the OK button (alternatively you can select the Display the created Catalogue if you 

wish to review the actual Catalogue record) 

Adding Stockitems 

This section continues from the section above. If you don’t immediately choose to create a stockitem 

record, you can select XReferences > StockItems from the Catalog menu to initiate the process. 

1. A prompt with the following message will display: No Stockitems exist for the Catalogue. Do 

you wish to create a new Item? 

 

2. Click on the Yes button – a New Stockitem prompt will display with the following message: 

Please choose a Form Type for the new Stockitem  
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3. Choose the appropriate Form type and click on the OK button – the Stockitem main screen 

will enter creation mode (the F2 Insert button will appear bolded) and a number of fields will 

be pre-populated: 

 

4. Complete the other fields as required – for example: Stats Code, Current Cost, Floor 

location, etc – to access a list of codes in a field press .<Tab>  

 

For example: in the Stats Code field, pressing .<Tab> will display a list of your Stats Codes 

and Descriptions – double-click on an entry to select it: 
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5. Scan in barcode in the Item No field (if you wish to create a system-generated barcode, leave 

this field blank) 

6. Click on the F2 Insert button when complete – a prompt with the following message will 

display: The Item has been Inserted. 

 

7. Click the OK button 

 

Multiple Copies 

To enter multiple copies of the same catalogue item: 

1. Scan in a new barcode into the Item No field – the F2 Insert button will once again become 

active (bolded) 

2. Change any other details as required – for example: Stats Code, Copy No and Floor location 

3. Click the F2 Insert button when complete 
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IMPORTING NEW ITEMS 

Most sites download their Catalogue data (from places like SLOWA and SCIS). Amlib stores the data 

in USMARC format, which is now the international standard. This is made up of hundreds of MARC 

Tags, which identify data. In the same way that Dewey numbers become familiar, common tags 

become known. 

SOME COMMON 

TAGS 

DESCRIPTION 

020 ISBN 

082 Dewey classification number 

100 Personal name main entry (usually author) 

245 Main title 

260 Publication information 

300 Physical description 

440 Series 

500 General notes 

520 Summary 

650 Subject headings (Topical) 

700 Personal name (Added entry) 

856 Electronic location and access (URL) 

Import MARC Catalogue Data  

There are generally four main stages in the download process. 

 

 

 

 

  

DATA 
Download
ed from 
SCIS or 
sent from 
SLOWA 
etc. 

NEW RECORDS 

Check the new data  

 Stockitems: adding 
barcodes, supplier, 
checking location 
etc. to items in file 

 Catalogues 

 Authorities 

HOLDING FILE 

Loads the data 

to the Screen 

for checking 

UPDATE 

[F3] begins the 

updating 

process after 

setting the 

defaults 
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Accessing the Data for the Download 

1. Launch the Amlib client 

2. Go to Main > Authorities > MarcTakeUp (alternatively use Ctrl + M) – the Marc Import 

screen will display: 

 

3. Click the F1 Open button to display the Open dialogue box 

4. Locate the file to be processed by using the Look in: drop-down box – for example: if the file 

is on the C: drive, the Look in: box may say Local Disk (C:) 

5. Once the file name has been located, use your mouse to select it and click on the Open 

button 

There are two processing options: Bibliographic Data or Authority Data – this guide covers the 

import of Bibliographic Data. 

Bibliographic Data 

This option is to load records which are Bibliographic Data in machine readable format which can be 

imported into Catalogue, Authority and Stockitem (where appropriate) applications of Amlib. 

1. The Marc Import – Open screen will display: 

 

Please Note: If the Import file (Bibliographic or Authority) contains more than 9999 records, it is 

recommended that Open and Update is selected (ticked) so that all records can be loaded into the 
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database. This eliminates the need to load in sections. The maximum records that can be viewed in 

the Holding file is 9999 records.  

HEADING FIELD EXPLANATION/OPTIONS EXAMPLE 

Marc Options Bibliographic 

Data 

Bibliographic data to be created 

for the Catalogue. 

Data from external 

source (for example: 

SCIS, SLOWA, Kinetica 

etc. with USMARC Tags) 

Authority Data Authority data for creation or 

updating of Authority Headings 

and/or cross references. 

See and See Also Update 

from SCIS or other source 

Update the database 

without viewing the 

Marc records 

Open and 

Update 

If checked (ticked), the imported 

items will not display in the 

Holding file.  

The Catalogue will be 

Updated immediately 

If unchecked (unticked), the 

imported items will display in 

the Holding file.  

Review records 

The Catalogue will not be 

updated until the F3 

Update button is 

selected 

Load Range All All records from the file are 

downloaded into a holding file. 

All 

Range Selected records from the file 

are downloaded into a holding 

file. If Range is selected, the next 

2 fields have to be updated. 

For example, 1 to 50 

2. Complete the options using the above table: 

a. Marc Options = Bibliographic Data 

b. Open and Update = ticked, unless you want to review each individual MARC record 

c. Load Range = All (unless the file sizes are quite large) 

3. Click on the OK button 
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Bibliographic Options 

1. The Bibliographic Options screen will display: 

 

HEADING FIELD EXPLANATION/OPTIONS EXAMPLE 

Marc Details We think the file 

contains 

The data type is displayed  

Standard format 

SCIS 

ABN  

 Total Bibliographic 

records 

The number of Bibliographic 

records will display 

32 

Total Authority 

records (this will only 

display if the import 

is for Authority 

headings) 

The number of Authority headings 

with See/See Also references will 

display 

0 
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2. Select the appropriate Each bibliographic record contains setting: 

Each 

Bibliographic 

record contains: 

Catalogue data only The system will determine the 

contents of the import file. If only 

Catalogue data exists in the file, 

this will be the Default option.  

SCIS Data 

 

Full Catalogue & 

Stockitem data 

The system will determine the 

contents of the import file. If both 

Catalogue and Stockitem data 

exists in the file, this will be the 

Default option.  

Please Note: This item can be 

selected to create “Dummy” 

Stockitems even though only 

Catalogue Data exists in the Import 

file. 

SL OF WA Data 

Brief Catalogue and 

Order data 

The system will determine the 

contents of the import file. If only 

brief Catalogue data and Order 

data exists in the file, this will be 

the default option. 

AOL Data 

When displaying 

the records 

show: 

All tags in the file All tags from the Import file will 

display in the Holding file for 

viewing. However, tags not defined 

in Amlib will not load into the 

Amlib Catalogue unless the Marc 

tag is defined. 

If Tag 650v is not used 

in Amlib it WILL still 

display in the Holding 

file. 

 

Only tags defined in 

Amlib 

Only tags used in Amlib will display 

in the Holding file.  

If Tag 650v is not used 

in Amlib it will NOT 

display in the Holding 

file. 
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3. If the Marc Details are set to import Full Catalogue & Stockitem data, the Item Default and 

Item Prices sections will also display: 

HEADING FIELD EXPLANATION/OPTIONS EXAMPLE 

Item Defaults 

Please specify 

default values 

for each item in 

the fields below 

Form The default values set in the Main 

> Supervisor > Installation > 

Stockitem tab will display if 

defined.  

If these fields are not yet defined, 

codes which will apply to the items 

can be entered. Rules for 

automatic entries of Form and 

Stats codes depending on the Tags 

that are imported, and be set in 

Cat Defs in the Stockitem Form and 

Stats codes. 

If during the Import, 

Cat definitions cannot 

be created, each 

Stockitem will have a 

default Form of BK 

(for example) 

 

Location CHELSEA 

Lib Group LIBRARY 

Stats Code ANF 

Floor Loc (optional) DISPLAY 

Process (optional) IN PROCESS 

Item Prices Minimum price of an 

item 

If the item price in the Import file is 

less than the price set here, enter 

the Minimum price 

The Import price is 

$8.00 but the 

Minimum price set 

here is $10.00, the 

price in the Stockitem 

will be $10.00 

 

Appreciate items by 

% 

Items can be appreciated by a 

percentage – for example: GST of 

10% 

10% 

Depreciate old 

stockitems 

Items to be depreciated will be 

dependent on the table set in 

Stockitem > Application > Stats 

Group 

 

Use average prices if 

no price 

Items will be given an average 

price, set in Stockitem > 

Application > Stats Group. If no 

price is entered in the Import File 

 

4. Click the OK button once you have completed modifying your settings 

Please Note: Form and Stats Code defaults from the Main > Supervisor > Installation > Stockitem 

tab display automatically in the fields. If there are no defaults entered, the field will be blank. 

Location displays as the Login Location. Entry of these fields is optional.  As the import of data is 

processed, the Stockitems will be given the default values if there are no catalogue definitions for the 

Form or Stats codes of the items. Form and Stats Code Cat definitions are found in Main > 

StockItems > StockitemForms or StockitemStatsCodes table for the particular code. 



 Catalogue Training – Short Online Course  

 

 

Last Updated: 26 February 2013 
 Page 27 

Reviewing Records to be Imported (Optional) 

It is possible for the importer to review (and edit) the MARC data being imported. 

1. If the importer has decided to review the records being imported (see Bibliographic Data 
step above), the Marc Import screen will display: 

 

2. If you do wish to edit the data (prior to import), use the editing buttons on the right to 
change or delete the individual tags 

Please Note: Editing of the data prior to import is not essential. Changes can be made after 
the data has been imported into the Catalogue. Remember that not all the tags will 
necessarily be Imported, so if editing is considered necessary, change only the tags you know 
will be imported! 

3. Use the F7, F8, F9 and F10 buttons to move between records 

4. Once the data has been reviewed, click the F3 Update button 

Find 

It is possible to use the find function to locate any matching text, tag number or specific Subfield in 

the Holding File data being displayed. For example: use this facility to check all Author entries or 

Subject headings. 

1. From the main menu, select Window > Find – the MarcImport - Find screen will display: 

 

2. Type in the Tag, Subfield or String to find and click the Find Next button 
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3. It will then find any matching data in the record currently being displayed: 

 

Catalogue Update Options 

1. The Update Options screen will then display, allowing you to select the Cat(alogue) and 

(Stock)Item Options: 

 Cat Options: When an incoming Catalogue is match with an existing Catalogue 

 Item Options: When an existing Catalogue is replaced all existing items 

 

PARAMETER FIELD EXPLANATION 
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Cat Options 

When an 

incoming 

Catalogue is 

matched with 

an existing 

Catalogue: 

Display an IGNORE/REPLACE 

message 

A message will display at each match occurs. At each 

match, the operator will get a choice to create a new 

catalog, replace the existing or to keep the existing details.  

Keep the existing Record ie NO 

UPDATE 

No Update occurs for the Catalogue 

Add Authorities but Replace Non-

Authorities 

Does not replace existing Authorities but adds new 

Authorities to the record. However, it replaces any Non 

Authority data from the Import 

Replace the existing Catalogue 

ENTIRELY 

All tags from the Import are used, overwriting any existing 

data 

FIELD OPTION EXPLANATION 

Replace all 

tags EXCEPT: 

 

Don’t delete the 

following tags 

from the 

existing 

catalogue eg. 

650,700 

This will vary according to the setting in Main > Supervisor 

> Installation > Catalogue tab:  

 MARCImport Replace: don’t delete these tags 

from the existing cat 

 MARCImport Replace: don’t import  these tags 

from the existing cat 

Adds non-identical tags when importing all but specified 

Tags. Existing data in the specified Tags remains 

unchanged 

 

Don’t import 

the following 

tags from the 

incoming 

catalogue eg. 

650,700 

Adds non-identical tags when importing. Does NOT import 

the new data in the specified Tags. Existing data in the 

specified Tags remains unchanged 
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PARAMETER FIELD EXPLANATION 

Item Options  

When an 

existing 

Catalogue is 

replaced, all 

existing 

Stockitems: 

Keep their current display No existing Stockitems are refreshed – they remain the 

same 

Are refreshed from the Catalogue All existing Stockitems are replaced by the new Catalogue 

details 

Are refreshed except lines: 

eg. 1,5,6 

Enter the line numbers to be retained – for example: 6 

(Line 6, which is usually Call Number). Line numbers 

correspond to the 6 lines of Stockitem display (for 

example: Line 1 is usually Title, Line 2 Author etc.) 

FIELD OPTION EXPLANATION 

Please choose 

the location to 

use when 

matching an 

order 

Exact Only order items where location is the same as the 

current Amlib location will be candidates for replacement 

Any Stockitems on the file may replace any order item on the 

database 

Only create 

stockitems 

Checked The import of data will result in no Catalogue records 

being created. Only Stockitems will be created. 

Unchecked 

(Default) 

Create Catalogue records as well as Stockitems 

2. Enter the options you would like, then click the OK button – the Saved Files screen will 

display: 

 

3. Type the names of the files into which all the newly created Catalogues, Authorities and/or 

Stockitems will be saved (if you do not want to check new items – for example: Authorities, 

do not enter a filename) 

4. Click the OK button 

HINT: These files assist in finding the newly created Catalogues, Authorities and/or Stockitems after 

the import. The Filenames are created so that you can identify the file later. A suggested Filename 

could be the type of data – for example: SCIS or EXCHANGE, the date and the initials of the staff 

member processing the data. 
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5. If confirmation of duplicate items has been requested in the parameters, a Catalogue Match 

screen will display every time a duplicate item is found: 

 

6. Are the above two records the same? Click the Yes, No or Replace button 

OPTION EXPLANATION 

Yes The catalogue entry that exists on the database will remain as displayed in the top box. 

A new Stockitem would need to be added if appropriate. The imported record will not 

be included in the New File created for Catalogue or Authorities 

No A new catalogue will be created with the data from the Imported data being used for 

the new catalogue record. The imported record will be included in the New File created 

for Catalogues or Authorities 

Replace The existing catalogue entry will remain but the data will be replaced with the data 

from the imported recorded. The imported record will not be included in the New File 

created for Catalogue but there may be some additions to the Authorities file 

7. An Update prompt will display, indicating the progress of the import: 

 

8. When the update is finished an Update prompt will display, showing the number of records 

Updated: 
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9. Click the OK button 

10. You will be able to view the log by selecting the F6 Log button 

F6 Marc Log 

This log lists any errors that were experienced in the process of importing the file and also what 

action was taken with certain items. Most of the errors that display in the log are caused by the tag 

numbers not being defined on the Amlib database. This may be because we did not wish to use them 

in the Catalogue data but were present in the data file. 

Checking New Stockitems 

1. Launch the Amlib client 

2. Go to Main > StockItems > Stockitem – the Stockitem screen will display 

3. From the menu, select File > DisplayFile – the Stockitem Saved Query Results screen will 

display: 
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4. Highlight the file you wish to access and click the F9 Select button – a Stockitem List of the 

imported items will display: 

 

5. You can now check to ensure that the item details are correct 

6. Double-click the first entry – the selected item will display in the Stockitem screen 

7. Add the correct Item No (barcode), Current Cost, Sts Code, Form code, Origin/Source (if 

required) and generally check other details 

 

8. To access a list of codes in a field press .<Tab>  

For example: in the Stats Code field, pressing .<TAB> will display a list of your Stats Codes and 

Descriptions – double-click on a entry to select it  

9. Click on the F3 Update button when complete – a prompt with the following message will 

display: The Item has been Updated. 

 

10. Click on the OK button 

1. Add 

Barcode 

2. Check 

Form and 

Stats codes 

3. Check 

Location 

5. Add correct 

price (do not 

add $ sign) 

4. Add 

Origin/Source 

(supplier) if 

required 

6. Add/remove any 

other relevant 

information 
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MODIFYING CATALOGUE DETAILS 

1. Launch the Amlib client  

2. Go to Main > Catalogue > Catalogue (or the  icon) – the Catalog screen will display: 

3. Initiate a F5 Query to locate the Catalogue record that requires editing (alternatively, if the 

item record is open in the Stockitem module, select XReferences > Catalogue) 

 

Modify Using the Work Sheet 

It is now possible to edit an existing catalogue record using the Catalogue Work Sheet. 

1. From the menu, select Catalogue > Catalog Modify using Worksheet – the Work Sheet 

screen will display: 

 

2. The catalogue record can then be edited/modified in the same manner as a new Catalogue 

record 

Field Heading Subfield 
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3. Existing Authorities cannot be altered in the Work Sheet – if a new Authority is to be created 

(for example: one with a different subdivision), then the F2 Insert button should be used to 

enter it on a new line to that of the existing heading (the existing heading can be retained or 

removed using the F4 Delete button) 

Insert 

Inserts a new Tag for the Bibliographic record.  

This process will be different depending on whether the Tag chosen from the list is an Authority or 

Non-Authority Tag.  

 

1. Click the Insert button on the right-hand side of the screen – the Select For Creation table 

with a list of Tag Nos will display: 

 

2. Double-click on the desired Tag 
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Insert Non Authority Tag 

1. If the selected Tag is a Non-Authority – the SubFields window will display: 

 

2. Please ensure you enter the correct data into the correct subfield – clicking the F6 Table 

button gives the Valid SubFields/Parts table available for that Tag: 

 

3. Once the data has been correctly entered click the F3 Update button 

Insert an Authority Tag 

1. If the selected Tag is an Authority – the Authority Replace screen will display: 

 

 Notice the Green colour of the list (in this example: a 650 - Subject Heading)? This is because 

the headings shown come from the Authority module 
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2. Type in a Search Term (for example: Fantasy) and click the F5 Query button – a list of 

matching terms will display: 

 

3. If the correct term is in the list:  

a. Highlight the term and click the F3 Replace button 

b. The Authority Replace window will close and the selected Authority will appear in 

the catalogue record 

4. If the correct term is NOT in the list or your search gives no results: 

a.  Click the F2 NewAut button – the SubFields table will display: 
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b. Please ensure you enter the correct data into the correct subfield – clicking the F6 

Table button gives the Valid SubFields/Parts table available for that Tag: 

 

c. Once the data has been correctly entered click the F3 Update button 

d. Click on the red X in top-tight corner to close the Authority Replace screen – the new 

Authority will have been added to the catalogue record: 

 

Once the Authority has been entered, it is available for use in subsequent catalogue records. 
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Replace 

Replaces the Tag data with an alternative heading. 

1. Highlight an Authority to be replaced 

2. Click the Replace button on the right-hand side of the screen – the Authority Replace table 
will display with highlighted Authority: 

 

3. Type in a Search Term (for example: Wizards) and click the F5 Query button – a list of 
matching terms will display: 

 

4. If the correct term is in the list:  
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a. Highlight the term and click the F3 Replace button 

b. The Authority Replace window will close and the selected Authority will appear in 

the catalogue record 

5. If the correct term is NOT in the list or your search gives no results: 

(Please Note: this option NOT available if User settings have been set to DISABLE 

modification of Authorities in the catalogue screen – the Insert button should be used to 

create a new Authority and the existing Authority removed from the record using the Delete 

button) 

a. Click the F2 NewAut button – a prompt with the following message may display: 

Creating an Authority replaces the existing Authority. Continue? 

 

b. Click on the Yes button – the SubFields table will display: 

 

c. Please ensure you enter the correct data into the correct subfield – clicking the F6 

Table button gives the Valid SubFields/Parts table available for that Tag: 

 

d. Once the data has been correctly entered click the F3 Update button 
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e. Click on the red X in top-tight corner to close the Authority Replace screen – the new 

Authority will have been added to the catalogue record: 

 

If the heading to be replaced is not found, a new Authority can be created. This only replaces the 

existing Authority in this particular item. 

Modify 

Please Note: It is possible to update User Name security so as to DISALLOW the editing of Shared 

Authorities using the Modify button. This helps ensure the integrity of the Shared Authorities (which 

may be in use in other Catalogue records). Authorities can then be modified by XReferencing to the 

Authorities module. 

1. Highlight the Tag to be modified and click the Modify button on the right-hand side of the 

screen – the Tag will open in the SubFields screen 

WARNING: If the tag is an Authority, changes will be made to ALL Catalogue records using this 

Authority. BEWARE! 

 

2. Make the changes 

3. Click the F3 Update button when complete 
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Delete 

Deletes a highlight tag (for this record only – does not affect other Catalogue records or any 

Authorities previously created). 

1. Highlight the Tag to be deleted and click the Delete button on the right-hand side of the 

screen – a prompt will appear with the following message: Delete Current tag. Are you sure? 

 

2. Click the Yes button 

3. The Tag will be deleted 

Hide/Show 

Alternates between hiding/showing tags for this record.  

1. Click on the Hide button on the right-hand side of the screen to hide the Tags in the 

displayed record (Hide will then be replaced by Show) 

2. Click on the Show button on the right-hand side of the screen to show the Tags in the 

displayed record (Show will then be replaced by Hide) 

Please Note: Show has to be selected to enable the Duplicate Button. 

Movement of Tags 

1. Highlight the Tag to move and use the arrow keys to move the Tags up or down 

 

Please Note: This sequencing possible within the record depends on what is set in the Main > 

Supervisor > Installation - Catalogue tab: Allow tags to be sequenced anywhere within a catalogue 

(Y/N) parameter. 
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 If it is left at the default Y, staff will be able to use the up and down arrows on the Catalogue 

record to reposition any MARC Tag within that record 

 If it is changed to N, this will then restrict the ability for adjusting the sequence of a MARC 

tag in a specific record to its specific range only. This means that if there is only one MARC 

tag to that record it cannot be moved, but if there is more than one MARC tag, for example 

subject headings, then these can be moved within this group only 

Catalogue Record Created / Last Edited Information 

For newly created (and imported) Catalogue records it is now possible to tell which user created a 

record, and who it was last edited by.  The top line shows when the record was last edited, and the 

bottom line remains the same, showing when the record was created.  This information is not 

retrospective so that for all existing records, only the user, date and time for the last update will be 

shown. 
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MASS DELETION OF STOCKITEMS/SAVING TO FILE 

Items can be deleted easily from a Saved File. These items can be wanded into the File. This is useful 

for Public Libraries who have to return items to SLWA, and who want to delete them from their 

catalogue. It is also useful for schools when a weed of resources is performed (for example: after a 

Stocktake). 

This can be done individually within the Stockitem module by calling up the item and clicking the F4 

Delete button. If it is the last copy for the Catalogue, you will be prompted to delete the Catalogue 

entry as well. 

Items can be deleted en masse from a Stockitem List (each item that is to be deleted needs to be 

highlighted) or alternatively from a Saved File. 

Stockitem List 

1. Launch the Amlib client 

2. Go to Main > StockItem > Stockitem – the Stockitem screen will display 

3. Initiate a F5 Query or Stockitem Where search to bring up a list of items to be deleted 

(alternatively, you may decide to use a Saved File as the basis of your deletions – select File > 

Display File > select a saved File > F9 Select) 

 

4. Highlight the items to be deleted 

5. From the Stockitem List main menu, select Table > Mass Item Deletion – the Mass Delete 

Items screen will display: 
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6. Add a tick in the Catalogue: Delete Catalogue if Last ? box 

7. Click the OK button – the following prompt will appear: 

 

8. Click the Yes button 

9. The items (and any associated Issue Catalogue records) will be deleted 
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Z39.50 SEARCHING 

Z39.50 is an international information retrieval standard that enables communication between 

computer systems, including those that operate on different hardware and use different library 

software (for example: Amlib, Spydus, Symphony, etc.). Searching of other libraries and databases is 

performed simultaneously in a single search (parallel searching). 

Schools can use the Z39.50 facility link to SCIS. You will need to contact SCIS directly to get your IP 

address authorised and they will supply the SCIS z39.50 details so that you can set them up as a 

Z39.50 Server.  

 See the Catalogue manual for details on how to set up new Servers and new Groups 

Please Note: Use of the bibliographic records via Z39.50 is subject to the terms and conditions of the 

source library. 

Amlib Z39.50 Client 

1. Launch the Amlib client  

2. Go to Main > Catalogue > CatZSearch – the Z39.50 Search screen will display: 

 

3. Click the F5 Query button – Query screen will display: 
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4. Select the Server or Server Group from the Available Servers drop-down box – for example: 

Public Libraries 

5. Type in the Search Attributes – for example:  ISBN, Title, Author, Subject or combination of 

these 

6. Click the OK button – the results will display in the main Z39.50 screen: 

 

7. The columns can be sorted by clicking any of the column headings 

8. Save selected records to a MARC file for import: 

a. Highlight the records (hold the Ctrl key and click on records to highlight more than 

one record) 

b. Click the F4 Import button – the Import method screen will display: 

 

c. Select your import option: 

 Click the Yes button: Save the Marc file and then import it 

 Click the No button: import directly (not all import options will be available) 

 Click the Cancel button: Cancel the import 

d. The highlighted records will saved to a MARC File shown in the dialogue box, to be 

imported into Amlib via MARC Takeup 
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e. The MARC Takeup process will begin automatically – ensure the folder is the correct 

folder – for example: My Documents 

Please Note: Please refer to Import MARC Catalogue Data: Bibliographic Data for details of the 

remainder of this process. 


