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BIBLIOGRAPHIES - OVERVIEW 

This course is offered for those that have come familiar with Amlib/Reports and would like to know 

more about a specific element of reporting. 

An Amlib Bibliography is the listing of a collection of resources in a Table or Report. These could 

include: 

 Simple listings for “easily defined” collections with brief details e.g. Video List, New Items. 

Setting up reports within Reports, RepStockitem offer the advantage that they are set up and 

ready for viewing at any time. They can report more than 1000 items 

 Simple listings can be presented for particular topics (harder to define than “collections” – 

usually defined as a result of a search in Stockitem) with brief details e.g. Olympics. Items can 

be saved to Files or reported from straight from a Table. Searches within Stockitems have a 

maximum of 1000 per set. 

 Detailed listings using Bibliographic information – full listing of new items just received with 

Subject Headings and Notes etc. 

 Detailed listings with Marc Tags – full listing with Marc information including Tag Nos 

 The simple listings can be altered with Report Writer. The more detailed listings can be 

customized by using the More Button associated with Fixed Layout templates. These allow 

more Customisation to the end result of the Bibliography. If the User of the program has 

some knowledge of Report Writer the Templates can be enhanced as desired 

 Some Report Templates are designed to work well for exporting to Excel 

 Usage reports for Borrowers and Stockitems 
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STOCKITEM REPORT 

Simple listings for “easily defined” collections with brief details for example DVD List can be created 

in the Stockitem Reporting Module. 

Item Report using RepStockitem 

Setting up reports from here offer the advantage in that they are set up and ready for viewing at any 

time. 

There are several Stockitem template designs that can be used to generate such listings. In the 

example below, the report template &STKTACT.QRP is used to generate a list of new Adult Fiction 

items received in the last 3 months. 

1. Launch the Amlib client 

2. Go to Main > Reports > RepStockitem – the Stockitem Report screen will display 

3. Click the F1New button – the Select Report Format screen will open: 

 

 
 

4. Highlight the Title, Author, Call No and Form template (&stktact.qrp) and click the Select button 

5. Type in an appropriate Report Description – for example New Items 

6. Click the F3 Save button  

7. Click the F7 Where button – the Stockitem Report – Where screen will display 

8. Include the following statement: 

1. Stats Code = AF (or whatever your Stats Code to select) 

2. Date Received >=  Current Date – 3 Months (select using the Special button) 

9. Click the F3 Save button when completed 

10. Press the F8 View button to preview the report – the Report – View screen will display: 
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Ideas for these format of Bibliographies where the results will be for codes or dates rather than 
keywords include: 
 
 

 New Items 

 New Items by Form/s (for example BK only ) 

 New items by a particular Stats code/s (for example Junior)  

 DVD list (or other Form codes like MP3 or EBK) 

 Non Book items 

 Items currently On Loan  

 Items Overdue (or to be invoiced) for Shelf Check 

 Items currently Not For Loan 

 Items received more than 10 years ago 

 Items in a particular location with Cost shown and added as a total 
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MS EXCEL FORMAT – STOCKITEM BIBLIOGRAPHY 

Title, Author, Call No, Form and Stats Code - &xstkcsv.QRP (Stockitems (Default)) 

1. From Main > Reports  >  Application select RepStockitem 

 

2. Select  New [F1]  

3. The Select Report Format window will display 

4. Highlight the MS Excel format – Stockitem List – Title, Author, Call No, Form, Stats 

 

5. Choose the Select Button 

6. Type a Description – for example New Items 2013 

7. Select F3 Save 

8. Select F7 Where 

9. Choose the relevant Column from Box 1. The choice will depend on what is required. For 
example, select the Perm Location if you wish to report on only items from particular Location/s. 
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Select DateReceived if you wish to reports on only those items received before/after a certain 
date or select a File of items to display 

 
10. Select F3 Save 

11. The Order can be selected – for example Title. Select F9 Order and arrow the Title over to the 

Sort  

12. Select F6 Print  

13. In the Print dialogue box, To Section, click the Radio button File, to save the report to a file 

 

 

14. Press OK. 

15. A Report - Save As Dialogue Box will display. Choose the Destination Folder for the Report and 

ensure that the Report is saved as a .txt file (Text Document) 
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16. This will set the Report ready to be saved to a File. To proceed, Report Scheduler must be 

activated. Select RepStartSchedule from Reports/Application. Ensure Save to File is included in 

the selections 

 

1. The Report’s progress can be checked in Reports, Application, RepPrintProgress. 

2. When the Scheduler has completed the task and the Report has been saved it can be 

accessed in Excel.  

3. Open a Blank page in EXCEL. Use File>Open to load the saved .txt file. The file was saved as a 

.txt file. Ensure that ‘All Files(*,*)’ is selected from the ‘Files of type:’ dropdown list 

4. EXCEL will identify that your file is a data delimited file. Use the Text Import Wizard (3 steps) 

to import your file.  

 

 
 

5. Press Next. 



 Amlib Bibliographic Reports Training Guide 

 

Last Updated: 14 August 2014 Page 11 

 

6. Select a Pipe (|) as this is the Delimiting character used for this report. 

7. Press Next. 

 

8. Select Finish 

 

9. The data will be transferred into the EXCEL table. Use EXCEL Formatting tools to customise 

the file as required 
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17. Adjust as required 

 

 

18.  

ITEM REPORT USING STOCKITEM TABLES 

Item report can also be created from a resulting query performed within the Stockitem module in 

Main > Stockitems > Stockitem. 

Stockitem Query 

1. Launch the Amlib client 

2. Go to Main > Stockitem > Stockitem – the Stockitem screen will display 

3. Enter a keyword to search, and select one of the option in the Query Via box 

 

 
 

 

Item Browse search for data displayed within the Stockitem Application 

Cat Browse search for data displayed within the Catalogue Application 

Keyword Searches any keyword within the Stockitem and Catalogue Application using the six 

lines available within Stockitem: Title, Author, Subject, Series, Publisher or Call No. 

Typing in the Subject line will search only Subject keywords. 

Any Searches for any keyword within the Stockitem and Catalogue Application e.g. Even if 

the Title line is chosen the keyword will be search in Title, Author, Notes, Subject etc. 

4. Press the F5 Query button – the Stockitem List will display with all the matching results 
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5. Highlight items from the Stockitem List to include in the report 

 
 

 

 

6. In the Stockitem List menu click Table > Report  - the List Report screen will display 
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11. Highlight a report template that has been setup, and click the F8 view button – the Report – 

View screen will display: 
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Keyword Query 

1. Launch the Amlib client 

2. Go to Main > Stockitem > StockitemKeyword – the Stockitem Keyword screen will display: 

 

3. Enter the keyword and press the TAB key on the keyboard. The keyword table fills with a 

count of the number of keywords found as a result of the search 

4. Highlight the entries to query from the table. For example, a search for Animals resulted in 

four types found for the word ‘Animals’ Series Title (E), Notes (N), (Subject (S) and Title (T),  

BUT four types were also found for Animal Series Title (E), Notes (N), (Subject (S) and Title 

(T). 

 

5. To only select the Title result, highlight the line with Type T  OR Hold the CTRL key on the 

keyboard and highlight the entries you wish to select 
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6. Select Paste after the relevant results have been highlighted 

7. Select the F5Query button, the Stockitem List will display 

 

Note:  

 When highlighting more than one entry from the Keyword table and selecting Paste, an 

OR search is defined between Keyword codes e.g. N.Fish (Notes – Fish) or S.Fish (Subject 

– Fish) or T.Fish (Title – Fish) . A count of the total catalogues found for the OR search will 

list in the Cat.Count column. If an AND search is required, the Keywords can be chosen 

separately from the Table and the AND operand is automatically selected 

 This can be repeated for other Terms as required 

 The Boolean operand can be manipulated independently by highlight the line from the 

resultant table and selecting the relevant AND, OR or NOT buttons 
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SENDING THE CONTENTS OF A TABLE TO MICROSOFT EXCEL OR WORD 

The search results displayed in tables can be copy and then pasted into a MS Excel worksheet or MS 

Word document? 

 From the List of results screen (for example: Stockitem List) highlight the selected records  

 From the menu, select Main > Base > Copy  

 Open an empty MS Excel Worksheet and from the menu, select Edit > Paste (or Ctrl - V) 

From a table of search results highlight the items for the report – there are 3 options :  Press Ctrl + 

Insert to copy the text (if you have Amlib Shortcuts) or Ctrl - C (if you have Windows Shortcuts) or 

from the menu, select Main > Base > Copy.  

In MS Excel or MS Word, paste the data in – all the columns will come across but you can delete 

those items you do not want: 

 

↓ 
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In MS Word: 

1. Make the page a Landscape (Page Layout tab > Orientation > Landscape) 

2. Paste or Ctrl - V 

3. Select All (Home tab > Select > Select All)  

4. Select Convert Text to Table (Insert tab > Table > Convert Text to Table) 

 

 
 

 

5. The Convert Text to Table screen will display – click the OK button 

  
 

 

6. It will look rather messy but set this way it is easier to delete Columns 
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Delete columns as required from  

  
 

7. After deleting columns, it is possible to edit the text in the columns – for example: Titles – 

make bold and italic.  

8. When completed, the table can be converted back to text (from Layout – Convert Table to 

Text) and Portrait layout if preferred. You may need to tidy it up little to get it to display the 

way you want it . 
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9. Pictures, Cover images or symbols can be added too, if required and extra formatting done 

etc. 
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BIBLIOGRAPHIC REPORTS WITH CATALOGUE DATA 

Catalogue data such as Subject Headings can be used to generate Bibliographic reports. These 

reports are generated using a saved catalogue file.  

A saved catalogue file can be created in various ways – for example a list of catalogue entries has 

been created via the Cat keyword search in the Catalogue 

Alternatively it is possible to search and find items in the Stockitems module first, and XReferenc to 

the catalogue for the items found in the query. This is the method shown below. 

Step 1: Create a Saved File 

1. Launch the Amlib client 

2. Go to Main > StockItems > Stockitem – the Stockitem screen will display 

3. Enter a keyword to search, and select one of the option in the Query Via box 

4. Press the F5 Query button – the Stockitem List will display with all the matching result 

 
 

5. Highlight items from the Stockitem List to include in the report 

 

 
 

6. From the menu, select XReferences > Catalogue – the Catalogue records for the selected 

items will then display in a Catalogue List: 
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7. From the menu, select File > Save All – the Catalogue Saved Query Results screen will display 

8. If a file does not exist that you may wish to add these records to click the F1 New button and 

create a new file, enter in the Details of the file, and click F3 Save button 

 

 
 

9. Highlight the file and click the F9 Select button –a prompt with the following message will 

display: The ‘XXX’ file contains XX catalogues. 

 

 
 
 

10. Click the OK button and close out of the Catalogue module 
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Step 2: Create the Report 

Now the report must be setup in the RepBibliographic screen.  

TEMPLATE DESCRIPTION REPORT TYPE 

&BIB.QRP Full Bibliographic without Tag 

Numbers 

Bibliographic (Default) 

&BIB2.QRP Full Bibliographic without Tag 

Numbers (in 2 columns) 

Bibliographic (Default) 

&BIBFULL.QRP Tag description, Tag No and 

Data included 

Bibliographic (Default) 

 

1. Go to Main > Reports > RepBibliographic – the Bibliographic Reports screen will display 

2. Click the F1 New button – the Select Reports Format screen will display 

3. Highlight the Full Bibliographic without tag # (&BIB.QRP) template and click the Select 

button 

4. Type in a Report Description – for example: Accession List 

5. Click the F3 Save button 

6. Click the F7 Where button – the Bibliographic Reports – Where screen will display: 

7. Enter in the following Where statement: 

a. Tags to Display – for example: TAGS to Display IN 020,082,100,245,650  

(Only the tags listed will display. If you wish all tags to show you would not list 

specific tags) 

b. Auth Tag – for example: Auth Tag = 100 

(In this context the Auth Tag is used to control the sort order of the items set in F9 

Order – for example: 100 will list items by the Author, 245 will list the items by title 

and 082 will list items by Call Number) 

8. Click the F3 Save button when complete 
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9. Click the F9 Order button – the Bibliographic – Order By screen will display 

10. Use the arrow keys, to move Auth Key from the Columns box to the Order By box 

11. Use the arrow keys to highlight and move Auth Key from the Columns box to the Order By 

box (the Auth Key using the Auth Tag set up at 7b) 

 

 

12. Click the F3 Save button when complete 

13. Click the F8 View button – a prompt with the following message will display: This type of 

report may use a Saved File as the Source. Do you want to select the file now? 
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14. Click the Yes button – the Select Saved File list will display: 

 

15. Highlight the Saved File (in this example: Marsden Books) and click the OK button 

16. The list will display in Report – View: 

 
 

 
17. Use the print button to print off the report 

 

Full Bibliographic details (&bibfull.qrp) 

Useful for checking Cataloguing Details 
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Can also use Auth Key > LIKE if you want to be more specific of what is returned on these Marc tags 
chosen like a specific title, author or subject perhaps. 
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FIXED LAYOUT REPORTS 

A Bibliographic report can use a fixed layout templates to enable users to customize the output of a 

report by mapping required Catalogue data to Marc Tag fields in a report using the F10 More 

parameter.  

It takes a little while to understand how the parameters are set up but once you command it, this 

becomes a useful way to present the information from Catalogue records. It enables you to 

determine: 

 The exact Content of the report – by picking specific Marc Tags  

 Allows you to Order the sequence of the data displayed 

 Report over 250 characters if required – for example from the Notes fields 

 Report only one Subject Heading or every Subject Heading contained in the Catalogue 

 Allows you to display or hide certain Subfields 

 If you can edit Report Writer Templates it allows for specific layouts of how the data is 

presented – for example, a DVD cover or Line 1 always in bold, Line 2 always in italics etc. 

Set Up F10 More Parameters 

1. Click the F10 More button – the More screen will display 

2. Click the F1 New or F2 Insert button  

3. Enter the following parameters (see examples below) 

4. Click the F3 Save button when complete 

Note: A report that uses the F10 More Parameter must run via the Scheduler. 

 

Bibliographic (Fixed Layout Reports) 

This function is used for mapping data to fields in Fixed Layout reports – for example: the DVD Cover 

template (&DVDCOV.QRP). 

Each row of this table may be used to collect 1 of the 20 fields on the report template. These first 20 

fields contain Tag or Subfield data (Fields 1-20), and the next 20 fields (Fields 1A – 20A) contain the 

associated Tag Descriptions (Go to Main > Authorities > MarcTags to see a complete list of Tag Nos 

and Tag Descriptions). The report outputs all the MARC data to the report. The inclusion of Fields 1A 

– 20A in the report is optional. 

 

 COLUMN 1 COLUMN 2 COLUMN 3 COLUMN 4 COLUMN 5 

HEADING Report Line 

Number 

Tag Number eg + or blank 

or and sf in 

('a', 'b') 

blank or and 

cat_sf in ('a', 

'b') 

Not used 

EXAMPLE 1 100    
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The table below explains how the user can specify which parts of the MARC tag to send: 

 

OPERATOR DESCRIPTION EXPLANATION 

blank (Default) The entire MARC tag is printed If the column is left blank, then the entire 

MARC tag is printed 

+ All data in the specified tag is 

printed no matter how many tags 

are included in the record  

All Subject listings are printed, where 

there is only one or several or hundreds! 

and sf in ('p', 'n') Only the subfields specified to be 

printed within this Authority Tag 

If 490 | Series statement tag, only the 

Series name and number printed 

and cat_sf in ('c') Only the subfields specified to be 

printed within this Non-Authority 

Tag 

If 260 | Publisher tag, only the 'c' (Date) 

subfield printed (and not Place or 

Publisher) 

 

 

 

2 245    

3 082    

4 650    

COMMENT Can be any 

number 

between 1 

and 20 

MARC Tag field 

number – for 

example: 245 

(Title) 

Any Tag can be 

matched to ant 

Line Number 

Specify which 

part of the MARC 

tag to send - see 

table below for 

more details 

Specify which 

part of the MARC 

tag to send - see 

table below for 

more details 
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A fixed layout template displaying the Tag (or Subfield) data (Fields 1-20), and Tag Descriptions 

(Fields 1A – 20A): 

 

 

Setting Order 

Sorting of Bibliographic reports is different to normal reports. The Tag that you wish to sort by is set 

in the Where Parameters - for example Title (245 Tag) and the sort order is set using the F9Order 

function and AuthKey. 

 

 

 

In the following example the Auth Tag in the Where parameter is used to control the sort order of 

the items set in F9 Order – for example: 100 will list items by the Author, 245 will list the items by 

title and 082 (or 099 – whichever Tag you use) will list items by Call Number 

| 

 
 

FIELDS 1A – 20A 

display Tag 

Descriptors held in 

Main > Authorities > 

MarcTags 

FIELDS 1 – 20 display 

the actual data for 

the relevant Marc 

Tags held in the 

Authority Module 
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Note:  Once this is set, when you run the using F6Print or F8View button, you generally must 

remember to click ‘Yes’ when the following message display as you usually have a File to choose, 

rather than setting the Where parameters: This type of report may use a Saved File as the Source. 

Do you want to select the file now? 

New items  

It is possible to use this style of Format to display New Resources 

In this case Date is available from the Where parameters 

1. Launch the Amlib client 

2. Go to Main > Reports > RepBibliographic – the Bibliographic Reports window will open 

3. Select F1 New 

4. Highlight the Template required – for example Fixed Layout report with 10 lines (it is possible 

not to use all 10 lines) and press the Select button
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5. Enter a description into the Description column  

 

 

 
 

 
 
 

6. Press F3 Save 

7. Select the F7 Where button 
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8. Choose Date from the Search Column 

9. Select ≥ from the Operator box 

10. Click the Special button 

11. Enter the required No of Days or Months and ensure the – (minus) button is clicked as we are 

looking back in the past 

 

12. Click Paste 

13. Click Save F3 

14. Now set the F10 More button as required 

15. Click Save F3 
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16. Click View 

17. Because this is set by Date, say No to the message about the File 

 

 
 

 
 
The Report will display: 
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 Amlib Bibliographic Reports Training Guide 

 

Last Updated: 14 August 2014 Page 35 

Some Notes about the Report 

Order is attained by: 

Choose a Marc Tag that all records will have (for example Auth Tag = 245 for Title) in the Where 

parameters as well as having the Date)  
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CUSTOMISING FIXED LAYOUT TEMPLATES 

Using the Report writer application REPWIN fixed layout templates can be altered as required.  For 

detailed instruction on how to edit report template using REPWIN – please contact Amlib Support.  

The table here provides a list of fixed layout template that can be altered: 

TEMPLATE DESCRIPTION REPORT TYPE 

&BIBCSV.QRP Bibliographic Export Fixed layout Reports 

&BIBFIXD.QRP Fixed Layout Catalogue Print Fixed layout Reports 

&BIBFIXS.QRP Fixed Layout Catalogue Print 
with Subject Headings 

Fixed layout Reports 

&BIBFL10.QRP Fixed Layout 10 fields Fixed layout Reports 

&BIBFL28.QRP Fixed Layout 2 columns 8 fields Fixed layout Reports 

&DVDCOV.QRP DVD Cover Fixed layout Reports 

&VIDCOV.QRP Video Cover Fixed layout Reports 

Note: Before altering any of the above templates, duplicate the template and rename it. The general 

practice of renaming a report template is to remove the ampersand (&) and add in a few letters 

indicating your library name for example: 

 &BIBFL10.QRP  EBIBFL10.qrp (Modified template name for Eldorado Library) 

Once a fixed template has been modified, the template needs to be loaded into Amlib (Main 

>Report>RepAddNew) 

Loading Fixed Layout Template (RepAddNew) 

1. Launch the Amlib client 

2. Go to Main > Reports > RepAddNew – the Report Files window will open 

3. From the Report Entity down box select ‘Bibliographic’ 

4. Click the F1 New button – the Bibliographic – New Report File  screen will display:  
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5. Type in an appropriate Description – for example: Author List – Fixed Layout 10 Lines with 

Author in Italics 

6. Template – click on the Browse button – the Choose Report window will open 

 

7. Navigate to the Amlib/Reports folder on your Amlib Server (if the template has been loaded 

onto your PC – then navigate to the local folder) 

8. Files of type:  

a. Select Custom Report Templates (*.qrp) for customised templates 

b. Select System Report Templates (*.qrp) for all standard system templates 

9. Locate the template to be loaded and highlight it  &BIBFL10.QRP 

10. Click the Open button – the template will be selected the Choose Report window will close 

11. Choose Type – it is essential that the appropriate type be chosen that this will inform how 

your template operates and the information that is sent to it – in this example: Fixed layout 

Reports has been selected.  Note that the Type will be the same as the original template the 

edited version was based on 

 

12. Message – leave blank 



 Amlib Bibliographic Reports Training Guide 

 

Last Updated: 14 August 2014 Page 38 

13. Click the F3 Update button 

14. Close out of the Report Files window. The template is now loaded and available for use in a 

Report. 

 

 

Adding Template to Reports Module 

Now that the template has been loaded into Amlib it will need to be added to the Bibliographic 

Reporting module. 

1. Launch the Amlib client 

2. Go to Main > Reports > Bibliographic 

3. Click the F1 New button – the Select Report Format screen will display:  

 
 

4. Highlight the report you would like to use and click the Select button 

5. Your selection will appear at the bottom of the Report table in red: 
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6. Type in an appropriate Report Description – for example: Authors Like King  

 

 This description often serves as the heading of the report as well 

 
 

 

7. Click the F3 Save button  
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EXPORTING BIBLOGRAPHIC DATA 

Bibliographic reports can be saved to a windows file and imported into application such as MS Word 

& Excel. These files can be used for a variety of purposes for example: 

 Enhancing the Report by adding graphics, changing fonts, adding text in a Word document 

etc. 

 Save it for a later date to view 

 Avoid using paper if the Report is for “In-house” purposes 

The following template needs to be added to Amlib to export Bibliographic data 

 BIBCSV.QRP  

Step 1: Load the Template 

1. Launch the Amlib client 

2. Go to Main > Reports > RepAddNew – the Reports Files screen will display 

3. From the Report Entity drop-down, select choose Bibliographic 

4. Click the F1 New button – the Bibliographic – New Report File screen will display: 

 

5. Enter the following details: 

a) Description: Bibliographic Export 

b) Template: click on the Browse button, change the Files of Type drop-down to System 

Report Templates (*.qrp), select the &BIBCSV.QRP template and click the Open 

button 

c) Choose Type = Fixed layout reports 

6. Click the F3 Update button when complete 
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Step 2: Create the Report 

1. From the Report Files screen choose Main > Reports > RepBibliographic – the Bibliographic 

Reports screen will display 

2. Click the F1 New button – the Select Report Format screen will display 

3. Highlight the &BIBCSV.QRP (Bibliographic Export) template and click the Select button 

4. Type in a Description – for example: Bib Data Export 

5. Click the F3 Save button 

 
 

Where Statement 

1. Highlight the new Report and click the F7 Where button – the Bibliographic Reports – Where 

screen will display 

2. There are three unique parameters: 

o Auth Tag: Search for a particular MARC tag 

o Auth Key: Check for particular data contained in the MARC tag 

o Tags to Display: MARC tags to display in report 
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3. The statement can include the following settings: 

a) Auth Tag – for example: Auth Tag = 245 (Title) 

b) Auth Key – for example: Auth Key LIKE Harry Potter (looks for all matching items where 

the Title BEGINS with Harry Potter) 

Please Note: If you want to export ALL holdings: Auth Key IS NOT NULL (pastewithout a 

value in 3) 

c) Tags to Display – for example: Tags to Display IN 020,100,245 (will display ISBN,author 

and Title in report) 

d) Tags to Display – for example: Tags to Display IN 020,100,245 (will display ISBN,author 

and Title in report) 

e) (optional) Enter a finish date: Date <= enter a date in DD/MM/YYYY format – forexample: 

10/10/2010 (a finish date is optional – if not inserted, the report will go up to the current 

date). 

f) You may also want to limit by Catalogue Number(s) 

4. Click the F3 Save button when complete 

 

 

Map the Output 

It is possible to export up to 20 fields or subfields (Fields 1-20). Go to Main > Authorities > MarcTags 

to see a complete list of Tag Nos). This F10 More screen allows you to determine the order in which 

the fields will be output and the format. 

1. Highlight the report and click the F10 More button – the More screen will display: 
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The table below explains how the user can specify which parts of the MARC tag to send: 

 

 
 

2. Use the F1 New button to insert export lines 
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3. Click the F3 Save button when complete 
 

Order the Report 

1. Highlight the report and click the F9 Order – the Order By screen will display: 

 

2. Select Auth Key and use the arrow to move it to the right column 

3. Click the F3 Save button when complete 

Step 3: Run the Report 

Start the Scheduler 

1. From the Reports screen, select Application > RepStartSchedule 

 

2. The Report Scheduler screen will then display 

3. Select your printing options: Ensure Save to File is ticked 

4. Also decide If a report is scheduled by another user do you still want to print it? = Yes/No 
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5. Then click the OK button 

6. After clicking OK, if you go back into the Application menu you will see that 

RepStartSchedule is now greyed out with a tick next to it – this indicates that the Scheduler is 

now running 

 

Please Note: If you need to restart the scheduler at any point, you will need to log out of all Report 

screens (Ctrl + L) and start at the beginning of these instructions. 

Scheduling the Report 

1. With your report highlighted, select the F6 Print button – the Print dialogue box will display 

2. Select from the following options: 

a. From: 

 Database (to search the entire database) 

b. To: 

 File (to save the report as a file) 

c. Frequency: 

 Once Only (if this is the only time you’re going to print this report) 

d. Schedule: 

 First Print Date (defaults to current date) 
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 First Print Time (defaults to current time) 

e. Selected Printer: 

 You can specify any active printer on the network to print to – including 

virtual printer drivers such as a third party software that allows you to print 

to PDF (For example: CutePDF Writer) 

 

3. Once you have selected all of your settings, click the OK button – the Report – Save As… 

screen will display – navigate to the location where you want to save the file, enter a File 

name (for example: bibexport.txt), change the Save as type to Text Document and click the 

Save button 

 

The report will then be sent for processing. 

Check Print Progress 

1. You can check the progress of your reports at any time by going into Main > Reports > 

RepPrintProgress 
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2. If your library uses the scheduler for a lot of reports, you can select a frequency type from 

the Filter drop-down menu at the top 

 

3. Your report will show up in Printed when it is complete 

 
 

Step 4: Open in Excel 

1. Launch MS Excel 

2. Select the Data tab and then the From Text button: 

  

3. Navigate to the text file you’ve saved – ensure that the Text Files = (*.prn;*.txt;*.csv) 

highlight it, and click on the Import button 
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4. The Text Import Wizard will open: 

 
 

 

5. Ensure that Original data type = Delimited, and then click the Next button 

6. Delimiters: deselect Tab and add a pipe | in the Other box (it is possible to use both if you 

don’t know which one the report is using but this may cause cell contents to be misaligned – 

so check carefully!) 

7. Click the Next button and then the Finish button 
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8. Your data will be transferred into the Excel sheet and you can now use the formatting tools 

to customise it: 
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FIXED LAYOUT REPORT WITH IMAGES (&CTITEMX.QRP ) 

This report also automatically includes some Stockitem data. Allows stored catalogue images to be 

printed (max 5 per catalogue with max 10 tags). A File is generally select to display the Catalogues 

with images. As this is a Fixed Layout Report, the F10More button is used to select the Catalogue Tag 

information to be printed in the first 6 lines of the Information about each image. Just ensure the 

template has the image placeholder size set to ‘size for best fit’ so you images display well. 

There is a special Report Type to use for this Template. 

 

The Order can be set to e.g. Auth Key  

 
 

This reports needs to be run on a saved catalogue file, no Where statements are required. 

The Item information is hard coded into the Report and cannot be customised without programming 

changes.  
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It includes: 

 Barcode 

 Description 

 Perm Location 

 Received 

 Current Cost 

 Original Cost 

 Memo 

 History 

 Cat Reference 

 

 

The data to become the relevant Fields are determined using the F10More button. 
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APPENDIX 1: EXAMPLE FIXED LAYOUT REPORTS 

 Fixed Layout Catalogue Print (BIBFIXD.QRP)  

The F10 More lines must correlate with the Report Template. The template is set with only 3 lines 

available. Therefore the F10 More option can only have 3 lines set.  If more lines are wanted, the 

template will need to have more fields added. 

 
 

 

 Fixed Layout Catalogue Print with Subject Headings (BIBFIXS.QRP)  
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The template itself has been set to display a single subject heading. Again only 3 lines of display are 

available; therefore the F10 More screen can only be set for 3 lines. 

 
 

 

 Fixed Layout – 10 fields (&BIBFL10.QRP) 

The Template allows for up to 10 lines to be set in the F10 More screen. 

 

 Fixed Layout – 2 columns 8 fields (&BIBFL28.QRP) 

 

The report displays in 2 columns, without the Marc Tag descriptors. Eight lines are available to set 

within the F10 More window. 
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APPENDIX 2: WHERE STATEMENT AND SPECIAL BUTTON 

Where Statement 

These are the set conditions that the report uses to determine the data to be sent from the database 

to the report template. In general, they are just search terms – for example: All borrowers, all 

borrowers except library staff, members at particular locations, etc 

A good way of getting familiar with Where statements is to perform Where searches in the Borrower 

and Stockitem modules (see below). 

1. Highlight the report in the Reports table and click the F7 Where button – the Reports - 

Where screen will display: 

 

2. You can then enter one or more search conditions: 

a. Choose Search column: The options differ between Report Categories and Report Types. 

If you’re not sure which of these is the correct one, it can help to have a look at the 

corresponding module screen you want to get information from – for example: the 

Borrower screen 

OPERATOR DESCRIPTION EXAMPLE 

LIKE Where the required data in this field 

begins with the text entered 

LIKE ELD (for Eldorado) 

LIKE Where the required data in this field does 

not begin with the text entered 

LIKE ELD (for all except Eldorado) 

IN Useful for selecting multiple codes IN A,J,YA (for all of these types) 

IN Useful for multiple codes not to be 

included 

IN ILL,LS (to exclude these types) 

= Where the text entered is exactly equal to 

the data required 

= A (borrowers with a code of A for 

Adult) 
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 Where the text entered is not equal to the 

data required 

Useful for NOT EQUAL TO NULL – choose 

this operator, do not enter any data and 

click the Paste button 

 J (borrowers who do not have a 

code of J) 

< Where the text entered is less than the 

data required 

< 01/10/13 (less than 1 Oct 2013) 

< Where the text entered is equal or less 

than the data required 

< 01/10/13 (less than or equal to 1 

Oct 2013) 

> Greater than >01/10/13 (greater than 1 Oct 2013) 

> Equal or greater than the text entered > 01/10/13 (greater than or equal to 

1 Oct 2013) 

b. Choose operator – select from the above list: 

c. Type the WHERE condition - this could be letters, numbers, dates, codes, etc (see 

also the Special button below) 

 

d. Once you have entered the Where (or Search) condition, click the Paste button – the 

condition will be added to the table at the bottom of the screen: 

3. You can then add in further conditions: 

 Join conditions together using the AND and OR Boolean operands buttons.  

 Delete unwanted items by highlighting the line and clicking the Delete button 

4. Click the F3 Save button when complete 
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Special Button 

The Special button can be used for a number of things including the creation of relational dates 

(dates that aren’t fixed but operate from the concept of a Current Date or the Start of Month). 

For example: if you would like to look at dates for items received since 3 months ago you could select 

the following 

 Issue Date Due Back >= Current date – 3 Months (minus sign before the 3 months) 

1. Select Date Received from the 1 Choose Search Column box 

2. Select the ≥ operand from the 2 Choose Operator box 

3. Click the Special button – another Where window will open 

4. Select the Special operand from the table – for example: Current Date 

5. Adjust the relational value of the selected operand by using the + or – buttons and the Days 

or Months boxes – for example: - 3 Months 

6. An example of the expressed condition will be visible in the box at the top of the window: 

 

7. Click the Paste button when complete 
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APPENDIX 3:  USEFUL COMMON REPORTS - BORROWER HIGH USAGE COUNT 

There are several report templates to count high Borrower usage. The report templates are designed 

to show items used more than 3, 6, 10 or 100 times within a specified period (using the F7 Where 

statement). The report templates will list the title and the number of times used. 

 &BORH3.QRP - Shows count where transactions > 3 

 &BORH6.QRP - Shows count where transactions > 6 

 &BORH10.QRP - Shows count where transactions > 10 

 &BORH100.QRP - Shows count where transactions > 100 

The reports are run against the Borrower History. Users that delete data from the Borrower History 

table need to be aware of the limitations of results. 

 

Load/Check the Template Type 

1. Launch the Amlib client 

2. Go to Main > Reports > RepAddNew 

3. The Report Files window will open. 

4. From the Report Entity drop-down menu , select the Report Screen (module) you would like 

to load a template for – for example:  Borrower 

5. Highlight a borrower history report (see list above) and click the F2 Modify button – the 

Borrower Modify Report File window will open 

(To load a new report template: click the F1 New button instead) 

6. Type in a Description – for example: Borrower History Count 

7. Choose Type: – ensure that Borrower History is selected 

8. You can leave Default Stats Code blank 

9. Update Entity (Y/N) = N 

10. Click the F3 Update button 

11. Close out of the Report Files window 

 

The template is now loaded and available for use in a Report. 
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Create Report 

1. Go to Main > Reports > RepBorrower 

2. Select F1 New – the Select Report Format screen will appear 

3. Highlight the Stockitem History report template you would like to use – &BORH3.QRP (Usage 

Count > 5), &BORH6.QRP (Usage Count > 10 ), &BORH10.QRP (Usage Count > 10) or 

&BORH100.QRP (Usage Count > 20) 

4. Click the Select button type in a  Description – for example: Usage Count > 10 Issues 

 

  
 

5. Ensure the Update Entity (Y/N) column is set to N 

6. Click F3 Save 
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Where Search Parameters 

1. Highlight the report and select the F7 Where button – the Borrower Reports – Where screen 

will open 

2. Enter the following Where search: 

a. History Type  LIKE  READ 

(Use the Paste button to insert the parameter into the list at the bottom of the 

screen) 

 

b. Enter a start date: History Date >= enter a date in DD/MM/YYYY format – for 

example: 01/01/2010 

c. Enter a finish date: History Date <= enter a date in DD/MM/YYYY format – for 

example: 10/10/2010 (a finish date is optional – if not inserted, the report will go up 

to the current date). 

 

d. When using a range of dates, you should use the brackets to enclose the date range. 
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e. You may want to add other restrictors – for example: Borrower No = or Borrower 

Class = 

3. Click the F3 Save button when complete – this will close the Borrower Reports – Where 

screen and return you to the Borrower Reports screen 

 

Order By Parameters 

1. Click the F9 Order button – the Borrower Reports – Order By screen will open 

2. Select BorBarNo from the Columns list and arrow it across into the Order By list 

3. Click the F3 Save button when complete – this will close the Borrower Reports – Order By 

screen and return you to the Borrower Reports screen 
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View/Print Report 

1. Highlight the report you wish to run and select the F8 View button 

2. The following message will appear: 

 

 
 

3. If you would like the report to run using the entire database (rather than a Saved List) then 

select No 

4. The report will then display: 

 

5. Select the print button to print the report 
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APPENDIX 4:  USEFUL COMMON REPORTS - STOCKITEM HIGH USAGE COUNT 

There are several report templates to count high Stockitem usage. The report templates are designed 

to show items used more than 5, 10 or 20 times within a specified period (using the F7 Where 

statement). The report templates will list the title and the number of times used. 

 &STKH5.QRP - Shows items where count > 5 

 &STKH10.QRP - Shows items where count > 10 

 &STKH20.QRP - Shows items where count > 20 

The reports are run against the Stockitem History. Users that delete data from the Stockitem History 

table need to be aware of the limitations of results. 

Create Report 

7. Launch the Amlib client 

8. Go to Main > Reports > RepStockitem – the Stockitem Reports screen will open 

9. Click the F1 New button – the Select Report Format screen will appear 

10. Highlight the Stockitem History report template you would like to use – &STKH5.QRP (Usage 

Count > 5), &STKH10.QRP (Usage Count > 10) or &STKH20.QRP (Usage Count > 20). 

11. Click the Select button 

12. Type in a Description – for example: Usage Count > 5 Issues 

13. Ensure the Create Fin (Y/N) column is set to N 
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14. Click the F3 Save button 

Where Search and Order By Parameters 

4. Highlight the report and select the F7 Where button – this will bring up the Stockitem 

Reports – Where screen 

5. Enter the following Where search: 

a. History Type = ISSUE 

You can use ISSUE, RENEW OR RETURN 

(Use the Paste button to insert the parameter into the list at the bottom of the 

screen) 

b. If using History Type = Issue, you may want to exclude any alterations made to the 

due date after renewals: History Contents NOT LIKE Due Date Altered 

c. Enter a start date: History Date >= enter a date in DD/MM/YYYY format – for 

example: 01/01/2010 

d. Enter a finish date: History Date <= enter a date in DD/MM/YYYY format – for 

example: 10/10/2010 (a finish date is optional – if not inserted, the report will go up 

to the current date). 

e. You may want to add other restrictors – for example: Borrower No = 

f. Click the F3 Save button when complete – this will close the Stockitem Reports – 

Where screen and return you to the Stockitem Reports screen 

 

6. Click the F9 Order button – this will bring up the Stockitem Reports – Order By screen 

a. Select Item No from the Columns list and arrow it across into the Order By list 

b. Click F3 Save – this will close the Stockitem Reports – Order By screen and return you 

to the Stockitem Reports screen 
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View Report 

6. Highlight the report you wish to run and select F8 View 

 

7. The following message will appear: This type of report may use a Saved File as the Source.  

Do you want to select the file now? 

 

 

8. If you would like the report to run using the entire database (rather than a Saved List) then 

select the No button 

 

9. The report will then display: 
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10. Select the print button to print the report ( unfortunately it is not possible to order this 
report by highest usages first)  
 


